16:01:46 <zul> #startmeeting
16:01:47 <meetingology> Meeting started Tue Feb 12 16:01:46 2013 UTC.  The chair is zul. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:01:47 <meetingology> 
16:01:47 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:02:05 <zul> #topic Review ACTION points from previous meeting
16:02:19 <zul> so was there any action points from the previous meeting?
16:02:41 * zul is a little unprepared
16:02:43 <jamespage> no
16:02:47 <zul> sweet
16:02:48 <smoser> well, there was one for me.
16:02:54 <smoser> to contact release team about alpha2
16:02:56 <smoser> which i have done.
16:03:02 <zul> smoser: sweet!
16:03:03 <jamespage> smoser: in which case I forgot to record it sorry
16:03:23 <zul> so next
16:03:32 <zul> #topic Raring Development
16:03:40 <Daviey> smoser: do you want to drive this?
16:04:04 <smoser> yeah
16:04:05 <smoser> ok.
16:04:50 <smoser> http://reports.qa.ubuntu.com/reports/rls-mgr/rls-r-tracking-bug-tasks.html#server
16:05:21 <smoser> that list looks reasonably well handled.
16:05:41 <smoser> so, move on
16:05:46 <smoser> alpha2 is thursday.
16:06:00 <smoser> i believe that what we've agreed to do is to just tag cloud-images as alpha2
16:06:07 <smoser> that will largely involve utlemming and i.
16:06:23 <Daviey> (and a call for testing for ISO.)
16:06:30 <smoser> utlemming you can make sure that our candiddate (daily) builds have what is necessary?
16:06:35 <smoser> (yes, and call for testing ISO)
16:06:54 <smoser> and then , get the ISO tracker populated and tests recorded and the like
16:07:01 <smoser> (i can help utlemming on that)
16:07:08 <utlemming> smoser: yup. We're ready in the build infrastruture department
16:07:15 <smoser> we should send out a call for testing.
16:07:28 <smoser> any one want to volunteer for that?
16:07:29 <utlemming> smoser: and ISO tracking integration has been added already
16:08:04 <Daviey> smoser: i'll do that.
16:08:13 <smoser> ok. so just as long as we get stuff over there, and let the release team know the amis we want populated, i'm good with that.
16:08:15 <smoser> thank you Daviey
16:08:28 <smoser> #ACTION Daviey send request for testing
16:08:28 * meetingology Daviey send request for testing
16:08:49 <Daviey> roaksoax: How is MAAS looking in raring?
16:10:13 <smoser> ok, we'll skip that repsonse maybe for general discussion section roaksoax
16:10:21 <smoser> so, we're at alpha-2 in the cycle.
16:10:44 <smoser> feature freeze is not too far off (March 7)
16:10:46 <jamespage> sorry - I was distracting roaksoax elsewhere
16:10:55 <smoser> be aware of that in your work.
16:11:12 <smoser> #subtopic blueprints
16:11:18 <smoser> http://status.ubuntu.com/ubuntu-raring/group/topic-raring-servercloud-overview.html
16:12:02 <roaksoax> Daviey: its looking good. Now with SRU approval we should be getting things done pretty quickly
16:12:03 <smoser> red are servercloud-r-openstack-ha, servercloud-r-openstack-grizzly, servercloud-r-image-access (smoser), servercloud-r-cloudarchive, servercloud-r-openstack-ubuntu-images
16:12:21 <smoser> and servercloud-r-apt-improvements.
16:12:28 <roaksoax> Daviey: so that will enable me to upload trunk to raring (since MAAS in raring is what is to be SRU'd)
16:12:39 <smoser> so, pelease, if you are in charge of one of those , please make some effort to get it into shape
16:12:48 <smoser> or to raise the fact that it might not be in good shape.
16:13:09 <smoser> anything else for this topic ?
16:13:12 <Daviey> -apt-improvements i fear will be postponed
16:13:17 <Daviey> rbasak: ^?
16:13:23 <smoser> i fear that indefinitely :-(
16:14:19 <hallyn> fwiw, user namespaces will not be sufficiently enabled in the raring kernel.  we will have a kernel in a ppa for ~ubuntu-lxc for raring, and r+1 will have fully enabled usernamespaces.
16:14:26 <hallyn> (this relates to a few items in the lxc blueprint)
16:14:35 <Daviey> hallyn: :(
16:14:45 <hallyn> oh it's ok, r+1 is so gonna rock
16:14:51 <Daviey> \o/
16:14:53 <hallyn> fully unprivileged creation and use of containers
16:15:02 <zul> as long as the next lts rocks
16:15:11 <hallyn> ooooh it will
16:15:37 <zul> anything else?
16:15:40 <smoser> hallyn, "fully unprivileged creation and use of containers" sounds crazy awesome.
16:15:41 <rbasak> I hope to have the apt code done for feature freeze, but I'm not sure it'll go into raring in time for review. But I'm hoping that it'll land when S opens at the latest
16:16:10 <smoser> rbasak, well, please remember that shoving it into R to be optionally enabled is quite preferable
16:16:11 <jamespage> zul: re the tracking report; I checked the package list
16:16:19 <rbasak> smoser: ack
16:16:21 <smoser> so that it makes it easier for people to test.
16:16:28 <smoser> and doesn't hurt anything.
16:16:28 <jamespage> it looks OK - I'll ping round an email with how to make stuff appear on it.
16:16:34 <rbasak> The catch is the desire for ABI compatibility in Debian
16:16:37 <zul> which package list?
16:16:57 <rbasak> Since I need to modify libapt slightly
16:17:38 <jamespage> zul: the list of packages that is maintained for the release tracking report (packages -> teams)
16:17:46 <zul> ah
16:17:56 <jamespage> (that is going to change to subs)
16:18:25 <zul> so i guess its time for a topic change
16:18:37 <zul> #topic Ubuntu Server Team Events
16:18:44 <zul> any upcoming events?
16:19:12 <zul> ODS and UDS will be here sooner to bite you on the bum
16:19:26 <Daviey> Yes, moving on :)
16:19:30 <arosales> scale11x upcoming
16:19:39 <arosales> MongoDB Austin this Friday :-)
16:19:49 <Daviey> be there or be relational
16:19:57 <zul> hah
16:19:59 * jamespage will be relational then
16:20:11 <arosales> I'll be there giving a Juju talk around Juan's sharding blog
16:20:17 <jamespage> arosales: nice one
16:20:19 <Daviey> Oh nice!
16:20:33 <zul> #topic Weekly Updates & Questions for the QA Team (hggdh)
16:20:38 <zul> hi hggdh you here?
16:21:25 <zul> if not
16:21:36 <zul> #topic Weekly Updates & Questions for the Kernel Team (smb)
16:21:39 <smb> More or less was busy with Xen (two issues in Precise, security updates in its package, preparing related security updates in the kernel). There was also some bug smoser had for me but I believe that was something I was nothing I could help further and promptly forgot what that was... :/ Oh, autoloading of some  special net hw modules. I believe the net part has been at least added to some udebs (Precise?) So are there other questions?
16:21:40 <zul> hi smb are you here?
16:21:43 <smb> ..
16:21:49 <smb> zul, yes
16:22:01 <zul> smb:  silly cut and paste
16:22:17 <smb> zul, Nah, prewrite and press enter. :)
16:22:23 <zul> uh huh :)
16:22:25 <smoser> yes, smb helped me with bug 1115710 and (related)_ bug 1015339.
16:22:29 <ubottu> bug 1115710 in module-init-tools (Ubuntu Quantal) "Mellanox mlx4_en network driver is not automatically loaded" [Medium,Triaged] https://launchpad.net/bugs/1115710
16:22:30 <ubottu> bug 1015339 in linux (Ubuntu Quantal) "installer initrd missing kernel modules for Mellanox ConnectX HCA Ethernet" [Undecided,Fix committed] https://launchpad.net/bugs/1015339
16:22:47 <zul> anything else for smb and his prewrite awesomeoness?
16:23:33 <zul> ok then
16:23:42 <zul> #topic Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:23:50 <zul> i know rbasak is around
16:24:06 <zul> or his evil twin
16:24:10 <zul> who is french
16:24:30 <zul> rbasak: any update?
16:25:00 <rbasak> Sorry
16:25:14 <rbasak> Nothing new to report. Any questions for me?
16:25:44 <zul> if not
16:26:02 <zul> #topic Open Discussion
16:26:15 <zul> so anyone else has something on the agenda?
16:26:22 <pmatulis> yes
16:26:46 <zul> pmatulis: ?
16:27:01 <pmatulis> we need to improve the ubuntu server guide.  seems the way we're doing it now doesn't work
16:27:40 <pmatulis> i'm afraid it will become obsolete in a few cycles if things don't improve
16:28:43 <zul> pmatulis: why not put out a call to volunteers again on the ubuntu-server mailing list
16:29:09 <pmatulis> zul: i did, last week, no one responded
16:29:14 <rbasak> pmatulis: what do you propose?
16:29:55 <pmatulis> rbasak: i've tried to create ways to focus on the guide
16:30:20 <pmatulis> but it doesn't seem to be bearing any fruit
16:31:08 <pmatulis> today i created a special team with an associated mailing list.  which i hope to use to awaken prior contributors every cycle
16:31:54 <pmatulis> fyi, https://wiki.ubuntu.com/DocumentationTeam/SystemDocumentation/UbuntuServerGuide
16:32:07 <hallyn> test team has worked hard to try and force test additions corresponding to each (UDS) feature item and each SRU item, perhaps we can do something analogous where we collect server guide updates in response to each?
16:32:19 <hallyn> don't require a server guide update for each, just collect items,
16:32:33 <hallyn> which then a team can go over (and contact the item author if needed)
16:33:50 <hallyn> <crickets>
16:34:01 <hallyn> i'd say such an undertaking could stand to have a UDS discussion
16:34:09 <jamespage> indeed
16:34:22 <pmatulis> hallyn: that's an idea, link guide contributions to UDS discussions
16:34:27 <hallyn> (in the meantime, a simple stern "make sure you update server guide for anything you've been working on")
16:34:38 <hallyn> pmatulis: even put them in the blueprints,
16:34:48 <pmatulis> right
16:34:50 <hallyn> next to the release notes maybe.
16:35:07 <rbasak> Perhaps we should have a standard "upgrade server guide" in every blueprint where it makes sense
16:35:14 <rbasak> update server guide that is
16:35:40 <jamespage> I think making it a milestoned work item makes alot of sense
16:35:59 <jamespage> then you won't get i***ts like me updating stuff a week before release cause its wrong
16:36:57 <jamespage> OK _ I'll take an action to add something to the blueprint template - basically a check to see if docs need updating
16:36:57 <hallyn> where would it fit though?  I don't think that
16:37:07 <hallyn> having one week where we try to remember the last six months' worth of changes works
16:37:25 <hallyn> hm yeah, that's a good start
16:37:29 <jamespage> well a milestone would indicate the point at which document updates must have been made by
16:37:34 <jamespage> not when you actually do the,
16:37:36 <jamespage> :-)
16:37:45 <jamespage> pmatulis: I'm right in saying there is a cutoff?
16:37:45 <hallyn> haha
16:38:21 <jamespage> zul: care to action me todo that?
16:38:25 <pmatulis> jamespage: yes, there is actually a 'string freeze'
16:38:32 <zul> jamespage:  sure
16:38:32 <jamespage> thats the one
16:38:45 <zul> #action jamespage to milesone documentation updates
16:38:45 * meetingology jamespage to milesone documentation updates
16:39:46 <zul> anything else?
16:40:37 <zul> #topic Announce next meeting date, time and chair
16:40:50 <zul> next week, same time, same place and someone else will be the chair
16:40:53 <zul> whee!
16:40:58 <zul> thanks for coming
16:41:00 <zul> #endmeeting