17:22:45 <czajkowski> #startmeeting
17:22:45 <meetingology> Meeting started Thu Feb 7 17:22:45 2013 UTC. The chair is czajkowski. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
17:22:45 <meetingology>
17:22:45 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
17:22:46 <dholbach> thanks bdrung, Laney
17:22:51 <czajkowski> #topic DMB catch up
17:23:09 <czajkowski> bdrung: Laney how are things in the life of the DMB these days?
17:23:55 <dholbach> Are you both up for reelection right now?
17:24:02 <bdrung> dholbach: yes
17:24:40 <dholbach> Looking back at your last term, how did you feel did the DMB generally cope with their tasks?
17:24:51 <bdrung> czajkowski: the team is working nicely together, but our decisions are controversial (see discussions on ubuntu-devel mailing list)
17:25:18 <dholbach> bdrung, is the general workload all right?
17:25:20 <Laney> i think we achieved some good things on process
17:25:38 <Laney> but work is ongoing
17:26:01 <dholbach> Laney, can you give us a few bullet points? (for those not watching the DMB closely)
17:26:17 <czajkowski> bdrung: aye we'll come back to that
17:26:42 <bdrung> dholbach: the workload is all right, but we could be more proactive (in case of expected deferrals)
17:26:52 <Laney> we made it easier to modify packagesets
17:27:19 <Laney> made their definitions more precise (to facilitate this)
17:27:25 <bdrung> * making it easier for DD to get PPU rights
17:28:00 <Laney> we'll be voting at our next meeting on granting the kernel team the right to manage their packageset
17:28:09 <dholbach> ah, nice
17:28:20 <Laney> as a result of being proactive on that at UDS
17:28:57 <Laney> we tightened up on our meetings as we were overrunning a lot every time previously
17:29:05 <Laney> now it's not so much of a problem
17:29:32 <dholbach> so you don't have to ask applicants to attend another meeting too often?
17:29:43 <Laney> correct
17:29:46 <dholbach> do you still handle (some of the) applications via mail?
17:29:49 <Laney> applicants know in advance which meeting they will be heard at
17:29:54 <Laney> in exceptional cases we can do that
17:30:07 <bdrung> the last exception was quite some time ago
17:30:11 <dholbach> YokoZar, welcome back
17:30:56 <czajkowski> so coming back to what bdrung mentioned above
17:31:08 <czajkowski> controversial decisions
17:31:19 <dholbach> I liked the discussion on ubuntu-devel@ - there were a couple of good ideas. Are you still discussing future changes to the DMB process internally? Or do you wait until a new DMB is formed?
17:31:21 <czajkowski> care to elaborate and tell us about that
17:31:49 <Laney> it's felt that our criteria should be clearer
17:32:11 <bdrung> some developers dislike that we deferred some applications.
17:32:38 <Laney> so that people know with more certainty when they should be applying
17:33:04 <czajkowski> defered as in ran out of time, or defered their applications as not suitable?
17:33:14 <Laney> the latter
17:33:58 <bdrung> defered their applications as not suitable _yet_
17:34:21 <czajkowski> nods
17:34:29 <dholbach> I liked Laney's suggestion of the DAT and the DMB working a bit more closely together. Do you feel there were other promising proposals?
17:34:40 <bdrung> dholbach: yes
17:35:04 <Laney> being proactive when there are clear issues visible a priori
17:35:05 <dholbach> (Or in general: applicants reaching out to the DMB beforehand.)
17:35:13 <czajkowski> so I guess I found this interesting given other boards when applications are asked to defer till more experience either come back at a later date, or appeal to the CC, I'd never seen a situation like the above take place on the mailing list,
17:35:18 <Laney> we have to avoid collusion and groupthink though
17:35:19 <czajkowski> is this normal?
17:35:42 <dholbach> Laney, can you elaborate?
17:35:47 <Laney> on which point?
17:36:37 <dholbach> avoiding collusion and groupthink
17:36:51 <Laney> it might be tempting to discuss concerns in advance internally
17:36:54 <dholbach> maybe my day has been too long already, but I'm not quite sure what it means :)
17:36:58 <Laney> and thereby come to a consensus in private
17:37:38 <czajkowski> dholbach: tis ok am confused also
17:38:27 <dholbach> ah ok, I guess that makes sense - I would have hoped, that everybody would just speak their mind in a prior exchange, but I guess it can't be avoided that somebody influences somebody else who hasn't made up their mind yet
17:38:55 <Laney> if you want to redirect an applicant away in advance of a meeting you might want to discuss with your fellow members before going to the applicant
17:39:23 <Laney> this isn't a bad thing per se, but it's not a formal vote so it should be handled properly
17:39:47 <Laney> as it would be difficult for someone to press on when advised against by one of the people that will be considering them
17:40:47 <dholbach> I'd hope that over time you'd find a good protocol for this, just by trying it out. :)
17:41:04 <Laney> actually i think perhaps a consensus would be a good thing to achieve here
17:41:24 <Laney> otherwise one person who doesn't necessarily represent the rest would be able to dissuade people too easily
17:41:35 <Laney> something that would have to be worked out in practice i suppose
17:42:07 <Laney> bdrung: perhaps you have another idea to add
17:43:41 <Laney> ok, i will outline my other idea
17:43:44 <dholbach> yeah, I can easily imagine having two people on a board, one more trusting or lenient, the other more demanding - in a discussion I'd hope they'd find a spectrum with everything between "absolute no-go" and "rubber-stamping the application"
17:44:10 <bdrung> hm, i think we should try it out and see how it works. if someone of us has doubt about one applicant, he can raise that doubt on the dmb channel and see if someone agrees. if two people of the dmb has doubts, asking the application makes sense
17:44:13 <Laney> it's quite simple: giving better feedback for both these soft deferrals and hard ones at a meeting
17:44:28 <Laney> currently if we do anything it's just by email which isn't very easy for people to find
17:44:39 <Laney> i think we could look at being more organised on this
17:44:48 <Laney> so that, over time, the expectations become more clear
17:44:56 <dholbach> and if one of them choses to vote -1 and the other one +1 afterwards, I guess that can't be avoided - or if you phrase your reply to the applicant before the meeting in a way which says "some of us felt you might want to look at doing a few more merges / writing a bit more about yourself in your application / come back in a month or two"
17:45:21 <dholbach> yeah, that sounds great
17:45:28 <Laney> i would be interested in us talking a bit about czajkowski's earlier point if you don't mind
17:45:36 <dholbach> sure
17:45:49 <Laney> namely why the dmb is (seen as being?) quite different from other membership boards
17:46:48 <Laney> i don't really have much insight into the other ones but i understand that it's quite common for people to be declined membership there?
17:46:58 <czajkowski> it happens from time to time yes
17:47:07 <bdrung> dholbach: we require +4 for an application to succeed. so voting +0 shows doubts and -1 shows a stronger no
17:47:24 <czajkowski> people are asked to come back again, usually with some areas to improve upon
17:47:27 <czajkowski> and that's fine
17:47:34 <czajkowski> more often than not they do then get approved.
17:47:41 <dholbach> I don't know, but from my time when I did this as part of the CC, it didn't happen very often - probably some one-digit percentage
17:47:57 <Laney> doesn't seem to me that there are any clearer standards for membership than there are for uploader applications?
17:47:58 <dholbach> but this might have changed with the membership boards
17:48:00 <pleia2> yeah, I wouldn't say "quite common" but it can be harder to understand what's required for approval since the scope of Membership is much broader and less concrete
17:48:20 <pleia2> so sometimes people don't get approved because they completely lack documentation and testimonials
17:49:19 <pleia2> presumably someone applying to DMB actually does always have a body of work they can show in some way
17:49:30 <Laney> right
17:49:40 <Laney> are dmb votes seen more as judgements on a person's work?
17:49:57 <Laney> so deferrals are some kind of implicit criticism there
17:50:27 <pleia2> as gentle as a deferral is for any of these boards, it will feel like rejection and be painful
17:50:29 <bdrung> or does gaining upload right is more attractive than being able to call oneself ubuntu member?
17:51:17 <dholbach> I could imagine that the review of the DMB is much more extensive than that of a membership approving board. With good testimonials, consistent and substantial work of a cycle you can get membership.
17:51:21 <pleia2> bdrung: I think that's highly dependent upon the person, motivations for both can vary wildly
17:51:36 <czajkowski> pleia2: +1
17:52:53 <Laney> people are often peturbed that the dmb goes against endorsements
17:53:02 <pleia2> and with membership, you don't actually need it to "get your work done" (ie - upload packages directly yourself), where as upload rights I'm sure many people apply for that reason
17:53:19 <dholbach> In the case of the DMB on the other hand you could have individual uploads inspected(?) and be asked about them. Or be asked why you didn't take part in some developers' activity. So it seems that the expectations are more concrete, even if still vague.
17:53:26 <Laney> right - it has the blocking factor
17:53:29 <Laney> blocking/enabling
17:56:40 <Laney> let's leave the introspection aside
17:57:02 <Laney> we'll see what we manage to achieve (hopefully i'll be on the board to help implement some changes)
17:57:22 * pleia2 nods
17:57:26 <dholbach> thanks a lot for looking into this
17:57:38 <czajkowski> thank you
17:57:53 <dholbach> the ideas which were brought up might take us a long way already
17:58:03 <dholbach> and generate some further discussion and ideas :)
17:58:38 <dholbach> is there anything you feel the CC could help you with?
17:59:37 <bdrung> one thing come to my mind: decoupling PPU from Ubuntu membership. Would that be a good idea?
17:59:45 <pleia2> bdrung: yes
17:59:55 <dholbach> I think we discussed it in some mailing list discussion already
17:59:57 <pleia2> we've discussed this a few times in the past, that tended to be the consensus
18:00:06 * dholbach nods
18:00:25 <Laney> we just need to implement it afaik
18:00:30 <bdrung> so it's just a matter of implementing it
18:00:51 <Laney> put it on the agenda
18:01:13 <bdrung> Laney: do you or should i?
18:01:17 <Laney> you please
18:01:40 <Laney> oh, I just remembered something: the post meeting tasks seem quite arduous which means that people often put them off
18:01:50 <Laney> https://wiki.ubuntu.com/DeveloperMembershipBoard/Agenda "After the meeting"
18:02:00 <Laney> lots of tedious wiki fiddling
18:02:07 <Laney> I wonder what fat we can trim there
18:02:26 <czajkowski> rotating the chair
18:02:28 <czajkowski> sharing tasks
18:02:47 <czajkowski> cant really not add them to the LP team :)
18:03:19 <dholbach> might be a good discussion on ubuntu-council-teams@lists.launchpad.net :)
18:03:21 <pleia2> Laney: as long as the minutes include approval details, the same mail can be sent to -news team as to -devel and -devel-announce
18:03:26 <dholbach> other teams certainly have the same problem
18:03:46 <bdrung> i find it tedious to write the meeting minutes and and team report
18:04:08 <pleia2> bdrung: are the meeting minutes different than the team report?
18:04:19 <dholbach> maybe using the bot more (using AGREED, using ACTION, etc) might help with that?
18:04:23 <pleia2> for the CC they're the same, helps a lot (though still tedious)
18:04:52 <dholbach> sorry, I have got to run - thanks a lot everyone - and bdrung, Laney: if you feel the CC or I can help with anything we discussed earlier, please let me know
18:04:55 <dholbach> hugs!
18:04:59 <Laney> sure
18:05:02 <Laney> thanks a lot
18:05:09 <bdrung> maybe the formatting is different
18:05:21 <czajkowski> using the bot has helped a lot
18:05:28 <czajkowski> as it does a lot of thw work for you
18:05:41 <czajkowski> anyway moving on as we've gone over the time
18:05:44 <czajkowski> any other comments?
18:06:00 <pleia2> it requires a constant nagging to get people to use #action and #info (we do it for Xubuntu)
18:06:18 <pleia2> and even I forget :)
18:07:02 <czajkowski> do we have any actions from this meeting /
18:07:24 <pleia2> we should figure out how to get the doc team to respond
18:07:38 <bdrung> having one recording clerk would be nice. :)
18:07:41 <pleia2> it's a bit worrying that no one from the core doc team even acked our email
18:07:59 <pleia2> just a couple who work on the wiki, and said they'd come but didn't :\
18:08:23 <czajkowski> bdrung: sharing is much better trust me
18:08:42 <czajkowski> #action czajkowski mail the docs team again and reschedule meeting
18:08:42 * meetingology czajkowski mail the docs team again and reschedule meeting
18:09:03 <bdrung> czajkowski: but then i have to ask myself every time how to write the minutes and how to format them
18:09:23 <czajkowski> bdrung: well, roating chair and perso doing the mins has worked for the Loco council
18:09:37 <czajkowski> I really do have to head tbh
18:10:18 <pleia2> ok, thanks everyone
18:10:28 <cprofitt> very good conversation about the issue everyone
18:10:42 <czajkowski> #endmeeting