16:00:00 <rbasak> #startmeeting ubuntu-server-team
16:00:00 <meetingology> Meeting started Tue Jan 29 16:00:00 2013 UTC.  The chair is rbasak. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:00:00 <meetingology> 
16:00:00 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:00:19 <rbasak> #topic Review ACTION points from previous meeting
16:00:25 <rbasak> • arosales to investigate why status tracker is not picking up all servercloud area BPs
16:00:35 <rbasak> Hey arosales. Is the agenda actually current?
16:01:08 <arosales> Hello
16:01:22 <arosales> rbasak: ya I took a look. Some of the BPs were missing work items.
16:01:34 <arosales> as soon as the work items are added it should pick it up.
16:01:46 <arosales> reminder to all to not include the string "work item" in the white board too :-)
16:02:10 <rbasak> arosales: ok, thanks!
16:02:25 <rbasak> So that takes us to the next action item:
16:02:27 <rbasak> • all, check status of assigned Work Items and refresh if necessary
16:02:51 <jamespage> o/
16:02:58 <zul> hilo
16:03:17 <rbasak> So we should all do that :)
16:03:33 <arosales> :-)
16:03:35 <rbasak> #topic Raring Development
16:04:02 <rbasak> jamespage: over to you?
16:04:19 <rbasak> In the agenda we have:
16:04:22 <rbasak> #link http://reports.qa.ubuntu.com/reports/rls-mgr/rls-r-tracking-bug-tasks.html#server
16:04:30 <jamespage> rbasak, sure
16:05:13 <jamespage> OK - so the maas bug list is looking much better - just a few outstanding
16:05:26 <jamespage> thanks roaksoax and the maas tema
16:05:33 <jamespage> looks like we have a few new ones
16:05:57 <jamespage> zul, bug 1099382
16:05:59 <ubottu> bug 1099382 in quantum (Ubuntu Raring) "quantum: Raring depwait on universe package alembic" [High,Confirmed] https://launchpad.net/bugs/1099382
16:06:07 <jamespage> I think that can be closed out now right?
16:06:19 <jamespage> bug 1090593
16:06:21 <ubottu> bug 1090593 in bind9 (Ubuntu Raring) " D.ROOT-SERVERS.NET changing January 3rd 2013" [Medium,Triaged] https://launchpad.net/bugs/1090593
16:06:56 <jamespage> that one needs to be SRU'ed as well - I note that lamont has prepared packages already - any takers?
16:06:59 <jamespage> maybe rbasak?
16:07:25 <rbasak> Sure, I can pick that up
16:07:34 <rbasak> Need to check that it's fixed in raring first
16:07:38 <jamespage> I sadly have not fixed bug 671065 yet
16:07:41 <ubottu> bug 671065 in dovecot (Ubuntu) "deliver broken because dovecot.conf uses !include_try" [Medium,In progress] https://launchpad.net/bugs/671065
16:07:45 * jamespage berates himself
16:07:56 <jamespage> hallyn, bug 1092715
16:07:57 <ubottu> bug 1092715 in qemu-kvm (Ubuntu Raring) "udevadm trigger --action=change not working in quantal and raring" [High,Confirmed] https://launchpad.net/bugs/1092715
16:08:50 <jamespage> ah - right - hallyn wants to make that invalid - some sort of inotify bug on some systems - that would reflect some of the behaviour I have seen
16:09:30 <hallyn> jamespage: i'm talking with pitti right now about the first part of that
16:09:35 <jamespage> smoser, bug 1100920 under control?
16:09:36 <ubottu> bug 1100920 in cloud-init (Ubuntu Raring) "In Ubuntu 12.10, the legacy 'user' cloud-config option is not handled properly" [Medium,Triaged] https://launchpad.net/bugs/1100920
16:09:40 <jamespage> hallyn, nice one
16:09:55 <jamespage> I *still* need to get the package list updated for that report
16:10:16 <jamespage> so - http://status.ubuntu.com/ubuntu-raring/group/topic-raring-servercloud-overview.html
16:10:28 <smoser> jamespage, yes.
16:11:28 <jamespage> picking on the reds
16:11:30 <jamespage> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-r-openstack-ha
16:11:46 <jamespage> is moving forwards - hopefully good working set of charms for grizzly by end of feb
16:12:12 <jamespage> zul: https://blueprints.launchpad.net/ubuntu/+spec/servercloud-r-openstack-grizzly
16:12:28 <zul> ill update it today
16:12:37 <jamespage> zul, but generally OK right?
16:12:44 <zul> yeah
16:12:54 <jamespage> smoser: https://blueprints.launchpad.net/ubuntu/+spec/servercloud-r-image-access
16:13:34 <jamespage> and hallyn: https://blueprints.launchpad.net/ubuntu/+spec/servercloud-r-binfmtns
16:13:53 <smoser> i'll update state there today. we're making good progress recently.
16:14:05 <jamespage> smoser, nice one
16:14:20 <jamespage> smb: I note actions on https://blueprints.launchpad.net/ubuntu/+spec/servercloud-r-kdump-tool for you - hows that going?
16:14:28 <hallyn> jamespage: yeah, i need to talk to smb and cjwatson about that binfmtns, but i think we'll postpone that
16:14:36 <hallyn> one action item on there i hope to get to today, actually
16:14:44 <hallyn> but the rest i just don't know we have time for this cycle
16:15:05 <jamespage> hallyn, OK _ I suggest you leave in place for the time being and do a status update in the whiteboard
16:15:07 <smb> jamespage, Finished a bit on that today, working with other to get other things together
16:15:08 <jamespage> we can defer later
16:15:14 <jamespage> smb, good-oh
16:15:16 * jamespage sighs
16:15:17 <jamespage> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-r-seeded-qa-workflow
16:15:20 <hallyn> jamespage: yes, i'm not defering yet, i'm still hoping to talk to them :)
16:15:24 * jamespage hits himself round the head
16:15:36 <smb> hallyn, Have not looked into that yet
16:15:42 <jamespage> OK _ so that is moving very slowly
16:15:48 <hallyn> smb: i think the first steps belong to myself and cjwatson
16:15:56 <hallyn> (but we shouldn't talk about that here i guess :)
16:16:09 <smb> hallyn, ok, agree. :)
16:17:05 <jamespage> re ^^ seeded-qa-workflow
16:17:17 <jamespage> hmm - well if people get time please try towrite some tests.
16:17:34 <Daviey> \o/
16:17:45 <jamespage> its lower priority that other work folk have on but if anyone from the ubuntu-server community has time please steal work items!
16:18:04 <jamespage> Daviey, https://blueprints.launchpad.net/ubuntu/+spec/servercloud-r-cloudarchive
16:18:48 <jamespage> smoser: guess https://blueprints.launchpad.net/ubuntu/+spec/servercloud-r-openstack-ubuntu-images follows the blueprint above...
16:19:15 <jamespage> anyway - things generally look OK; please keep you blueprints updated (weekly if poss) so we can continue to track progress
16:19:21 <jamespage> rbasak, back to you
16:19:36 <smoser> yes
16:19:38 <rbasak> #topic Ubuntu Server Team Events
16:19:53 <Daviey> This weekend FOSDEM
16:19:55 <rbasak> We noted last time that FOSDEM is coming up. Me, Daviey and jamespage are going.
16:20:03 <jamespage> w00t!
16:20:16 <arosales> Scale11x at the end of feb (http://www.socallinuxexpo.org/scale11x/)
16:20:27 <jamespage> catch "Automating Openstack testing on Ubuntu" at 1150 on Saturday morning in the Testing Automation devroom
16:20:35 * jamespage goes to write the slides
16:20:40 <arosales> :-)
16:21:03 * jamespage apologises for the shameless self promotion
16:21:13 * Daviey adds it to his diary
16:21:36 <rbasak> #topic Weekly Updates & Questions for the QA Team (hggdh)
16:21:50 <rbasak> hggdh: around?
16:21:58 <hggdh> nothing noteworthy from me. Any questions for me?
16:22:20 <jamespage> o/
16:22:32 <hggdh> yessah?
16:22:34 <jamespage> hggdh: do you have any details of the testing schedule for 12.04.2?
16:23:25 <hggdh> jamespage: nothing should change from what we currently do; but we are going to add new jobs to cater for 12.04.2 (as opposed to 12.04.1)
16:23:51 <hggdh> these jobs should be a copy of hte current ones, only using the updated iso
16:24:13 <hggdh> as soon as we have an usable image we should start
16:24:16 <hggdh> ..
16:25:04 <rbasak> OK, thanks hggdh!
16:25:05 <rbasak> #topic Weekly Updates & Questions for the Kernel Team (smb)
16:25:14 <smb> Hm, cannot think of something worthwhile to report. Are there questions?
16:26:09 <smb> sounds like a no...
16:26:15 <rbasak> I guess not. Thanks smb!
16:26:20 <rbasak> Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:26:25 <rbasak> #topic Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:26:33 <rbasak> rbasak: any questions?
16:26:43 <rbasak> Nothing new! Any questions for me?
16:26:44 <rbasak> :)
16:27:15 <rbasak> #topic Open Discussion
16:27:21 <rbasak> Looks like this will be a quick meeting :)
16:27:28 <arosales> quick question
16:27:45 <arosales> hggdh: for my learning :-)  are the tests you are looking at for server at http://iso.qa.ubuntu.com/qatracker/milestones/243/builds
16:27:52 <arosales> for this example it would be raring daily
16:28:08 <arosales> or are there other tests ?
16:28:50 <smoser> i do have a general discussion item
16:29:04 * arosales may have missed hggdh . .  .
16:29:05 <hggdh> arosales: for the ISO testing should be similar to these, but for Precise.
16:29:11 <smoser> Februrary 14 is "Alpha 2 for opt-in flavors" (https://wiki.ubuntu.com/RaringRingtail/ReleaseSchedule)
16:29:36 <hggdh> arosales: plus manual testing, and kernel testing
16:29:46 <arosales> hggdh: are those tracked else where?
16:30:03 <smoser> personally, i feel that we should have some concentrated test prior to and at least produce a coherant image.
16:30:21 <smoser> at least for cloud-images, we keep "release" images indefinitely and its ueful to have a stick in the mud
16:30:29 <smoser> does anyone have any disagreements or thoughts?
16:30:36 <hggdh> arosales: the ISO testing will be tracked at iso.qa.u.c (together with manual tests), the kernel tests in Jenkins
16:31:18 <utlemming> smoser: I agree with producing an alpha2
16:32:03 <arosales> hggdh: ok, thanks for the info. I'll take a look at http://iso.qa.ubuntu.com/ and https://jenkins.qa.ubuntu.com/view/SRU%20Kernel/ for server testing coverage
16:32:18 <smoser> jamespage, Daviey ?
16:32:34 <smoser> i'm suggesting we run around like headless chickens to produce something that no one will use
16:32:39 <rbasak> smoser: cloud images only, or CD images as well?
16:33:16 <arosales> cloud images are moving to  3 week release cycle following the kernel.  Those images would have further testing and perhaps more content update than a daily.
16:33:47 <jamespage> smoser, I'd +1 a cloud-image for a2
16:33:48 <utlemming> arosales: except raring is exempted from that cadence until post-GA
16:34:04 <jamespage> utlemming, I was hoping you might say that :-)
16:34:20 <arosales> utlemming: ah, good point for dev
16:35:07 * arosales apologizes for the incorrect info there for raring.  Thanks for the correction utlemming :-)
16:35:24 <arosales> I think we just need to notify the release team we want to opt in for A2
16:36:00 <smoser> rbasak, i dont know about cd images.
16:36:09 <smoser> i personally find the excercise useful
16:36:21 <smoser> and think that by actually tryint to do things, we'll find lots of fallout
16:37:41 <rbasak> OK sounds like most are in favour of a cloud A2 image anyway
16:37:54 <rbasak> smoser: do you want to take an action to push that forwards?
16:38:08 <smoser> sure.
16:38:31 <rbasak> #action smoser to push A2 cloud image forwards
16:38:31 * meetingology smoser to push A2 cloud image forwards
16:38:46 <rbasak> Anything else for Open Discussion?
16:38:55 <utlemming> rbasak: actually that should be my action
16:39:38 <rbasak> utlemming: ok we'll make it your action. Not sure how to tell meetingology that though :-)
16:39:49 * rbasak will fix it in the minutes
16:40:03 <rbasak> #topic Announce next meeting date and time
16:40:10 <rbasak> The next meeting will be at Tue, 5 Feb 2013 16:00:00 +0000. The chair will be jamespage!
16:40:15 <jamespage> w00t!
16:40:21 <jamespage> thanks rbasak
16:40:23 <rbasak> #endmeeting