18:05:06 <tgm4883> #startmeeting Ubuntu-TV Community Meeting
18:05:06 <meetingology> Meeting started Fri Jan 25 18:05:06 2013 UTC. The chair is tgm4883. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
18:05:06 <meetingology>
18:05:06 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
18:05:22 <tgm4883> #chair tgm4883 mhall119
18:05:22 <meetingology> Current chairs: mhall119 tgm4883
18:05:52 <tgm4883> So since this is our first community meeting, it's a bit unstructured
18:06:09 <tgm4883> #topic Community Questions
18:06:26 <tgm4883> Are there any questions from anyone in the community?
18:06:49 <steve_fi> I have a few, can just fire them all out?
18:06:56 <tgm4883> fire away
18:07:20 <tgm4883> I'll make subtopics for them, so it's well organized
18:07:49 <steve_fi> according to the wiki, you still need unity 2d to get UbuntuTV to work, but it seems that Ubuntu is moving from that ... is there any plans to support it in unity3d any time soon?
18:08:06 <tgm4883> #subtopic according to the wiki, you still need unity 2d to get UbuntuTV to work, but it seems that Ubuntu is moving from that ... is there any plans to support it in unity3d any time soon?
18:08:32 <tgm4883> hmm, I'm assuming that meetingology got that
18:08:43 <tgm4883> I've got no input on that question. mhall119?
18:08:45 <mhall119> steve_fi: yes, since last year the efforts have been focused on re-writing everything in Nux and Unity 3d, but it's not been a very easy process
18:09:47 <tgm4883> AFAIK, bobweaver works on most of that. Unfortunately he isn't here
18:10:00 <mhall119> yeah, he's been the only one working on it
18:10:06 <tgm4883> jhop said he'd be a little late as well, although IDK if he knows any more
18:10:26 <mhall119> various issues with the compexity of compix and the lack of good Nux documentation has been holding it back
18:10:28 <tgm4883> lastly, I also pinged willcooke about the meeting, but didn't hear back
18:10:46 <steve_fi> ah ok, next is just does anyone know if the current build of UbuntuTV works at all on Raring?
18:11:05 <tgm4883> #subtopic does anyone know if the current build of UbuntuTV works at all on Raring?
18:11:29 <tgm4883> I'd say it's doubtful. But again, a question for bobweaver
18:11:32 <mhall119> I think bobweaver has the unity2d version working in Quantal now, and available in PPA that makes it easier to install and try
18:11:37 <bobweaver> steve_fi, no I or at least I dont. also the phone uses qml so once the phone code is released then there is that
18:11:50 <tgm4883> o/
18:11:51 <bobweaver> everything that I have is 12.04
18:11:53 <steve_fi> ah ok, thanks for the information!
18:11:53 <bobweaver> yo
18:12:11 <mhall119> hi bobweaver
18:12:13 <bobweaver> hello
18:12:52 <tgm4883> steve_fi, more questions?
18:13:07 <steve_fi> Nope, that's all for now thanks
18:13:13 <tgm4883> ok
18:13:18 <tgm4883> anyone else have any questions?
18:13:54 <tgm4883> Lets move on to status updates, and we'll ask for questions again at the end
18:14:04 <tgm4883> #topic Status Updates
18:14:36 <tgm4883> bobweaver, any updates?
18:15:12 <bobweaver> as far as ?
18:15:22 <tgm4883> bobweaver, anything you want to update
18:16:43 <bobweaver> nope maybe that I will be just doing things(coding) for fun and the "heck" of it . until the phone goes public. maybe I have a lot of personal things going on
18:17:22 <tgm4883> ok
18:17:25 <tgm4883> mhall119, anything to update
18:18:08 <mhall119> no, but hopefully we'll have more to report once the Phone code is public and we can start getting an idea of how it will integrate with desktop and TV
18:18:24 <tgm4883> ok
18:18:48 <tgm4883> DVR/Guide update
18:19:17 <tgm4883> I made a large push this week with the guide scope. I'd say it is 95% done.
18:19:44 <tgm4883> I still need to get a guide lens written, as I'm still using the videos lens for it
18:19:54 <tgm4883> It also needs packaged
18:20:37 <tgm4883> I'll need to figure out how to package a python library as well. The library for accessing the mythtv services is probably only 30% done, but it's the 30% we need :)
18:21:10 <mhall119> tgm4883: I can try and help with that
18:21:18 <tgm4883> 100% done would mean supporting everything the services API allows, but we won't use most of that for Ubuntu TV so we can consider that portion complete
18:21:26 <tgm4883> mhall119, that would be very helpful :)
18:21:45 <tgm4883> I was going to do a video this morning showing off the features, but that didn't happen
18:21:55 <tgm4883> I will do one soon though
18:22:07 <tgm4883> now that the guide scope is mostly finished
18:22:19 <tgm4883> #action tgm4883 to make video showing mythtv features
18:22:19 * meetingology tgm4883 to make video showing mythtv features
18:22:51 <tgm4883> The DVR scope is as it was last week. 95% done
18:23:07 <tgm4883> The last 5% on both scopes will come after packaging and user testing
18:23:28 <tgm4883> #action tgm4883 mhall119 package mythtvservices library and both mythtv scopes
18:23:28 * meetingology tgm4883 mhall119 package mythtvservices library and both mythtv scopes
18:23:56 <bobweaver> tgm4883, what are you targetin for that lens ?
18:24:09 <tgm4883> bobweaver, what do you mean?
18:24:13 <tgm4883> what version?
18:24:15 <bobweaver> version of Ubuntu ?
18:24:28 <tgm4883> well, we'll need an update from mhall119 on that
18:24:33 <tgm4883> mhall119, did that bug get sorted?
18:24:51 <mhall119> tgm4883: the gobject dee stuff?
18:25:02 <tgm4883> yea
18:25:03 <tgm4883> bug 1096708
18:25:05 <ubottu> bug 1096708 in dee (Ubuntu) "'SharedModel' object has no attribute 'append' using Python 3 on 12.04" [Undecided,New] https://launchpad.net/bugs/1096708
18:25:23 <mhall119> I pinged some folks about it, but I guess they haven't looked into it yet
18:25:43 <tgm4883> bobweaver, to answer your questions, the scopes currently work on 12.10 and above. If that bug gets fixed, then it will work on 12.04 and above
18:27:42 <tgm4883> For anyone unaware, Unity lens/scopes work across platforms. So these lens/scopes I'm writing can be used in a regular Ubuntu Unity Desktop
18:28:16 <tgm4883> That's about all the update I have
18:28:21 <tgm4883> Any other updates from anyone?
18:29:12 <tgm4883> Guess not
18:29:21 <tgm4883> In that case, I'm going to open it back up for questions
18:29:32 <tgm4883> #topic Community questions/comments/concerns
18:29:47 <mhall119> thanks tgm4883!
18:29:57 <tgm4883> If anyone has any questions/comments/concerns/ideas/etc, now is the time to shout them out
18:32:21 <zuric> Hi, what the status of Unity 3D portage ?
18:33:10 <mhall119> zuric: stalled for now, we're waiting to see what is going ot happen with the QML Phone shell
18:33:19 <tgm4883> zuric, that was answered earlier and will be available in the logs. But a short recap... what mhall119 said
18:33:53 <zuric> ok thanks
18:34:06 <Pajn> Is any community effort wanted at this time?
18:34:25 <mhall119> Pajn: absolutely
18:34:44 <steve_fi> is help wanted on a specific version of Ubuntu?
18:35:10 <steve_fi> with regards to testing and submitting bugs?
18:35:15 <tgm4883> Community help is always wanted. I'd say we're at a point where we can actually accept help now
18:35:35 <tgm4883> previously, we weren't really in a position to accept community help, as there wasn't a whole lot to test
18:36:04 <mhall119> steve_fi: there isn't a whole lot to test atm, you can try tgm4883's MythTV scopes if you have a MythTV backend
18:36:09 <tgm4883> at least for me, I'll get the mythtv stuff packaged this week with mhall119's help
18:37:02 <bobweaver> for every one that would like to try out the newest code that I have been making you can it is built almost daily
18:37:10 <bobweaver> the ppa is u2t
18:37:14 <bobweaver> I will get link
18:37:32 <bobweaver> https://launchpad.net/~u2t/+archive/bleedingedge
18:37:49 <mhall119> also anybody who wants to hack on that
18:37:59 <mhall119> it's Qt/QML right?
18:38:11 <bobweaver> that in no way is going to be the UBuntu TV but I am sure that there is going to be things that are intergrated
18:38:27 <bobweaver> yeah that is unity 2d
18:38:47 <bobweaver> there is all sorta beta code up in there
18:38:54 <mhall119> so anybody who wants to experiment with some UI stuff, you can use that branch
18:38:57 <bobweaver> but that is like a playground
18:39:14 <bobweaver> yeah I have not pushed branch
18:39:34 <bobweaver> latest things that I have done to that are as follows
18:40:25 <bobweaver> made so one can switch launcher to rght or left, added previews , made new lens view and a full dbus settings changer
18:40:53 <bobweaver> add welcome screen mock up (what I think is going to be phone )
18:41:02 <bobweaver> that will be nice to look at
18:41:46 <bobweaver> but if there is anyone that wants to write into 3d have at it But I want nothing to do with NUX or compiz besides in unity2d spread
18:42:49 <bobweaver> there is alot things that need to be know about the phone only time will tell
18:43:08 <bobweaver> but if qml will be real easy to tie in
18:44:26 <bobweaver> but if anyone wants to hack at that with me have at it.
18:45:08 <bobweaver> I gotta run thanks mhall119 and tgm4883 and everyone else. sorry about early this week (I have a lot going on (personal))
18:45:26 <tgm4883> If anyone has any questions/comments/concerns/ideas/etc, now is the time to shout them out
18:51:06 <tgm4883> ok, since we're getting toward the end of our time and nobody has asked any more questions I'm going to wrap this up in about 2 minutes
18:51:18 <tgm4883> so if anyone has any questions/comments/concerns/ideas/etc, now is the time to shout them out
18:53:17 <tgm4883> #endmeeting