20:07:25 <JoseeAntonioR> #startmeeting Meeting of the One Hundred Paper Cuts team for 13-01-24
20:07:25 <meetingology> Meeting started Thu Jan 24 20:07:25 2013 UTC.  The chair is JoseeAntonioR. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
20:07:25 <meetingology> 
20:07:25 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
20:07:33 <JoseeAntonioR> #chair notgary
20:07:33 <meetingology> Current chairs: JoseeAntonioR notgary
20:07:44 <notgary> Ah
20:08:07 <notgary> JoseeAntonioR: now that's quite neat :0
20:08:09 <notgary> :)
20:08:26 <notgary> JoseeAntonioR: thanks for sorting that out for me :)
20:08:35 <JoseeAntonioR> Agenda for today is at https://wiki.ubuntu.com/OneHundredPaperCuts/Meetings/24Jan2013
20:08:40 <JoseeAntonioR> no probs
20:09:47 <notgary> If anyone hasn't yet read the agenda, can you please take a couple of minute now to do so
20:10:36 <notgary> first item
20:11:01 <notgary> #topic Review of previous meeting minutes
20:11:49 <notgary> Last time we decided to focus the project on the foundation UI technologies in Ubuntu
20:12:05 <notgary> So GTK+ and Compiz will be our primary targets
20:12:28 <notgary> the idea being to work on the apps that use them, and try and fix the bugs in the foundation so other apps can benefit
20:13:00 <notgary> William Hua (attenuate) from the desktop team kindly volunteered to help us work on GTK issues
20:13:17 <notgary> We also decided to create and maintain our own PPA
20:13:33 <notgary> where we would keep scripts and tools that will helps us get our job done a lot easier
20:14:28 <notgary> We decided that, in order to get design input on paper cuts, we should assign them to jnick_tait, a project manager on the design team, who would delegate them to another designer
20:14:37 <notgary> and last of all
20:15:03 <notgary> we decided that it would be better to use #ubuntu-desktop as out main irc channel
20:15:07 <notgary> instead of our own
20:15:19 <notgary> so we were not isolated from the rest of the community in our own little corner
20:15:35 <notgary> that's the minutes from the previous meeting
20:15:57 <notgary> Is everyone happy that that's how things went down last time?
20:17:00 <notgary> Heh
20:17:28 <notgary> Guess no-ones here from last time :)
20:17:37 <notgary> #accepted Review of previous meeting minutes
20:18:01 <DiegoTc> +1
20:18:22 <notgary> Oh yeah, voting would probably be better for these :P
20:18:27 <notgary> Lets try that
20:18:52 <notgary> #vote Acceptance of the minutes of the last meeting
20:18:52 <meetingology> Please vote on: Acceptance of the minutes of the last meeting
20:18:52 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
20:18:58 <notgary> +1
20:18:58 <meetingology> +1 received from notgary
20:19:43 <notgary> DiegoTc: Now's your chance to +1 :)
20:19:57 <DiegoTc> +1
20:19:57 <meetingology> +1 received from DiegoTc
20:20:12 <notgary> Anyone else here for the paper cuts meeting wanting to vote?
20:20:37 <notgary> guess not :P
20:20:40 <notgary> #endvote
20:20:40 <meetingology> Voting ended on: Acceptance of the minutes of the last meeting
20:20:40 <meetingology> Votes for:2 Votes against:0 Abstentions:0
20:20:40 <meetingology> Motion carried
20:21:03 <notgary> Item 2 was added by a person who's not here yet, so we'll move onto item three
20:21:11 <notgary> #topic Developer week
20:21:33 <notgary> This coming tuesday
20:21:53 <notgary> I'll be giving a developer week session on the paper cuts project on Ubuntu on air
20:22:17 <notgary> I'll be doing the speaking on the stream and questions will be taken in #ubuntu-classroom-chat
20:22:30 <notgary> I've got a list of talking points here https://wiki.ubuntu.com/OneHundredPaperCuts/Events/DeveloperWeek2013
20:22:46 <notgary> And my plan was to talk around them
20:23:00 <notgary> The list is not complete, and will still be in flux probably right up until the last minute
20:23:14 <notgary> But does anyone have anything they think should be covered that isn't there?
20:23:40 <DiegoTc> Give me some minutes to check it out
20:23:47 <notgary> Cool
20:24:15 <DiegoTc> I suppose this Fixing paper cuts
20:24:44 <notgary> What about it?
20:26:16 <notgary> DiegoTc: What about fixing paper cuts?
20:27:42 <notgary> Is guess DiegoTc 's AFK just now. Anyone else got a thought about the current plans for developer week?
20:28:42 <DiegoTC> Hi
20:28:46 <notgary> Hey :)
20:28:49 <DiegoTC> sorry laptop when of
20:28:58 <notgary> No worries
20:29:13 <notgary> What are your thoughts on the current developer week plans?
20:29:25 <DiegoTC> So I suppose that in this part Fixing paper cuts
20:29:39 <DiegoTC> you wil talk about how to fix bugs?
20:29:53 <DiegoTC> that have been assign or no?
20:30:44 <notgary> The process you need to go through to get a bug fixed in Ubuntu, including getting patches merged upstream. the process of fixing a paper cut is very similar to the process of fixing a normal bug in Ubuntu, so most it will be covering those processes again
20:30:57 <notgary> I won't go into the details of specific apps
20:31:03 <notgary> Or of specific bugs
20:31:26 <notgary> That's all
20:31:26 <DiegoTC> well long time ago i haven't read the documentation of fixing bugs
20:31:48 <notgary> It's changed quite a bit over the past few years
20:31:52 <DiegoTC> But last time I sow there is missing something important
20:32:02 <DiegoTC> How to configure your working enviroment
20:32:13 <notgary> Hmm
20:32:13 <DiegoTC> you know the code is in launchpad
20:32:20 <DiegoTC> but okay whats next
20:32:34 <notgary> That is a good point
20:32:40 <DiegoTC> documentation wasn't clear for that
20:32:44 <DiegoTC> so lets say
20:32:51 <DiegoTC> I want to fix the title of compiz
20:33:03 <DiegoTC> okay, but what I need to work on compiz code?
20:33:15 <DiegoTC> I have the code
20:33:21 <DiegoTC> how do i configure it
20:33:29 <DiegoTC> is something special
20:33:37 <DiegoTC> is there any specific IDE
20:33:45 <DiegoTC> or gedit is good for that
20:34:22 <DiegoTC> that's my opinion
20:34:39 <notgary> It's a pretty good one though
20:35:04 <notgary> Over the past couple of months we've been setting up an area on the wiki that we call our Dojo - https://wiki.ubuntu.com/OneHundredPaperCuts/PaperCutsNinja/Dojo/GTK3
20:35:24 <notgary> It's going to cover tips and ticks to working with the different apps and packages that we're going to be working on
20:36:02 <notgary> In the run up to the session, we could make sure there's a bit there for configuring your development environment
20:36:33 <notgary> Since most of the apps we'll touch will be based on GTK, there should be a lot of steps in common between each one
20:36:42 <notgary> Perhaps a weekend project :P
20:36:47 <notgary> What do you think?
20:37:22 <DiegoTC> yeap
20:37:31 <DiegoTC> that sounds a good idea
20:38:31 <notgary> #vote Write a guide to configuring a development environment for working with paper cuts
20:38:31 <meetingology> Please vote on: Write a guide to configuring a development environment for working with paper cuts
20:38:31 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
20:38:35 <notgary> +1
20:38:35 <meetingology> +1 received from notgary
20:38:48 <DiegoTC> +1
20:38:48 <meetingology> +1 received from DiegoTC
20:38:58 <notgary> Anyone else think that's a good idea?
20:39:26 <notgary> The rest of them all think it's rubbish :)
20:39:30 <notgary> #endvote
20:39:30 <meetingology> Voting ended on: Write a guide to configuring a development environment for working with paper cuts
20:39:30 <meetingology> Votes for:2 Votes against:0 Abstentions:0
20:39:30 <meetingology> Motion carried
20:39:48 <notgary> Item 4
20:39:53 <notgary> #topic Getting more people involved
20:40:20 <notgary> Getting more people involved in the project is critical to it's long term survival
20:40:41 <notgary> DiegoTc: As a new contributor, how did you end up getting involved?
20:41:13 <DiegoTC> notgary: you mean how did I discover papercut
20:41:25 <DiegoTC> or how I plan to get involved?
20:42:02 <notgary> How did you discover it and what was it that made you want to get involved. If we can identify the things that are attracting people right now then we can do more of that in the future.
20:43:05 <DiegoTC> Ahh
20:43:10 <DiegoTC> I read your article
20:43:13 <DiegoTC> in planet.ubuntu
20:43:34 <notgary> Which one? I've been shamelessly spamming Planet with paper cut article :)
20:43:42 <DiegoTC> the first one
20:43:58 <DiegoTC> helping in ubuntu and no one notice it
20:44:09 <DiegoTC> that all cool people are in unity
20:44:28 <notgary> This one? http://www.notgary.com/2013/01/want-to-get-involved-with-ubuntu-get.html
20:44:43 <DiegoTC> yes
20:45:02 <notgary> That one seems to be the most popular, and I did write it differently to the rest
20:45:32 <DiegoTC> Actually I have always want to start helping fixing bugs, but lets said time, work, college, and each time I download the code and didn't find no place to go to configure I just left it that way
20:46:12 <notgary> You're just the person I've been aiming these at
20:46:22 <notgary> People who want to help out
20:46:27 <notgary> But don't get round to it
20:46:46 <notgary> I figure that if I keep reminding people that we're here
20:46:53 <notgary> They'll eventually come and check us out.
20:47:40 <notgary> I think we need to set up our own little internal project for getting more people involved
20:47:57 <notgary> It's a pretty big task (persuading people to come along0
20:48:25 <notgary> and it'll involved more time and effort than we can put in with the 15 minutes we have left in this meeting
20:48:58 <notgary> So what don't we decide here that we need a real plan for attracting new contributors
20:49:15 <notgary> and discuss it outside of the meeting, on the mailing list and in #ubuntu-desktop
20:49:30 <notgary> How does that sound?
20:50:08 <DiegoTC> that sounds great
20:50:33 <notgary> #vote Devise and implement a strategy for getting more people involved in the project
20:50:33 <meetingology> Please vote on: Devise and implement a strategy for getting more people involved in the project
20:50:33 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
20:50:37 <notgary> +1
20:50:37 <meetingology> +1 received from notgary
20:50:54 <DiegoTC> +1
20:50:54 <meetingology> +1 received from DiegoTC
20:51:04 <notgary> Anyone else wanna chip in their vote?
20:51:24 <notgary> Nope? Your loss.
20:51:28 <notgary> #endvote
20:51:28 <meetingology> Voting ended on: Devise and implement a strategy for getting more people involved in the project
20:51:28 <meetingology> Votes for:2 Votes against:0 Abstentions:0
20:51:28 <meetingology> Motion carried
20:51:41 <notgary> Next one should be a short one
20:51:47 <notgary> #topic Meetings
20:51:53 <notgary> After this meeeting
20:52:08 <notgary> I think we should start having regular meetings once a week
20:52:23 <notgary> I think there's been such a low turnout this time because we're not having regular meetings
20:52:33 <notgary> so they're not fresh in people's minds
20:52:41 <DiegoTC> well I am not friend or regular meeting
20:52:51 <notgary> and they haven't gotten into a routine of attending them
20:52:53 <DiegoTC> its 14:53 right now
20:52:55 <notgary> Why not?
20:53:02 <DiegoTC> I am on work :p shouldn't be here
20:53:06 <notgary> Ah
20:53:30 <notgary> We also have a regular contributor who fixes a lot of bugs in GTK apps who live in Australia
20:53:36 <notgary> and so cannot attend any meeting
20:54:02 <DiegoTC> Meeting probably on Saturday?
20:54:02 <notgary> They would be held at 1900 UTC (an hour before this one started tonight)
20:54:20 <notgary> If people are up for a weekend meeting, then that would be fine
20:55:18 <notgary> I figured that contributors will be scattered around the world in many different timezones, so no matter what time we chose, someone would be unhappy
20:55:33 <notgary> What we can vote on then (since we're running out of time and you have to get back to work)
20:55:57 <notgary> is to speak with the rest of the contributors and find out what sort of time they would like
20:56:21 <notgary> #vote Decide on a regular meeting time
20:56:21 <meetingology> Please vote on: Decide on a regular meeting time
20:56:21 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
20:56:25 <notgary> +1
20:56:25 <meetingology> +1 received from notgary
20:57:05 <DiegoTC> +0
20:57:05 <meetingology> +0 received from DiegoTC
20:57:10 <notgary> #endvote
20:57:10 <meetingology> Voting ended on: Decide on a regular meeting time
20:57:10 <meetingology> Votes for:1 Votes against:0 Abstentions:1
20:57:10 <meetingology> Motion carried
20:57:24 <notgary> So there are two items left on the agenda that we won't cover tonight
20:57:47 <notgary> The first, item 2, was added by someone who isn't here to discuss it, so I'll move it to the next meeting's agenda for him
20:58:09 <notgary> and the second is more of me just pontificating about what sort of future I see for the project
20:58:15 <notgary> which I can do in a blog post
20:58:16 <notgary> :)
20:58:25 <notgary> So unless you have anything else to add
20:58:30 <notgary> I think we can conclude this meeting
20:58:39 <DiegoTC> yeap
20:58:43 <notgary> Cool
20:58:43 <DiegoTC> thats fine for me
20:58:48 <notgary> #endmeeeting
20:58:56 <notgary> #endmeeting