19:05:43 <cody-somerville> #startmeeting
19:05:43 <meetingology> Meeting started Mon Jan  7 19:05:43 2013 UTC.  The chair is cody-somerville. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:05:43 <meetingology> 
19:05:43 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
19:06:00 <cody-somerville> #link https://wiki.ubuntu.com/DeveloperMembershipBoard/Agenda
19:06:20 <cody-somerville> #topic Review of previous action items
19:06:51 <cody-somerville> Before we begin, do we have quorum?
19:07:01 <micahg> o/
19:08:03 <Laney> |o_
19:08:17 <cody-somerville> Cool. Looks like we do.
19:08:25 <cody-somerville> #subtopic laney to describe criteria and process for lightweight amending of ppu rights (for dds)
19:08:39 <Laney> #link http://people.ubuntu.com/~laney/dynamic-ppu-procedure.txt
19:09:04 <Laney> Since I just did this now, we should talk about it next meeting once everyone has had the chance to read it
19:09:11 <cody-somerville> Agreed.
19:09:42 <cody-somerville> #action DMB members to read proposal and be prepared to vote next meeting on next action
19:09:42 * meetingology DMB members to read proposal and be prepared to vote next meeting on next action
19:09:57 <cody-somerville> #subtopic micahg to ask docs people if they want to apply for a packageset
19:10:09 <micahg> done by e-mail
19:11:14 <cody-somerville> #topic PerPackageUploader Applications
19:11:47 <cody-somerville> #subtopic Bjoern Michaelsen for libreoffice
19:11:58 <cody-somerville> #link https://wiki.ubuntu.com/BjoernMichaelsen/DeveloperApplication
19:12:04 * Sweetshark reporting in.
19:12:07 * bdrung arrives
19:12:14 <Laney> ah good
19:12:18 <cody-somerville> Sweetshark: Hello. Please introduce yourself and your application.
19:12:22 * micahg though stokachu was first..
19:13:13 <Sweetshark> cody-somerville: Hi, Im Bjoern Michaelsen, Im maintaining LibreOffice since Natty and apply for package upload right now. ;)
19:13:39 <Sweetshark> You will find the details in the link.
19:14:31 <Sweetshark> (Probably more than enough, If you have questions to something specific, please ask)
19:15:20 <cody-somerville> Sweetshark: Do you have any other upload permissions to Ubuntu at this time?
19:15:27 <Sweetshark> cody-somerville: no.
19:15:31 <Laney> just FYI, I think I better abstain from this since we're on the same team. There's quorum without me anyway so it doesn't matter.
19:15:44 <cody-somerville> Sweetshark: Have you applied for upload permissions previously?
19:15:48 <Laney> and I have to go out hopefully not for long, as I just explained in private
19:16:22 <Sweetshark> cody-somerville: yes: http://irclogs.ubuntu.com/2012/03/26/%23ubuntu-meeting.html#t19:01
19:17:38 <barry> Sweetshark: can you talk a little bit about what you've done since then, that address some of the issues brought up in the last meeting?
19:20:14 <Sweetshark> barry: well, for micahgs library version bump question, I think I just misunderstood the question. We discussed it quickly on the day after IIRC. Note that in
19:20:22 <Sweetshark> an ironic twist of history LibreOffice will get ABI incompatible _without_ bumping the so version (a long tale).
19:21:01 <barry> Sweetshark: is that documented anywhere?
19:22:44 <Sweetshark> as for more endoresements: you now have seb128 and didrocks in addition, plus the debian maintainer indirectly (its kinda hard to get a direct commitment to anything ubuntu from rene: he is still rather hostile to ubuntu -- he stated 'ubuntu must die' before and after I joined Canonical on public mailing lists to me. Things are getting a lot better now though)
19:22:56 <bdrung> ABI breakage without so version bump?
19:23:33 <Sweetshark> barry: the conversation with micahg or ABI breakage without version bump?
19:23:57 <barry> Sweetshark: abi
19:24:15 <barry> (although maybe you can also update us on the discusion w/micah)
19:24:59 <Sweetshark> barry: sure -- it was discussed on the LibreOffice ESC meeting over at least a few weeks. I can try to find link for it -- its a complex issue.
19:27:11 <bdrung> Sweetshark: do you see yourself as Ubuntu representative?
19:27:47 <Sweetshark> barry: tl;dr: LibreOffice tries to do minimal changes to the ABI, thus most stuff wont break, but as there is a big ecosystem of (closed source or inhouse) extension for LO/OOo it would be unhelpful to break them indescriminatly esp. if that makes LO and OOO extensions uncompatible,
19:27:52 <Sweetshark> bdrung: sure
19:29:16 <Sweetshark> bdrung: see me wearing Ubuntu shirts at the LibreOffice conference. Or staying longer to also take part in the Ubucon representing all of Ubuntu/Canonical and LibreOffice.
19:29:52 <bdrung> Sweetshark: the upload history indicates a different perspective. the last uploads to raring was 1.5 month ago.
19:29:58 <Sweetshark> (LibreOffice conference and Ubuncon happened back to back in Berlin last year)
19:30:13 <cody-somerville> Five more minutes for questions.
19:30:21 <bdrung> we have a rc2 version in the archive instead of the latest release (which is a bug fix release)
19:31:48 <Sweetshark> bdrung: Raring will ship LO 4.0 thus I will upload that. I am working on preparing that package. As LO 4.0 is still in beta, I do that in the LO prereleases PPA until it is deemed stable enough.
19:32:02 <Sweetshark> bdrung: rc2=final
19:32:15 <Sweetshark> final is a renamed rc2
19:32:21 <bdrung> libreoffice has a MRE, but precise stays at 3.5.4 instead of getting 3.5.7 and quantal has 3.6.2 instead of 3.6.4
19:33:37 <Sweetshark> bdrung: Im currently working on 3.5.7. 3.5.7 has a regression against 3.5.4 thus cant be uploaded as is. The 3.5.7 is actually in precise-proposed.
19:34:47 <bdrung> Sweetshark: ah, i didn't saw 3.5.7 in precise-proposed, because it's stuck in the unapproved queue
19:35:12 <cody-somerville> #vote Bjoern Michaelsen for libreoffice PPU
19:35:12 <meetingology> Please vote on: Bjoern Michaelsen for libreoffice PPU
19:35:12 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
19:35:31 <Sweetshark> bdrung: same essentially for 3.6.4/quantal IIRC ...
19:36:04 <barry> +1 [on the strength of the endorsements]
19:36:04 <meetingology> +1 [on the strength of the endorsements] received from barry
19:36:42 <micahg> -1, lack of devel release uploads, still problems with with some uploads
19:36:42 <meetingology> -1, lack of devel release uploads, still problems with with some uploads received from micahg
19:37:41 <bdrung> +0 lack of devel release uploads, i want to be more confident when granting PPU rights for libreoffice. i am willing to sponsor that package.
19:37:41 <meetingology> +0 lack of devel release uploads, i want to be more confident when granting PPU rights for libreoffice. i am willing to sponsor that package. received from bdrung
19:38:42 <Sweetshark> micahg: what devel-release upload did you want to see? 4.0 alpha and beta?
19:38:54 <cody-somerville> +1 Based on endorsements despite concerns shared by colleagues on DMB. Length of contribution and demonstrable experience with upstream project also contributing factors.
19:38:54 <meetingology> +1 Based on endorsements despite concerns shared by colleagues on DMB. Length of contribution and demonstrable experience with upstream project also contributing factors. received from cody-somerville
19:39:01 <stgraber> +0 [I don't like the idea that we should grant PPU just because nobody wants to actually take the time to review this package. If we never had an issue with it, that'd be fine, but that's far from being the case.]
19:39:01 <meetingology> +0 [I don't like the idea that we should grant PPU just because nobody wants to actually take the time to review this package. If we never had an issue with it, that'd be fine, but that's far from being the case.] received from stgraber
19:39:01 <micahg> Sweetshark: well, if not that, 3.6.4
19:39:29 <bdrung> Sweetshark: either 3.6.4 or a pre-release of 4.0 that is stable enough for wider testing
19:40:14 <cody-somerville> #endvote
19:40:14 <meetingology> Voting ended on: Bjoern Michaelsen for libreoffice PPU
19:40:14 <meetingology> Votes for:2 Votes against:1 Abstentions:2
19:40:14 <meetingology> Motion carried
19:40:37 <cody-somerville> Sweetshark: Unfortunately based on the DMB voting procedure, your application was not successful at this time.
19:41:35 <bdrung> Sweetshark: ping me if you need a sponsor
19:42:38 <cody-somerville> Sweetshark: A member of the DMB will be in contact to help provide you with pointers on what is required for a subsequent application to be successful.
19:42:53 <cody-somerville> #topic Ubuntu Core Developer Applications
19:43:14 <cody-somerville> #subtopic Adam Stokes for Ubuntu Core Developer
19:43:38 <cody-somerville> #link https://wiki.ubuntu.com/AdamStokes
19:43:58 <cody-somerville> stokachu: Hello. Please introduce yourself and your application.
19:44:56 <stokachu> Hi, names Adam Stokes, I work in Canonical's Sustaining Engineering(SEG). Im applying for core dev in order to further SEG position in maintenance of existing Ubuntu technologies.
19:45:33 <stokachu> As the wiki states I've been contributing to opensource for roughly 8 years and am familiar with processes from both RHEL, Fedora, and Ubuntu
19:45:51 <stokachu> Obiously, since joining Canonical it has been all Ubuntu
19:46:37 <bdrung> stokachu: anything you dislike at Ubuntu and we could learn from RHEL and Fedora?
19:46:56 <stokachu> To be honest, the build system at Fedora is pretty cool
19:47:17 <bdrung> what makes the build system cool?
19:48:59 <stokachu> They use git exclusively with some lookaside caches for the source, a clean interface for creating updates (bohdi), and the build system (koji) which seems to handle builds in almost realtime
19:49:44 <stokachu> For RHEL specifically there are a set of tools which automated RPM verification and errata updates which streamlines the package update process
19:50:20 <cody-somerville> That does sound very interesting.
19:50:32 <stokachu> FYI I dont dislike Ubuntu way of doing things either
19:50:35 <stokachu> :)
19:50:48 <cody-somerville> Any thoughts of getting involved with the Ubuntu build side of things?
19:51:12 <stokachu> Honestly, I have this idea of trying to replicate a build system using git for Ubuntu
19:51:25 <stokachu> but thats a task that'll have to wait until I have more time
19:51:43 <micahg> we've had a blueprint item of sorts from building out of bzr for several cycles
19:52:07 <stokachu> One thing I do think we need since we are entering more of the enterprise market is for an errata system of some sort
19:52:30 <stokachu> that could be attached to package updates for customers/community to understand more clearly
19:52:45 <bdrung> what's the advantage of an errata system over a bug tracker?
19:53:20 <stokachu> Errata system would be simpler overview of what was addressed and would list the bugs associated with the fix
19:53:38 <stokachu> also any cve's addressed etc
19:53:50 <stokachu> along with documentation on how to get those updates and where to go for support
19:54:01 <barry> stokachu: have you used udd and bzr much?  dvcs details aside, are they comparable?
19:54:12 <stokachu> Also we could integrate with documentation team to write a more user friendly sysnopsis of what was fixed
19:54:32 <bdrung> yes, some changelog entries are not user friendly :)
19:55:17 <stokachu> barry: there are similarities and I can say they are comparable as it was easy for me to migrate from a Fedora environment to Ubuntu development
19:57:09 <stokachu> As far as changes go i would like to see a formal procedure for sru's whether it be through merge proposals or debdiffs
19:57:22 <stokachu> seems to be the preference of the one doing the sponsorship
19:57:37 <bdrung> stokachu: have done any sync or merges? do you collaborate with Debian?
19:58:36 <bdrung> stokachu: some sponsors prefer merge proposals and others prefer debdiffs. getting a consensus is hard
19:58:37 <stokachu> I haven't done any collaboration with Debian yet, however, I do contribute heavily to sosreport and did the addition of Debian support. Eventually, I was going to send that to Debian for inclusion
19:58:42 <cody-somerville> stokachu: The DMB would like to ask if you'd consider changing your application today from core-dev to Ubuntu Contributing Developer.
19:59:07 <stokachu> Ive been given mixed directions on which one to apply for
19:59:17 <stokachu> Contributing Developer doesn't have upload rights I was told
19:59:39 <cody-somerville> It does not. However, we think it would be a good stepping stone.
19:59:54 <cody-somerville> An application for UCD today would have a higher probability of success.
20:00:25 <cody-somerville> It's unanimously agreed (albeit unofficially ofcourse) that you're core-dev material but your application is unfortunately lacking at this time.
20:00:34 <stokachu> So what would that get me for UCD? And how would that help me in providing a better support experience to our paying customers?
20:00:39 <micahg> it grants Ubuntu membership and acknowledges your dev contributions to date are worthy of that membership
20:01:34 <micahg> stokachu: why did you apply for membership in the first place?
20:02:54 <bdrung> core-dev are expected to be generalist with experience from syncs/merges to SRUs
20:03:38 <stokachu> It is part of my goal to not only benefit the community from my contributions but more importantly give customers added benefit of having an active Ubuntu engineer fixing their issues
20:04:05 <stokachu> I guess im applying for UCD at this time
20:04:19 <cody-somerville> stokachu: The developer membership board is a body that recognizes contributions to the Ubuntu project and are stewards of upload privileges to the benefit of the Ubuntu project. Providing support to Canonical's paying customers is not under our purview or within our scope of direct consideration though is recognized.
20:05:27 <stokachu> Ill reapply for core-dev when I have more syncs/merges from Debian then
20:05:43 <cody-somerville> stokachu: I think such an endeavour would be HIGHLY successful. Thank you. :)
20:05:56 <cody-somerville> The board will now consider your application for UCD and vote.
20:06:15 <cody-somerville> #vote Ubuntu Contributing Developer for Adam Stokes
20:06:15 <meetingology> Please vote on: Ubuntu Contributing Developer for Adam Stokes
20:06:15 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
20:06:28 <barry> +1
20:06:28 <meetingology> +1 received from barry
20:06:30 <micahg> +1
20:06:30 <meetingology> +1 received from micahg
20:07:12 <cody-somerville> +1 Excellent application. Strong endorsements. On clear path to becoming core-dev in the future.
20:07:12 <meetingology> +1 Excellent application. Strong endorsements. On clear path to becoming core-dev in the future. received from cody-somerville
20:07:13 <bdrung> +1 [ i will be happy to see you again in some months applying for core-dev with some experience with syncs/merges ]
20:07:13 <meetingology> +1 [ i will be happy to see you again in some months applying for core-dev with some experience with syncs/merges ] received from bdrung
20:07:23 <stgraber> +1
20:07:23 <meetingology> +1 received from stgraber
20:08:31 <cody-somerville> #endvote
20:08:31 <meetingology> Voting ended on: Ubuntu Contributing Developer for Adam Stokes
20:08:31 <meetingology> Votes for:5 Votes against:0 Abstentions:0
20:08:31 <meetingology> Motion carried
20:08:46 <cody-somerville> Congratulations stokachu.
20:09:04 * barry has to leave
20:09:05 <stokachu> sweet! thanks all
20:09:16 <Laney> congrats
20:09:39 <stokachu> Will someone email me any recommended paths I should look at wrt Debian syncs/merges?
20:09:57 <stokachu> My thinking is to go 4-6 months and re-apply after I've done some of that work
20:10:41 <cody-somerville> stokachu: A member of the DMB will send you a quick e-mail after the meeting with some tips.
20:10:48 <cody-somerville> #topic Any Other Business
20:10:50 <stokachu> awesome, thanks for everyone's time
20:10:55 <bdrung> stokachu: i think we should continue this discussion on #ubuntu-devel
20:11:06 <cody-somerville> Any other business before I close the meeting?
20:11:10 <bdrung> yes
20:11:26 <bdrung> 4 DMB members expire on 2013-02-13
20:11:43 <bdrung> we need to have a selection for new members till then
20:12:09 <Laney> Call for nominations now, start voting 2 weeks beforehand
20:12:19 <Laney> or 10 days, or whatever
20:12:23 <Laney> bdrung: do you want to run it?
20:12:29 <Sweetshark> bdrung: I never fail to get sponsors ;). They are just increasingly annoyed by having to sponsor other peoples work, thus asking me to apply. The only thing I _personally_ want the rights for that it also lets me on planet ubuntu.
20:12:33 <Sweetshark> bdrung: there is no time for that. uploading 3.6.4 would require forwardporting (and developing 3.6 on raring in addition to 4.0 on raring, 3.6 on quantal and 3.5 on precise), as seen from the naive uncoordinated update upload of 3.6 to raring which instantly broke (NOT by me). Uploads to a mismatching series (that is anything other than 4.0/raring, 3.6/quantal, 3.5/precise) have to be optional unless we change our policy on the version we
20:12:40 <Sweetshark> bdrung: there is no time for that. uploading 3.6.4 would require forwardporting (and developing 3.6 on raring in addition to 4.0 on raring, 3.6 on quantal and 3.5 on precise), as seen from the naive update upload of 3.6 to raring which instantly broke (not by me). Uploads to a mismatching series (that is anything other than 4.0/raring, 3.6/quantal, 3.5/precise) have to be optional unless we change our policy on the version we want in the re
20:12:47 <Sweetshark> So there were intentionally no uploads to the dev release up until now and only uploads to the prereleases PPA. And that is published and accepted policy.
20:12:54 <bdrung> we had 2 weeks voting time
20:13:13 <Laney> https://wiki.ubuntu.com/CommunityCouncil/Restaffing
20:13:21 <bdrung> Laney: no :)
20:13:30 <Laney> what
20:14:11 <bdrung> i don't want to run the election if someone else will do it
20:15:07 <Laney> oh, ok sure I don't mind
20:15:13 <Laney> unless someone else wants to
20:15:19 <cody-somerville> Sounds good.
20:15:39 <cody-somerville> or wait
20:15:40 <bdrung> thanks Laney for volunteering
20:15:57 <Laney> I am one of those expiring though, if that makes a difference
20:16:04 <cody-somerville> Should election be run by someone expiring/possibly running again?
20:16:10 <Laney> if I decide to run again I'll let someone else do the poll
20:16:21 <cody-somerville> Laney: I think you should run again. :)
20:16:37 <cody-somerville> #action DMB to sort out re-election stuff.
20:16:37 * meetingology DMB to sort out re-election stuff.
20:16:58 <cody-somerville> Thanks folks. Great meeting. Look to ml for minutes and what not later today.
20:17:03 <cody-somerville> #endmeeting