18:05:07 <tgm4883> #startmeeting Ubuntu TV weekly meeting
18:05:07 <meetingology> Meeting started Fri Jan 4 18:05:07 2013 UTC. The chair is tgm4883. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
18:05:07 <meetingology>
18:05:07 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
18:05:34 <tgm4883> The agenda can be found at https://wiki.ubuntu.com/UbuntuTV/Meetings
18:05:45 <tgm4883> Note that there is nothing on the agenda
18:06:15 <CrestedNewt> is BobWeaver in? I don't see him
18:06:29 <tgm4883> we pinged him, but I didn't see him around
18:06:56 <tgm4883> Since there is nothing on the agenda, I'll open the floor to anyone that has anything to say and/or questions or comments
18:07:03 <tgm4883> #topic Open Floor
18:07:32 <mhall119> so, given the holidays since our last meeting, there probably isn't anything new to discuss
18:07:44 <tgm4883> mhall119, my guess as well
18:07:46 <CrestedNewt> Do we know the current status of development?
18:07:55 <CrestedNewt> ie - where are we?
18:08:05 <mhall119> except, well, omg! Phone!
18:08:23 <tgm4883> CrestedNewt, I'm not aware of the current status of the non-mythtv parts
18:08:29 <CrestedNewt> Ubuntu Phone is to be discussed later :D
18:08:35 <mhall119> CrestedNewt: I know bobweaver has been experimenting with different things on the old unity2d code
18:08:43 <mhall119> I don't know if anything new has been done on the unity 3d port
18:09:11 <CrestedNewt> OK, just so that I get this right .....
18:09:21 <mhall119> tgm4883: how is the MythTV scope work going?
18:09:29 <CrestedNewt> Bobweaver is working on the old 2D platform
18:09:40 <mhall119> CrestedNewt: he's been working on both
18:09:51 <CrestedNewt> and he is hoping to have a stable platform with which to move forwards?
18:09:59 <mhall119> he's been porting to Unity 3d, but still using the 2d code for prototyping
18:10:07 <tgm4883> The main scope is great. Playback of content works nicely and looks good
18:10:13 <tgm4883> the guide data parts though....
18:10:23 <mhall119> CrestedNewt: that's the goal, yes
18:10:44 <CrestedNewt> mhall119 - ok that's good news
18:10:49 <mhall119> tgm4883: the main scopes searches already recorded stuff?
18:11:11 <tgm4883> Currently I'm seeing if upstream will add some stuff to the API so I don't have to do a query on each show just to get description
18:11:25 <tgm4883> mhall119, yes, that part works great
18:11:59 <mhall119> tgm4883: you can always just use the title in the search results, and only query for the description if they open it in a preview
18:12:16 <tgm4883> I need to move the servicesapi.py file to it's own package though so I can separate the guide and playback scopes
18:12:40 <tgm4883> mhall119, yea that is what I have it doing now, but then you can only search title/subtitle
18:12:42 <mhall119> tgm4883: cool
18:13:12 <tgm4883> But I'm not adding description back in unless I can get it to a reasonable run time
18:13:17 <mhall119> tgm4883: maybe you can put a bit in the next blog post about your progress and how people can help you with it
18:13:42 <tgm4883> #action tgm4883
18:13:42 * meetingology tgm4883
18:13:59 <mhall119> any screenshot of the TV UI, even the old 2d one, showing results from MythTV would cause some excitement too
18:14:20 <tgm4883> yea I need to work with bobweaver to get a TV UI setup for that
18:14:27 <tgm4883> or have him do a couple screenshots
18:15:47 <mhall119> Any ideas on what we can do with the new phone & SDK to capitalize on some of that buzz for the TV?
18:16:05 * tgm4883 shrugs
18:16:09 <tgm4883> I haven't looked at phone much
18:16:32 <mhall119> it's pretty cool, and the SDK is something that people should use to write TV apps too
18:17:05 <mhall119> I'll talk to bobweaver about maybe getting some screenshots of the example app running on the TV UI, see if it's worth talking about
18:18:11 <tgm4883> it's QML, so bobweaver should be happy
18:18:49 <CrestedNewt> OK, in the UK atm there is a push on http://www.youview.com/features/ and http://go.sky.com/vod/page/tvListing.do
18:18:51 <mhall119> yeah, he's already been in #ubuntu-phone
18:19:47 <CrestedNewt> the sky solution allows video on the move .... but it requires silverlight
18:19:52 <mhall119> tgm4883: your guide scope, is that using MythTV as it's backend?
18:20:00 <tgm4883> mhall119, yes
18:20:29 <mhall119> and can MythTV use the sources CrestedNewt just mentioned?
18:21:00 <tgm4883> mhall119, err, it's not like that
18:21:42 <tgm4883> mhall119, so you can think of mythtv similar to how we're thinking about ubuntu tv (or vice versa). Mythtv has a backend and a frontend (in the case of Ubuntu TV, we're basically just making a UTV a frontend)
18:22:04 <tgm4883> any online sources and such that mythtv could use, would be mythtv frontend plugins
18:22:15 <tgm4883> which don't make sense here, we'd just make them unity scopes
18:22:40 <tgm4883> unless i'm not understanding what these things are
18:23:13 <mhall119> oh, ok, so tv guides aren't being stored in the backend?
18:23:33 <CrestedNewt> both of the sites I posted are 'historical' VOD services.... I was just thinking about the tie in with ubuntu_phone
18:23:45 <tgm4883> yes, the tv guide is stored in the backend, but this looks to be more than just a tv guide
18:24:06 <mhall119> oh, ok
18:24:28 <CrestedNewt> no probs - I just thought that I would clear that up :D
18:24:33 <mhall119> I was mostly interested in just the tv guide data, if MythTV can support multiple sources, then we only need a single source to get it out of MythTV
18:24:52 <mhall119> makes our job easier that way
18:25:25 <tgm4883> mhall119, you should get guide data from the same place that you are scheduling recordings
18:25:29 <tgm4883> so in this case, mythtv
18:26:05 <tgm4883> mythtv supports schedules direct and XMLTV I think
18:26:30 <mhall119> ok
18:26:39 <tgm4883> well, and EPG
18:26:43 <tgm4883> but that sucks in the US
18:27:59 <tgm4883> so with mythtv, you can have multiple sources, and you might have a different set of guide data for each source (which is why I say tie the two together)
18:28:35 <tgm4883> from the UTV POV, the only source if mythtv (and mythtv figures out all the other important stuff)
18:29:45 <mhall119> sounds good to me
18:29:55 <tgm4883> yea the more I look at youview, the more it sounds like it should be a scope
18:30:03 <CrestedNewt> OK, blue sky stuff here for future discussion but I think that it needs to be noted somewhere..... Sky offer this planner http://tv.sky.com/tv-guide#/day/0 and you can then decide to record from this service as well as getting more programme information. The record function is only available if you are a Sky subscriber. DO NOTHING WITH THIS YET but views for later on would be good.
18:31:19 <mhall119> CrestedNewt: where does that record it to? your local hardware, or something on their network?
18:31:58 <CrestedNewt> sends a signal through satellite to your box which has a viewing card. These are linked to your username
18:32:11 <mhall119> ah, ok
18:32:29 <tgm4883> looks like there is a sky DVR box too
18:32:32 <tgm4883> with storage
18:33:00 <CrestedNewt> yes - the top of range box has 1080i output and a 1 TB HDD
18:35:21 <mhall119> alright, any other topics to discuss?
18:35:31 <tgm4883> I've got none
18:35:53 <CrestedNewt> I have none - other than I need to get something to document :D
18:36:17 <mhall119> alright, I'll try and get some information from Canonical's side about how the new Phone stuff might be impacting the TV, and vice-versa, to see how it all should fit together
18:36:27 <mhall119> and we'll get with bobweaver when he's online for some screenshots and stuff
18:36:36 <tgm4883> sounds good
18:36:37 <CrestedNewt> mhall119 - good man!!
18:36:44 <mhall119> alright, thanks guys!
18:36:48 <tgm4883> #endmeeting