07:59:19 <coolbhavi> #startmeeting ubuntu arb meeting
07:59:19 <meetingology> Meeting started Sun Dec  2 07:59:19 2012 UTC.  The chair is coolbhavi. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
07:59:19 <meetingology> 
07:59:19 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
08:00:02 <coolbhavi> ajmitch, here is the agenda: https://wiki.ubuntu.com/AppReviewBoard/Agenda
08:00:24 <ajmitch> yep, I have it open
08:01:35 <ajmitch> it's been awhile since the last meeting & the group has shrunk a little bit, not sure how relevant old action items are
08:02:51 <coolbhavi> ajmitch, yes. So there are a couple of real burning issues: 1) the review process almost seems to be slowed down 2) the dev's who have submitted their packages as a part of app developer showdown are really angry
08:03:45 <ajmitch> yes, I'm sorry that I haven't been doing a lot on the queue lately, I'm guessing that we've had 0 interest from other ubuntu developers to look over packages
08:04:58 <coolbhavi> ajmitch,  thats perfectly fine :-) any thoughts on how to keep the reviews rolling over until we have the new arb process in place?
08:05:07 * ajmitch has been trying to look at tools more than the queue lately, but hasn't got much to show
08:05:34 <ajmitch> there's no easy way to get the reviews done unless we just do them
08:06:20 <ajmitch> even if I get you a queue that has lintian/licensecheck run & builds packages automatically, there's still a fair bit of manual work to do
08:06:44 * coolbhavi too is concentrating on getting arb profile into lintian so we can get another app review week going
08:07:24 <ajmitch> that'll help a bit
08:07:39 <ajmitch> most of the work items I have from UDS are related to tools like this
08:08:20 <coolbhavi> any thoughts of about getting the queue closed for sometime (as in a freeze period) and concentrate on clearing the queue
08:08:31 <coolbhavi> for some time?
08:08:41 <coolbhavi> would that help?
08:08:59 <ajmitch> we don't have a large number of new submissions, I think closing the queue could be seen fairly negatively
08:09:16 <ajmitch> then again, it's not like we could make the reputation much worse :)
08:10:25 <coolbhavi> hmm agreed it has negatives but the queue has around 100+ apps I believe
08:11:29 <ajmitch> we did talk about this at UDS & considering closing the queue to be a bad idea
08:11:49 <ajmitch> do you think we can just pick through the queue for packages that are 99% ready & get those in?
08:12:34 <ajmitch> I'll try & get some of this automation in place asap so that we can see what's low-hanging fruit
08:13:40 <coolbhavi> yes those in pending review and review in progress especially ones from app-developer-showdown might help
08:15:38 <ajmitch> any ideas on convincing people that they should help out? :)
08:15:54 <ajmitch> it's been a struggle since the ARB was introduced, so I'm not optimistic
08:16:10 <coolbhavi> I'll add a action item for both then to identify packages which are already in shape
08:17:14 <coolbhavi> yes but as you said it was a struggle as it requires some amount of motivation and free time
08:17:39 <ajmitch> and for people to consider extras.u.c to be worthwhile
08:18:07 <ajmitch> for most developers, new packages are a low priority anyway
08:18:35 <coolbhavi> +1 added to that the queue is not so public facing
08:20:44 <coolbhavi> #action ajmitch and coolbhavi to scout for some low hanging fruits in the queue to help clear the queue
08:20:44 * meetingology ajmitch and coolbhavi to scout for some low hanging fruits in the queue to help clear the queue
08:21:34 <coolbhavi> do you think a new round of recruitment can help in this regard?
08:21:41 <coolbhavi> ajmitch, ^^
08:22:24 <ajmitch> maybe a little bit, but we haven't really had anyone interested despite recent mails to the list about the process
08:23:54 <coolbhavi> yes. but considering a 7 member team will be more effective than a 3 member team right now it might help
08:24:30 <ajmitch> sure, if you can get 4 more people to step forward & commit
08:24:47 <coolbhavi> I'll bring this up on the list then for discussion
08:25:32 <coolbhavi> #action coolbhavi to mail the arb list about a new round of recruitment
08:25:32 * meetingology coolbhavi to mail the arb list about a new round of recruitment
08:25:57 <ajmitch> ok
08:28:36 <ajmitch> has the TB approved the process change?
08:28:46 <coolbhavi> ajmitch, the other two points were: still we have not got any formal signoff from the TB regarding new arb process and we were not able to meet frequently in the recent past
08:29:59 <coolbhavi> ajmitch, can you help regarding reaching out to the TB for a formal approval?
08:30:00 <ajmitch> yes, that's why I asked about the TB signoff, I know that it was mentioned in a TB meeting
08:30:45 <ajmitch> https://lists.ubuntu.com/archives/technical-board/2012-November/001437.html is the last action on the TB list
08:31:09 <ajmitch> I'll check & see if they want to approve it or if we just go with it
08:31:25 <coolbhavi> great!
08:31:36 <ajmitch> I suspect they'll be fine with us just going ahead, there were no objections on the list
08:32:40 <coolbhavi> yes agreed but a formal signoff would be a good go ahead signal for us to atleast follow up on ubuntu-devel
08:32:59 <ajmitch> right
08:33:06 <ajmitch> so the other thing is more regular meetings
08:33:25 <coolbhavi> I'll mark down an action for this
08:34:05 <coolbhavi> #action ajmitch to check with the TB for approval of new arb process
08:34:05 * meetingology ajmitch to check with the TB for approval of new arb process
08:34:26 <coolbhavi> regarding meetings
08:35:28 <coolbhavi> how about having meetings on sunday this time as long as a new recruitment run goes into pace?
08:35:43 <ajmitch> fine by me
08:36:24 <coolbhavi> great then! ll catch up with alessio too regarding this.
08:37:01 <ajmitch> ok, hopefully he can make it to the next one
08:37:13 <ajmitch> I'm guessing once a month is enough?
08:38:57 <coolbhavi> right. but twice in a month for next couple of months maybe wont harm as it enables us to track the queue better I think. But then its your choice :)
08:39:30 <ajmitch> christmas holidays are coming up, so twice a month will be pushing it
08:40:10 <coolbhavi> :) fine then!
08:40:53 <coolbhavi> any other things up for discussion?
08:41:08 <ajmitch> I think that's about it
08:42:04 <coolbhavi> thanks a lot ajmitch for coming in :) you are really one of the arb's rockstars :)
08:42:25 <ajmitch> no, not really :P
08:43:21 <coolbhavi> atleast you were one of those guys who formed the arb :) thanks a lot again!
08:43:29 <coolbhavi> #endmeeting