16:20:39 <smoser> #startmeeting ubuntu-server-team
16:20:39 <meetingology> Meeting started Tue Nov 13 16:20:39 2012 UTC.  The chair is smoser. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:20:39 <meetingology> 
16:20:39 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:20:59 <smoser> #topic Review ACTION points from previous meeting
16:21:10 <smoser> no action items carried over
16:21:17 <smoser> #topic Raring Development
16:21:36 <smoser> Daviey, did you want to talk some here?
16:21:45 <smoser> blueprints should be just about settled.
16:21:58 <Daviey> smoser: I think you can cover it :)
16:22:10 <smoser> i'll take an action to review them today or tomorrow and bother anyone whose are not in good state.
16:22:12 <Daviey> smoser: You, jamespage and myself will be reviewing blueprints this week, right?
16:22:28 <smoser> #action smoser, jamespage, daviey review blueprints
16:22:28 * meetingology smoser, jamespage, daviey review blueprints
16:22:32 <jamespage> Daviey, smoser: lets schedule some time todo that then
16:22:44 <smoser> after meeting, jamespage
16:22:56 <smoser> other thing here is that  would like to get "milestones" in place.
16:23:37 <Daviey> smoser: Monthly ?
16:23:38 <smoser> we dont really have milestones (alpha1, alpha2...) but i thinkw e want to still target blueprints for "general finished" at given points in the cycle.
16:24:16 <smoser> ah. the Monthly things are in now.
16:24:17 <smoser> coo.
16:24:54 <smoser> ie, you can now target bugs to "ubuntu-13.04-month-1"
16:25:07 <smoser> (also 'alpha-X' which is strange)
16:25:08 <smoser> anyway.
16:25:13 <smoser> anyone have anything else for this ?
16:25:57 <smoser> o. moving on
16:26:04 <smoser> #topic Ubuntu Server Team Events
16:26:25 <Daviey> None planned AFAIK?
16:26:29 <smoser> utlemming and I will be at re:invent which is the week after next.
16:26:47 <smoser> dr mimms and SpamapS also i think.
16:27:04 <smoser> #topic Weekly Updates & Questions for the QA Team (hggdh)
16:27:19 <smoser> hggdh is not present...
16:27:24 <SpamapS> indeed
16:27:25 <smoser> anyone have QA like topics for disucssion ?
16:27:30 <SpamapS> oh sorry I forgot to pipe up in events
16:27:40 <SpamapS> I'll also be talking at ScaleLA next Tuesday
16:27:59 <SpamapS> http://www.meetup.com/scalela/
16:28:02 <smoser> cool.
16:28:02 <Daviey> Oo
16:28:35 <smoser> #topic Weekly Updates & Questions for the Kernel Team (smb)
16:28:37 <smb> Working on on bug 1023755. Depending on io scheduler (cfq/deadline) I think I got one half down to somewhere between v3.3-rc7 and v3.3 (bug messed up the bisect), the other half may be related to cfq and seemed to exist in Quantal stiil. Beside that I am working on an update to Xen Raring to cover the things we said we would do at UDS.
16:28:39 <smb> ..
16:28:39 <ubottu> Launchpad bug 1023755 in linux (Ubuntu) "Precise kernel locks up while dd to /dev/mapper files > 1Gb (was: Unable to delete volume)" [Undecided,Confirmed] https://launchpad.net/bugs/1023755
16:28:44 <smoser> smb is all over it.
16:29:42 <smoser> smb, also... it seemed like you had some kernel changes in the pike for 10.04
16:30:20 <smb> smoser, Oh yeah that. Sort of dump the special ec2 patches and just use the same codebase as for the generic kernels
16:30:29 <smoser> http://people.canonical.com/~smb/lucid-ec2-ng
16:30:31 <smb> Just slightly different options and a few other patches
16:30:50 <smoser> if anyone wants to give that stuff a spin on EC2 (generic xen couldn't hurt i dont think), that'd be great
16:31:03 <smoser> thanks smb.
16:31:12 <smoser> #topic Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:31:16 <rbasak> Nothing new to report. Any questions for me?
16:31:39 <smoser> rbasak, i've just uploaded to precise-proposed a cloud-init update that addresses 'ports.ubuntu.com' for arm
16:31:48 <smoser> SpamapS, ... your help would be appreciated on that review.
16:31:50 <rbasak> Awesome. Thanks!
16:32:16 <smoser> anything else related to the arm ?
16:32:25 <smoser> #topic Open Discussion
16:32:39 <smoser> our cloud iamges are currently experiencing issues for raring
16:32:48 <smoser> utlemming did some bisection yesterday.
16:32:54 <smoser> there were two issues:
16:33:17 <smoser> a.) we weren't finding the Ec2 Datasource on ec2 or openstack
16:33:57 <smoser> b.) we appear to "lose" some output that shoudl hit the console, making debugging harder. ie, cloud-init's 'log.warn' should get to/dev/console, but the messages were not getting there.
16:34:19 <smoser> c.) cloud-init in raring == cloud-init in quantal at the moment
16:34:21 <smoser> so..
16:34:25 <smoser> that will be fun.
16:34:44 <smoser> anyone else open discussion , or solutions to my problems ?
16:34:59 <zul> also we have an SRU for nova and quantum on quantal that seems to be stuck or not moving
16:35:09 <zul> (ie: uploaded but not processed)
16:35:40 <zul> smoser: i dont have a solution to your problem ;)
16:35:54 <smoser> ah. we should also welcome mikal, but since he lives in the far distant future, he is not here.
16:36:17 <smoser> mikal will be working on openstack for us. hooray.
16:36:20 <SpamapS> Hey has anyone been following debian's cloud image efforts?
16:37:31 <smoser> i'm on ec2debian mailing list
16:37:36 <smoser> but thats about it. and that is slow moving.
16:37:46 <smoser> was there something specifically you were interested in SpamapS  ?
16:38:23 <SpamapS> its not ec2debian, there's a debian-cloud now
16:38:38 <SpamapS> They're pushing images into Azure as well as EC2
16:38:54 <SpamapS> smoser: I'm just wondering if people have thoughts on how we might collaborate there.
16:39:16 <xnox> there was call for help maintaining cloud-init in/for debian images.
16:39:25 <SpamapS> As Debian users move onto the cloud, they'll likely bring new ideas that we can incorporate into Ubuntu's cloud images.
16:39:27 <utlemming> SpamapS: do you have a link?
16:39:36 <smoser> http://lists.debian.org/debian-cloud/2012/11/threads.html
16:39:43 * smoser will join list.
16:39:55 <xnox> some of this stuff was on debian-private though (the azure bits)
16:39:59 <SpamapS> https://lists.debian.org/debian-cloud/
16:39:59 <smoser> and respond to call for cloud-init.
16:40:19 <SpamapS> xnox: Azure is being discussed on debian-cloud tho
16:40:38 <SpamapS> https://lists.debian.org/debian-cloud/2012/11/msg00039.html
16:40:41 <xnox> SpamapS: now it is =) good.
16:40:56 <SpamapS> xnox: <phew> thought I was being a real oaf there for a second.
16:41:44 <utlemming> SpamapS: for Azure, I probably need to spend some time with them, since I package their agent.
16:41:47 * xnox was only following debian-private.
16:42:57 <SpamapS> utlemming: yeah, it might be good to not duplicate that effort. :)
16:43:38 <SpamapS> Oh there's also a #debian-cloud on OFTC
16:44:56 <smoser> thanks SpamapS
16:44:59 <smoser> anyone have anythign else ?
16:46:09 <smoser> #topic Announce next meeting date and time
16:46:21 <Daviey> Same time, or an hour later?
16:46:30 <zul> same time
16:46:37 <smoser> this meeting has been 16:00 UTC for probably 2 years.
16:47:02 <smoser> but that isn't necessarily a reason that US/Pacific people should have to be online at 8:00 AM
16:47:14 <SpamapS> yeah, sucks for west coast US but meh
16:48:14 <smoser> ok. failing any other arguments...
16:48:17 <Daviey> smoser: and for the alst 2 years, west-coasters have complained, and sucked at turning up :)
16:48:40 <SpamapS> nobody on the west coast of the US uses Ubuntu server
16:48:46 <smoser> ok.
16:48:54 <SpamapS> well I mean except *all of silicon valley*, but who cares about those nerds?
16:48:56 <smoser> next meeting: Tuesday 2012-11-20 at 1600 UTC - #ubuntu-meeting
16:49:10 <smoser> #end-meeting
16:49:12 <smoser> #endmeeting