16:00:07 <Ursinha> #startmeeting ubuntu-server-team
16:00:07 <meetingology> Meeting started Tue Oct  2 16:00:07 2012 UTC.  The chair is Ursinha. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:00:07 <meetingology> 
16:00:07 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:00:18 <Ursinha> hello all
16:00:30 <Ursinha> are you all here?
16:00:32 <SpamapS> no
16:00:35 <SpamapS> but keep going
16:00:40 <Ursinha> #topic Review ACTION points from previous meeting
16:00:59 <Ursinha> * jamespage to look into aligning release team and server team trackign reports
16:01:14 <jamespage> Ursinha, golly -is that still on the list....
16:01:23 <Ursinha> jamespage, hehe... this one involves me, right?
16:01:27 <jamespage> yep
16:01:37 <jamespage> and as we are sooo bad at communicating with each other...
16:01:41 <Ursinha> [action] jamespage and Ursinha to look into aligning release team and server team tracking reports
16:01:41 * meetingology jamespage and Ursinha to look into aligning release team and server team tracking reports
16:01:58 <Ursinha> it's mine too now :)
16:02:28 <Ursinha> we can catch up tomorrow, will try to find a spot for us to talk
16:02:30 <Ursinha> #topic Quantal Development
16:02:36 <Ursinha> #link https://wiki.ubuntu.com/QuantalQuetzal/ReleaseSchedule
16:02:50 <Ursinha> #subtopic Release Bugs
16:03:02 <Ursinha> I don't think this works?
16:03:21 <Ursinha> #link http://reports.qa.ubuntu.com/reports/ubuntu-server/release-bugs.html
16:03:26 <Ursinha> so, let's see
16:04:04 <JoseeAntonioR> Ursinha: you won't get a reply for link, or for subtopic
16:04:21 <Ursinha> that's different
16:04:29 <Ursinha> thanks JoseeAntonioR
16:04:34 <Ursinha> I'm looking at the bugs
16:05:59 <Ursinha> so, there is bug 1017847
16:06:01 <ubottu> Launchpad bug 1017847 in qemu-linaro (Ubuntu) "qemu segfaults when creating an armhf container on an amd64 host" [High,Confirmed] https://launchpad.net/bugs/1017847
16:06:12 <Ursinha> are we working on it for this cycle? it has the rls-q-incoming tag
16:06:23 <Ursinha> serge isn't here
16:06:28 <hallyn> sure i am
16:06:39 <hallyn> last i tried i couldn't reproduce due to other failures - i should try again...
16:06:48 <Ursinha> ah!
16:06:51 <Ursinha> :)
16:07:11 <Ursinha> hallyn, if we're not fixing, we might want to remove the tag or add another one to say we're not fixing this cycle
16:07:19 <Ursinha> if is a valid issue, of course
16:07:33 <hallyn> the issue definately was valid at one point
16:08:51 <Ursinha> right..
16:09:28 <hallyn> (added to my list)
16:09:34 <Ursinha> we have two critical bugs, one is fix committed by smoser
16:09:43 <Ursinha> other is critical, SpamapS set it to critical
16:09:46 <Ursinha> bug 1047520
16:09:47 <ubottu> Launchpad bug 1047520 in php5 (Ubuntu Quantal) "NEWS and release notes need updating" [Critical,New] https://launchpad.net/bugs/1047520
16:09:50 <Ursinha> SpamapS, are you fixing that?
16:10:13 <smoser> what is the one that is fix-committed by me ?
16:10:53 <Ursinha> bug 1049177
16:10:55 <ubottu> Launchpad bug 1049177 in isc-dhcp (Ubuntu Precise) "isc-dhcp-server apparmor profile should have include ".d" " [Medium,In progress] https://launchpad.net/bugs/1049177
16:11:13 <Ursinha> the quantal task
16:11:23 <Ursinha> for maas
16:11:37 <smoser> roaksoax, should that be fix-released in maas ?
16:12:03 <smoser> ie, do we have a maas package that uses its own dhcp server?
16:12:34 <SpamapS> Ursinha: yes I'll take a look at that
16:12:46 <roaksoax> smoser: i think we do, i haven't looked at the latest changes made to that package
16:12:50 <roaksoax> (maas-dhcp(
16:12:53 <Ursinha> thanks Sp4rKy
16:12:55 <Ursinha> oops
16:12:58 <Ursinha> SpamapS, even
16:13:02 <Sp4rKy> :)
16:13:02 <Ursinha> (sorry Sp4rKy)
16:13:25 <smoser> Ursinha, well, either way, its under control
16:13:34 <smoser> (it is fixed in daily ppa)
16:13:48 <Ursinha> cool
16:13:58 <Ursinha> do you have any issues you want to bring into attention?
16:14:21 <SpamapS> bug 1047520 is actually already Fix Released
16:14:23 <ubottu> Launchpad bug 1047520 in php5 (Ubuntu Quantal) "NEWS and release notes need updating" [Critical,Fix released] https://launchpad.net/bugs/1047520
16:14:34 <SpamapS> so, woot :)
16:15:07 <Ursinha> cool :)
16:15:09 <Ursinha> I found another critical bug: bug 1044632
16:15:10 <ubottu> Launchpad bug 1044632 in juju (Ubuntu Quantal) "Modify format 2 so that it supports raw strings" [Critical,New] https://launchpad.net/bugs/1044632
16:16:04 <Daviey> OT: /me chimes in that he is only partially here atm.
16:16:24 <jimbaker> Ursinha, that's part of the 0.5.2 release of juju
16:16:58 <Ursinha> jimbaker, I ask because it's targeted to the release, only wanted to know if that bug is going to make it or if it's going to be sru'd later
16:17:09 <jimbaker> SpamapS is currently working on a micro release that will be in a sru
16:17:53 <Ursinha> ah, right
16:17:54 <jimbaker> actually bad phrased - 0.5.2 is that micro release, then to included in an upcoming sru
16:18:06 <Ursinha> so we might want to target that to quantal-updates,right?
16:18:23 <Daviey> SpamapS: any news on using ubuntu-cloud lxc template for local provider ?
16:19:12 <jimbaker> Ursinha, that's a sru for precise. it should be part of the final for quantal
16:19:26 <Ursinha> jimbaker, right, thanks for the info
16:19:45 <Ursinha> I'll talk to people about bugs outside the meeting, otherwise this will take forever
16:19:49 <Ursinha> will move on to blueprints
16:19:58 <Ursinha> #subtopic Blueprints
16:20:05 <Ursinha> #link http://status.ubuntu.com/ubuntu-quantal/ubuntu-server.html
16:20:09 <Ursinha> the link that Daviey hates
16:21:30 <Ursinha> that link is indeed not nice if you want to be objective :/
16:22:03 <SpamapS> Daviey: yes, branch is proposed and in review today actually
16:22:35 <SpamapS> jimbaker: format 2 does not exist in 0.5.x
16:22:55 <SpamapS> jimbaker: that bug is only relevant in 0.6
16:23:29 <SpamapS> Ursinha: we don't need to target that at quantal-updates. I have a final drop of Juju code planned for later this week.
16:23:39 <Ursinha> SpamapS, awesome then
16:23:43 * SpamapS apologizes for lagging :-P
16:23:46 <Ursinha> :)
16:24:12 <Ursinha> that link is somehow impossible to follow up, the blueprints one, so please remember to update yours if haven't already
16:24:53 <Ursinha> I'll move on
16:24:55 <Ursinha> #topic Ubuntu Server Team Events
16:25:44 <Ursinha> * CFP deadlines
16:25:53 <Ursinha> ** SoCal Linux Expo (Deadline: Dec. 10) http://www.socallinuxexpo.org/cfp
16:26:07 <Ursinha> any other events?
16:27:03 <Ursinha> I'll take that as a no :)
16:27:11 <Ursinha> #topic Weekly Updates & Questions for the QA Team (hggdh)
16:27:25 <hggdh> hi
16:27:26 <Ursinha> hi hggdh, any updates for us?
16:28:08 <hggdh> just a question from me -- the iSCSI and MAAS tests for the ISO -- it seems you want us to run it
16:28:30 <hggdh> we need to have the details on how to do it, can you please pass them over?
16:29:26 <hggdh> and, additionally, I found an easy way to have the ISO dns-server tests to actually execute, I will be proposing a merge soon for USIT
16:29:28 <hggdh> ..
16:29:31 <Ursinha> who asked you that, hggdh?
16:29:59 <hggdh> Ursinha: nobody asked us that, but then the server team did not run them on the Beta 2 tests
16:30:13 <Ursinha> ah, oops
16:30:45 <Ursinha> Daviey, who could provide the info to hggdh to run these tests?
16:31:28 <jamespage> hggdh, I can pass you info on the iscsi tests
16:31:47 <hggdh> oh, an additional point on MAAS
16:32:16 <Ursinha> [action] jamespage to provide info to hggdh about how to run iSCSI and MAAS tests for the ISO
16:32:16 * meetingology jamespage to provide info to hggdh about how to run iSCSI and MAAS tests for the ISO
16:32:17 <hggdh> it now seems to support virsh, but there is no docs on how to fill in the fields on the "Add Node" screen
16:32:47 <hggdh> and the "Doc" button on the page does not even talk about virsh...
16:34:47 <Ursinha> roaksoax or smoser, ^^
16:35:42 <roaksoax> i think we would need to check that with iupstream I've only worked with IPMI
16:35:53 <roaksoax> but should be pretty straight forward
16:36:32 <smoser> i've not tested current maas with virsh
16:36:48 <smoser> but it is on the list of things i'd like to know how to do
16:37:59 <Daviey> Ursinha: hggdh should grab me out of meeting :)
16:38:05 <Ursinha> cool :)
16:38:16 <Ursinha> is that enough information for you, hggdh?
16:38:53 <hggdh> yes it is :-)
16:38:58 <Ursinha> great :)
16:39:02 <Ursinha> moving on, then
16:39:06 * hggdh prepares the net to grab Daviey
16:39:23 <Ursinha> #topic Weekly Updates & Questions for the Kernel Team (smb)
16:39:29 <Ursinha> hello smb
16:39:29 <smb> I don't have much to report right now... I hope I am finally homing in on bug 1021471. Just compiling a new test kernel for that right now. Should be on people by the time this meeting ends...
16:39:31 <ubottu> Launchpad bug 1021471 in linux (Ubuntu Quantal) "clone() hang when creating new network namespace (dmesg show unregister_netdevice: waiting for lo to become free. Usage count = 2)" [High,Triaged] https://launchpad.net/bugs/1021471
16:39:44 <smb> ..
16:39:47 <SpamapS> smb: thanks for fighting to get that going. Its quite important for juju. :)
16:39:58 <SpamapS> and really for LXC users
16:40:17 <Daviey> +1
16:40:44 <Ursinha> great, thanks smb
16:40:47 <Ursinha> any questions for smb?
16:41:16 <Ursinha> okay, moving on
16:41:18 <Ursinha> #topic Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:41:23 <rbasak> Quantal on ARM is looking good. MAAS on ARM is almost done too - all the critical pieces are written now, appear to be working and are in various stages in the pipeline for landing in the next week.
16:41:26 <rbasak> Any questions for me?
16:42:13 <Ursinha> maybe not :)
16:42:15 <Ursinha> thanks rbasak
16:42:24 <Ursinha> #topic Open Discussion
16:42:30 <Ursinha> discuss!
16:43:09 <Ursinha> you are making me sad today, people
16:43:22 <Ursinha> :)
16:43:22 <zul> gee thanks
16:43:27 <Ursinha> lol
16:43:52 <Ursinha> no one is into discussing today :)
16:43:53 <Ursinha> #topic Announce next meeting date and time
16:43:56 <Ursinha> sooo
16:44:03 <SpamapS> Ursinha: thanks!!
16:44:14 <SpamapS> oh damn I thought that was EOM
16:44:21 <Ursinha> Next meeting will take place Oct 9th, same bat-channel
16:44:38 <Ursinha> who's next in the line
16:45:01 <Ursinha> if that is a line, so jimbaker is our next chair
16:45:06 <Ursinha> jimbaker, is that ok for you?
16:45:33 <Ursinha> that should do :P
16:45:40 <Ursinha> #endmeeting