16:03:48 <arosales> #startmeeting ubuntu-server-team
16:03:48 <meetingology> Meeting started Tue Aug 28 16:03:48 2012 UTC. The chair is arosales. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:03:48 <meetingology>
16:03:48 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:03:49 <zul> utlemming: thats an odd shape head
16:03:57 <arosales> #topic Review ACTION points from previous meeting
16:04:21 <arosales> smoser follow up on bug 1028453
16:04:23 <ubottu> Launchpad bug 1028453 in ubuntu-meta (Ubuntu) "Quantal Ubuntu Server minimal install oversized" [High,Confirmed] https://launchpad.net/bugs/1028453
16:04:40 <smoser> hm.. /me did not do that.
16:05:13 <arosales> do we need to carry that forward, no not really
16:05:45 <arosales> smoser: ^
16:05:50 <smoser> well we need to fix it. i'll get an answer.
16:06:06 <arosales> #action smoser follow up on bug 1028453
16:06:06 * meetingology smoser follow up on bug 1028453
16:06:07 <ubottu> Launchpad bug 1028453 in ubuntu-meta (Ubuntu) "Quantal Ubuntu Server minimal install oversized" [High,Confirmed] https://launchpad.net/bugs/1028453
16:06:18 <arosales> #topic Quantal Development
16:06:36 <arosales> #topic Release Bugs - http://reports.qa.ubuntu.com/reports/ubuntu-server/release-bugs.html
16:07:06 <arosales> bug 1028453
16:07:08 <ubottu> Launchpad bug 1028453 in ubuntu-meta (Ubuntu) "Quantal Ubuntu Server minimal install oversized" [High,Confirmed] https://launchpad.net/bugs/1028453
16:07:24 <arosales> utlemming: looks like you touched this last week
16:07:43 <utlemming> arosales: that was an accidental assignment on my part
16:07:44 <Daviey> Hmm, i thought this was resolved
16:07:46 <arosales> Any takers on getting this resolved before beta1?
16:08:10 <arosales> Daviey: could you comment in the bug?
16:08:27 <arosales> bug 1030914
16:08:28 <ubottu> Launchpad bug 1030914 in python-glanceclient (Ubuntu) "trying to overwrite '/usr/bin/glance', which is also in package glance-client" [High,Confirmed] https://launchpad.net/bugs/1030914
16:08:31 <Daviey> yeah, leave it with me
16:08:36 <Daviey> zul: ^^
16:08:37 <arosales> Daviey: thanks
16:08:48 <zul> Daviey: thanks
16:09:03 <Daviey> (zul bug 1030914)
16:10:11 <arosales> in parallel bug 1034701
16:10:12 <ubottu> Launchpad bug 1034701 in horizon (Ubuntu Quantal) "ImportError: Could not import settings 'openstack_dashboard.settings': missing dependency on python-glanceclient" [High,Triaged] https://launchpad.net/bugs/1034701
16:11:21 <arosales> adam_g: ^ any idea on import settings on this one ^
16:11:39 <m_3> adam's in transit to cloud open I think
16:11:50 <arosales> m_3: ah yes, thanks.
16:12:14 <arosales> zul: Daviey: the list is largly openstack :-)
16:12:42 <Daviey> arosales: is that because the infra teams marks them up better? :)
16:12:43 <arosales> less cobbler, couchdb, and the oversized disk install
16:13:04 <arosales> Daviey: or just flakey code that produces bugs
16:13:06 <arosales> :-)
16:13:09 <jamespage> bug 1034701 should be fixed now - its just not been closed
16:13:10 <ubottu> Launchpad bug 1034701 in horizon (Ubuntu Quantal) "ImportError: Could not import settings 'openstack_dashboard.settings': missing dependency on python-glanceclient" [High,Triaged] https://launchpad.net/bugs/1034701
16:13:11 <arosales> but probably the former
16:13:23 <arosales> ok, so moving on to the next bug then
16:13:34 <arosales> bug 1028509
16:13:35 <ubottu> Launchpad bug 1028509 in nova (Ubuntu) "'nova rescue' fails if an instance image does not have a kernel_id" [Medium,Confirmed] https://launchpad.net/bugs/1028509
16:13:59 * arosales starts broken record
16:14:06 <arosales> Daviey: zul ^
16:14:30 <zul> havent gotten to that one
16:14:42 <arosales> zul: ok thanks
16:14:48 * arosales going to list the remaining openstack bugs for daviey and zul:
16:14:59 <arosales> bug 995285
16:15:00 <ubottu> Launchpad bug 995285 in nova (Ubuntu Quantal) "if /etc/sudoers.d/nova_sudoers is removed, upgrades fail" [Low,Triaged] https://launchpad.net/bugs/995285
16:15:12 <arosales> bug 1024281
16:15:13 <ubottu> Launchpad bug 1024281 in python-glanceclient (Ubuntu) "Bug during installation. conflicts: python-glanceclient + glance-client" [Undecided,Confirmed] https://launchpad.net/bugs/1024281
16:15:23 <arosales> bug 1025203
16:15:24 <ubottu> Launchpad bug 1025203 in quantum (Ubuntu) "Trying to overwrite '/etc/quantum/plugins/openvswitch/ovs_quantum_plugin.ini', which is also in package quantum-server" [High,Triaged] https://launchpad.net/bugs/1025203
16:15:36 <jamespage> dupe of bug 1030914
16:15:37 <ubottu> Launchpad bug 1030914 in python-glanceclient (Ubuntu) "trying to overwrite '/usr/bin/glance', which is also in package glance-client" [High,Confirmed] https://launchpad.net/bugs/1030914
16:16:18 <arosales> jamespage: roger that, can up update the bug?
16:16:23 <jamespage> ack
16:17:08 <arosales> I think adam_g is working on 1024281
16:17:26 <arosales> zul any update on 995285
16:17:28 <jamespage> he is
16:17:47 <zul> *sigh* i just need to keep my head down
16:18:01 <Daviey> :)
16:18:07 <arosales> poor zul, sorry :-/
16:18:13 <zul> none yet im expecting when the first glanceclient bug is fixed then the rest will follow
16:18:25 <arosales> zul: ok thanks
16:18:39 <arosales> one for roaksoax: bug 858867
16:18:41 <ubottu> Launchpad bug 858867 in cobbler (Ubuntu) "XMLRPC allows unauthed users access to various methods (which it shouldn't) " [Medium,Triaged] https://launchpad.net/bugs/858867
16:18:46 <zul> only one? ;)
16:18:57 <arosales> one that made it to the list
16:18:59 <jamespage> that should not be in the list any more
16:19:16 <jamespage> removed from tracking
16:19:30 <arosales> jamespage: thanks
16:19:51 <arosales> and any update on the couchdb bug 844995
16:19:54 <ubottu> Launchpad bug 844995 in python-couchdb (Ubuntu) "Drop support for couchdb related packages" [Undecided,Triaged] https://launchpad.net/bugs/844995
16:20:35 <jamespage> I think that just needs demoting now
16:20:46 <arosales> who has the action there?
16:20:55 <jamespage> yep - its in the component mismatches list
16:21:53 <jamespage> it will get swept up by the archive admins - no further action required really - but I'll update the ticket to suggest demotion.
16:21:59 <arosales> jamespage: ok, thanks
16:22:06 <arosales> next up blueprints
16:22:29 * arosales guesses these should be more of links than topic changes
16:22:39 <arosales> #link http://status.ubuntu.com/ubuntu-precise/ubuntu-server.html
16:22:57 <arosales> #action arosales update IRCComands for Quantal dev
16:22:57 * meetingology arosales update IRCComands for Quantal dev
16:22:59 <Daviey> jamespage: i cna demote couch.
16:23:20 <jamespage> Daviey, please do then and close the bug report
16:23:33 <arosales> so we are keeping out of the red, but not in the green
16:24:00 <jamespage> hrm - this one http://status.ubuntu.com/ubuntu-quantal/ubuntu-server.html
16:24:14 <arosales> jamespage: yes, sorry
16:24:25 <Daviey> jamespage: yes sir!
16:24:37 <arosales> another one to udpate in the IRCCommands
16:24:39 <arosales> :-)
16:24:40 * jamespage is feeling bossy today for some reason!
16:24:51 <arosales> to go over a few of the essential and highs that are in the red.
16:24:58 <arosales> jamespage: no thank you !
16:25:20 <arosales> openstack ha
16:25:25 <arosales> @27% https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-openstack-qa
16:25:25 <meetingology> arosales: Error: "27%" is not a valid command.
16:25:39 <Daviey> Yeah, that is totally invalid.
16:25:49 <arosales> milestone is beta1?
16:26:06 <arosales> zul more of beta2?
16:26:22 <arosales> beta1 is sept 6th
16:26:27 <zul> beta2
16:26:30 <arosales> #link https://wiki.ubuntu.com/QuantalQuetzal/ReleaseSchedule
16:26:46 <arosales> zul ok, thanks updated
16:27:17 <arosales> arm deployment @ 50% https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-arm-deployment
16:27:19 <arosales> rbasak: ^
16:27:34 <arosales> rbasak: beta1 target
16:28:00 <rbasak> The remaining pieces are maas related. I'm not sure they're going to make beta1
16:28:24 <arosales> rbasak: any eta on arm support landing in MAAS?
16:28:37 <rbasak> Not yet
16:29:13 <arosales> ok, keep us up todate on that progress, and thanks for working in it.
16:29:38 <arosales> Daviey: folsom @36% https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-openstack-folsom
16:29:41 <arosales> target beta1
16:30:58 <Daviey> yep!
16:31:07 <arosales> so good for beta1?
16:31:07 <Daviey> I suspect it needs refreshing
16:31:23 * arosales trusts daviey :-)
16:31:24 <Daviey> arosales: we continually release state code, so we are rocking
16:31:30 <arosales> roger that
16:31:56 <arosales> Daviey: same with https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-openstack-stable
16:32:07 <arosales> no milestone on this one . . .
16:32:15 <Daviey> ok, will check through them shortly
16:32:25 <arosales> progress @ 24% on that one
16:32:29 <arosales> Daviey: thanks
16:32:55 <arosales> jamespage: I think we just need to update the bug process with the reports that are coming for https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-server-iso-tests-review
16:33:25 <arosales> jamespage: sorry that was for https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-bug-triage-review
16:33:31 <jamespage> arosales, I'll be working on that BP this/next week
16:33:35 <arosales> test review is also in the queue for UTAH
16:33:41 <arosales> jamespage: thanks
16:34:17 <jamespage> arosales, yes - the gravity report is now looking pretty good - I need to catchup with Ursinha on the automated bug closure stuff
16:34:18 <arosales> maas next steps @ 53% https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-maas-next-steps
16:34:28 <Ursinha> :D
16:34:30 <arosales> roaksoax: ^
16:34:55 * roaksoax looks
16:35:13 <roaksoax> most likely to postpone a few items
16:35:17 <arosales> SpamapS: I think this one we need to sync up with the juju core team https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-juju-charms-release-policy
16:35:26 <roaksoax> the most important things are don't
16:35:28 <arosales> roaksoax: ok, please postpone where appropriate
16:36:07 <arosales> roaksoax: how do you feel about https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-openstack-ha
16:36:11 <arosales> on target for beta1?
16:36:52 <roaksoax> arosales: debian maintainer was on hollidays so I was hoping he would reply this week, Otherwise we'll have to do something ourselves
16:36:57 <arosales> utlemming: /me guesses some of these will go to done this week https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-jenkins-cloud-builder
16:37:07 <roaksoax> (some stuff should hut OpenStack trunk), but if it doesn't we can ship it ourselves
16:37:15 <arosales> roaksoax: ok, I'll leave as beta1 and check again next week
16:37:15 <utlemming> arosales: as I type, I'm attempting to online it now
16:37:20 <arosales> utlemming: thanks.
16:37:41 <arosales> m_3: still now love for unit testing https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-juju-charm-unit-tests
16:37:57 <arosales> at 10% :-(
16:38:16 <arosales> m_3, jimbaker: could we get that updated this week please
16:38:39 <m_3> arosales: will do
16:38:39 <arosales> m_3 it has a beta1 target, are you ok with that milestone?
16:39:18 <arosales> m_3: thanks or taking a look
16:39:22 <arosales> #topic 12.04.1 Development (jamespage & smoser)
16:39:34 <jamespage> released - please remove from agenda
16:39:36 <smoser> shipped.
16:39:38 <arosales> :-)
16:39:54 * arosales wonders if there will be a 12.04.2
16:40:01 <jamespage> thanks to everybody who fixed bugs that targetted 12.04.1 - v much appreciated
16:40:03 <arosales> but for now lets focus on qunatal
16:40:10 <arosales> jamespage: yes +1 to that
16:40:26 <arosales> 12.04.2 team that is (of course there will be a release :-)
16:40:36 <arosales> #topic Ubuntu Server Team Events
16:40:39 * jamespage hides
16:40:55 <arosales> CloudOpen is currently undeway https://events.linuxfoundation.org/events/cloudopen
16:41:00 <SpamapS> err
16:41:02 <SpamapS> starts tonight
16:41:11 <arosales> SpamapS: ah ok
16:41:20 <arosales> SpamapS: you and adam_g are presenting there, correct?
16:41:23 <SpamapS> otherwise crap I'm missing it! :)
16:41:33 <SpamapS> Yes, I'll be speaking tomorrow, and Adam on Friday
16:41:46 <arosales> great, let us know if there is a recording
16:42:06 <arosales> jimbaker: your speaking at UCAR seminar this week too, correct?
16:42:13 <jimbaker> arosales, on thur afternoon
16:42:22 <jimbaker> 3p iirc
16:42:37 <arosales> great, let us know how it goes
16:42:50 <arosales> #topic Weekly Updates & Questions for the QA Team (hggdh)
16:43:15 * arosales doesn't see hggdh online
16:43:35 <SpamapS> perhaps we should seek a different QA contact?
16:43:40 <SpamapS> hggdh hasn't joined us in a *long* time
16:43:50 <arosales> we did meet with the QA team, and we are going to do some investigation into UTAH
16:43:53 <SpamapS> and I feel like we have QA more integrated into our team
16:44:14 <arosales> #link http://utah.readthedocs.org/en/latest/index.html
16:44:36 <arosales> #action arosales to follow up with hggdh and QA team on Server IRC contact
16:44:36 * meetingology arosales to follow up with hggdh and QA team on Server IRC contact
16:44:48 <arosales> #topic Weekly Updates & Questions for the Kernel Team (smb)
16:45:01 <arosales> smb`: Hello, andy updates from the kernel side?
16:46:11 <arosales> smb`: please feel free to interrupt if you have an update later in the meeting
16:46:25 <arosales> #topic Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:46:30 <rbasak> Calxeda ECX-1000 was announced as part of the 12.04.1 release, although we've had it in precise-updates for a while now.
16:46:37 <rbasak> Any questions for me?
16:46:58 <arosales> +1 on additional arm support in server :-)
16:47:14 * arosales already bugged rbask on arm support in maas :-)
16:47:36 <arosales> next topic
16:47:37 <arosales> #topic Open Discussion
16:47:53 <SpamapS> Hey I had an idea..
16:48:04 <SpamapS> we should probably mention CFP's that are open in the events section
16:48:32 <m_3> SpamapS: yeah, that'd be useful
16:48:50 <arosales> #action arosales to update events to include CFP
16:48:50 * meetingology arosales to update events to include CFP
16:48:54 <SpamapS> http://www.openstack.org/summit/san-diego-2012/call-for-speakers/
16:48:57 <m_3> along with the cfp deadlines please
16:49:03 <SpamapS> CFP for OpenStack summit/conf is Thursday
16:49:13 <SpamapS> err, deadline for ^^
16:50:12 <SpamapS> I'd suggest also that people add all open CFP's that are relevant to Ubuntu Server to the agenda while they're open
16:50:35 <arosales> SpamapS: nice suggestion. Folks please feel free to update the meeting wiki with any CFPs you know about or bring them up when the events section comes around.
16:51:03 <jimbaker> arosales, sounds good
16:51:07 <arosales> Any other topics?
16:51:29 <SpamapS> zul: did you ever know that you're my hero?
16:51:41 <SpamapS> OT?
16:51:46 <arosales> and on that note :-)
16:51:46 <zul> SpamapS: hmmm/
16:51:54 <arosales> #topic Announce next meeting date and time
16:52:06 <arosales> next meeting = Tuesday 2012-09-04 at 1600 UTC
16:52:26 <arosales> Thanks all for joining the server irc meeting :-)
16:52:28 <arosales> #endmeeting