14:01:08 <phillw> #startmeeting Ubuntu QA - agenda at https://wiki.ubuntu.com/QATeam/Meetings
14:01:08 <meetingology> Meeting started Wed Aug 22 14:01:08 2012 UTC.  The chair is phillw. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
14:01:08 <meetingology> 
14:01:08 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
14:01:38 <phillw> #topic attendance
14:01:54 <phillw> can those present please asy o/
14:01:57 <smartboyhw> o/
14:01:58 <phillw> *say*
14:02:20 <balloons> o/
14:03:06 <phillw> #topic previous actions
14:03:38 <phillw> balloons: have you actioned the one from 2 weeks ago?
14:03:57 * phillw balloons edit http://qa.ubuntu.com/ to reflect correct time of weekly meeting (phillw, 14:57:28)
14:05:08 <smartboyhw> phillw: I looked at qa.ubuntu.com, and I think balloons hasn't done it.
14:05:10 <balloons> phillw, theres an open rt with ops to fix
14:05:20 <balloons> i cannot do this myself
14:05:31 <balloons> the reason is someone made it part of the theme
14:05:32 <phillw> balloons: is this okay to carry over to be chased?
14:05:41 <balloons> yea.. really :p
14:05:55 <balloons> yes, carry
14:06:13 <phillw> #action balloons to chase up the incorrect meeting time on qa.ubuntu.com
14:06:13 * meetingology balloons to chase up the incorrect meeting time on qa.ubuntu.com
14:06:43 <phillw> #topic Ubuntu updates
14:07:05 <phillw> balloons: would be so kind as to give the current state of play?
14:08:54 <balloons> sure
14:11:00 <balloons> 12.04.1 for ubuntu testing is fairly complete
14:11:22 <balloons> there's been a couple bugs targetted for inclusion should a respin need to occur, but that's not happened
14:12:07 <balloons> on the flavors side, I know there has been some upgrade failure bugs :-)
14:12:47 <balloons> ..
14:12:52 <phillw> 12.04.1 is for a later topic, but thanks. how is Quantel going?
14:13:14 <smartboyhw> #link http://iso.qa.ubuntu.com/qatracker/milestones/219/builds
14:14:19 <balloons> ahh :-)
14:14:37 <balloons> quantal has seen some new testing efforts with unity and compiz this week
14:15:01 <balloons> that i think is going well, with some folks getting the first pass at llvmpipe and reporting bugs
14:16:01 <balloons> I clarified my thoughts on cadence testing, and talked a bit about the future. arm daily builds are currently broken in quantal due to the unity3d move
14:16:42 <balloons> in addition, nvidia driver is broken causing some havoc among the community depending on the driver to run quantal and unity3d
14:17:03 <balloons> (since unity2d has been dropped)
14:18:34 <balloons> discussions as to how this was handled will happen later, although, as I mentioned, I would like to see us change how we handle changes like this in the future
14:19:27 <balloons> we don't have stability outside of milestones..
14:19:27 <balloons> ..
14:19:37 <phillw> thanks.
14:19:40 <smartboyhw> :)
14:20:08 <phillw> #topic discussion of test cases on iso tracker
14:20:17 <phillw> I'll start this one...
14:20:43 <phillw> The moving to 'old' of test cases without 'new' has caused issues
14:21:12 <smartboyhw> phillw: That's not moving:(
14:21:17 <phillw> This really does need to looked into.
14:22:17 <phillw> balloons: smartboyhw maybe we should move to the last sub-topic?
14:22:33 <balloons> phillw, I'm unsure what your saying here
14:22:38 <smartboyhw> balloons: I agree
14:23:33 <phillw> balloons: I went to carry out a test on behalf of a team and was met with a redundant test example, with no updated information available.
14:23:52 <smartboyhw> phillw: I don't understand now, really
14:23:54 <balloons> ?
14:24:03 <balloons> precise sadly is using the old testcases
14:24:22 <balloons> updating the links would take a bit.. and this is the last time it will be used. I let it go
14:24:24 <phillw> it simply said that the test case was 'old'
14:24:49 <phillw> smartboyhw: does help explain it for you?
14:25:14 <balloons> phillw, I'm confused.. I guess move on and we'll come back
14:25:14 <smartboyhw> phillw: I'm more confused with your lines 8 lines above.
14:25:46 <phillw> #topic Updating Wiki
14:26:45 * njin arrived
14:26:45 <phillw> balloons: with your permission, I'll put in an action for us both to catch our breath & have a concerted effort once again, to get it more new comer friendly?
14:27:03 <phillw> welcome njin
14:27:17 <njin> hallo everybody
14:27:22 <balloons> phillw, the fight must go on :-0
14:27:22 <smartboyhw> welcome njin
14:27:30 <balloons> but i think we are in a good spot
14:27:47 <balloons> i plan to maybe make a new video
14:27:50 <smartboyhw> Actually I forgot to add a G+ and FB topic to the agenda...
14:27:53 <phillw> #action phillw balloons to continue to update Wiki
14:27:53 * meetingology phillw balloons to continue to update Wiki
14:28:26 <phillw> smartboyhw: it can be disussed at AOB
14:28:31 <smartboyhw> OK
14:29:00 <phillw> I can skip 12.04.1 as we have already had an update.
14:29:19 <smartboyhw> Wait, I saw Mythbuntu images not tested now
14:29:36 <phillw> #topic Any Other business, over load of QA team
14:29:45 <balloons> o/
14:29:50 <phillw> smartboyhw: it's here
14:30:06 <phillw> balloons: please take the floor
14:30:20 <smartboyhw> phillw: ?
14:30:42 <balloons> I also wanted to mention I ended some testing campaigns this week that had run there course
14:30:54 <balloons> I'll post some followup feedback and thank yous
14:31:00 <smartboyhw> OK
14:31:07 <balloons> ..
14:32:27 <phillw> balloons: just for discussion, I think QA attempted a 'bridge too far'.
14:32:36 <smartboyhw> phillw: What bridge?:)
14:32:55 <phillw> smartboyhw: http://en.wikipedia.org/wiki/Operation_Market_Garden
14:33:10 <smartboyhw> ?
14:33:42 <smartboyhw> I'm not used to you guys showing Wiki links that I don't understand.
14:34:34 <smartboyhw> What? balloons left?
14:34:42 <smartboyhw> Oh, he's back:)
14:34:45 <balloons> whoa... sorry
14:35:06 <njin> balloons, your dog pllayng with the power cqable ?
14:35:12 <balloons> lol..
14:35:19 <balloons> me hitting ctrl + w
14:35:19 <smartboyhw> njin: +1, LOL and :P
14:35:31 <balloons> dog is napping
14:35:39 <balloons> sorry phillw, ask again
14:35:47 <phillw> balloons: I think that trying to do re-writes of testing cases, carrying on standard release testing, bringing in cadence testing, testing 12.04.1 was too much for our resources to cope with.
14:36:01 <smartboyhw> phillw: 12.04.1 will end today
14:36:09 <phillw> This has resulted in some frustrated testers.
14:36:23 <smartboyhw> phillw: Who are the frustrated testers, BTW?:(
14:36:48 <phillw> smartboyhw: I do not need to name people. nor would I ever.
14:37:09 <smartboyhw> OK, but I thought it isn't too much, just 3 items after today or tmr
14:38:01 <balloons> phillw, yes, alot has been asked of QA this cycle
14:38:43 <njin> of course, this is Q cicle
14:38:47 <phillw> balloons: I fear too much has. The last thing I want is for testers to say 'this is getting silly' and walk away.
14:39:11 <smartboyhw> phillw: No.
14:39:14 <phillw> I did promise that I would bring the matter up.
14:40:03 <balloons> phillw, burnout potential will always be with us, no matter our workload
14:40:22 <balloons> i would remind everyone to make sure they keep there own workloads sane :-)
14:40:25 <phillw> balloons: it can be reduced by not asking them to do 3 tasks at one?
14:40:35 <balloons> it's important to pause.
14:40:52 <balloons> phillw, perhaps the issue at hand here is people feeling obligated to help on every bit of testing
14:41:10 <smartboyhw> balloons: That's my case:)
14:41:14 <phillw> balloons: they are dedicated people, and fell personally that they have failed if they do not 'keep up'. i do ask that this is borne in mind in future.
14:41:15 <balloons> I would rather them see 3 things going on as an oppurtunity to chose one to invovle themselves
14:41:40 <smartboyhw> balloons: I want to join all 3...:(
14:41:44 <balloons> I know.. if I ask for 4 things at once, and one doesn't seemingly get attention...
14:41:50 <balloons> the people will do it anyway
14:41:56 <balloons> and I'm very grateful for that
14:42:15 <balloons> but yes, that leads to burnout.. and I don't want that at all
14:42:25 <phillw> balloons: indeed it is. we need to address the issue of 'where to concentrate our resources', they are not infinite.
14:42:47 <balloons> ahh! the issue of what we test and what we work on is more concrete
14:43:06 <smartboyhw> balloons and phillw: Does that mean we will only let people to select 1 or 2 tests to do?
14:43:08 <balloons> that we can speak specifically too
14:43:32 <balloons> smartboyhw, you are always free to test in whatever capacity you wish
14:43:36 <balloons> as is everyone else..
14:43:58 <balloons> i do try to space things out and allow for pauses, but it's not always possible
14:44:16 <balloons> that said,, if there are feelings of frivilous testing going on. let's discuss specifically
14:44:26 <phillw> balloons: yes, but we do need to rate which is 'please do this one, the others can wait to another day when you have slept and have time'
14:44:33 <smartboyhw> OK thx balloons
14:45:01 <smartboyhw> phillw: I think the standard one is better
14:45:02 <phillw> balloons: if it not made possible, then the release cycle requires looking at.
14:45:06 <balloons> phillw, I can try and communicate the 'please be kind to yourself!' mantra when I push things out
14:45:26 <balloons> for instance, the unity testing overlapping 12.04.1
14:45:53 <balloons> I didn't want it to happen, but it did. however, there are folks who don't iso test, who could go out and mess with it right away
14:45:53 <phillw> that would be one... cadence overlapping milestones would be another
14:45:54 <smartboyhw> Actually, 12.04.1 will be ending today, right??? It's 12.04.2 coming. Now I'm confused
14:46:28 <balloons> if your isotesting 12.04.1... perhaps that's enough, and you can test unity if you wish later
14:46:45 <njin> ell but I think that this is not the right time to evaluate things, too many works and really few people cause vacations
14:46:47 <smartboyhw> balloons: I don't have more to test.
14:46:56 <phillw> I still have no deffinitive answer to the testers. "What is the priority each week?"
14:47:04 <phillw> maybe that could be done?
14:47:08 <smartboyhw> phillw: It would be difficult
14:47:20 <balloons> phillw, sure..
14:47:29 <smartboyhw> 1st week: Unity 2nd week: Cadence 3rd week: Unity 4th Week: Milestone?
14:47:39 <balloons> if we are working from deadlines, this week is 12.04.1
14:48:07 <smartboyhw> Well, today IS the deadline for 12.04.1 testing, am I correct?:)
14:48:26 <phillw> balloons: indeed, and a major problem in upgrade-manager has been found that will result in a 'no-go'
14:48:46 * balloons notes they are respinning the alts as we speak
14:49:11 <smartboyhw> balloons: True
14:49:15 <smartboyhw> Also Mythbuntu
14:49:23 <phillw> 10.04.4 --> 12.04 is a massive fail. This should have been caught much earlier, but the testers were running around doing other testing.
14:49:57 <balloons> phillw, well..
14:50:17 <balloons> this is a big topic.. I'm not sure opening that can of worms would be productive
14:50:51 <balloons> let's push forward to what you want to see in the future
14:50:58 <smartboyhw> I think we should discuss it in #ubuntu-testing instead...
14:51:04 <phillw> balloons: maybe next time testers are asked to do stuff, maybe explain back that they are as rare as rocking horse droppings? :P
14:51:15 <smartboyhw> :D
14:51:21 <balloons> :D
14:51:22 <balloons> ..
14:51:25 <smartboyhw> ..
14:51:28 <njin> yeah, we have to put more attention on lts to lts+1
14:51:36 <phillw> balloons: that is what I was hoping to do.
14:51:45 <jibel> phillw, which problem in upgrade-manager are you talking about ?
14:51:47 <jibel> but number ?
14:51:50 <jibel> bug
14:52:34 <njin> I'we only run one test and it was working
14:53:10 <phillw> jibel: I have the logs from #kubuntu-devel, but that is not for a meeting
14:54:20 <phillw> can we all migrate to #ubuntu-testing and discuss? this is not strictly a "meeting" topic?
14:54:21 <jibel> phillw, ok, paste it on #ubuntu-testing, I'd like to know what a "massive fail" is
14:54:33 <smartboyhw> phillw: I AGREE
14:54:49 <phillw> please move to #ubuntu-testing
14:54:55 <phillw> #endmeeting