18:00:29 <AlanBell> #startmeeting
18:00:29 <meetingology> Meeting started Sun Jul 29 18:00:29 2012 UTC.  The chair is AlanBell. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
18:00:29 <meetingology> 
18:00:29 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
18:00:38 <AlanBell> hi all, who is here for the IRC meeting?
18:00:40 <funkyHat> I will be here, for a change!
18:00:46 * funkyHat 
18:00:46 <AlanBell> yay, hi funkyHat
18:01:04 <funkyHat> Hi ⢁)
18:01:58 <AlanBell> I should have sent a reminder to the list probably
18:02:24 <LjL> oh hello
18:02:25 <AlanBell> but I know Pici isn't around
18:02:27 <AlanBell> hi LjL
18:02:38 <Pendulum> AlanBell: you were a bit busy
18:03:00 <AlanBell> I was, doing BBQ stuff
18:03:11 <AlanBell> and watching beach volleyball, important stuff like that
18:03:40 <AlanBell> ok, lets start on the agenda
18:04:00 <AlanBell> https://wiki.ubuntu.com/IRC/IrcCouncil/MeetingAgenda
18:04:09 <AlanBell> #topic Review last meetings action items
18:04:52 <AlanBell> x1k is up for membership but isn't in the channel it seems
18:05:03 <IdleOne> hello
18:05:53 <AlanBell> #progress m4v Pici AlanBell to look into adding ban removal to ubottu cababilities
18:06:24 <AlanBell> https://lists.ubuntu.com/archives/ubuntu-irc/2012-July/001565.html
18:06:26 <Tm_T> I liked what was posted on the mailinglist
18:06:35 <topyli> hi, sorry i'm late
18:06:35 <AlanBell> m4v has made good progress
18:06:49 <AlanBell> "I did like everyone to test the feature with scratDev in #ubuntu-bots-test,
18:06:51 <Tm_T> topyli: academic quarter (:
18:06:51 <AlanBell> just go there and set some bans and quiets. Report any bugs you find and ping
18:06:54 <AlanBell> me for questions."
18:06:57 <AlanBell> hi topyli
18:07:45 <topyli> yes m4v is doing great
18:08:01 <AlanBell> that does all sound really cool
18:08:26 <AlanBell> so I think we should get lots of people in #ubuntu-bots-test to try it out
18:08:52 <AlanBell> and get bug reports filed and suggestions made
18:09:08 <IdleOne> I tested yesterday with a ban and a quiet, only problems I had were user error.
18:09:53 <IdleOne> the bot responses could be a little more informative, m4v said he was aware and going to work on them.
18:09:56 <AlanBell> ok, well I will certainly have a play with it
18:10:06 <LjL> i didn't test this yet, but i'm all for having ubottu handle this. a bit concerned over duplicated effort, but i guess it's things that happen
18:10:43 <AlanBell> it is an ubottu clone isn't it?
18:10:48 <IdleOne> it is
18:11:04 <LjL> AlanBell: yeah but i mean, niko also had something like this (except it wasn't 100% an ubottu clone etc, yes i know)
18:11:59 <AlanBell> yes, but there were problems with the test suite etc
18:12:18 <AlanBell> ok, so lets promote the testing of this bot over the next few weeks
18:12:33 <AlanBell> and also try to break it/do evil things to it
18:13:16 <LjL> i have dinner now, can't attend any further. don't decide anything i'd approve of!
18:13:28 <bazhang> hah
18:13:40 <AlanBell> hehe
18:13:50 <topyli> LjL: did we ever? :)
18:13:54 <AlanBell> ok, so that is great progress, really pleased with that
18:14:07 <AlanBell> #topic Open items in the IRCC tracker
18:14:30 <AlanBell> right, so we redirected a bunch of launchpad emails to the tracker, somewhat more than we expected to do
18:14:57 <AlanBell> now every time someone is added or removed or expires from a team we get a ticket created
18:15:07 <topyli> it is a bit of a problem. now we have to go close those tickets, and i've failed to do that
18:15:27 <AlanBell> the intention was to redirect the "contact this team" link to the ticket tracker, but it had unexpected side effects
18:15:45 <IdleOne> You guys are getting all the " This person has extended their membership emails?
18:15:46 <AlanBell> I wasn't sure at first if this was a bug or a feature, but I am now leaning towards "bug"
18:16:01 <funkyHat> I think it's a bug too
18:16:04 <AlanBell> IdleOne: yeah, we get that anyway, but now the tracker hassles us to resolve the "issue"
18:16:06 <topyli> yes it backfired a bit, it's not really much better than that stuff coming to my inbox
18:16:22 <topyli> s/much/any/
18:16:40 <AlanBell> ok, so lets undo that then and put it back as it was
18:16:49 <topyli> yes
18:17:22 <AlanBell> #action AlanBell to revert the IRCC launchpad contact redirect to the tracker
18:17:22 * meetingology AlanBell to revert the IRCC launchpad contact redirect to the tracker
18:17:55 <topyli> someone is free to take the action of taunting me for suggesting this in the first place :)
18:18:43 <AlanBell> :)
18:18:52 <AlanBell> I think there are no "real" tickets
18:19:23 <topyli> right
18:19:40 * AlanBell closes the open ones
18:20:39 <AlanBell> #topic Review Bugs related to the Ubuntu IRC Council
18:20:47 <AlanBell> #subtopic bug 892500 eir is still not fit for purpose in #ubuntu
18:20:48 <ubottu> Launchpad bug 892500 in ubuntu-community "eir is still not fit for purpose in #ubuntu" [Undecided,In progress] https://launchpad.net/bugs/892500
18:21:08 <AlanBell> well we discussed this one, I will add a note to it linking to that email and the testing we are doing
18:21:10 <topyli> still in progress
18:21:16 <AlanBell> yes
18:21:19 <AlanBell> #subtopic bug 913541 there are a number of people with Ubuntu IRC cloaks who have expired from the ubuntumembers group - AlanBell
18:21:20 <ubottu> Launchpad bug 913541 in ubuntu-community "there are a number of people with Ubuntu IRC cloaks who have expired from the ubuntumembers group" [Undecided,In progress] https://launchpad.net/bugs/913541
18:21:46 <AlanBell> pici was having a go at this one, I will check the current progress on this and maybe help with it over the next few days, I want to get this to zero
18:22:03 <AlanBell> ok, that is the bugs
18:22:07 <AlanBell> #topic alignment of launchpad teams and channel access lists
18:22:24 <AlanBell> I haven't done much on this for a bit, but I will pick it up again over the next week or so
18:22:46 <AlanBell> #topic membership applications
18:23:19 <AlanBell> we have a membership application from x1k in the agenda, however he is not in the channel
18:23:22 <topyli> x1k is not around
18:23:44 <topyli> deferred?
18:24:04 <IdleOne> probably best
18:24:26 <AlanBell> yes I think so too
18:24:50 <AlanBell> #topic Any Other Business
18:25:05 <AlanBell> anyone got any other items to raise today?
18:25:17 <topyli> i noticed that our team reports are lagging
18:25:21 <IdleOne> BT access? DO all the ops have it?
18:25:24 <IdleOne> Do*
18:25:57 <AlanBell> topyli: that is a very fair point
18:25:57 <topyli> those in probation don't, but everyone else?
18:26:18 <AlanBell> those in probation should have access too
18:26:20 <AlanBell> I think
18:26:25 <topyli> AlanBell: i can bring them up to date when i'm bored enough
18:26:39 <AlanBell> it is only a lack of actually doing it that is the problem
18:26:48 <IdleOne> it makes it difficult to learn how to use BT without access
18:26:57 <topyli> IdleOne: yes
18:27:01 <AlanBell> so how do we give bantracker access, is this a tsimpson question?
18:27:23 <IdleOne> AlanBell: m4v has the capability to add BT access also
18:27:29 <AlanBell> ok, great
18:27:41 <IdleOne> someone on the IRCC should have it too
18:27:44 <IdleOne> so :)
18:27:58 <AlanBell> yeah, that would be handy
18:28:01 <topyli> yep, but i don't think any of us does
18:29:09 <AlanBell> ok, that is something to sort out
18:29:44 <topyli> it's legacy from the time when tsimpson was on the ircc, and we forgot to handle it
18:30:11 <IdleOne> afaik tsimpson jussi and m4v have the owner capability
18:30:35 <IdleOne> but it only makes sense that the IRCC has the power to add users.
18:30:39 <AlanBell> ok, we will get that sorted and make sure all the ops have access
18:31:04 <AlanBell> we had a training class last week by Myrtti http://irclogs.ubuntu.com/2012/07/26/%23ubuntu-classroom.html
18:31:15 <AlanBell> which was really good, but lightly attended
18:31:31 <AlanBell> I know some people had timezone issues and wanted to read the logs which is fine
18:32:13 <AlanBell> we have another training session on Thursday 2nd
18:32:43 <AlanBell> at 17:00 UTC with LJL leading it
18:32:50 <topyli> we could advertise the log, and maybe my 'helping when you're not an op' class
18:32:51 <AlanBell> a tour of the bots and channels
18:33:04 <AlanBell> topyli: yes, that would be great
18:33:08 <topyli> oh, let's wait until that's done too
18:33:28 <IdleOne> i don't think we should wait on spreading good info
18:33:38 <AlanBell> we should try and get more people to participate in the next one, particularly the new operators
18:33:42 <IdleOne> we can have multiple blog posts and do just as well
18:34:05 <topyli> true, it's not like we're exactly spamming the planet currently :)
18:34:07 <IdleOne> Myrtti's class was excellent and people should hear about it
18:34:11 <AlanBell> IdleOne: agreed, the more the merrier
18:34:24 <AlanBell> topyli: you have access to the blog, want to post an article about it?
18:34:36 <topyli> AlanBell: ok
18:34:52 <AlanBell> #action topyli to blog about the training classes/logs
18:34:52 * meetingology topyli to blog about the training classes/logs
18:35:02 <AlanBell> ok, any other things to discuss now?
18:35:10 <topyli> AlanBell: add an action for me also to fix the team reports so i don't forget
18:35:15 <pleia2> we tossed one up on the classroom blog late last week too (friday I believe)
18:35:24 <pleia2> so hopefully that'll help too :)
18:35:29 <AlanBell> #action topyli to sort out team reports
18:35:29 * meetingology topyli to sort out team reports
18:35:37 <AlanBell> thanks pleia2
18:38:22 <IdleOne> topyli: maybe add a blurb about testing the new bot features too? :)
18:38:49 <AlanBell> good idea, so if that is everything . . .
18:38:58 <AlanBell> #endmeeting