14:01:14 <stgraber> #startmeeting 12.04.1 team meeting
14:01:14 <meetingology> Meeting started Thu Jul 26 14:01:14 2012 UTC.  The chair is stgraber. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
14:01:14 <meetingology> 
14:01:14 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
14:01:44 <stgraber> stokachu, smoser, jamespage, jibel_, skaet: ping
14:01:47 <smoser> o/
14:01:57 <jibel_> o~
14:02:27 <NCommander> o_/
14:02:36 <stgraber> #topic Action items review
14:02:52 <stgraber> xnox to liase with ballons, gema and jibel w.r.t. fs/storage testing
14:03:08 <stgraber> no xnox around, so not sure what's the status on this, will keep it on the list of now
14:03:19 <stgraber> #topic Review of upcoming deadlines
14:03:21 <jibel_> no news from xnox this week
14:03:46 * skaet o/
14:04:05 <stgraber> jibel_: ok, I know he's quite busy (days off and quite a bit of work when he's around), so I wouldn't expect much to change at this point
14:04:07 <stgraber> - 2012/08/02: Beginning of PointReleaseProcess and DesktopInfrastructureFreeze
14:04:11 <stgraber> - 2012/08/09: KernelFreeze, LanguageTranslationDeadline, SRU Fix Validation Testing
14:04:13 <stgraber> - 2012/08/16: FinalFreeze, ReleaseNoteFreeze
14:04:16 <stgraber> - 2012/08/23: Ubuntu 12.04.1
14:04:38 <stgraber> in case it's not already clear ;) you have ONE week to get your fixes in!
14:05:05 <stgraber> #topic Quick look through the current bug lists, checking for progress.
14:05:21 <seb128> hey
14:05:26 <stgraber> hey seb128
14:05:36 <seb128> sort of around but at GUADEC so I might drop offline or not be responsive
14:05:48 <stgraber> seb128: just did the action reviews and pasted the deadlines, starting with the bugs now.
14:05:51 <stgraber> The number of targeted bugs went from 120 last week to 106.
14:05:52 <seb128> if you have questions for me please ask them while I'm around ;-)
14:05:54 <stgraber> Of these 106, 45 are in fix commited state (likely waiting in -proposed)
14:05:56 <stgraber> and 14 are marked "in progress" (waiting to be approved).
14:06:10 <stgraber> So that's 47 bugs that still need fixing of which 19 aren't assigned to somebody.
14:06:13 <stgraber> With just one week to go, now would be a good time to cleanup these lists and remember your teammates that they have bugs to fix :)
14:06:16 <seb128> we should start moving agressively stuff to .2 I guess
14:06:26 <seb128> right, will do that
14:06:35 <stgraber> The full list of bugs can be found at: https://bugs.launchpad.net/ubuntu/precise/+bugs?field.milestone%3Alist=49926
14:06:38 <stgraber> The list of remaining bugs to fix can be found at: http://goo.gl/RUiZe
14:06:40 <stgraber> Some of these aren't assigned to someone yet: http://goo.gl/22zV2
14:06:43 <seb128> did we have an improved report?
14:07:02 <stgraber> we have http://people.canonical.com/~arges/point-release/milestone-12.04.1.html thanks to arges
14:07:17 <arges> seb128, still getting the cron job set up on cranberry
14:07:30 <seb128> thanks
14:07:49 <stgraber> xnox offered to help arges and stokachu with the required rdepends rebuild for their multiarch packages by using his rebuild scripts on the HP cloud.
14:09:10 <stgraber> stokachu, arges: did you make any progress on that side (multiarch bugs)? I expect these to take quite a while to verify, so we really need them in ASAP
14:09:37 <arges> stokachu is out right now, but I'll sync with him when he gets out of his meeitngs
14:10:07 <stgraber> ok
14:10:38 <stgraber> If someone has fixes will be uploaded after the deadline and this was agreed with the release team, please let me know, otherwise I'll move all remaining bugs to 12.04.2.
14:10:41 <stgraber> #action stgraber to move all remaining bugs from 12.04.1 to 12.04.2 on the 2nd of August at 21:00 UTC
14:10:41 * meetingology stgraber to move all remaining bugs from 12.04.1 to 12.04.2 on the 2nd of August at 21:00 UTC
14:10:47 <stgraber> *that will be
14:11:28 <stgraber> I'd obviously prefer that people re-milestone their own bugs before that ;)
14:11:55 <stgraber> that's it on my side for the bugs, anyone has anything to highlight?
14:12:42 * arges looks
14:13:46 <arges> stgraber, http://launchpad.net/bugs/979003  <-- this one
14:13:48 <ubottu> Launchpad bug 979003 in eglibc (Ubuntu Precise) "libc incorrectly detects AVX support" [High,In progress]
14:13:50 <skaet> stgraber,   some of the remaining bugs we may want to go to -updates instead of 12.04.2 - so a scrub rather than bulk move is probably appropriate.
14:15:25 <stgraber> arges: I'm told that one will be fixed on time by infinity
14:15:25 <stgraber> arges: along with a couple others eglibc bugs
14:15:36 <seb128> ok, I'm moving room, might get disconnected
14:15:49 <stgraber> skaet: yeah, that's why I'd prefer the assignee to re-milestone their own bugs before I mass re-milestone the rest. I'm just going to move from 12.04.1 to 12.04.2, but anything that should instead go to updates should ideally be done by the assignee
14:15:58 <arges> stgraber, ok cool that's my understanding too
14:16:15 <stgraber> #topic Media oversizedness (skaet)
14:16:55 <skaet> no updates on this from me.    We do need to understand why we're oversized.
14:17:13 <stgraber> so, currently the only images that are oversized are amd64, amd64+mac and i386 daily-live
14:17:25 <stgraber> one of the main reasons is the inclusion of duplicate kernel headers
14:17:41 <stgraber> infinity said he'd hack live-build to fix that, but that didn't happen yet apparently
14:18:10 <stgraber> I'll poke infinity post-meeting regarding eglibc + live-build, to confirm that these will land before the 2nd
14:18:16 <skaet> thanks.
14:19:06 <stgraber> I haven't looked at flavour oversizedness yet, mostly because we're not building them yet (AFAIK), but it's possible that we'll have some problems with kubuntu, xubuntu, .. too
14:19:15 <stgraber> edubuntu should be fine as it's a DVD and has around 2GB of free space :)
14:20:36 <stgraber> #topic Round table
14:20:45 <stgraber> stgraber@castiana:~$ echo $(shuf -e NCommander seb128 stgraber stokachu arges jibel skaet smoser jamespage)
14:20:49 <stgraber> stokachu stgraber arges NCommander smoser jamespage jibel seb128 skaet
14:20:59 <stgraber> no stokachu, so skipping to me
14:21:25 <stgraber> I've been uploading a bunch of SRUs that had patches attached or were easy cherry-pick. I have a couple more like that to do.
14:21:41 <stgraber> I'm also going to do another round of SRU verification as the list is getting a bit long to my taste.
14:21:54 <stgraber> Besides that, I've been nagging my teammates and cleaning up the bug list :)
14:21:57 <stgraber> arges:
14:22:15 <arges> Trying to get the point-release dashboard working on cranberry
14:22:29 <arges> it works on my machine, but not there, so trying to debug it
14:23:12 <arges> I know its very late in the cycle here, but I'm hoping its more useful in .2
14:23:14 <arges> ..
14:23:51 <stgraber> NCommander:
14:23:52 <stgraber> around?
14:24:56 <stgraber> apparently not
14:24:58 <stgraber> smoser:
14:25:08 <smoser> - server tracked bugs list is quite resonable.
14:25:09 <smoser> It really feels to me like 12.04.1 and maas updates are not likely.
14:25:09 <smoser> I believe the team is still considering what to do for maas updates to LTS. I'll poke today.
14:25:43 <smoser> we've had some srus. maas is the big stuff still left on the bug list.
14:25:53 <smoser> 'im pinging others on their bugs right now.
14:26:00 <smoser> <end>
14:26:17 <NCommander> stgraber: sorry, was OTP'ed
14:26:32 * NCommander will wait for you to comearound
14:26:37 <stgraber> NCommander:
14:27:04 <NCommander> highbank SRUs are in propsed, known to work (aside fromyou have to enable proposed on the kernel command line for the moment)
14:27:23 <NCommander> Expecting no issues to passing into updates, and mreed already validated, and mahmoh is re-validating as a second check
14:28:02 * smoser was also covering for jamespage per his request
14:28:17 <NCommander> Unless castrophy strikes, Highbank will release with 12.04.1 as planned
14:28:32 <NCommander> </end>
14:29:32 <stgraber> jibel_:
14:29:49 <jibel_> SRU verification of ubiquity, update-manager and other upgrades defects and found no regression.
14:30:05 <jibel_> Blocked on bug 1017580 , the test case must be clarified
14:30:07 <ubottu> Launchpad bug 1017580 in ubiquity (Ubuntu Precise) "Add the ability to run custom scripts inside ubiquity-dm" [Wishlist,Fix committed] https://launchpad.net/bugs/1017580
14:30:17 <jibel_> and bug 987050 , alternate is not installable
14:30:18 <ubottu> Launchpad bug 987050 in ubiquity (Ubuntu Precise) "No "Prepare for shipping ..." option after OEM install from D-I" [Medium,Fix committed] https://launchpad.net/bugs/987050
14:30:41 <jibel_> precise alternate and server fail to install with a typical 'no kernel module found' which should be fixed with debian-installer 20101020ubuntu136.2 uploaded yesterday.
14:30:51 <jibel_> But from the version file on the media the image is built with 20101020ubuntu136 (version from the release pocket)
14:31:14 <stgraber> jibel_: I can take care of bug 1017580 if you want
14:31:15 <jibel_> my understanding was that images are built from proposed, is it the case for d-i based images too ?
14:31:19 <ubottu> Launchpad bug 1017580 in ubiquity (Ubuntu Precise) "Add the ability to run custom scripts inside ubiquity-dm" [Wishlist,Fix committed] https://launchpad.net/bugs/1017580
14:31:45 <jibel_> I'll continue SRU verification by the top of the list.
14:31:53 <jibel_> Did a bunch of installation with Ubiquity 2.10.18 and no new bug found so far.
14:31:54 <jibel_> ..
14:32:31 <stgraber> jibel_: yeah, all images are supposed to be built with -proposed enabled... not sure what happened to the alternates...
14:32:40 <jibel_> and server
14:33:37 <stgraber> seb128:
14:33:47 <seb128> not a lot from desktop
14:33:55 <seb128> we got a new unity SRU in proposed
14:34:06 <seb128> we should get another set of compiz uploads
14:34:14 <seb128> then some GNOME updates and small fixes
14:34:18 <seb128> then done for .1
14:34:19 <seb128> ..
14:34:49 <stgraber> skaet:
14:34:51 <skaet> discussed with vanhoof the cedartrail* landing late,   looking into a bug with the slideshow on a fresh install,  settled with martin and david that david will be doing the translation updates.   Doing calculations to add rest of LTS dailies to cron job,  will add after A3 publishes.
14:35:03 <skaet> ..
14:36:26 <stgraber> #topic AOB
14:36:41 <stgraber> one reminder on bug statuses as I've had to fix quite a few lately
14:37:05 <stgraber> for the SRU tasks (series = precise, milestone = 12.04.X), the reports and scripts usually expect the following
14:37:25 <stgraber> triaged + assigned => bug is being worked on or at least on someone's todo list
14:37:41 <stgraber> in-progress => fix has been uploaded and is waiting in the queue for an SRU team member to review
14:37:52 <stgraber> fix-commited => the fix has landed in -proposed and is pending verification
14:38:02 <stgraber> fix-released => the fix has landed in -updates and is available to everyone
14:38:45 <stgraber> the most common mistakes I've seen so far has been marking fix-released when they're only in -proposed and marking fix-commited when the fix hasn't even been uploaded yet (or is still in the queue)
14:39:24 <stgraber> I'm doing weekly passes on the 12.04.1 bugs to try and fix any mistake so the reports are accurate, but would be even better if the statuses would be correct to start with :)
14:39:29 <stgraber> ..
14:39:32 <stgraber> anything else?
14:41:35 * skaet thinks silence indicates EOM... ;)
14:42:23 <stgraber> #endmeeting