15:00:47 <skaet> #startmeeting
15:00:47 <meetingology> Meeting started Fri Jul 13 15:00:47 2012 UTC.  The chair is skaet. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:00:47 <meetingology> 
15:00:47 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
15:00:53 <skaet> Agenda (and minute location):
15:00:53 <skaet> https://wiki.ubuntu.com/ReleaseTeam/Meeting/2012-07-13
15:00:53 <skaet> .
15:00:53 <skaet> Upcoming dates:
15:00:53 <skaet> 12.10
15:00:54 <skaet> 2012/07/16-19: practice freeze queue test?
15:00:56 <skaet> 2012/07/23: Quantal Alpha 3 image candidates start
15:00:58 <skaet> 2012/07/26: Quantal Alpha 3
15:01:00 <skaet> 2012/08/23: Quantal Feature Freeze
15:01:02 <skaet> 12.04.1
15:01:04 <skaet> 2012/08/02: DesktopInfrastructureFreeze
15:01:06 <skaet> 2012/08/09: KernelFreeze, LanguageTranslationDeadline, SRU Fix Validation Testing
15:01:08 <skaet> 2012/08/16: FinalFreeze, ReleaseNoteFreeze
15:01:10 <skaet> 2012/08/23: Ubuntu 12.04.1
15:01:12 <skaet> .
15:01:26 <skaet> Work Items:
15:01:27 <skaet> 2012/06/29 -  3041 (was 2763 last week):  rather dramatic uptick in workitems for this pont in the cycle, being investigated.  As a result though the overall burn down trendline is looking a bit concerning again.   Please help get us back where we should be by making sure https://launchpad.net/~/+upcomingwork is up to date for your tasks.
15:01:27 <skaet> .
15:01:27 <skaet> Bugs:
15:01:28 <skaet> Quantal: http://reports.qa.ubuntu.com/reports/rls-mgr/rls-q-tracking-bug-tasks.html
15:01:30 <skaet> 12.04.1: https://bugs.launchpad.net/ubuntu/precise/+bugs?assignee_option=none&field.milestone%3Alist=49926
15:01:33 <skaet> .
15:01:58 <skaet> Pending action items:
15:01:58 <skaet> * [brendand] provide prioritized list of HW CERT targets for 12.04.1,
15:01:58 <skaet> top 5, and prioritized order after that. (brendand, 20120629 15:12:00)
15:01:58 <skaet> .
15:01:58 <skaet> Weekly Status Received:
15:01:59 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-July/001529.html - HW Cert - brendand
15:02:01 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-July/001527.html - QA - gema
15:02:03 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-July/001544.html - QA community - balloons
15:02:05 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-July/001528.html - Security - mdeslaur
15:02:07 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-July/001532.html - Kernel - ogasawara
15:02:09 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-July/001541.html - Foundations - ogra
15:02:11 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-July/001542.html - Server - arosales
15:02:13 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-July/001531.html - Desktop - seb128
15:02:17 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-July/001539.html - Unity - popey
15:02:19 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-July/001534.html - Edubuntu - stgraber
15:02:20 <seb128> hey
15:02:21 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-July/001538.html - Kubuntu - Riddell
15:02:23 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-July/001536.html - Lubuntu - gilir
15:02:25 <popey> o/
15:02:51 <stgraber> the 12.04.1 link above is for bugs that are targeted to 12.04.1 but aren't assigned to anyone. Please have a look and assign any relevant bug to your team members. (https://bugs.launchpad.net/ubuntu/precise/+bugs?assignee_option=none&field.milestone%3Alist=49926)
15:02:56 <stgraber> full list is available at: 15:01 < skaet> 12.04.1: https://bugs.launchpad.net/ubuntu/precise/+bugs?assignee_option=none&field.milestone%3Alist=49926
15:03:00 <stgraber> gah...
15:03:05 <skaet> hiya seb128 , popey,  welcome.   just finished pasting the preamble stuff.
15:03:14 <skaet> ..
15:03:14 <stgraber> full list is available at: https://bugs.launchpad.net/ubuntu/precise/+bugs?field.milestone%3Alist=49926
15:03:18 <stgraber> there we go :)
15:03:19 <stgraber> ..
15:03:33 <skaet> #topic Questions and Comments
15:03:44 <brendand> top 5 list is:
15:03:46 <brendand> https://bugs.launchpad.net/bugs/994685
15:03:46 <brendand> https://bugs.launchpad.net/bugs/1016195
15:03:46 <brendand> https://bugs.launchpad.net/bugs/990575
15:03:48 <ubottu> Launchpad bug 994685 in linux (Ubuntu Precise) "[Dell Inspiron 17] Headphone jack outputs no sound" [Medium,Fix committed]
15:03:50 <ubottu> Launchpad bug 1016195 in linux (Ubuntu) "[Dell Latitude E6220] Crashes or exits with signal 9 when under heavy load" [High,Confirmed]
15:03:51 <ubottu> Launchpad bug 990575 in linux (Ubuntu) "Entire desktop becomes unresponsive after suspend/resume" [High,Confirmed]
15:04:17 <skaet> Thanks brendand!  :)
15:04:18 <brendand> that's a top 3 :)
15:04:23 * skaet marks that action item done
15:04:35 <skaet> and glad to have it less than 5.  :)
15:04:39 <ogasawara> I'll have my team follow up.
15:04:39 <ogasawara> ..
15:04:46 <skaet> ..
15:05:19 <brendand> skaet - i had a little comment on : https://bugs.launchpad.net/ubuntu/precise/+source/ubiquity/+bug/1021293
15:05:21 <ubottu> Launchpad bug 1021293 in ubiquity (Ubuntu Precise) "Ubuntu 12.04 install stalls when doing apt-get upgrade" [High,Triaged]
15:05:45 <skaet> go ahead
15:05:47 <brendand> skaet - the issue is that the bug only manifests with the release image, so we can't use it at the moment
15:06:03 <brendand> skaet, so fixing it in 12.04.1 is essentially moot
15:06:30 <cjwatson> well.  except that given that it's apparently related to which packages get related, if we don't fix it in .1, it could recur at any time.
15:06:58 <cjwatson> sorry I haven't had time to look into it yet but I've had to focus on bug 1023036
15:07:00 <ubottu> Launchpad bug 1023036 in ubiquity (Ubuntu Quantal) "Error on /usr/share/ubiquity/plugininstall.py", line 1687, affecting desktop images (preseeded install)" [Critical,In progress] https://launchpad.net/bugs/1023036
15:07:11 <brendand> cjwatson, sure. for now we need to continue with the 12.04.1 daily though
15:07:31 <brendand> cjwatson, i totally understand that other more critical bugs have come up this week
15:07:43 <cjwatson> that's reasonable, I just don't think we can drop its priority on that basis
15:08:01 <brendand> cjwatson, at the moment i believe the 12.04.1 daily is broken as well
15:08:32 <gema> brendand: server is, yes
15:08:55 <brendand> gema, you don't have reason to believe desktop is? i saw the build was failed
15:09:08 <gema> brendand: I was going to type and desktop and alternate
15:09:09 <cjwatson> build or test?
15:09:17 <gema> cjwatson: test
15:09:34 <gema> well, there is no build today of desktop :?
15:09:35 <brendand> cjwatson, i meant jenkins 'build'. sorry
15:09:45 <brendand> old habit
15:09:52 * doko waves from debconf
15:10:49 <gema> brendand, cjwatson the tests are failing but we haven't had the time to get to them with all the other failures
15:11:03 <gema> I will try to get to that before leaving today
15:11:25 <brendand> gema - i think we are having a stab at it right now, so maybe we'll let you know soon!
15:11:34 <gema> brendand: thanks
15:12:05 <arosales> o/
15:12:07 <skaet> brendand ..?
15:12:13 <gema> ..
15:12:18 <brendand> skaet, i'm done
15:12:27 <brendand> ..
15:12:29 <skaet> thanks,  go arosales
15:12:46 <arosales> 2 comments
15:13:18 <arosales> ogra: looks like the arm build server are lagging due to panda board availability
15:13:35 <arosales> if so I can see if we have a few extras to help with the build progress
15:13:36 <ogra_> arosales, yes, they do
15:14:16 <arosales> orga_ I'll contact you offline to see if we can help with hardware issue
15:14:26 <ogra_> arosales, well, i think elmo'S team has a mandabox somewhere already, if thats actually the case i would rather like to see the time invested in bringing that one up than to add extra free flaying pandas in the DC
15:14:33 <arosales> gema: I think james page should have updated the server test cases for tomcat
15:15:10 <ogra_> arosales, i know kate asked in direction IS, lets wait for that feedback first
15:15:29 <skaet> ogra_, arosales,  pgraner's been in touch with IS,  will let you both know when I hear something back.
15:15:36 <ogra_> great
15:15:37 <arosales> orga_ : ok, feel free to ping me if the hardware continues to be an issue and I can try to help hunt down some additional ones
15:15:42 <gema> arosales: thanks
15:15:47 <arosales> ..
15:15:51 <ogra_> o/
15:15:59 <pgraner> ogra_, elmo is looking into it
15:16:08 <skaet> thanks arosales,  go ogra_
15:16:12 <ogra_> pgraner, yay, thanks :)
15:16:22 <pgraner> ogra_, additionally I've got imx6's with sata that rtg & infinity have to see if we could use them
15:16:25 * ogra_ hands a bouquet to ogasawara ....
15:16:39 <arosales> pgraner: skaet: thanks
15:17:07 <ogra_> ogasawara, as mentioned in the foundations report, we'd like to see some kernel team focus on bug 1023174 ... just wanted to mention it here additionally
15:17:09 <ubottu> Launchpad bug 1023174 in linux (Ubuntu) ""ip -6 addr flush" flushes much more than just the addresses" [Medium,Confirmed] https://launchpad.net/bugs/1023174
15:17:10 <ogra_> ..
15:17:35 <ogasawara> ogra_: ack, have already sent email out to have it investigated by my team.
15:17:39 <ScottK> o/
15:17:50 <skaet> thanks ogra_,   ScottK go
15:17:59 <ScottK> Sorry about breaking everything python3 yesterday.  It should all be good now thought.
15:18:01 <ScottK> ..
15:18:11 <ScottK> thought/though
15:18:22 <skaet> thanks ScottK
15:18:40 <skaet> I've got a couple of comments,  if no other hands.  ;)
15:19:01 <skaet> on the subject of bugs,   to continue on from stgrabers comments,  we're starting to run out of time for 12.04.1.
15:19:46 <skaet> so its important that bugs found, get to the developers as soon as possible.
15:19:46 <skaet> In working through the bugs over last few days,  I�ve been see several cases where the bug is not release targetted and prioritized correctly,  so the development teams are not seeing it in a timely manner,  which is a particular concern as we�re dealing with the 12.04.1 and quantal development bugs right now.
15:19:46 <skaet> .
15:19:46 <skaet> As a reminder, we are using the tag "rls-q-incoming" to signal a bug needs to be looked at by the development teams for inclusion in the release.  If the development team is going to fix it,  it will be targetted to the series, and possibly a specific milestone.
15:20:14 <skaet> These nominated incoming bugs can be found: http://reports.qa.ubuntu.com/reports/rls-mgr/rls-q-incoming-bug-tasks.html.   Goal here is to keep this report as empty as possible.
15:20:14 <skaet> The bugs that the development teams are committed to fixing can be found here:
15:20:15 <skaet> http://reports.qa.ubuntu.com/reports/rls-mgr/rls-q-tracking-bug-tasks.html
15:20:15 <skaet> (no incoming tag, and targetted to quantal gets a bug on this list)
15:20:15 <skaet> For those bugs targetted to quantal that there isn't a plan in place to fix, the tag 'rls-q-notfixing' will be on the bug,  and they'll show up in:
15:20:19 <skaet> http://reports.qa.ubuntu.com/reports/rls-mgr/rls-q-notfixing-bug-tasks.html
15:20:21 <skaet> .
15:20:23 <skaet> For those bugs that its important to fix for 12.04.1,  please make sure the bug is targetted/nominated to the precise series, and milestoned to 12.04.1 - that will get it on the development team that�s focusing on 12.04.1�s radar.
15:20:27 <skaet> If you have any questions,  feel free to ping me.
15:20:29 <skaet> ..
15:20:59 <skaet> Any one have reservations about cjwatson�s requested test days for the launchpad queue upload processing code next week?  (7/16 2100 -> 7/19 2100)   If no one comments before the end of the meeting,  that will be the plan.
15:20:59 <skaet> .
15:21:21 <Daviey> sounds reasonable to me.
15:21:38 <skaet> coolio
15:21:47 <seb128> works for desktop
15:21:55 <stgraber> +1
15:22:37 <skaet> ok,  I'll move on for now.
15:22:39 <skaet> ..
15:22:41 <cjwatson> Great, thanks - I'll try to make things as non-disruptive as possible.  Archive admins, once again, please make sure to tell me about any problems you see
15:22:44 <cjwatson> ..
15:23:15 <skaet> popey,  when is the next drop targetted for 12.04.1?
15:23:40 <skaet> (or seb128,  if you know)
15:24:07 <seb128> skaet, next week
15:24:14 <popey> sorry, yup
15:24:15 <seb128> the SRU got started to be prepared this week
15:24:43 <seb128> we are trying to remind popey and friends that we need that SRU regularly, they promised it will come soon ;-)
15:24:46 <seb128> popey, right? ;-)
15:24:50 <popey> correct
15:25:20 <skaet> popey,  is there a plan visible somewhere for the drops anticipated for quantal and 12.04.1?
15:25:38 <popey> hmm, no. Will fix that.
15:25:46 <skaet> thanks popey.  :)
15:25:56 <skaet> ..
15:26:14 <skaet> seb128,  fair number of bugs are showing up in the desktop section for quantal, http://reports.qa.ubuntu.com/reports/rls-mgr/rls-q-tracking-bug-tasks.html
15:26:14 <skaet> which ones are the desktop team going to be focusing on fixing?
15:26:54 * skaet doesn't expect an answer now... ;)
15:27:11 <seb128> skaet, we expect to fix all of those ;-)
15:27:26 <seb128> skaet, the list is not that long if you consider that desktop team is ~15 people
15:28:23 <seb128> ..
15:28:34 <skaet> heh, ok.   :)  lets see how it looks next week.
15:28:36 <skaet> ..
15:28:57 <skaet> balloons,  what is the status of the accessibility testing requested?
15:28:57 <skaet> do you need help reaching out to that community?
15:28:59 <stgraber> 1~
15:29:03 <stgraber> oops :)
15:29:12 <seb128> our list is not longer that foundation's or kernel's ones on that page though
15:29:13 <seb128> ..
15:29:28 <balloons> skaet, I spoke with seb128 and I simply put out a heads up on it..
15:29:45 <skaet> balloons,  any feedback?
15:30:03 <balloons> there wasn't anything in particular to test beyond being on the lookout for weirdness from what I understand
15:30:31 <skaet> did anyone do some accessibility specific tests on them?
15:30:46 <balloons> feedback is it appears like nothing major broke yet  :-p I didn't hear anything negative.
15:31:00 <balloons> That said, I don't know how the accessibility tests are/where affected
15:31:13 * skaet was hoping that some of the broken things got better actually....
15:31:28 <balloons> since I'm talking, I'm still in process of getting info on what's happening with unity testing this cycle
15:31:47 <balloons> but regression testing will happen alongside that I suspect
15:31:49 <balloons> ..
15:32:17 <skaet> seb128,  could you ask TheMuso to put together a list of tests worth focusing on for accessibility, so we can get that a bit more directed?
15:32:30 <seb128> can do
15:32:39 * seb128 to ask TheMuso to put together a list of tests worth focusing on for accessibility
15:32:43 <skaet> Thanks  seb128.  :)
15:32:46 <seb128> or how that work?
15:32:52 <seb128> I got the syntax wrong?
15:33:17 <skaet> #action:  seb128 to ask TheMuso to put together a list of tests worth focusing on for accessibility
15:33:17 * meetingology :  seb128 to ask TheMuso to put together a list of tests worth focusing on for accessibility
15:33:26 <seb128> skaet, thanks
15:33:27 <seb128> ..
15:34:11 <skaet> popey,  do you have any guidance for balloons?  ^
15:34:26 * popey looks
15:35:17 <popey> i see no questions :S
15:35:39 <popey> oh, i see
15:35:56 <skaet> maybe I misinterpreted,  but thought that balloons was looking for info on what needs to be tested for unity this cycle.
15:36:46 <balloons> skaet, yes, popey and I have been playing tag
15:36:52 <balloons> but we'll work it out
15:37:04 <popey> I'll catch up with balloons after this meeting about it
15:37:17 <popey> balloons, lets have a hangout in a bit
15:37:23 <popey> ..
15:37:37 <skaet> popey,  coolio,   summary might be useful to others as well, so if you could publish it somewhere that would be good.  :)
15:37:51 <popey> once I know, you'll know :)
15:37:55 <skaet> :)
15:38:08 <balloons> skaet, yea we can post a summary to release lit
15:38:09 <balloons> *list
15:38:27 <skaet> perfect.  :)   Thanks!
15:38:31 <skaet> ..
15:38:36 * skaet looks for hands?
15:38:40 <balloons> o/
15:38:52 <skaet> go ahead balloons
15:39:17 <skaet> or were you just showing me a hand.  ;)
15:39:35 <balloons> I also wanted to mention, I know now is the time for feature and new application stuff to land. So please let me know if you want/need any testing around what's landing. We have a nice setup with the package tracker now and the community is ready to go :-)
15:39:58 <balloons> skaet, lol..
15:40:06 <balloons> ..
15:40:10 <skaet> thanks balloons.   :)
15:40:24 <gema> o/
15:40:34 <skaet> go gema
15:41:06 <gema> we seem to be having lots of problems with automated tests. Some of them are due to the code, some others due to environment, I'd like everyone to be aware that this is the case
15:41:15 <gema> and put special care on not breaking things if posible
15:41:26 <gema> at least until we are out of the woods
15:41:31 <gema> ..
15:41:42 <skaet> thanks gema.
15:42:04 <skaet> +1 from me on that sentiment.   Be nice for things to get solid again.
15:42:25 <skaet> ..
15:43:00 <skaet> ok,  I think that's it for the questions and comments for this meeting.
15:44:15 <ScottK> 0/
15:44:20 <skaet> heh
15:44:32 <skaet> just caught me on the endmeeting.... go ScottK
15:44:34 <ScottK> In yesterday's meeting I forgot to mention we've got a Qt SRU that'll get uploaded today or tomorrow.
15:44:38 <ScottK> ..
15:44:49 <stgraber> ScottK: good to know, thanks
15:44:50 <stgraber> ..
15:44:55 <skaet> thanks ScottK.
15:44:56 <skaet> ..
15:45:18 <cjwatson> gema: I think I have a fix for the most notorious of the desktop failures, FWIW.  At least once I debug the bugs in the bug-fix :-)
15:45:32 <gema> cjwatson: many thanks :DDDD
15:45:35 <seb128> cjwatson, \o/
15:45:53 <skaet> Thanks ogra_, roadmr, brendand, arosales, seb128, popey, cjwatson, stgraber, ScottK, balloons, Daviey, gema, pgraner
15:45:57 <skaet> #endmeeting