21:04:37 <ajmitch> #startmeeting
21:04:37 <meetingology> Meeting started Fri Jun 29 21:04:37 2012 UTC.  The chair is ajmitch. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
21:04:37 <meetingology> 
21:04:37 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
21:05:05 <ajmitch> OK, arb agenda is https://wiki.ubuntu.com/AppReviewBoard/Agenda
21:05:09 * stgraber waves
21:05:17 * highvoltage splashes
21:06:28 <ajmitch> was looking over http://ubottu.com/meetingology/logs/ubuntu-meeting/2012/ubuntu-meeting.2012-05-25-21.09.log.html from the last meeting, there weren't any actions added aside from the UDS items
21:07:34 * wendar waves
21:07:46 <ajmitch> yay, people :)
21:08:23 <highvoltage> I'm really tired so sorry for my lack of enthusiasm :)
21:08:25 <ajmitch> do we want to quickly go over the developer portal bugs, or just be happy that they're there & being looked at? :)
21:09:01 * ajmitch mostly wants to get people voting on submissions, fwiw :)
21:09:49 <highvoltage> Ok, I'll catch up with the votes tomorrow. And also all the nice things dolbach has been talking about.
21:10:12 <ajmitch> yeah, I've been talking with dholbach a bit & following what he's been doing with the apps branch & arb-lint
21:10:13 <highvoltage> and also try to get some sense of how many competition apps there are and what I can do about it
21:10:27 <ajmitch> apparantly there are 30+ for the competition
21:10:45 <ajmitch> I expect some won't be packaged for /opt/extras.ubuntu.com
21:11:38 <ajmitch> this sort of covers some of the UDS workitems, with the competition & the tools for reviewing
21:12:46 <ajmitch> one thing that came up this week was whether ~ubuntu-dev should be added to the ~ubuntu-app-review-contributors team
21:12:52 <ajmitch> thoughts?
21:14:16 <highvoltage> sounds like it makes sense
21:14:36 <highvoltage> the more the arb process is integrated in the rest of ubuntu, the better
21:14:39 <highvoltage> (imho)
21:15:05 <ajmitch> it'd allow any ubuntu developer to commit to the branches dholbach is importing, and let them comment & change state of apps on myapps
21:15:11 <ajmitch> which I think is fine
21:15:26 <ajmitch> assuming you find the branches useful
21:15:59 <wendar> well, remember that ubuntu-app-review-contributors gets special access in MyApps
21:16:15 <wendar> do we want to grant that to all ubuntu-devs?
21:16:22 <ajmitch> right, that's what I'm asking
21:16:47 <wendar> it seems like some kind of verification step makes sense
21:16:55 <ajmitch> since changing the myapps state doesn't affect a whole lot unless they're rejected
21:17:07 <highvoltage> I guess in that case they might as well just join #ubuntu-arb and ask to be added
21:17:23 <highvoltage> (or mail or whatever)
21:17:28 <wendar> I thought review contributors could do more than just change state?
21:18:05 <highvoltage> what's the concern? that someone might do something malicious?
21:19:14 <wendar> more concerned about accidental disruptive changes, from people who don't know the interface yet
21:19:18 <wendar> it's still a little buggy
21:19:45 <wendar> but, if they really only have access to comment and non-destructive state changes, then I have no concern
21:19:59 <wendar> it is worth asking ubuntu-dev if they *want* to be added though
21:20:18 <wendar> aren't there default notifications sent out to review contributors?
21:20:39 <wendar> or, is that only direct to the arb mailing list, and not individual notifications?
21:20:48 <ajmitch> that's what dholbach was checking, he said he hadn't received any
21:21:44 <wendar> is that because they're going to ubuntu-app-review-board members? or to the mailing list?
21:21:52 <ajmitch> to the mailing list
21:22:36 <wendar> ok, limited access and not spamming ubuntu-devs are my only concerns
21:23:04 <wendar> if that's all sorted, and ubuntu-dev wants to be added, I'm fine with it
21:23:04 <ajmitch> alright
21:23:26 <highvoltage> sounds reasonable
21:23:29 <stgraber> +1
21:23:35 <wendar> another possibility is to just ask achuni to grant access to all ubuntu-dev, without joining up the launchpad teams
21:23:35 <ajmitch> it's a bit hard to ask a team that encompasses everyone with upload rights, ~ubuntu-dev is often added to other teams
21:24:07 <ajmitch> that could work
21:24:12 * ajmitch just wants more people reviewing
21:24:32 <wendar> yeah, making that as easy as possible is a good idea
21:25:06 <wendar> though, there something neat about being granted priviledges when you join a team :)
21:25:33 <ajmitch> ideally we'd have some active arb helpers who could then go on to the arb team (election, appointment, whatever) & vote on apps
21:26:13 <ajmitch> the term length is indefinite in LP for some reason, but I know we all won't want to do this forever :)
21:29:02 <ajmitch> ok, that vaguely covers the recruiting agenda item from last month
21:30:00 * ajmitch isn't sure if any of us have managed to set aside a regular reviewing time lately, so will skip that :)
21:30:24 <ajmitch> #topic General state of the ARB queue
21:30:36 <wendar> ajmitch: hmmm... we all had term expirations last I checked...
21:30:39 <ajmitch> I'm worried that applications are getting lost in the voting process
21:30:50 <ajmitch> wendar: I checked the other day, we no longer do
21:31:20 <wendar> ajmitch: how odd. I know mine's coming up soon
21:31:41 <ajmitch> https://launchpad.net/~app-review-board/+members shows no expiry dates
21:32:16 <wendar> ajmitch: yup, you're right
21:32:27 <wendar> ajmitch: well, it's 2 years after start anyway
21:32:30 <ajmitch> it's a life sentence :)
21:32:41 <highvoltage> oh dear
21:33:03 <wendar> so, 3 of us are out this September
21:33:14 <wendar> but, I don't think we should wait until then to add new people
21:33:39 <ajmitch> no, nominally there are 7 on the board, but a couple haven't been heard from for quite some time
21:33:46 <wendar> really, I'd be happy to treat it as more of a promotion process
21:33:50 <ajmitch> so would I
21:34:06 <wendar> we'd still need to do the poll of all ubuntu-devs
21:34:12 <wendar> but, it could be on a one-off basis
21:34:26 <ajmitch> & not require adjusting quorum for votes on apps, even universe just requred 2 +1s from MOTUs for new apps
21:34:48 <wendar> yeah, quorum is a fixed number, shouldn't vary by the size of the board
21:35:03 <wendar> (it already is that way, so no change needed)
21:35:14 <ajmitch> we've struggled to get 3 votes lately, I know everyone's been busy (myself included)
21:35:37 <wendar> ajmitch: yes, I'm thinking I may switch to making voting my first priority
21:35:43 <ajmitch> I came across an example of a lens that had the vote started about 7 weeks ago, but never got to +3
21:35:52 <wendar> especially if we get some regular arb contributors
21:36:19 <ajmitch> what do you think of a trello board for being able to see the state of the apps being worked on & reviewed? too much duplication?
21:36:23 <highvoltage> yeah I think it makes sense priorotising voting, the last thing we want is a backlog of perfectly good apps.
21:36:25 <wendar> reviewing an app that's already been cleaned up takes a lot less time than cleaning up a new one
21:36:40 <wendar> ajmitch: yeah, I wondered about using trello too
21:36:45 <ajmitch> really, the arb's only role should need to be voting
21:37:06 <wendar> ajmitch: it doesn't have to be a lot of work to maintain trello, if it's just the name and link for each app
21:37:13 <ajmitch> we can all do package clean up if we want, but voting is the main task
21:37:23 <ajmitch> wendar: right
21:37:48 <wendar> trello is far, far simpler to maintain than a wiki page for app status :)
21:37:52 <ajmitch> that way if you put an app up for vote, move it to the voting list in trello so we can see what to look at
21:38:00 * ajmitch uses it a bit at work now
21:38:21 <wendar> and we can grant arb contributors full edit rights on trello
21:38:27 <ajmitch> yep
21:38:45 <wendar> and, any app submitter can quickly check the status of their app
21:38:47 <ajmitch> stgraber, highvoltage: in favour of it?
21:38:58 <highvoltage> yep
21:40:17 <stgraber> sounds good
21:40:17 <ajmitch> #action ajmitch to set up trello board for tracking application votes & reviewer notes
21:40:17 * meetingology ajmitch to set up trello board for tracking application votes & reviewer notes
21:40:23 <ajmitch> ok
21:40:52 * ajmitch thought this weekend was going to be completely full with work, but it seems next weekend will be
21:41:24 <ajmitch> dholbach's suggested this apps sprint this week, I'll probably be lurking around #ubuntu-arb in the evenings as usual
21:42:06 <ajmitch> not sure how crazy everyones' schedules are, but it'd be nice to get through a few apps for the competition over the next few days
21:42:48 <wendar> Sunday is okay for me this week
21:42:57 <wendar> and Wednesday is a holiday
21:43:11 <ajmitch> lucky :)
21:43:13 <wendar> but otherwise I've got a couple hours in the morning and a couple in the evening
21:43:22 <wendar> so, I can do short snippets
21:43:30 <ajmitch> any time is helpful
21:43:36 <wendar> but, not big stuff
21:43:46 <wendar> like, a whole app review usually takes me 4 hours
21:43:56 <wendar> (with finding and fixing bugs)
21:43:59 <ajmitch> I can understand that, it can be quite involved
21:44:09 <ajmitch> we'll try & get some cleaned up apps for voting on
21:44:10 <wendar> I know I've got a couple that are just about ready to go up for vote
21:44:13 <ajmitch> they should take less time
21:44:18 <wendar> so, I can focus on those for this week
21:44:29 <wendar> and, on voting on the ones that are already up for vote
21:44:59 <wendar> does trello let you assign a task to a person/
21:45:00 <wendar> ?
21:45:12 <ajmitch> yes
21:45:21 <ajmitch> just drag their icon onto the card
21:45:31 <wendar> cool, that'll help
21:45:38 <ajmitch> I'll probably need to get the email you use for trello so I can add people
21:45:51 <wendar> like, when I'm working on an app, I can put it in an active channel, and then tag it with my user
21:46:28 <wendar> because honestly, right now it'll take me 30minutes just to find all my active apps, check on their status, and figure out what the next step is for each :(
21:46:48 <ajmitch> yeah, and you can leave comments on each card, it's fairly quick to use
21:47:57 <wendar> okay, that'll help alot :)
21:48:08 <ajmitch> with that, is there any other business to talk about?
21:48:15 <ajmitch> apart from the meeting time & the next chair
21:50:01 <wendar> sounds like not :)
21:50:32 <ajmitch> ok :)
21:50:51 <ajmitch> does this meeting time still work for people, and who volunteers to be the next chair? :)
21:53:07 * ajmitch will have to volunteer someone for it soon
21:53:31 <ajmitch> highvoltage: you're next alphabetically, available for it next month?
21:53:46 <highvoltage> ajmitch: ok
21:54:01 <ajmitch> thanks
21:54:55 <ajmitch> next meeting at 21:00UTC on 27 july
21:54:59 <ajmitch> #endmeeting