16:03:52 <SpamapS> #startmeeting Ubuntu Server Team
16:03:52 <meetingology> Meeting started Tue Jun 26 16:03:52 2012 UTC.  The chair is SpamapS. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:03:52 <meetingology> 
16:03:52 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:04:18 <SpamapS> #topic Review ACTION points from previous meeting
16:04:24 <SpamapS> arosales to follow up with rbask on finding the correct home for the Ubuntu Server blog.
16:04:29 <SpamapS> Oh, and hi everybody ;)
16:04:36 <arosales> rbasak: has made an IS request to have the blogged moved
16:04:54 <arosales> SpamapS: so that in progress per rbasak's work
16:05:03 <SpamapS> woot
16:05:20 <Daviey> \o/
16:05:21 <SpamapS> #action rbasak follow up on IS request to move Ubuntu Server blog
16:05:21 * meetingology rbasak follow up on IS request to move Ubuntu Server blog
16:05:25 <SpamapS> Review ACTION points from previous meeting
16:05:27 <SpamapS> oops
16:05:39 <SpamapS> Ctrl-C before Ctrl-Shift-V...
16:05:40 <SpamapS> jamespage to follow up with hallyn on servercloud-q-server-iso-tests-review
16:05:59 <Daviey> 16:53 < jamespage> hallyn, pre-empting my non-action from last weeks team meeting
16:05:59 <jamespage> SpamapS, I've actually remembered what that is now
16:06:02 <Daviey> 16:53 < jamespage> the check from the servercloud-q-server-iso-tests-review blueprint was related to checking the functionality of a VM post host upgrade
16:06:03 <hallyn> inprogress :)
16:06:05 <Daviey> 16:53 < jamespage> I think
16:06:07 <Daviey> 16:53 < jamespage> i.e. if we upgrade precise->quantal do VM's keep functioning
16:06:20 <jamespage> SpamapS, still inprogress
16:06:27 <jamespage> but I really don't think we need to track it here
16:06:38 <hallyn> nope
16:06:41 <hallyn> thx
16:06:48 <Daviey> sounds sensible to drop it's special treatment :)
16:07:48 <SpamapS> sorry got lagged out for a second
16:08:01 <SpamapS> utlemming to follow up with rbasak on getting armhf images using highbank
16:08:15 <utlemming> SpamapS: in progress
16:09:12 <SpamapS> do we need to check in on that again next week? Sounds like its getting handled
16:09:32 <SpamapS> #topic Quantal Development
16:09:33 <utlemming> if we need follow up next week, I'll raise it
16:09:42 <SpamapS> Release Bugs - http://reports.qa.ubuntu.com/reports/ubuntu-server/release-bugs.html
16:09:57 <SpamapS> https://launchpad.net/bugs/974584
16:09:59 <ubottu> Launchpad bug 974584 in sysvinit (Ubuntu Quantal) "Semaphores cannot be created in lxc container" [High,Triaged]
16:10:11 <SpamapS> hallyn: ^?
16:10:25 <SpamapS> https://launchpad.net/bugs/920197
16:10:27 <ubottu> Launchpad bug 920197 in python-webob (Ubuntu Quantal) "[SRU] webob last stable version 1.1.1 response header bug" [High,Triaged]
16:10:31 * SpamapS parallelizes
16:10:42 <SpamapS> zul: ^?
16:10:56 <zul> crap totally forgot about that one
16:10:56 <SpamapS> https://launchpad.net/bugs/1001846
16:10:58 <ubottu> Launchpad bug 1001846 in cobbler (Ubuntu) "cobbler fails to install with error code 1" [High,Confirmed]
16:11:13 <SpamapS> Andres is not here, will skip that
16:11:24 <SpamapS> https://launchpad.net/bugs/1008537
16:11:27 <ubottu> Launchpad bug 1008537 in sphinx (Ubuntu) "[FTBFS] Segmentation fault during tests" [High,Confirmed]
16:11:53 <SpamapS> Also no arges here
16:12:07 <SpamapS> https://launchpad.net/bugs/1009579
16:12:11 <ubottu> Launchpad bug 1009579 in tomcat7 (Ubuntu) "[MIR] tomcat7 (replaces tomcat6)" [High,New]
16:12:14 <SpamapS> jamespage: ^?
16:12:27 <jamespage> SpamapS, its in the MIR queue
16:12:41 <jamespage> tomcat7 got acked - but I pulled in a new dep for testing enablement
16:12:46 <SpamapS> jdstrand: how is the MIR queue for quantal looking btw?
16:12:52 <SpamapS> https://launchpad.net/bugs/1014005
16:12:54 <ubottu> Launchpad bug 1014005 in ipxe (Ubuntu) "Please generate and include ipxe.dsk to the ipxe binary package" [Wishlist,Triaged]
16:13:04 * jamespage is about to add three more package to the MIR queue
16:13:05 <SpamapS> ipxe, no assignee
16:13:09 <hallyn> SpamapS: bug 974584, i pinged slangasek yesterday, will do so again today
16:13:11 <ubottu> Launchpad bug 974584 in sysvinit (Ubuntu Quantal) "Semaphores cannot be created in lxc container" [High,Triaged] https://launchpad.net/bugs/974584
16:13:17 <SpamapS> Daviey: ^^ ? ipxe in your sphere of interest?
16:13:23 <SpamapS> hallyn: cool
16:13:35 <hallyn> Daviey somehow things i want to maintain ipxe :)
16:13:44 <hallyn> so next time we push ipxe, i was going to see about doing 1014005
16:13:58 <SpamapS> https://launchpad.net/bugs/935516
16:13:58 <hallyn> haven't looked enough to even be sure it's reasonable
16:14:00 <ubottu> Launchpad bug 935516 in genshi (Ubuntu Precise) "genshi version 0.6-2 FTBFS on i386 in precise" [High,Triaged]
16:14:01 <SpamapS> This needs an assignee
16:14:47 <SpamapS> anyone?
16:15:13 <Daviey> hallyn: :D
16:15:44 <SpamapS> moving on
16:15:45 <SpamapS> Blueprints - http://status.ubuntu.com/ubuntu-quantal/ubuntu-server.html
16:15:46 <Daviey> SpamapS: it's blocked on upstream
16:16:05 <SpamapS> bad trend line.. ;)
16:16:23 <arosales> some ARM server blueprint work items came in late
16:16:46 <hallyn> I think I might need to go through some of my items and break them down further (and other people's lxc items)
16:16:50 <arosales> I'll try to get the trend line readjusted to accommodate those late additions.
16:16:54 <hallyn> they certainly are not half-day or less chunks, as we used to aim for
16:17:19 <SpamapS> I don't know if we can hilight any yet
16:17:27 <SpamapS> Seems like we're just now really getting definition on them
16:17:56 <arosales> hallyn: let me know when if you add work items, so I can sync the trend line after that
16:18:12 <SpamapS> so unless there's a specific blueprint people want to bring up.. I think we should probably move on
16:18:22 <hallyn> arosales: ok (thanks, didn't know you wanted that)
16:18:23 <arosales> be nice if we can get a good trend line representation by end of the week
16:18:47 <SpamapS> indeed
16:18:50 <SpamapS> #topic 12.04.1 Development (jamespage & smoser)
16:19:14 <Daviey> desktop-q-xorg-general is essential for server quantal, apparently
16:19:22 <Daviey> oops, sorry
16:19:27 <jamespage> http://people.canonical.com/~jamespage/server-sru/precise-sru.html
16:19:38 <jamespage> Not much to update since last weel
16:20:09 <jamespage> quite a bit of stuff needs verification - especially around the recent nova upload - zul is there any specific arrangement around that?
16:20:38 <zul> jamespage: errmm......ill talk to you offline about it
16:20:41 <SpamapS> With Nova, we need to just make sure the CI tests pass with the packages from proposed
16:20:46 <jamespage> zul, sure
16:20:51 <jamespage> SpamapS, ack
16:21:06 <adam_g> if thats all we need, we can have something referenced on them soon
16:21:19 <SpamapS> Other than that, verification of any High/Criticals that have actual test cases would be appreciated, but is not necessary. The update will move to -updates when all the CI tests have worked.
16:21:34 <Daviey> SpamapS / zul: can i be in the offline discussion please
16:21:49 <zul> Daviey: yep
16:21:59 <jamespage> if anyone wants to pickup a few SRU's then pick something from the 'Unassigned' list - based on priority would be good
16:22:19 <jamespage> Daviey, smoser: we also need to sort out what MAAS is going to target for 12.04.1
16:22:34 <Daviey> jamespage: yes.
16:22:39 <smoser> roaksoax, clearly is involved in that, and "upstream"
16:22:45 <jamespage> sure
16:22:54 <Daviey> jamespage: it's semi-blocked atm fwiw
16:23:05 <SpamapS> Anything else?
16:23:10 <jamespage> nope
16:23:18 <SpamapS> #topic Ubuntu Server Team Events
16:23:38 <SpamapS> Velocity is this week, with jcastro and hazmat attending, talking about Juju
16:24:10 * jamespage <- Euro Python next week (talking about Juju)
16:24:23 <SpamapS> Also OSCON is coming up July 16 - 20 in Portland, and we will have a juju charm school there
16:24:59 <SpamapS> #topic Weekly Updates & Questions for the QA Team (hggdh)
16:25:07 <SpamapS> no hggdh today
16:25:12 <SpamapS> Anybody else have QA news though?
16:25:25 <Daviey> Sort of..
16:25:39 <jamespage> QA team are starting to transfer ISO test cases to UTAH - meeting with gema next week to review
16:25:41 <Daviey> If you have an opportunity to try the daily candidates for A2, please do so :)
16:26:02 <Daviey> jamespage: Gema will be here?
16:26:12 <jamespage> no not here - outside of this meeting
16:26:20 <Daviey> jamespage: can i be pinged into that please?
16:26:25 <jamespage> Daviey, sure
16:26:36 <smoser> wait...
16:26:36 <jamespage> later in the week
16:26:42 <smoser> wait. daily candidates?
16:26:46 <smoser> are we not expecting kernel upload still?
16:26:50 <smoser> smb, ?
16:26:56 <smb> done
16:27:13 <smb> Kernel 3.5.0-2.2 has been uploaded to quantal-proposed (i386 ec2 issue)
16:27:18 <smoser> and we have ISOs that have those in it?
16:27:20 <smb> about 2 hrs ago
16:27:33 <Daviey> no, not yet
16:27:36 <SpamapS> good segue
16:27:39 <SpamapS> #topic Weekly Updates & Questions for the Kernel Team (smb)
16:27:41 <smoser> well, then testing would make no sense.
16:27:41 <Daviey> I will spin new images shortly
16:27:47 <smoser> Daviey, can you do that?
16:27:52 <smoser> the kernel is in -proposed
16:27:58 <smb> Apart from ther quantal kernel... Finally the scheduler bug that tried to drive me crazy has been identified. A proper upstream fix is under discussion and testing.
16:27:59 <smoser> so we wont even pick it up in cloud iamge builds.
16:28:03 <SpamapS> Daviey: sorry thought you were done begging for ISO testers ;)
16:28:04 <smb> ..
16:28:04 <smoser> by design we do not pick up proposed.
16:28:10 <Daviey> smoser: I'm on the hook for spinning cd's this week
16:28:27 <Daviey> smb: have the bug number?
16:28:32 <smoser> i guess i should have realized this change earlier, but did not.
16:28:44 <smb> Daviey, of what. Things are a bit jumbled up... ;)
16:28:58 <smoser> ie if we're using -proposed during the development cycle, then our cloud image builds will not pick from it, ever.
16:29:03 <Daviey> smb: Do you have bug numbers for anything concerning you? :)
16:29:19 <Daviey> smoser: Yes, same as cd images.
16:29:33 <smb> bug 999755
16:29:34 <ubottu> Launchpad bug 999755 in linux (Ubuntu) "Kernel crash in rb_next doing ohai loops" [Medium,Confirmed] https://launchpad.net/bugs/999755
16:30:23 <smb> Otherwise nothing of immediate importance
16:31:10 <SpamapS> Settled then?
16:31:21 <SpamapS> #topic Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:31:44 <Daviey> ta
16:33:35 <SpamapS> rbasak: ^^
16:33:55 * Daviey does a little jig whilst waiting.
16:34:33 <SpamapS> rbasak: we'll come back if you have anything
16:34:42 <SpamapS> #topic Welcome jimbaker to Server team (arosales).
16:34:58 <SpamapS> jimbaker`: welcome.. again? ;)
16:35:01 <arosales> SpamapS: sorry that didn't removed from last week
16:35:10 <arosales> but welcome jimbaker` to the server team :-)
16:35:11 <Daviey> woot.. double welcome, he must be special
16:35:16 <SpamapS> we should make it a weekly item tho
16:35:18 <jimbaker`> thanks!
16:35:18 <Daviey> (my fault for not remvoing it)
16:35:20 <SpamapS> really, we want to be welcoming
16:35:26 <SpamapS> #topic Open Discussion
16:36:12 <SpamapS> o/` Henry Kissinger.. I've been missing ya.. o/`
16:37:05 <SpamapS> Alright, everybody is busy and ready to work, so... without further adue..
16:37:24 <SpamapS> #topic Announce next meeting date and time
16:37:41 <Daviey> lets go home.
16:37:54 <SpamapS> Tuesday, July 3, 16:00 UTC, here in #ubuntu-meeting
16:38:03 <SpamapS> #endmeeting