16:00:52 <arosales> #startmeeting ubuntu-server-team
16:00:52 <meetingology> Meeting started Tue Jun 12 16:00:52 2012 UTC.  The chair is arosales. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:00:52 <meetingology> 
16:00:52 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:01:09 <arosales> #topic Review ACTION points from previous meeting
16:01:30 <arosales> rbasak: how is the migration to ubuntuserver.org going?
16:02:02 <rbasak> I had assumed that was a joke action. I have no knowledge of ubuntuserver.org or anything surrounding it whatsoever.
16:02:40 <arosales> I think that was in reference to our server team blog, correct
16:02:53 <smoser> hm.. funny. it probably was a joke action and then got carried over too.
16:03:02 <smoser> nice. for shame on whoever chaired last week.
16:03:03 <arosales> If so, are there any objections about where the blog current lives?
16:03:22 <rbasak> I would just like to see the typo fixed, which is how I ended up with the joke action
16:03:37 <m_3> rbasak: I think you were dissing the site and got volunteered by the meeting chair :)
16:03:53 <arosales> rbasak: where is that typo again?
16:03:57 <rbasak> In the headline
16:03:59 <rbasak> peices
16:04:39 <arosales> ah ok, here https://ubuntuserver.wordpress.com/
16:04:59 <arosales> rbasak:  did you want to follow up with jamespage and see who has access and get that corrected?
16:05:07 <arosales> rbask, if not I can.
16:05:34 <jamespage> arosales, rbasak: I think I might have access
16:05:36 <rbasak> I don't think it's worth me being involved. I know nothing about it, and am not sure what I can add
16:05:49 <rbasak> (apart from another cook for the broth)
16:05:58 <arosales> ok, I will follow up
16:05:58 <SpamapS> o/
16:06:33 <arosales> #action arosales to correct "pieces" on ubuntu server blog
16:06:33 * meetingology arosales to correct "pieces" on ubuntu server blog
16:06:57 <arosales> smoser:  did you have a chance to follow up with rbasak on bug 972077
16:07:00 <ubottu> Launchpad bug 972077 in apt (Ubuntu) "apt repository disk format has race conditions" [Medium,Confirmed] https://launchpad.net/bugs/972077
16:07:07 <smoser> rbasak, ping, re 972077
16:07:14 <smoser> (no, i didn't. but i will)
16:07:19 <arosales> ok thanks smoser
16:07:22 <arosales> #topic Precise Development
16:07:30 <arosales> bugs
16:07:31 <arosales> http://reports.qa.ubuntu.com/reports/ubuntu-server/release-bugs.html
16:07:45 <arosales> bug https://launchpad.net/bugs/974584
16:07:48 <ubottu> Launchpad bug 974584 in sysvinit (Ubuntu Quantal) "Semaphores cannot be created in lxc container" [High,Triaged]
16:08:17 <arosales> hallyn: were you taking a look at this one ^
16:08:41 <arosales> bug 920197
16:08:43 <ubottu> Launchpad bug 920197 in python-webob (Ubuntu Quantal) "[SRU] webob last stable version 1.1.1 response header bug" [High,Triaged] https://launchpad.net/bugs/920197
16:09:01 <arosales> zul: and jamespage this one queued up correctly for SRU in 12.04.1?
16:09:10 <jamespage> yep
16:09:13 <zul> yep
16:09:30 <arosales> cool thanks zul and jamespage
16:09:34 <arosales> bug 1001846
16:09:36 <ubottu> Launchpad bug 1001846 in cobbler (Ubuntu) "cobbler fails to install with error code 1" [High,Confirmed] https://launchpad.net/bugs/1001846
16:09:36 <hallyn> hm, yeah, i dropped the fix for bug 974584 both in debian and ubuntu bugs, i don't have upload rights...
16:09:39 <ubottu> Launchpad bug 974584 in sysvinit (Ubuntu Quantal) "Semaphores cannot be created in lxc container" [High,Triaged] https://launchpad.net/bugs/974584
16:10:00 <arosales> smoser: I think you were looking for more info on this one did airtonix give what was needed?
16:10:06 <hallyn> think the debian maintainer got sick of me
16:10:22 <arosales> hallyn: thanks for the update on 974584
16:10:36 * smoser re-looks
16:10:48 <arosales> hallyn: let us know if you don't get a response soon
16:10:56 <arosales> smoser: thanks
16:11:10 <arosales> bug https://launchpad.net/bugs/1009294
16:11:11 <smoser> hm... roaksoax is not around. i think there is enough info in that bug to move forward.
16:11:12 <ubottu> Launchpad bug 1009294 in Ubuntu Precise "Grub update breaks automated dist-upgrade scripts on AMI images" [High,Fix committed]
16:11:48 <arosales> smoser: looks like you had the todo here to get the fix commited. Is that now in the ubuntu cloud images?
16:12:35 <arosales> well catch roaksoax later on the cobbler bug
16:12:37 <arosales> bug 880339
16:12:38 <ubottu> Launchpad bug 880339 in mysql-5.5 (Ubuntu Precise) "AppArmor profile needs update" [Medium,Incomplete] https://launchpad.net/bugs/880339
16:12:48 <smoser> someone should verify images are fixed for that cloud image bug
16:12:56 <smoser> and we need to refresh the 12.04 images.
16:13:04 <utlemming> smoser: I can do that...
16:13:05 <SpamapS> arosales: that one is a dupe of one that I'm working on
16:13:08 <arosales> jamespage:  I think you were tracking bug 880339, is that now fixed?
16:13:15 <utlemming> smoser: and I plan on re-spinning precise ASAP
16:13:34 <SpamapS> arosales: I think we can drop it from the list, having been incomplete without a response for so long
16:13:35 <arosales> utlemming: could you help with verifying the fix smoser commited?
16:13:42 <utlemming> arosales: yup
16:13:54 <arosales> utlemming: thanks
16:13:59 <hallyn> arosales: i've got a note in my tickler to bug ubuntu-devel on thu if no action from maintainer
16:14:03 <jamespage> arosales, yes - SpamapS please could you ensure the bug that you are working on has a task for precise and is targetted to 12.04.1
16:14:22 <arosales> #action drop 880339 from bug list — no response
16:14:22 * meetingology drop 880339 from bug list — no response
16:14:34 <SpamapS> arosales: no action needed
16:14:35 <arosales> thanks SpamapS
16:14:43 <arosales> ah, ok :-)
16:14:45 <SpamapS> arosales: its already closed as Invalid actually
16:15:00 <SpamapS> there was a recent response.. that the user had screwed it up themselves
16:15:06 <arosales> I'll make sure to remove the subscription of ubuntu server team too
16:15:15 <Daviey> (sorry for speaking out of turn.. but the ubuntuserver.org blog transition wasn't a joke action.. it needs to happen, and rbask wanted to see it improved.)
16:15:27 <arosales> bug 993291
16:15:30 <ubottu> Launchpad bug 993291 in nis (Ubuntu Quantal) "[SRU] package nis 3.17-32ubuntu1.2 failed to install/upgrade: invoke-rc.d: unknown initscript, /etc/init.d/nis not found." [Medium,Triaged] https://launchpad.net/bugs/993291
16:16:11 <arosales> jamespage: looks like 993291 is tracking ok, correct?
16:16:21 <jamespage> arosales, yeah - I just picked that up
16:16:36 <arosales> jamespage: ok, thanks
16:16:42 <arosales> bug 1009553
16:16:43 <ubottu> Launchpad bug 1009553 in ubuntu-meta (Ubuntu) "jeos install oversized" [Medium,Confirmed] https://launchpad.net/bugs/1009553
16:17:08 * jamespage is unsurprised
16:17:09 <arosales> jamespage:  is this one a result of just droping -virtual kernel?
16:17:21 <arosales> any fix needed?
16:17:30 <jamespage> well its always close to the line - but yes that does seem to be the problem this release
16:17:54 <Daviey> Well, we should dive for extra opportunities to reduce it's size
16:18:00 <Daviey> but growth is expected.
16:18:04 <jamespage> I'm not sure TBH - I though the -virtual piece was going to be managed with additional module packages
16:18:15 <jamespage> which is the bulk of the oversize ATM
16:18:25 <jamespage> ~60MB I think
16:18:38 <jamespage> smb`, any opinion on ^^
16:18:58 * smb` tries to catch up
16:19:17 <utlemming> jamespage: -virtual did indeed get dropped...and the kernel bloat in the AMI's is ~200M as a result
16:19:29 <jamespage> utlemming, sounds about right :-)
16:19:51 <arosales> in parallel for bug 920197, zul is that progressing as expected?
16:19:53 <ubottu> Launchpad bug 920197 in python-webob (Ubuntu Quantal) "[SRU] webob last stable version 1.1.1 response header bug" [High,Triaged] https://launchpad.net/bugs/920197
16:20:11 <zul> arosales: no it needs some work still which im doing this afternoon
16:20:12 <smb`> utlemming, Why there would be a virtual meta which only consists of the smaller part
16:20:55 <utlemming> smb: is there a -virtual meta then?
16:21:05 <arosales> zul: ok thanks. Make sure to ping smoser or jamespage both on the 12.04.1 team if any assistance is needed.
16:21:15 <smb`> utlemming, linux-generic-meta -> linxu-image-generic + linux-image-extra-generic   vs. linux-virtual-meta -> linux-image-generic
16:21:17 <zul> arosales: ack
16:21:36 <jamespage> smb`, utlemming: sounds like we are bloating out to much
16:21:49 <jamespage> arosales, please action smb, utlemming and I to discuss offline
16:21:58 <jamespage> well online but not in this meeting :-)
16:22:08 <utlemming> +1, we'll discuss this right after
16:22:11 <smb`> jamespage, At least that is the theory, we need to reality check but, yes put up an action
16:22:26 <arosales> #action jamespage and utlemming to discuss dropping -virtual kernel; re bug 1009553
16:22:26 * meetingology jamespage and utlemming to discuss dropping -virtual kernel; re bug 1009553
16:22:28 <ubottu> Launchpad bug 1009553 in ubuntu-meta (Ubuntu) "jeos install oversized" [Medium,Confirmed] https://launchpad.net/bugs/1009553
16:22:36 <arosales> utlemming: jamespage and smb thanks
16:22:38 <jamespage> ta
16:22:43 <arosales> bug 1008537
16:22:46 <ubottu> Launchpad bug 1008537 in webkit (Ubuntu) "[FTBFS] Segmentation fault during tests" [Undecided,Confirmed] https://launchpad.net/bugs/1008537
16:22:56 <arosales> failed to build
16:23:28 <arosales> may be similar to bug https://bugs.launchpad.net/bugs/968308
16:23:30 <ubottu> Launchpad bug 968308 in openjdk-6 (Ubuntu) "Opening Eclipse workbench causes SIGSEGV" [Undecided,Confirmed]
16:23:39 <arosales> anyone interested in taking a look ?
16:24:10 <arosales> webkit and sphinx
16:24:49 <arosales> any interested folks?
16:25:22 <Daviey> i'll investigate it.
16:25:29 <arosales> Daviey: thanks
16:25:35 <arosales> moving onto blueprints http://status.ubuntu.com/ubuntu-quantal/ubuntu-server.html
16:25:58 <arosales> so we got some good work items documented, and dependencies liked to topics.
16:26:19 <arosales> please take a look if the dependency linkage looks correct for your blueprint
16:26:59 <arosales> also be sure to be implementing the blueprint spec into blueprints, jamespage do you have a link handy?
16:27:14 <jamespage> https://wiki.ubuntu.com/BlueprintSpec
16:27:21 <arosales> jamespage: thanks
16:27:24 <jamespage> I do - thanks skaet!
16:27:39 <arosales> Any other items on blueprints?
16:28:09 * arosales forgot the two topics under quantal dev
16:28:14 <hallyn> hm, in https://blueprints.launchpad.net/ubuntu/+spec/servercloud-q-server-iso-tests-review, i hope someone will explain to me what that action item assigned to me is
16:29:03 <arosales> jamespage:  can you assist hallyn with work items on the ISO tesing?
16:29:11 <jamespage> hallyn, arosales: yep
16:29:21 <arosales> #action jamespage to follow up with hallyn on servercloud-q-server-iso-tests-review
16:29:21 * meetingology jamespage to follow up with hallyn on servercloud-q-server-iso-tests-review
16:29:24 <arosales> jamespage: thanks
16:29:26 <hallyn> thx
16:29:33 <arosales> #topic Ubuntu Server Team Events
16:29:59 <arosales> jim is at  http://static.usenix.org/events/config10/index.html
16:30:01 <arosales> this week
16:30:17 <arosales> Velocity coming up in a couple of weeks.
16:30:23 <arosales> any other events?
16:30:36 <jamespage> I pretending to be hazmat at EuroPycon at the start of July
16:30:55 <arosales> cool, should be fun pretending to be hazmat :-)
16:30:57 <SpamapS> jamespage: I can't wait to see your beard :)
16:31:07 <arosales> #topic Weekly Updates & Questions for the QA Team (hggdh)
16:31:14 <arosales> hggdh: Any updates from QA?
16:31:17 <jamespage> SpamapS, I'm working on that :-)
16:32:01 <jamespage> hggdh, whats the current status on UTAH?
16:32:35 <arosales> perhaps hggdh isn't around at the moment. hggdh please feel free to comment if you return.
16:32:40 <arosales> #topic Weekly Updates & Questions for the Kernel Team (smb)
16:32:49 <arosales> smb`:  how is the kernel looking?
16:33:01 <smb`> Mostly harmless...
16:33:19 <arosales> any questions for smb` ?
16:33:52 <arosales> thanks smb`
16:34:07 <arosales> #topic Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:34:08 <rbasak> Calxeda's Highbank machine is now enabled in Quantal! We're planning a more detailed announcement on this soon, including installation instructions. MAAS support for this machine is now the next step.
16:34:11 <rbasak> Any questions for me?
16:34:24 <arosales> woot :-)
16:35:02 <arosales> no other questions for rbasak
16:35:11 <arosales> #topic Open Discussion
16:35:13 <utlemming> rbasak: so we need to get together
16:35:30 <utlemming> and get the armhf images using the Highbank then
16:36:19 <arosales> Daviey: I'll follow up with rbasak on seeing how we can get our server team blog moved to the correct home. I have an action items to correct the spelling so I'll investigate the move with rbask.
16:36:38 * rbasak just wanted the typo fixed!
16:36:46 <rbasak> That'll be <5 minutes for someone with access, right?
16:37:11 <Daviey> rbasak: we need to move it regardless
16:37:21 <Daviey> rbasak: You volunteered AIUI.
16:37:23 <rbasak> Where should it go?
16:37:33 <arosales> #action utlemming to follow up with rbasak on getting armhf images using highbank.
16:37:33 * meetingology utlemming to follow up with rbasak on getting armhf images using highbank.
16:37:36 * rbasak didn't volunteer. He just asked for the typo to be fixed.
16:37:37 <Daviey> rbasak: canonical hosted.. under that domain (owned by canonical)
16:37:51 <m_3> prob a good idea to talk to jcastro about it
16:38:00 <Daviey> rbasak: just need to raise an RT and get IS to setup wordpress under that domain.
16:38:07 <Daviey> and migrate content... can you take that?
16:38:18 <rbasak> Who has access to the current wordpress?
16:38:25 <rbasak> To migrate content I'll want access
16:38:29 <Daviey> rbasak: it's wordpress.org.. so all of us.
16:38:33 <Daviey> err, .com
16:38:42 <rbasak> Credentials?
16:38:47 <Daviey> rbasak: anyone on the team can have an account
16:38:59 <rbasak> Who has admin access?
16:39:00 <Daviey> rbasak: If you don't have one, i can add you.
16:39:13 <rbasak> Please
16:39:13 <Daviey> rbasak: lets take this offline.
16:39:36 <arosales> ok, thanks Daviey
16:39:45 <arosales> Any other topics to discuss?
16:40:14 <arosales> ok, thanks for everyone's time
16:40:15 <arosales> #topic Announce next meeting date and time
16:40:17 <jamespage> o/
16:40:23 <jamespage> I had one actually
16:40:24 <arosales> Tuesday 2012-06-19 at 1600 UTC
16:40:28 <arosales> jamespage:  go
16:40:54 <jamespage> OK - so smoser and I and representing the server team for the 12.04.1 release
16:41:13 <Daviey> so don't mess it up.
16:41:18 <jamespage> we have a regular catchup with all of the other 12.04.1 folk every 2 weeks
16:41:38 <jamespage> I spent some time updating zul's reports - http://people.canonical.com/~jamespage/server-sru/precise-sru.html
16:42:14 <jamespage> it you come across any bugs that should be SRU'ed please raise tasks for precise and target them to 12.04.1 - that way they will appear in the report
16:42:45 <jamespage> assigning someone or an upload being accepted into -proposed results in them moving to 'inflight'
16:43:10 <jamespage> I'd also like to have a regular slot in the meeting as well
16:43:23 <jamespage> not to review the entire report but to focus on any problematic bugs...
16:43:48 <jamespage> oh - http://people.canonical.com/~jamespage/server-sru/ contains series based reports for all supported releases as well
16:43:49 <arosales> perhaps after the quantal development section
16:43:58 <jamespage> that would make sense to me
16:44:14 <arosales> #action arosales to add 12.04.1 Development section
16:44:14 * meetingology arosales to add 12.04.1 Development section
16:44:57 <arosales> jamespage: and smoser 	thanks for rep'ing server in the 12.04.01 team
16:45:06 <arosales> any other items to discuss
16:45:49 <arosales> Next meeting is Tuesday 2012-06-19 at 1600 UTC. Thanks for attending, and bearing with me ;-)
16:45:55 <arosales> #endmeeting