18:07:41 <AlanBell> #startmeeting IRC Team
18:07:41 <meetingology> Meeting started Sun May 27 18:07:41 2012 UTC. The chair is AlanBell. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
18:07:41 <meetingology>
18:07:41 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
18:07:45 <jokrebel> Hi
18:07:49 <AlanBell> hi all, who is here for the meeting o/
18:07:53 <dax> o/
18:07:55 <IdleOne> o/
18:07:56 <AlanBell> https://wiki.ubuntu.com/IRC/IrcCouncil/MeetingAgenda
18:07:56 <Myrtti> hello
18:08:01 <AlanBell> agenda is there
18:08:15 <Fuchs> o/
18:08:35 <IdleOne> is there quorum?
18:09:00 <AlanBell> probably not, might have to skip some bits or finish them off outside the meeting
18:09:24 <Myrtti> aw :-(
18:09:57 <AlanBell> #topic Review last meetings action items
18:10:12 <AlanBell> https://wiki.ubuntu.com/MeetingLogs/IRCC/20120429 is the minutes from last time
18:10:27 <AlanBell> action items for me were to do a call for ops (done)
18:10:35 <AlanBell> and to schedule the UDS session (done)
18:10:40 <AlanBell> yay
18:10:46 * AlanBell likes done
18:10:55 <AlanBell> #topic Open items in the IRCC tracker
18:11:02 <IdleOne> 2 dones == cookie 4 you
18:11:04 <AlanBell> there was an appeal
18:12:56 <AlanBell> Lars Torben Kremer appealed a long term ban, but as there was no supporting information as to why we should do that the appeal was denied
18:13:16 <ikonia> I'm surprised to be honest that he bothered to appeal
18:13:34 <ikonia> I didn't think he'd be able to follow the process.
18:13:53 <AlanBell> there is an open appeal too, from mcloy, I closed that yesterday when the matter was resolved, but it appears that the user has reopened it today
18:14:02 <ikonia> no doubt
18:14:16 <AlanBell> I don't want to discuss that now, just declaring what is in the tracker for this agenda item
18:14:38 <AlanBell> #topic Review Bugs related to the Ubuntu IRC Council
18:15:24 <AlanBell> there are two bugs now, we closed a bunch last meeting
18:15:35 <AlanBell> bug 892500
18:15:37 <ubottu> Launchpad bug 892500 in ubuntu-community "eir is still not fit for purpose in #ubuntu" [Undecided,In progress] https://launchpad.net/bugs/892500
18:15:44 <AlanBell> so this one is the bantracking bots bug
18:15:54 <AlanBell> what do people think of ubottu-fr?
18:16:02 <ikonia> as a starting base, much much better
18:16:12 <IdleOne> Don't know how to use it yet, but I do like the information it provides
18:16:28 <IdleOne> it is a little more verbose on what is happening than eir is
18:16:35 <ikonia> the fact that it works with BT, is enough of a reason for me alone
18:16:44 <IdleOne> that is a + for it
18:17:07 <AlanBell> ok, are there any actions you would like me to take on this subject, like removing eir, or getting a plan for it to be merged into ubottu (or the other way round)
18:17:16 <ikonia> yes, I'd like eir removed
18:17:25 <IdleOne> I would like to see -fr merged into ubottu
18:17:31 <IdleOne> before removing eir
18:17:35 <ikonia> at the moment we have eir/ubottu/ubottu-fr
18:17:37 <ikonia> removing eir so it stops managing bans and phases out
18:17:42 <IdleOne> and testing the newbottu
18:17:44 <ikonia> allowing ubottu/ubbotu-fr to merge in
18:18:00 <ikonia> the longer we leave eir to manage bans the longer/hardware/more effort it will be to phase it out
18:18:05 <ikonia> hardware ??? harder
18:18:07 <dax> I'm not familiar with this situation, but would removing eir mean that there are some bans that aren't tracked/expiring properly?
18:18:16 <IdleOne> dax: yes.
18:18:35 <ikonia> dax: yes, and I've said I will query the eir database to phase them out until it's clear
18:18:38 <ikonia> dax: which is why I'd like it gone sooner rather than later so there are less entries
18:18:41 <IdleOne> best thing would be to comment all eir bans for #ubuntu and stop using it, letting it finish its work
18:18:51 <ikonia> IdleOne: you can't stop it while it's in the channel
18:18:57 <dax> ikonia: Indeed. If it's going to happen at some point, earlier is probably better.
18:19:03 <ikonia> it's never going to finish while it's in the hcannel
18:19:05 <Fuchs> minor sidenote: as already stated in #ubuntu-ops, the #ubuntu-de op team is also discussing ban management, and we'd be interested in results from these tests. Also poke us if we can help somehow.
18:19:21 <IdleOne> ikonia: we can stop commenting on new bans.
18:19:29 <IdleOne> with eir that is.
18:19:31 <AlanBell> anyone want to speak up for eir remaining in #ubuntu?
18:19:34 <ikonia> IdleOne: that won't stop eir managing the ban
18:20:07 <ikonia> don't all rush at once
18:20:25 <IdleOne> then how do we phase it out while maintaining a sane ban list?
18:20:51 <ikonia> IdleOne: you kill it out of the channel and just manually query it until it's #ubuntu list is empty
18:20:55 <Daviey> perhaps a re-cap of eir's isues would be handy?
18:20:57 <dax> One point here is that we didn't used to have eir, so this is roughly equivalent to the situation when eir was introduced and there were a few hundred bans without expiration set.
18:20:58 <ikonia> IdleOne: or manually remove the enries from eir
18:21:01 <dax> We managed just fine then.
18:21:22 <IdleOne> true
18:21:35 <AlanBell> removing eir would be a reversable step, nobody is objecting, it has been out of the way in the control channel for some time, there isn't a huge list of bans in it and ikonia will help manage the process of the bans in flight, so I don't see a problem with removing it
18:21:44 <ikonia> the real value eir brought was the floodbot/excemtion removal
18:21:45 <IdleOne> ok. kill eir soon as ubottu is merged and lets all learn to use the new bot :)
18:21:46 <AlanBell> #action alanbell to sort out removal of eir
18:21:46 * meetingology alanbell to sort out removal of eir
18:21:57 <ikonia> so as long as ubottu-fr is able to do that, I don't see a problem with the ban list
18:22:07 <ikonia> Daviey: do you want the bug number or an explination
18:22:15 <AlanBell> and please start using ubottu-fr more and ask niko for more information/help
18:22:21 <Daviey> explanation, for the nosey.
18:22:26 <AlanBell> Daviey: sorry, I missed your comment there
18:22:39 <AlanBell> Daviey: bug 892500 has some information on it
18:22:40 <ubottu> Launchpad bug 892500 in ubuntu-community "eir is still not fit for purpose in #ubuntu" [Undecided,In progress] https://launchpad.net/bugs/892500
18:22:53 <dax> which links to https://bugs.launchpad.net/ubuntu-bots?field.searchtext=%5Beir%5D , which has a list
18:22:58 <ikonia> Daviey: basically it was rushed into production and doesn't fit in with the current channel needs, eg: doesn't work with ban tracker, noisey on it's notifucations, controlled by freenode so harder to maintain etc etc
18:23:32 <Daviey> ok
18:23:46 <Daviey> thanks
18:24:10 <AlanBell> bug 913541 is the other open one, I think pici was looking at that
18:24:12 <ubottu> Launchpad bug 913541 in ubuntu-community "there are a number of people with Ubuntu IRC cloaks who have expired from the ubuntumembers group" [Undecided,In progress] https://launchpad.net/bugs/913541
18:24:41 <AlanBell> I will follow up with pici later in the week
18:24:46 <IdleOne> guessing that will stay in progress for a while
18:25:15 <AlanBell> yeah, just want to get it down to zero, then manage it as an ongoing process
18:25:18 <dax> AlanBell: how long's the list of those now? iirc someone made one and Pici's been contacting folks from it?
18:25:19 <AlanBell> #topic alignment of launchpad teams and channel access lis
18:25:23 <IdleOne> Can staff remove cloaks even if the user is not on,ine?
18:25:33 <IdleOne> online
18:25:41 <Fuchs> yes
18:25:49 <dax> IdleOne: yes, though in non-adversarial situations like this it's probably better if someone attempts contact first
18:26:12 <Daviey> Incidentally, my membership expired without me realising it.. I only still have it through inheritance of other groups. :/
18:26:21 <AlanBell> ooh
18:26:37 <IdleOne> AlanBell: maybe set an end date for it and anybody not contactable gets the cloak removed? dax I agree it is better to try and get in touch first, but this can go on forever if there is no time frame
18:26:43 <AlanBell> that sort of thing does happen, and this process is about sorting that out
18:26:45 <dax> IdleOne: indeed
18:27:15 <AlanBell> we have done things like there was a MOTU who expired from that, but wanted to keep membership, so we just sorted it out
18:27:41 <AlanBell> by checking with the CC and giving the user an IRCC awarded membership
18:28:04 <AlanBell> so that is the kind of thing we can do to resolve the situation, but each one is individual
18:28:24 <AlanBell> anyhow, on to the alignment of launchpad teams and channel access lists
18:28:34 <ikonia> AlanBell: is there anything that can be fed back into the CC that the membership status currently doesn't really mean/do anything
18:28:40 <AlanBell> I have been doing some stuff with launchpad lib
18:28:49 <ikonia> maybe ask them to work on something to give it value/credability more
18:28:59 <Daviey> ikonia: The email alias is lost with alomost immediate effect.
18:29:20 <AlanBell> ikonia: it does a number of things, some less obvious than others, but we can talk about that later
18:29:21 <Daviey> (which is probably more important than a cloak)
18:29:48 <ikonia> Daviey: much more
18:31:03 <AlanBell> so we have launchpad groups for applying to be an op of a channel, and we have channel access lists
18:31:15 <AlanBell> these are not very well synchronised
18:31:41 <AlanBell> I am suggesting that we do a semi-automatic process to align them, and tidy them up
18:32:15 <Daviey> AlanBell: didn't Pici do some work around this, ~2 years ago?
18:32:19 <AlanBell> http://paste.ubuntu.com/1003884/
18:32:50 <AlanBell> is some code that iterates through the groups and generates stuff that can be passed to chanserv to adjust access lists
18:33:02 <AlanBell> http://paste.ubuntu.com/1003857/ would be sample output from it
18:33:41 <AlanBell> I was looking at doing a more intelligent comparison, but it is fine to just pass non-active flags to chanserv, it ignores anything that is already right
18:34:19 <dax> flags #foo bar -sriRfF+votiA is valid, btw
18:34:29 <AlanBell> this does depend on a couple of things, it means that every op will need to have their nickserv account name in their launchpad page
18:34:48 <AlanBell> dax: thanks for that, double the efficiency
18:34:58 <IdleOne> half the lines
18:35:10 <AlanBell> most people do have their primary nick, which for most people is their account name
18:35:15 <dax> AlanBell: lines 93-98 on that output paste look a bit wonky?
18:35:36 <AlanBell> dax: ah, yes I fixed that bug
18:35:59 <AlanBell> output is now like that without the wonky
18:36:23 <IdleOne> chanserv access list. Now with less wonk.
18:37:08 <AlanBell> Daviey: pici did the work on the members thing, I am not aware of anything directly in this area
18:37:17 <IdleOne> AlanBell: so besides all the ops adding their nickserv account name to LP what is needed?
18:37:19 <Daviey> ah, that must be what i am thinking ok.
18:37:25 <AlanBell> so, what this does is give every op +votiA
18:37:46 <AlanBell> so some people will get a few tweaks to their access
18:38:07 <AlanBell> #kubuntu for example has a wide assortment of flags, for reasons unknown to me
18:38:37 <AlanBell> there is also the option at this time to say that no humans have +F to channels, everyone is the same
18:38:48 <AlanBell> just the ubuntuirccouncil account having founder access
18:38:48 <dax> Some folks have IRC handles from other networks (e.g. OFTC) on their Launchpad. Not sure if that breaks things.
18:39:08 <AlanBell> dax: the code checks for 'freenode' in the network name
18:39:15 <dax> ah, missed that, nvm
18:39:50 <AlanBell> the worst that can happen is that chanserv tells me I am trying to do something on a non-registered nick
18:40:09 <AlanBell> alternatively we could run this and leave the various people with founder flags right where they are
18:40:23 <AlanBell> opinions please . . .
18:40:26 <dax> the worst that can happen is that the nick is, in fact, registered by someone else ;)
18:40:38 <Tm_T> AlanBell: I have no issues for people having founder flags
18:40:42 <AlanBell> dax: yeah, I will be mailing everyone to point that out
18:40:44 <IdleOne> that could be messy
18:40:53 <Tm_T> AlanBell: as long as ubuntuirccouncil has the rights it needs
18:41:17 <AlanBell> dax: and I will manually check for that, it is only a few people who have multiple nicks listed
18:43:03 <AlanBell> any other thoughts on people with founder flags?
18:43:53 <ikonia> the ubuntu irc council is responsible for channels in the names space
18:43:58 <dax> dunno if this still applies, but the subject of flags in e.g. #kubuntu has been a fun discussion in the past.
18:43:59 <ikonia> they should have founder flags to the channels,
18:44:48 <AlanBell> dax: good to know, thanks
18:45:12 <AlanBell> yeah, going to need founder flags to run the script and do anything useful with the output I should think
18:45:20 <IdleOne> I'm with ikonia I think the IRCC should have founder on all the channels in the namespace
18:45:52 <AlanBell> I believe the only one I need to sort out is #lubuntu, I will talk to unit193 about that
18:46:06 <dax> IdleOne: yeah, I think that bit's uncontroversial
18:46:24 <Unit193> A few xubu ones, you don't have any access in -devel
18:46:28 <dax> in that everyone who disagreed with it has been argued with until they stopped by now :P
18:46:38 <AlanBell> Unit193: just the core channels list
18:47:08 <AlanBell> ok, so lets leave people with +F with +F if they are still part of the ops team, and everyone else gets +votiA
18:47:24 <IdleOne> sounds good
18:47:31 <AlanBell> and ubuntuirccouncil gets the full christmas tree of blinking lights across the core channels
18:48:08 <m4v> what does +F allow that doesn't allow the other rest of flags? because I think is only that you can't be removed easily from the access list.
18:48:41 <AlanBell> I believe you pop up in some IRC clients as the owner of the channel
18:49:05 <AlanBell> and you can do /msg chanserv help flags to find out more details
18:49:09 <dax> no clients that I've seen. that'd be a bit insane
18:49:35 <ikonia> +F is just "your channel" you can do what you want
18:49:38 <AlanBell> oh, ok that has been a reason some people have given for wanting +F
18:49:46 <IdleOne> mIRC does it I think, but who cares about mirc anyway
18:50:12 <m4v> you can "do what you want" with +*
18:50:14 <dax> I doubt it does it out of the box. Maybe some ridiculous mIRC script does it, iono. Next time someone claims that, I'd be interested in knowing which :)
18:50:29 <Unit193> /cs info #xubuntu for example.
18:51:11 <dax> but anyway. leaving +F people alone would probably be a good way of avoiding possible issues
18:51:11 <AlanBell> ok, so this is something I will progress, and there will be various emails informing people every step of the way
18:51:41 <AlanBell> I expect I will make some errors and annoy some people who didn't read the emails, but everything that is done in this exercise is reverseable
18:52:18 <AlanBell> I will be making every effort to inform people of what I am doing, down to the lines I am sending to chanserv
18:52:43 <AlanBell> right, lets move on to an item we sadly won't be able to vote on today
18:52:45 <AlanBell> #topic membership applications
18:53:05 <m4v> my point is, if you need the flags for practical use, you need +* and not +F, if you want to see UbuntuIrcCouncil in chanserv info, then yeah.
18:53:09 <IdleOne> for what it is worth. +1 for Fuchs membership
18:53:15 <AlanBell> we have an application, and I would like to give Fuchs the grilling, even though we can't vote today :)
18:53:22 <AlanBell> hi Fuchs, please introduce yourself
18:53:45 <Fuchs> Yes :) Hello everybody, my name is Christian, nickname is Fuchs. I am mostly active on IRC in the german ubuntu channels as an operator,
18:54:01 <Fuchs> and not very active in the english ones. But some people might know me due to other things I do, e.g. being staff.
18:54:17 <Fuchs> I have prepared a wiki page with my contributions: https://wiki.ubuntu.com/Fuchs and some testimonials
18:54:43 <AlanBell> that is indeed a nice wiki page
18:54:49 <Fuchs> the first two being from people from ubuntuusers.de, including an ubuntu member (toddyhb), and the last 3 ones from fellow german IRC ops, two of them also came along today :)
18:55:05 <AlanBell> so who is here shouting for Fuchs?
18:55:15 * ppq is :)
18:55:17 <Myrtti> I am :-)
18:55:35 <ikonia> to be honest, it's hard to say anything non-positive
18:55:53 <AlanBell> well that wiki page answers most of the questions I would have around LoCo involvement and general community contribution
18:56:08 <Fuchs> feel free to ask away anyway, I'll be happy to answer :)
18:56:15 <ppq> (I left him a testimonial, I'm Benedikt Haus)
18:56:40 <AlanBell> Fuchs: what are your plans for community contribution going forward?
18:56:53 <ikonia> ppq: then why is your IRC name ircname : Paul Giblock
18:57:05 <Fuchs> AlanBell: with regards to #ubuntu-de: I am currently looking with several persons (including niko) what we could use as a ban management,
18:57:21 <Myrtti> ikonia: you're looking at the wrong /whois
18:57:24 <Myrtti> that's why
18:57:32 <ppq> hehe
18:57:34 <ikonia> Fuchs: do you have any ban managment
18:57:35 <ikonia> oops, idiot, sorry
18:57:39 <Fuchs> AlanBell: since currently we don't have any. I also started the ubuntuusers.de official IRC presence in the past months (you maybe remember the meeting we had), to have contact with our community on IRC as well
18:57:44 <ppq> ikonia: https://launchpad.net/~ppq that's me
18:57:52 <Fuchs> ikonia: currently not, no
18:57:55 <jokrebel> I know Fuchs as always available and very supportive. My English is not so good, but he is very busy at the german Channel with much know-how and very diplomatic in critcal situations.
18:58:04 <ikonia> ppq: sorry, I got you confused with the guy in #ubuntu-ops, I thought you where hium
18:58:12 <Fuchs> ikonia: eir came up, since I am staffer I already know it. Then niko told me about ubottu-fr
18:58:37 <ppq> ikonia: no problem :)
18:58:38 <Fuchs> ikonia: it will be a topic in our next op meeting again, that's why I am also interested in your experience with it
18:59:10 <ikonia> all too sensible
18:59:26 <AlanBell> ok, that sounds great to me Fuchs, I will discuss with the rest of the IRCC and we will vote on it and get back to you as soon as possible
18:59:39 <Fuchs> AlanBell: great, thank you. You know where you can find me if you need anything else :)
18:59:46 <IdleOne> Did I say I +1 Fuchs for membership
18:59:52 <AlanBell> #topic Any Other Business
18:59:55 <IdleOne> in case I didn't. I do.
18:59:58 <AlanBell> IdleOne: you just did :)
19:00:12 <AlanBell> anyone got anything else they want to raise?
19:00:31 <IdleOne> My children. close this meeting so we can get on with real life again :P
19:00:38 <AlanBell> #endmeeting