20:06:49 <jmarsden|work> #startmeeting
20:06:49 <meetingology> Meeting started Wed May 16 20:06:49 2012 UTC.  The chair is jmarsden|work. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
20:06:49 <meetingology> 
20:06:49 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
20:06:56 <StephenSmally> ok
20:07:41 <jmarsden|work> OK, so we need to figure out some sort of future direction, and we need a new wiki champion, as I understand it.
20:07:52 <jmarsden|work> #topic wiki champion
20:08:06 <jmarsden|work> Anyone know of any volunteers for that role so far?
20:09:02 <jmarsden|work> OK.  So all we can do for now is make the need known.
20:09:19 <bodhi_zazen> amjjawad might be a great person to do this , he is not available until after at least June 1st
20:09:31 <jmarsden|work> #action jmarsden|work to email the list asking for volunteer wiki champions
20:09:31 * meetingology jmarsden|work to email the list asking for volunteer wiki champions
20:09:40 <StephenSmally> Well, i think we should have at leats three teams: Wiki team, Devel team and Art team
20:09:45 <StephenSmally> *least
20:10:10 <StephenSmally> Each team should have a "center" person
20:10:10 <Unit193> amjjawad has said that he doesn't like wikis, and doesn't understand them though.
20:10:36 <will_> Wiki, or "Docs"?
20:10:36 <bodhi_zazen> Yea, but, I have spoken with him more recently, and there are ways to support him
20:10:40 <nothingspecial> There are forum staff waiting to help with moving any documentation currently on the forums to the wiki http://bodhizazen.net/tweaks/ubforums2ubwiki.sh.txt
20:10:46 <bodhi_zazen> http://bodhizazen.net/tweaks/ubforums2ubwiki.sh.txt
20:10:56 <bodhi_zazen> script to convert forums posts -> wiki syntax
20:11:05 <bodhi_zazen> script works well, has been tested
20:12:19 <jmarsden|work> Sounds like we can let the wiki champion opening go until at least June 1st so amjjawad can provide his input on the subject.
20:12:30 <jmarsden|work> Moving on to the more general issue...
20:12:36 <jmarsden|work> #topic future direction
20:12:51 <StephenSmally> Guys, i know everyone wants to do something for lubuntu, but IMHO the organization is not clear
20:13:07 <StephenSmally> Is not clear who and how much are the developers
20:13:23 <StephenSmally> The art team seems is made by rafael only
20:13:50 <bodhi_zazen> o/
20:13:59 <StephenSmally> yes?
20:14:29 <bodhi_zazen> I suggest you encourage community members to be more actively involved
20:14:34 <wxl> someone correct me if i'm wrong but isn't julien still developing? just not going to be relaly involved in any sort of communications?
20:14:47 <bodhi_zazen> julien is developing
20:14:58 <bodhi_zazen> https://lists.ubuntu.com/archives/lubuntu-users/2012-May/001516.html
20:15:46 <StephenSmally> Ok, but Julien is not the only developer...
20:15:48 <jmarsden|work> Correct.  And I'm here too, not that I have done a lot of development/packaging recently, but I have not gone away :)
20:16:02 <jmarsden|work> Officially the lubuntu-dev membership can be seen at https://launchpad.net/~lubuntu-dev/+members#active
20:16:37 <bodhi_zazen> 3 developers , or am I reading that wrong ?
20:16:46 <jmarsden|work> Right.
20:16:59 <StephenSmally> yes, plus the Lsc team
20:17:03 <wxl> considering so much is upstream i don't see that as disporportionate
20:17:24 <StephenSmally> which counts 5 member
20:17:53 <StephenSmally> IMO is disproporzionate
20:18:20 <StephenSmally> the problem is that each developer cares about his code
20:18:43 <StephenSmally> for example pcman fix pcmanfm bugs (which is good, don't misunderstand me)
20:19:05 <StephenSmally> but we don't have a real team behavior
20:19:14 <nothingspecial> so we come back to encouraging the community to be more actively involved
20:19:25 <nothingspecial> ?
20:19:25 <bodhi_zazen> +1 nothingspecial
20:19:35 <wxl> encouraging them to be devs will require training
20:19:54 <wxl> i'd even like to contribute as a dev but don't feel that i have a good background to do so
20:20:06 <bodhi_zazen> training or reading
20:20:16 <nothingspecial> or mentoring?
20:20:28 <wxl> any and all but should be clear how to do it
20:20:32 <jmarsden|work> Learning, not necessarily training... self-study works too.  How you get the skills is less important than having them.
20:20:40 <bodhi_zazen> mentoring with expected reading ;p
20:20:41 <StephenSmally> I think that if we organize the teams better, we would be able to get more volunteers
20:21:25 <StephenSmally> I mean, if a volunteer don't know who talk to to  know how to fix a bug, he won't fix it
20:21:34 <StephenSmally> (poor example, i admit)
20:21:45 <bodhi_zazen> communication helps
20:22:12 <nothingspecial> across the community
20:22:18 <wxl> +1 StephenSmally
20:22:27 <bodhi_zazen> rewarding those who contribute, with training / education helps
20:23:01 <jmarsden|work> StephenSmally: Do you have specific suggestions for how to "organize the teams better"?  Either now, or can you write up your ideas and email the list, or put them on a wiki page, or whatever works to get them documented somewhere?
20:23:30 <StephenSmally> i will write something on the mailing list
20:23:37 <jmarsden|work> Great, thanks.
20:23:47 <bodhi_zazen> You can not expect someone to spend 6 hours reading, and 10 hours coding, without some payoff
20:24:02 <bodhi_zazen> developers willing to review code, mentor a little goes a long way
20:24:03 <jmarsden|work> #action StephenSmally  to write up ideas for improved team organization and email the lubuntu-users mailing list
20:24:03 * meetingology StephenSmally  to write up ideas for improved team organization and email the lubuntu-users mailing list
20:24:23 <bodhi_zazen> And you can not expect community without developers talking with users
20:24:28 <StephenSmally> bodhi_zazen, what you mean with payoff?
20:24:44 <nothingspecial> inviting people, encouraging participation, keeping the dialogue going
20:24:54 <bodhi_zazen> What are you going to do to motivate volunteers to donate hours of their time developing ?
20:25:15 <StephenSmally> There are no way you can motivate somebody
20:25:31 <StephenSmally> (IMO)
20:25:32 <bodhi_zazen> yes and no
20:25:36 <bodhi_zazen> you can discourage them
20:25:46 <wxl> bodhi_zazen: i imagine that julien will still to some degree talk to users
20:25:49 <bodhi_zazen> volunteers leave if they feel they have no voice
20:25:51 <wxl> but will likely do it through bug reports
20:26:02 <will_> Is there a backlog of development work?
20:26:22 <StephenSmally> will_, not really, or i don't know it
20:26:31 <wxl> everyone's motivated by different things
20:26:40 <jmarsden|work> There's always bug fixes and proposed enhancements, ... to LXDE components and to pcmanfm in particular
20:26:46 <wxl> some people are motivated by money, others egalitarianism, e.g.
20:27:06 <will_> jmarsden|work: is that listed anywhere? Like a Bugzilla report? I think that would be helpful to list somewhere on the Dev wikipage
20:27:24 <wxl> i suspect that there are plenty of people who would love to code but don't know where to start
20:27:34 <nothingspecial> wxl: collaboration is the key
20:27:48 <StephenSmally> Also, another problem for developers is that LXDE is currently hosted on git
20:27:50 <wxl> i think if we had some sort of even informal mentoring program that would encourage a lot of people
20:27:57 <StephenSmally> but a lot of lubuntu programs are hosted on launchpad
20:28:08 <wxl> StephenSmally: THAT is a problem. what would it take to move it?
20:28:55 <wxl> will_: if i remember correctly there's a todo list on the wiki, but i haven't looked in a while. that would be the logical place for it in any case. that or maybe lubuntu.
20:29:09 <wxl> s/lubuntu/launchpad/
20:29:18 <will_> ah ok.
20:29:41 <StephenSmally> I think launchpad is more developer-oriented, you can have mailing lists, teams and so
20:29:44 <jmarsden|work> StephenSmally: why is using git a problem for developers?  It works for me :)
20:29:56 <wxl> but i think we're talking about a developer todo list, StephenSmally
20:30:08 <StephenSmally> jmarsden|work, I mean, the incosistency between git and bazaar
20:30:15 <bodhi_zazen> wiki.ubuntu.com for teams
20:30:24 <Unit193> And, for example, other DE's for Ubuntu flavors aren't on LP.
20:30:48 <jmarsden|work> StephenSmally: Just one more version control system... not a major obstacle, IMO.
20:31:28 <wxl> one thing that seems important to deal with: i think julian was a coordinator for devs and now he's taking the role of contributor, which is fine, but who's going to take care of coordinating? who's going to take care of the dev wiki?
20:31:43 <nothingspecial> I wonder why we are talking about development and not about the team/community, which as far as I can tell seems to be the issue
20:32:32 <kanliot> the dev team can decide about the dev wiki
20:32:32 <jmarsden|work> wxl: If it needs it and Julien no longer wants to do so, I can take care of the dev related wiki pages.
20:32:38 <wxl> well i think honestly it's all very important, nothingspecial. the reason why making sure we've got the development covered is because otherwise we beocme stale and outdated.
20:32:41 <jmarsden|work> The developmebt TODO list is at https://wiki.ubuntu.com/Lubuntu/Developers/TODO
20:33:08 <nothingspecial> thanks wxl
20:33:23 <will_> jmarsden|work: Thanks!
20:33:33 <wxl> i think, though, that we need a good head for wiki and-- i think-- support, too
20:34:08 <kanliot> i'll do wiki if chris is sure hes done
20:34:30 <jmarsden|work> wxl: Agreed in principle, but specifics on that need to wait until amjjawad has a chance to give us his input
20:34:46 <wxl> jmarsden|work: ok :)
20:35:40 <jmarsden|work> kanliot: OK, our first volunteer for new wiki champion... thanks for offering.  Feel fre to confirm with Chris by private email that he is "really done" if you are concerned about accidentally "stepping on his toes".
20:35:59 <kanliot> k jmarsden|work
20:36:12 <jmarsden|work> #topic any other business
20:36:23 <wxl> if someone is needed for support, i'd help, too. i'm a bit tentative. life suddenly flares up and gets busy for me from time to time, but if there's no one else, i'm game.
20:36:24 <jmarsden|work> OK, is there anything else we need to discuss today?
20:36:27 <MrChrisDruif> I've got very small toes
20:36:33 <nothingspecial> I am here to work with both wiki and support with the forums
20:36:38 <kanliot> lol
20:36:43 <nothingspecial> any team really
20:37:24 <jmarsden|work> Ok... sounds like we are done for today.  Thanks everyone, we will meet again same time same place next week.
20:37:55 <jmarsden|work> #endmeeting