18:58:14 <AlanBell> #startmeeting IRC team
18:58:14 <meetingology`> Meeting started Wed May  2 18:58:14 2012 UTC.  The chair is AlanBell. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
18:58:14 <meetingology`> 
18:58:14 <meetingology`> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
18:58:25 <AlanBell> hi all, who is here for the IRCC meeting?
18:59:02 <ikonia> present
18:59:04 <Myrtti> _o/
18:59:05 <oCean> yessir
19:00:03 <AlanBell> lets give it a few minutes for others to pop along
19:02:03 <AlanBell> hi funkyHat and topyli
19:02:15 <topyli> o/
19:02:53 <funkyHat> Hi ô/
19:03:01 <AlanBell> https://wiki.ubuntu.com/IRC/IrcCouncil/MeetingAgenda
19:03:24 <AlanBell> ok, lets get started
19:03:53 <AlanBell> we don't have to clear out in a hurry at the end of the hour, but lets try and get through it by then anyhow
19:04:05 <AlanBell> #topic Review last meetings action items
19:04:08 <AlanBell> #progress people to provide feedback on the ubottu-fr trial on bug 892500
19:04:10 <ubottu> Launchpad bug 892500 in ubuntu-community "eir is still not fit for purpose in #ubuntu" [Undecided,In progress] https://launchpad.net/bugs/892500
19:04:31 <topyli> do we have any?
19:04:35 <AlanBell> only a little bit of feedback provided, anyone got anything else to add about ubottu-fr
19:05:23 <oCean> Have not really been able to actually test it
19:05:44 <oCean> Or more honestly, Ignored it, since it's confusing to have to work with multiple bots
19:06:26 <oCean> And I still think that the list with bugs filed for eir is valid for any bot handling our bans/mutes
19:06:36 <ikonia> I've fed back on ubuntu-fr, I think it's the way to go
19:06:40 <AlanBell> um, ok, but that doesn't help us to get to the goal of not having multiple bots
19:06:48 <ikonia> it needs trimming down though
19:06:57 <ikonia> but you can only do that once you've picked a direction to develop
19:07:55 <oCean> Can we assume, with little feedback there is, others have ignored it too?
19:07:55 <AlanBell> ok, I like the idea of using the ubottu-fr code too
19:08:37 <AlanBell> that seems likely
19:08:51 <topyli> yeah
19:09:11 <oCean> I think that is because we are not sure which way we're going
19:09:27 <ikonia> yes, pick a path and lets go !
19:09:30 <ikonia> get behind it like it or not
19:09:38 <ikonia> I'll even shut up about eir if that's the way you want to go
19:09:42 <ikonia> but lets get stuck in
19:09:59 <oCean> I definitely agree
19:10:27 <ikonia> at least there has been discussion this time
19:10:30 <ikonia> thought/testing behind it
19:10:35 <ikonia> get some opinions etc,
19:10:46 <AlanBell> it is something we can maintain as well
19:11:12 <ikonia> AlanBell: the work niko has done makes it pretty much "too good" out of the box, so we should be able to trim it back
19:11:13 <LjL> i think we can do trials, but either we all say "ok, we're trialling ubottu-fr, so let's ONLY use ubottu-fr for a month [or whatever] and nothing else", or otherwise we'll all continue using what we're used to
19:11:15 <ikonia> rather than develop it
19:11:29 <ikonia> LjL: yeah, the dual bot thing has confused me a bit
19:11:36 <AlanBell> ok, lets move on for now, we will come back to the eir bug in a second
19:11:39 <ikonia> lets wade in, one way or another
19:11:58 <AlanBell> that is a fair point about not using multiple bots, thats why we moved eir out of the way
19:12:03 <ikonia> has it gone ?
19:12:09 <AlanBell> so that it would still process expiries
19:12:12 <ikonia> I thought we where still supposed to be using it
19:12:27 <ikonia> it was still in #ubuntu picking up bans the other day
19:12:29 <AlanBell> it is in #ubuntu-ops-monitor
19:12:34 <topyli> we just moved the control channel
19:12:42 <ikonia> AlanBell: yeah, but it's still picking up bans in #ubuntu, so it's not going to be phased out
19:12:47 <ikonia> it's just not spamming #ubuntu-ops-team any more
19:12:56 <topyli> right
19:12:58 <AlanBell> well it will pick them up if it is there
19:13:08 <AlanBell> but it is mainly there so that it will remove bans
19:13:08 <ikonia> can we dump it out of ubuntu for a while ?
19:13:24 <oCean> Sure, most of us are still using eir
19:13:33 <ikonia> oCean: that's why LjL's point is valid
19:13:38 <oCean> yep
19:14:02 <AlanBell> if someone has a ban set to expire in 30 days or so and we remove eir altogether then that removal won't get processed
19:14:12 <ikonia> could the council have a little think please and knock up a draft plan ?
19:14:25 <jussi> it makes sense to use code that already fits with supybot if we are aiming for a single bot solution
19:14:28 <ikonia> AlanBell: could we not say "we'll work it out manually for a while"
19:14:45 <ikonia> just to phase it out, we can always phase it back in if it's decided eir is the way forward
19:15:17 <LjL> i don't think eir needs to be removed, just for it to be made clear that it's not the one to be used (if it's decided so)
19:15:28 <ikonia> one way or another we'll have to deal with those bans
19:15:28 <ikonia> LjL: but it picks up every ban
19:15:40 <ikonia> it will still have it in the database and the default nag of 2 days option (or whatever it is)
19:15:45 <oCean> AlanBell: I can still update the overview on somedom, so we can see which ban has expired
19:15:48 <oCean> then remove manually
19:16:02 <ikonia> is there a way to put it into read only mode
19:16:06 <ikonia> so it doesn't pickup anything new ?
19:16:18 <AlanBell> probably not
19:16:22 <oCean> Also, I think eir can still remind us of exired bans even when eir is not in #u
19:16:25 <AlanBell> not without affecting other channels
19:16:33 <ikonia> ahhh of course
19:16:37 <ikonia> didn't think of the other channels
19:16:54 <funkyHat> How many bans are likely to be in eir? Would it be feasible to move them manually to ubotu-fr after disabling eir in #u?
19:17:16 <oCean> funkyHat: currently 107
19:17:21 <funkyHat> Or script it if we can get a detailed enough output from eir
19:17:28 <ikonia> funkyHat: oCean 's script run weekly until they are phased out would probable work simpler
19:17:31 <ikonia> just review on a sunday or something for a month or two
19:17:36 <funkyHat> Ok
19:17:38 <ikonia> hell, I'll take an action to do it if needed
19:17:42 <AlanBell> sounds good
19:17:45 <oCean> exactly
19:18:17 <topyli> i'd be fine with that
19:18:34 <ikonia> it's not exactly a long term issue, and probably just a simple way of phasing it out
19:18:45 <funkyHat> Yep, sounds good
19:18:51 <AlanBell> what is the overlap between ubottu and ubottu-fr? Can we put bits of ubottu-fr into ubottu easily?
19:19:28 <ikonia> as I recall niko basically did a modular hot swap
19:19:30 <ikonia> so you can swap in / out what you want
19:19:38 <ikonia> ubottu-fr was just a snapshot of ubottu's later code from what I recall
19:19:38 <ubottu> ikonia: I am only a bot, please don't think I'm intelligent :)
19:19:44 <LjL> do we want to phase it out before we know whether ubottu-fr is "good enough", though? do most of us currently know anything about ubuntu-fr? i'm still leaning towards something like yelling at every op "use ubottu-fr instead of eir for a month!", but without killing eir immediately
19:20:01 <tsimpson> that depends on how ubottu-fr works, ubottu is a regular supybot with plugins. so as long as all the code is external to supybot, it should be fine
19:20:05 <LjL> ikonia: no, i don't think it is just that. it has been modified (the supybot core, that is) to my knowledge
19:20:30 <LjL> the good news, i seem to recall, is that the modifications are being pushed upstream (to supybot)... don't quote me on that, it's what i seem to recall hearing
19:20:31 <ikonia> LjL: I don't know, so I'm not stating anything factually
19:20:51 <AlanBell> ok, we need to have a chat with niko about this
19:21:03 <tsimpson> heh, good luck getting anything upstream in supybot
19:21:16 <niko> there is some core changes in ubotu-fr, that means, you can't use channel plugin of ubotu-fr without the full bot, but that means too that you can load any kind of ubottu plugin into ubotu-fr
19:22:02 <AlanBell> oh that sounds fine then
19:22:05 <LjL> niko: yeah, it's inconvenient, though, to rely on a non-standard supybot. should we need to put a bot up quickly, we can't just apt-get supybot or whatever
19:22:36 <oCean> But LjL has a point, with so little review/trials done on ubotu-fr, how much do we trust it, to replace eir, and actually remove eir from #u
19:22:41 <AlanBell> so we can load all the ubottu plugins into an ubotu-fr clone and bring it up as ubottu
19:22:42 <niko> wget the tar files, sudo python setup.py install, and that's all
19:23:12 <funkyHat> So what are the issues with getting ubotu-fr code into supybot?
19:23:33 <ikonia> tsimpson: I'm guessing you've had a tough time getting anything upstream ?
19:23:39 <niko> ubotu-fr code is dedicaced for ircd-seven, that's the big point
19:23:46 <tsimpson> ikonia: upstream seem dead
19:23:49 <ikonia> ahh
19:23:53 <ikonia> so very hard then
19:24:03 <oCean> aren't we getting a little ahead with discussing merges etc?
19:24:08 <ikonia> niko: would it be possible to make that part a "module" rather than part of the code base
19:24:11 <ikonia> oCean: sorry, yes
19:24:28 <ikonia> I got excited
19:24:39 <topyli> why not fork it properly then, if upstream is not maintaining the original?
19:24:40 <niko> ikonia: not really, too much stuff need to be done in core files, due to how supybot was written
19:24:50 <tsimpson> topyli: because the code is both insane, and ugly
19:25:00 <topyli> ok :)
19:25:02 <oCean> if we trust current ubotu-fr enough, I say remove eir, bring ubotu-fr in, and run,test,file bugs, etc
19:25:10 <ikonia> I have the impression tsimpson may not have had a good time
19:25:29 <AlanBell> yeah, I think we need to jump in with both feet here
19:26:06 <AlanBell> we also need to get through this meeting :)
19:26:11 <oCean> Is there a manual/usage wikipage of some sorts on ubotu-fr usage?
19:26:23 <niko> http://nicolas.coevoet.fr
19:26:55 <AlanBell> I will mail the list with a plan to set up an ubottu-fr clone with the ubottu plugins loaded and get it to replace ubottu
19:27:11 <oCean> niko: I see very few lines under usage :)
19:27:12 <AlanBell> we can discuss on the mailing list and at UDS for those going or attending remotely
19:27:21 <oCean> OK
19:27:27 <AlanBell> lets crack on with the agenda now
19:27:33 <AlanBell> #topic Open items in the IRCC tracker
19:27:38 <AlanBell> there are none \o/
19:27:43 <AlanBell> #topic Review Bugs related to the Ubuntu IRC Council
19:27:46 <topyli> yay!
19:27:49 <AlanBell> #subtopic bug 788503 IRC Guidelines too #ubuntu centric - tsimpson
19:27:51 <ubottu> Launchpad bug 788503 in ubuntu-community "IRC Guidelines too #ubuntu centric" [Undecided,In progress] https://launchpad.net/bugs/788503
19:28:04 <AlanBell> ok, I put the text we had on the wiki
19:28:17 <topyli> yeah, thanks for that
19:28:37 <AlanBell> https://wiki.ubuntu.com/IRC/Guidelines has been updated
19:28:52 <topyli> it is improved
19:28:58 <AlanBell> I think it is better than it was, if there are further improvements to be made then great, we can make them on the wiki
19:29:09 <topyli> yes
19:29:16 <funkyHat> So is this done? ⢁)
19:29:16 <AlanBell> I will close that bug now
19:29:29 <AlanBell> fix released
19:29:52 <AlanBell> #subtopic bug 884671 Ubuntu IRC operator recruitment is slow and ungainly - jussi
19:29:53 <ubottu> Launchpad bug 884671 in ubuntu-community "Ubuntu IRC operator recruitment is slow and ungainly" [Undecided,In progress] https://launchpad.net/bugs/884671
19:30:32 <AlanBell> so for this one we have a new procedure of processing applications from existing core ops as fast as we can conveniently do it
19:30:42 <topyli> this is streamlined a bit with the fast approval of "old" ops
19:30:44 <topyli> yes
19:31:04 <AlanBell> I think we have one to do from a couple of days ago, but generally we are responsive on this now
19:31:44 <AlanBell> I also want to do a big call for ops for lots of channels and process all the queues to do an intake of operators for the Quantal cycle
19:31:59 <AlanBell> and generally have an intake at the start of each development cycle
19:32:21 <AlanBell> I think that makes operator recruitment regular and quite gainly
19:32:29 <AlanBell> so I think that bug is fixed :)
19:32:57 <topyli> we could compile a list of channels and simply send out a call for ops. it's been a while
19:33:11 <AlanBell> yup, and it is the start of the cycle
19:33:18 <topyli> yes
19:34:30 <LjL> Just for the record: I still think you should have a "procedure" (or lack of one, whatever makes it happen) for appointing ops outside of a semestral recruitment process or whatever. And I'm not sure I see how a new release makes new ops automatically needed, on the other hand. But this has been discussed a lot before, so I'm just saying this for the logs, basically.
19:34:30 <topyli> we can close the bug
19:34:45 <AlanBell> fix released
19:35:01 <AlanBell> noted LJL
19:35:14 <AlanBell> #subtopic bug 892500 eir is still not fit for purpose in #ubuntu -ikonia
19:35:15 <ubottu> Launchpad bug 892500 in ubuntu-community "eir is still not fit for purpose in #ubuntu" [Undecided,In progress] https://launchpad.net/bugs/892500
19:35:55 <AlanBell> so on this one we look like going in the ubotu-fr direction, I will mail the list and get some actions together for this.
19:36:09 <AlanBell> #subtopic bug 913541 there are a number of people with Ubuntu IRC cloaks who have expired from the ubuntumembers group
19:36:10 <ikonia> yeah, the ubottu-fr plan covers this
19:36:11 <ubottu> Launchpad bug 913541 in ubuntu-community "there are a number of people with Ubuntu IRC cloaks who have expired from the ubuntumembers group" [Undecided,In progress] https://launchpad.net/bugs/913541
19:36:22 <AlanBell> Pici: did you get anywhere with this one?
19:37:09 <AlanBell> um, pici hasn't said anything, maybe he is indisposed
19:37:15 <AlanBell> lets move on
19:37:25 <AlanBell> #subtopic bug 916247 devel wiki on ubottu.com needs some attention
19:37:27 <ubottu> Launchpad bug 916247 in ubuntu-community "devel wiki on ubottu.com needs some attention" [Undecided,In progress] https://launchpad.net/bugs/916247
19:38:12 <AlanBell> well this was full of spam, that got cleared up and locked down, migrating the data to wiki.ubuntu.com might be a good idea, but the formatting will need a lot of manual fixing and nobody is leaping forward to take on that rather dull task
19:38:37 <ikonia> I can help with it, I can't "do" it
19:38:43 <ikonia> the ubuntu wiki is a tough mistress
19:38:44 <AlanBell> the bug was the spam, which has been addressed, I don't think the devel wiki in itself is a major overhead to have just sitting there
19:39:06 <AlanBell> I am inclined at this point to just leave it and close the bug
19:39:20 <topyli> moving the content is a different issue really
19:40:37 <AlanBell> ok, commented and [C[C[C[C[C[C[C[C[C[C[C[C[C[C[C[C[C[C[C[C[C[C fix released then
19:40:42 <AlanBell> oops
19:40:54 <topyli> ok
19:40:59 <AlanBell> right, moving on
19:41:08 <AlanBell> #topic end of the induction/probation period for the current intake of operators
19:41:37 <topyli> oh it's time is it?
19:41:37 <AlanBell> so we have a bunch of operators from the #lubuntu area who are at the end of their 3 month intro period
19:42:24 <AlanBell> there have been a couple of resignations from people who for various reasons decided not to continue and I think one of them never showed up at all
19:43:17 <AlanBell> we should email them individually I think
19:43:18 <Myrtti> remind us of the nicknames again?
19:43:29 <Myrtti> or shhould I go check myself :-P
19:43:53 <AlanBell> https://launchpad.net/~irc-lubuntu-ops/+members#active
19:44:06 <topyli> i haven't noticed any serious worries with the lubuntu ops. those who are not active are another story
19:45:09 * AlanBell tidies up a couple
19:46:17 * Myrtti nods
19:46:37 <AlanBell> anyone know m0hi?
19:47:02 <topyli> not me
19:47:10 <Unit193> AlanBell: IAmNotThatGuy
19:47:25 <AlanBell> oh, I have seen that nick
19:48:12 <Sidewinder> IAm... is currently in #ubuntuforums
19:48:35 <Sidewinder> Shall I ask him to join here?
19:48:42 <AlanBell> Sidewinder: that would be great
19:48:45 <ikonia> is he active in #lubuntu ?
19:48:47 <Sidewinder> K
19:48:51 <Myrtti> he's on the channel
19:49:02 <Myrtti> there hasn't been that much need for ops there...
19:49:32 <Myrtti> then again I can't remember if he was on the lesson at -classroom either, and I don't know if he needs it
19:49:41 <topyli> oh maybe i should apply there myself, i like that kind of channels
19:49:58 <AlanBell> yeah, I don't have any concerns really, as an Ubuntu Member
19:50:49 <Sidewinder> AlanBell, I politely paged IAmNot ThatGuy
19:51:11 <AlanBell> ok, thats fine, will chat later, I don't have any concerns really
19:51:19 <Myrtti> idle 29minutes
19:51:25 <Unit193> (There is no meeting directly after this)
19:51:41 <AlanBell> ok, lets move on
19:51:43 <AlanBell> #topic Calling for new operators
19:51:53 <AlanBell> ok, new cycle new intake of operators
19:52:00 <topyli> yes let's just do it
19:52:18 <funkyHat> Yep
19:52:21 <AlanBell> I will update my list of everyone in the queue and do a call for ops
19:52:44 <AlanBell> then we can process the queues and get a new group in
19:52:54 <topyli> ok
19:52:57 <AlanBell> #action AlanBell to sort out a call for ops
19:52:57 * meetingology` AlanBell to sort out a call for ops
19:52:57 <Myrtti> which channels are we looking for?
19:53:05 <Myrtti> and do you want me to redo my classroom?
19:53:45 <AlanBell> pretty much all the core channels and yes please Myrtti
19:54:09 <AlanBell> and I want to get a few more classroom sessions scheduled too
19:54:19 <topyli> you did have a good subject which you might do every now and then if you have the energy
19:54:21 <Myrtti> may I suggest a specific call for certain timezones?
19:54:43 <AlanBell> good point, what times are in need of coverage?
19:55:22 <Myrtti> I think nighttime Europe is always in need
19:55:33 <Myrtti> few extra eyes wouldn't be bad
19:55:56 <topyli> so, pacific america?
19:55:58 <AlanBell> ok, kind of 00:00 to 08:00 UTC
19:56:15 <Myrtti> topyli: or au/nz/jp
19:56:17 <AlanBell> doesn't really matter where people actually are, just what time they are on IRC
19:56:22 <Myrtti> depends on the viewpoint
19:56:25 <Myrtti> exactly
19:56:38 <topyli> yeah :)
19:56:46 <AlanBell> ok, I will put something about that in the call for ops
19:56:48 <AlanBell> ok, moving on
19:56:57 <AlanBell> #topic alignment of launchpad teams and channel access lists
19:57:17 <AlanBell> right now the access lists and launchpad teams are in approximate agreement at best
19:57:29 <AlanBell> https://docs.google.com/spreadsheet/ccc?key=0Ankl5FhsdSiZdGZVV2ZuLVRwa2c5M3pqX3BEaUhXMFE
19:57:38 <AlanBell> is all the access lists
19:57:51 <topyli> someone was helping with this, no?
19:57:58 <AlanBell> anyone who pms me an email address can have edit access to thi
19:58:24 <AlanBell> knome was helping to identify some issues
19:59:12 <AlanBell> I was thinking of doing a bit of automation to get the launchpad groups and the access lists in the spreadsheet side by side
19:59:19 <AlanBell> then we can make them all match up
19:59:29 <ikonia> hasn't Pici done work on this before
19:59:31 <ikonia> maybe worth checking
19:59:37 <EvilResistance> AlanBell:  i see one flaw there, though: not every nickname that patches on Launchpad is up-to-date here on Freenode
20:00:13 <EvilResistance> s/patches/is/
20:00:13 <AlanBell> EvilResistance: that is a good point, but everyone in the core ops team does have a nick on their launchpad page (I checked)
20:00:38 <AlanBell> if any don't tie up I will be asking them to change the launchpad nick to their account name
20:00:39 <EvilResistance> indeed, just wanted to point that out, you'd need to make sure the nicks are kept up to date ;)
20:00:45 <AlanBell> it is done on account names rather than nicks
20:00:46 <topyli> isn't it a requirement in the first place, so you can be an op? :)
20:01:20 <AlanBell> account  : Resistance
20:01:35 <Resistance> :P
20:01:58 <AlanBell> ok, don't need to go through the spreadsheet line by line right now
20:02:01 <AlanBell> oh, one thing
20:02:24 <AlanBell> VotiA or VotriA or something else as the default? should it be the same over all channels?
20:02:36 <AlanBell> and should people have founder flags?
20:03:50 <AlanBell> some channels have a wide assortment of flags for operators, it looks a bit messy but I guess it works fine
20:03:55 <Resistance> AlanBell:  from an ITSec point of view, i think that only members of IRCC should have the founder flag, anyone else who has founder flag has sort of a god power over a channel.
20:04:00 <topyli> i think we've just done VotiA, but i'm far from clueful in this
20:04:34 <AlanBell> ok, we will have a bit of a think about this and work out some conventions I think
20:04:39 <topyli> yeah i agree, ops don't need founder flags
20:04:43 <AlanBell> bit of a pici question
20:04:52 <AlanBell> #topic UDS blueprint
20:05:00 <AlanBell> so UDS is coming up next week
20:05:10 <AlanBell> I am going in person, anyone else going to be there?
20:05:46 <Myrtti> Resistance +1
20:06:14 <topyli> just remote lurking. i'll probably be semi-actively following the community track
20:06:25 <Myrtti> wasn't sponsored, so not going
20:06:53 <AlanBell> would you like to have an IRCC session set up so we can have a chat over the audio streaming thingie?
20:07:23 <topyli> why not, if we have something to chat about :)
20:07:56 <AlanBell> ok, I will set one up then, I will try to get a morning slot for it
20:08:07 <AlanBell> #action AlanBell to schedule UDS session
20:08:07 * meetingology` AlanBell to schedule UDS session
20:08:14 <AlanBell> #topic setting up an election of another council member
20:08:33 <AlanBell> there are 4 people on the IRCC, there should be 5 according to our charter
20:08:43 <topyli> yeah
20:09:06 <AlanBell> we deferred fixing that into the Q cycle but I think we are now in a much better position to go ahead with it
20:09:30 <funkyHat> And we are now in the Q cycle ⢁D
20:09:42 <topyli> we need to feel around for candidates
20:09:50 <Myrtti> I'm happy I'm practically unelectable \o/
20:09:56 <AlanBell> \o/
20:10:06 <Myrtti> I can continue to heckle from the peanut gallery
20:10:23 <AlanBell> mmm peanuts
20:10:42 <Unit193> Yep, we can toss the peanuts at them. :D
20:10:42 <funkyHat> I know of one potential candidate, and I remember someone else being mentioned too
20:10:56 <AlanBell> ok, not much more to say on this one, just wanted to announce it and get started on it
20:11:05 <AlanBell> we will talk to the CC about the process
20:11:24 <AlanBell> final item now
20:11:27 <AlanBell> #topic set up #ubuntu-discuss for on-topic non-support discussion and ramblings
20:11:57 <AlanBell> we have had Canonical sending people into #ubuntu to join the discussion about ubuntu
20:12:05 <AlanBell> people who don't have an active support problem
20:12:20 <Myrtti> #ubuntu-project
20:12:22 <AlanBell> this isn't ideal so we talked to canonical about this issue and got it fixed
20:12:41 <AlanBell> but it would be nice to have an area for on-topic talk about ubuntu that isn't support
20:12:50 <AlanBell> and isn't what -offtopic is
20:12:56 <ikonia> that was always my dream for -offtopic
20:13:35 <LjL> you can kill #ubuntu-offtopic, or you can talk about interesting things there and make it better, your call i guess
20:13:51 <ikonia> option 2 is always my preference
20:13:57 <topyli> i'd use -ot
20:14:23 <topyli> or *continue* to use -ot, rather
20:14:28 <ikonia> I would if you could have a discussion in there
20:14:45 <funkyHat> It is quite possible to have a discussion in -ot
20:15:19 <AlanBell> well right now it is being used for a perfectly nice conversation about films
20:15:20 <Sidewinder> Unless you want to create an #ubuntu-offtopic-offtopic, which I wouldn't recommend.
20:15:35 <AlanBell> Sidewinder: more of an #ubuntu-ontopic
20:16:03 <Sidewinder> Not a bad idea; just non-support..
20:16:03 <AlanBell> I don't want to remove #ubuntu-offtopic
20:16:04 <LjL> so you want a channel for support, a channel for Ubuntu discussions that are not support, and a channel strictly for discussions that are not about Ubuntu
20:16:06 <LjL> seems overkill to me
20:16:19 <LjL> and a good way to kill either or both the "secondary" channels
20:16:43 <Sidewinder> There is that.
20:17:06 <topyli> i think -ot is just fine for any ubuntu-related discussion. you're not required to talk about flashlights there. it's just for whatever is not support
20:17:08 <AlanBell> it is possible that it won't be a viable channel long term, I don't know without trying it
20:17:10 <Sidewinder> I don't feel that ot is overly busy.
20:17:28 <guntbert> maybe make it more obvious in -ot that is is intended for discussion about ubuntu - not just a general "anything goes"
20:17:39 <funkyHat> I don't see much issue with encouraging more ubuntu-related discussion in -ot. At the moment it's not a terribly busy channel
20:17:40 <LjL> guntbert: well but it's not. it's for both things
20:18:11 <funkyHat> guntbert: well it is a general channel too
20:18:16 <guntbert> LjL: ok, (I said 'not just' :-)
20:18:24 <Sidewinder> If it ain't broke, don't fix it. IMHO
20:19:05 <topyli> it's not broken. sure, we could always tend to it better, but that's not the channel's fault as such
20:19:05 <AlanBell> "Join the discussions in #ubuntu on Freenode" is what the canonical stuff said
20:19:13 <guntbert> I see one problem: quality discussion just don't happen there - do they?
20:19:24 <AlanBell> "Join the discussions in #ubuntu-offtopic on Freenode" would be a strange thing for them to say to customers
20:19:35 <topyli> quality discussion does happen in -ot. just not all the time
20:19:51 <LjL> so the issue is the channel name?
20:19:53 <topyli> AlanBell: that's true
20:20:01 <Sidewinder> guntbert, I think they do; it's not just limited to that.
20:20:54 <Sidewinder> LjL, I think the name's fine, but that's just me.
20:20:56 <AlanBell> LjL: partly, yes, and partly because someone arriving in a totally off-topic discussion might be confusing
20:21:19 <topyli> canonical could say "join #ubuntu for support and #ubuntu-offtopic for general discussion"
20:21:31 <funkyHat> I think arriving to see an off topic discussion is better than joining a dead channel
20:21:33 <LjL> AlanBell: make #ubuntu-chat or #ubuntu-discuss or whatever and redirect it to #ubuntu-offtopic if the issue is the channel name in "marketing", i don't think that's an issue. if the problem is the content, well i don't think it's an issue either, but i guess it might be
20:21:36 <guntbert> how about doing it the freenode way?   #help = #freenode              so #ubuntu-offtopic = #ubuntu-discuss
20:21:44 <Sidewinder> topyli, I think that's THE answer.
20:21:56 <Resistance> i think topyli has the right idea there
20:21:58 <funkyHat> Maybe if -ot gets too crowded we could rethink having a -discuss or -project channel
20:22:32 <funkyHat> (assuming some of the crowd is actually project related ;)
20:23:29 <guntbert> I too like topyli's proposal
20:24:05 <funkyHat> Yep
20:24:34 <AlanBell> how much of the crowd at the moment is made up of people who are developers on the project in some way?
20:24:56 <ikonia> pretty much zero
20:25:05 <Resistance> what ikonia said, at the most maybe 1%
20:25:08 <topyli> in -ot? not too many
20:25:28 <ikonia> offtopic has nothing to do with ubuntu in any way
20:25:30 <ikonia> even community
20:25:32 <ikonia> people don't user/support/discuss ubuntu, it's just another defocus
20:25:37 <Myrtti> most of the time it feels like -uk is better for that discussion ;-)
20:25:42 <ikonia> Myrtti: it is
20:25:45 <AlanBell> yup
20:26:00 <topyli> i'm always talking about ubuntu or linux in -ot
20:26:01 <Myrtti> s/that//
20:26:14 <topyli> except when i'm talking about something else :)
20:26:24 <Sidewinder> Heh,.
20:26:27 <ikonia> topyli: yes, your a rarer beast, as is ljl and a few others
20:26:27 <ikonia> but a lot of the users have no "ubuntu" reason to be there
20:27:15 <AlanBell> and lots of people who do some contribution to ubuntu in some context don't really want to be there
20:27:15 <topyli> there are a lot of people there who don't even use ubuntu anymore, but used to at some point and just like the people
20:27:37 <ikonia> topyli: I don't think you have to use it, but have an interest in it, follow it, be aware of it so you can actually participate
20:27:48 <ikonia> be "involved" in someway
20:27:52 <AlanBell> both are fine, I don't want to go shutting down -offtopic as a kind of defocusy chatter place
20:28:11 <topyli> ikonia: it would be more "ubuntu" that way for sure
20:28:15 <AlanBell> a lot of loco teams don't have active channels so -offtopic kind of takes that role a bit
20:28:30 <Sidewinder> Currently it's just less strict.
20:28:35 <ikonia> topyli: at the moment there is no "ubuntu" community to that channel, beyond the fact that it has the ubuntu coc
20:28:57 <ikonia> it's not made up of members/users/interested parties etc, its just people
20:29:27 <ikonia> you could chnge the channel name to offtopic and it would not have any difference to the users/content
20:29:56 <dax> If memory serves, the top three people in that channel don't use Ubuntu; topyli breaks the trend by being in 4th place :P
20:30:11 <ikonia> I don't think using it is a requirement
20:30:13 <Myrtti> topyli: have you moved back to Ubuntu now?
20:30:15 <Myrtti> :-P
20:30:20 <topyli> i'm back on ubuntu yes :)
20:30:22 <ikonia> but being part of the community, following it's disucssion/development etc
20:30:30 <ikonia> being able to join in with it in some way
20:30:54 <dax> I will refrain from discussing my opinions on whether AtomicSpark is part of the Ubuntu community, but I don't think I (#2) am :P
20:31:31 <AlanBell> ok, so how do we draw this item to a conclusion?
20:31:52 <topyli> yeah you're an example of someone who *was* a part of the community for a long time and now just hang in there with old friends :)
20:32:15 <topyli> AlanBell: well, frankly i'd do nothing but tell canonical to clarify their message
20:32:19 <Sidewinder> Homeostasis?
20:32:30 <Sidewinder> topyli, +1
20:33:02 <Resistance> I'm not on the Council, but I think that, at the least, telling Canonical to clarify their message is the first step, but that more in-depth research and discussion on this topic needs to be done to determine whether an Ubuntu discussion channel needs to exist separate from -offtopic
20:33:04 <Sidewinder> If we were voting, that is..
20:33:05 <topyli> maybe it will improve -ot if canonical starts sending people there, who are actually interested in discussing ubuntu
20:33:08 <funkyHat> I agree. And if we want to have more ubuntu related discussion in -ot we need to just have more ubuntu related discussion
20:33:12 <funkyHat> Yes
20:33:12 <AlanBell> well I did that, and Mark said
20:33:14 <AlanBell> * if there is a better IRC channel for general "hello, I'm interested in X with Ubuntu, where should I go?", then let me know and I'll update the team to use that for the cases where they do judge the audience to be developer or at least highly technical in nature.
20:33:30 <AlanBell> the other option is that canonical don't send people to IRC
20:33:43 <AlanBell> and send them to askubuntu.com or something instead
20:33:50 <Resistance> AlanBell:  that'd be cutting out one of the big support communities, there.
20:33:58 <topyli> well the latter one does not sound very good
20:35:06 <Resistance> i think IRC is better for real-time support, askubuntu.com and ubuntuforums.org take some time to actually get decent responses, and to be honest, there's more people on IRC who really know what they're talking about
20:35:12 <Resistance> (at least, in comparison to askubuntu.com)
20:35:19 <AlanBell> it isn't about support
20:35:22 <topyli> also, it's not *so* terrible to come to the main channel, it's natural. it's just that people will use their energy to guide these people to the correct channels like -ot or -server or whatever
20:35:41 <topyli> i don't know how big this problem is for #ubuntu
20:35:58 <AlanBell> this was about their communications around ubuntu for android
20:36:31 <topyli> is there *any* channel where people talk about ubuntu for android?
20:36:41 <topyli> does it even have anything to do with the community?
20:36:47 <LjL> ^
20:37:23 <LjL> maybe the problem is that Canonical and its developers should interact with the community, not "send" people to IRC when there's no way anyone can have a clue about the product
20:37:33 <dax> Does it have publicly accessible source-code anywhere?
20:37:48 <dax> (because if not, it's not an Ubuntu community project, it's a Canonical project using Ubuntu branding)
20:38:01 <AlanBell> http://paste.ubuntu.com/963188/
20:38:21 <AlanBell> silly pastbin with no wrapping
20:38:28 <topyli> ubuntu one has nicely settled on its own channel, it's not bothering us too much i think
20:38:36 <topyli> at least that's how it used to be
20:39:18 <AlanBell> so yes, there should be more canonical developers involved, but no they are not going to all join #ubuntu-offtopic and stay there
20:39:39 <topyli> probably not. they have jobs :)
20:40:45 <Myrtti> this might be something that could be discussed in UDS...
20:40:58 <AlanBell> that is a good point
20:41:09 <AlanBell> get some more canonical opinions on the matter too
20:41:36 <topyli> yes. the devs will be there
20:41:36 <Myrtti> indeed
20:41:50 <AlanBell> ok I will put it on the agenda of the UDS meeting
20:41:50 <Sidewinder> AlanBell, What's wrong with them joining #u? I for one have noticed some questions asked there that were not answered and I could not.
20:42:29 <Myrtti> Sidewinder: there is nothing to support
20:42:39 <AlanBell> Sidewinder: because they don't have a support question and the general feeling at the time was nobody wanted people turning up in #u wanting to "join the conversation"
20:42:40 <LjL> Sidewinder: that Ubuntu's policy has always (to my knowledge) been that it's a technical support channel only, not for opinions, information about products, discussion, etc - if we opened *that* door, a lot of stuff would come in
20:42:41 <Myrtti> Sidewinder: so it doesn't fit on a support channel at the moment
20:43:02 <AlanBell> anyhow, lets discuss that more next week
20:43:02 <Sidewinder> OIC.
20:43:05 <AlanBell> #topic Any Other Business
20:43:13 <AlanBell> anything else to discuss now?
20:43:18 <Myrtti> AlanBell: #ubuntu+1
20:43:23 <Myrtti> (see -ops)
20:43:32 <AlanBell> ah right, shall we open it again?
20:43:43 <topyli> if Q is open, why not?
20:43:52 <AlanBell> can't see any particular reason no to, the toolchain is open
20:43:56 <Sidewinder> LjL, I agree.
20:44:07 <AlanBell> lets do it
20:44:12 <topyli> yeah
20:44:18 <AlanBell> ok, anything else
20:44:19 <oCean> AlanBell: One more thing, since you skipped quite quickly through the "eir not fit for purpose"
20:44:29 <oCean> Recently I removed a lot of bans/mutes. Most of those had no comments at all, so I had to go through logs etc to see if they could be removed
20:44:49 <oCean> Because I don't really want to go through all that again, and we don't want to do that if we're weekly reviewing which bans can be removed, I suggested changing eir's config (or for any new bot) to autoremove-after-expire.
20:45:01 <AlanBell> ok, I think if people are not commenting on bans they are fair game for removal
20:45:06 <oCean> So if you want a ban/mute to stay, just make sure you btset it with an expire date and/or comment, or after 2 days it is gone and so preventing all these undocumented bans
20:45:42 <oCean> we can agree, but others should be aware of it
20:45:55 <oCean> since even after a couple of days, we have lots of expired and uncommented bans again
20:46:18 <topyli> sounds good to me. an email to the list should handle the communication
20:46:32 <oCean> yup
20:46:48 <topyli> oCean: are you volunteering to compose this email? :)
20:47:04 <oCean> sure, but it would not go out before the weekend
20:47:09 <topyli> because you would know what you're talking about, unlike me
20:47:13 <oCean> don t think we're in a hurry though
20:47:33 <topyli> ok
20:48:17 <AlanBell> fine
20:48:22 <AlanBell> anything else to discuss?
20:48:42 <AlanBell> #endmeeting