18:02:28 <ajmitch> #startmeeting Application Review Board
18:02:28 <meetingology> Meeting started Fri Mar 30 18:02:28 2012 UTC.  The chair is ajmitch. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
18:02:28 <meetingology> 
18:02:28 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
18:03:12 <ajmitch> #link https://wiki.ubuntu.com/AppReviewBoard/Agenda
18:03:40 <ajmitch> sorry, still waking up :)
18:04:59 <ajmitch> ok, we'll begin on that action review, I'll quickly go throuh & check what's still there from last month
18:05:08 <ajmitch> #topic Action review
18:06:32 <ajmitch> wendar: you were going to check with doko about when python-support will be removed from the archive, I'm guessing the answer is whenever it's not used anymore?
18:06:50 <wendar> yup
18:06:56 <wendar> it's moved to universe for Precise
18:07:12 <wendar> which is still fine for Extras dependencies
18:07:28 <wendar> but, right now we're manually removing it from packages
18:07:40 <wendar> so, I suggest we keep doing that in Precise
18:07:43 <ajmitch> right, it's easier to use dh_python2 anyway
18:07:51 <wendar> and expect it may be gone from P+1
18:08:02 <wendar> yeah, I much prefer dh_python2
18:08:24 <ajmitch> ok, will mark that action as done
18:09:01 * ajmitch hasn't seen any movement on bug 894582, might be getting a bit late to get it fixed for precise unless it's done this week
18:09:02 <ubottu> Launchpad bug 894582 in python-distutils-extra "Python templates should use dh_python2" [Undecided,New] https://launchpad.net/bugs/894582
18:10:19 <ajmitch> anyone else feel inspired to take that on & see if it can be fixed for release?
18:11:07 * stgraber -> ENOTIME
18:11:23 <ajmitch> stgraber: yeah, that's what I figured :)
18:11:55 <ajmitch> I'll add it to my todo list then, but I don't have a great amount of spare time either right now
18:12:11 <wendar> how about UDS?
18:12:25 <ajmitch> wendar: sorry?
18:12:27 <wendar> as in, talk about it at UDS and see if we can get some TUITs from elsewhere?
18:12:55 <ajmitch> ah right, I was mostly wanting it for precise release, so people who build on precise can make packages that we don't have to change too much
18:12:56 <wendar> If we could get it on mvo's list for next cycle, that'd be great
18:13:45 <wendar> it seems too disruptive for an FFE
18:13:50 <ajmitch> I'll try for this week, otherwise sort it at UDS
18:13:57 <wendar> yup, sounds good
18:14:21 <ajmitch> #action ajmitch to look at bug #894582
18:14:21 * meetingology ajmitch to look at bug #894582
18:14:22 <ubottu> Launchpad bug 894582 in python-distutils-extra "Python templates should use dh_python2" [Undecided,New] https://launchpad.net/bugs/894582
18:14:48 <ajmitch> ok, now onto the developer-portal bugs
18:15:35 * highvoltage is listening, even though quiet
18:15:45 * ajmitch also hasn't seen any activity on there, and hasn't emailed david pitkin back, to nag him
18:16:13 <ajmitch> highvoltage: it's ok, you can keep quiet & we'll assign the rest of the tasks to you :)
18:16:23 <wendar> heh
18:16:38 <highvoltage> I've already been a bad rmb member regarding my tasks already :(
18:17:08 <ajmitch> heh
18:17:29 <ajmitch> well, I'll see what I can do about nagging about bugs again in this case :)
18:18:03 <ajmitch> #topic When should we open extras for precise?
18:18:13 <ajmitch> wendar: your topic
18:18:39 <wendar> I'd like to suggest opening up the extras archive for precise now.
18:18:52 <wendar> instead of waiting until after the precise release
18:19:20 <wendar> so we can publish a few apps ahead of time, and have them available in the software center at release
18:19:32 <ajmitch> ok, I'm not opposed to that, as a development platform precise won't really change in the next few weeks
18:20:26 <ajmitch> stgraber, highvoltage - what do you think of it?
18:21:32 <stgraber> yeah, opening now (post-beta2) should be safe
18:21:41 <highvoltage> yeah sooner is probably better than later
18:21:54 <stgraber> it's very unlikely any of the submissions would be pushed to Ubuntu before release (with FFe and all the other paperwork)
18:21:58 * ajmitch doesn't feel like voting on it, so we'll take that as agreed
18:22:31 <wendar> who wants to turn it on?
18:22:40 <wendar> stgraber has done it in the past
18:22:51 <ajmitch> where is that done?
18:23:06 <stgraber> wendar: the repository is already ready for precise, but someone probably needs to check that MyApps is too
18:23:29 <wendar> stgraber: so if we published to the Extras PPA today, it would be copied over?
18:23:48 <stgraber> wendar: yes
18:24:31 <wendar> stgraber: excellent
18:25:23 <ajmitch> then for existing packages in the queue (of which there are many), should we switch to targetting them to precise?
18:26:08 <wendar> ajmitch: that's my next question on the agenda
18:26:21 <ajmitch> wendar: right, I'll change the topic for it :)
18:26:33 <ajmitch> #agreed Open extras for packages before precise release
18:26:56 <ajmitch> #topic Should we review existing packages for precise?
18:27:08 <wendar> I've got a few more lenses/scopes that are specific to Oneiric, but for all other submissions, I'd like to package it for Precise instead.
18:27:36 <wendar> it just seems silly to be releasing new apps on Oneiric two weeks before the Precise release.
18:27:46 <ajmitch> I expect most people will upgrade from oneiric, so if an app builds & works on precise they should go there
18:28:16 <ajmitch> I don't think most submissions indicate which release they're targetting
18:28:44 <highvoltage> ajmitch: but they should, shouldn't they?
18:28:50 <wendar> yeah, I guess if we find into some that only build and run on Oneiric, it's worth considering publishing them to Oneiric, instead of making the developer fix them up
18:29:19 <wendar> highvoltage: we generally just dictate that they all target the current release
18:29:49 <wendar> highvoltage: so, indicating any other release is just a "bug" in their submission, that we fix before shipping it
18:30:08 <highvoltage> ok
18:30:23 <ajmitch> like a recent submission that had maverick in debian/changelog, though it didn't build on oneiric
18:30:58 <ajmitch> ok, I guess we're agreed that it's generally a good idea to do reviews for precise
18:31:42 <ajmitch> #topic Notify developers with published Oneiric apps of process for resubmitting for Precise.
18:33:26 <ajmitch> wendar: you added this one earlier today, I'm guessing we don't have a large number of applications which should be resubmitted for precise
18:33:38 <wendar> Yup, a pretty small number.
18:33:49 <wendar> This was mainly a follow up to the last two topics.
18:34:11 <wendar> To say: I'll volunteer to send a personal email to everyone who already has an app in Oneiric.
18:34:19 <ajmitch> yeah, cielak was asking about this process as well
18:34:24 <ajmitch> great
18:34:28 <wendar> Telling them that we've opened up the archive for submissions to Precise.
18:34:44 <wendar> And, if they want to get their app in before release, they can do it now.
18:35:20 <ajmitch> will they need to resubmit through myapps, even if it's not a new upstream release?
18:35:57 <wendar> How about we say they can either submit to MyApps, or just contact us on the mailing list?
18:36:02 <ajmitch> or in cases like harmonyseq, should we just bump the version number in the changelog for precise?
18:36:18 * ajmitch isn't sure if just copying packages in the PPA will work)
18:36:45 <wendar> I don't think we even need to bump the version number in the changelog, as long as we rebuild with precise as the target in the changelog
18:37:08 <wendar> I mean, bump the version number if we have to make any changes other than the release target
18:37:15 <wendar> but, otherwise, it's just a rebuild
18:37:18 <ajmitch> the debian revision needs changed at least, from ...11.10.1 to 12.04.1
18:37:19 <stgraber> wendar: well, then we need to bump the version
18:37:38 <stgraber> wendar: as you can't have two binary packages in the repository with the same version but different content
18:37:52 <wendar> stgraber: yeah, true enough
18:37:59 <stgraber> wendar: so we either copy to the new series (and use exactly the same binary package) or we rebuild and then need to bump the version at the same time
18:38:15 <wendar> simple version bump as a "rebuild for precise"
18:38:31 <wendar> I'd rather rebuild than copy the binary package
18:38:44 * stgraber too
18:39:08 <ajmitch> ok
18:39:19 <stgraber> so bump to .12.04 and upload for these that don't need any extra change (when told by the developer they want it in precise)
18:39:22 <wendar> ajmitch: that's true, the debian revision has to change, since we have the Ubuntu release version number in the package version string
18:39:31 <ajmitch> #action allison to send a personal email to everyone who already has an app in Oneiric.
18:39:31 * meetingology allison to send a personal email to everyone who already has an app in Oneiric.
18:40:32 <ajmitch> anything else on that one, or do we move onto the big topic about the queue state? :)
18:40:48 <wendar> onward :)
18:40:59 <ajmitch> #topic State Of The Queue
18:41:57 <ajmitch> so though I had good intentions a week or so ago, I haven't had time to really look at & comment on applications this week, have just casually looked at some recent submissions
18:42:27 <wendar> I've been doing quick replies on the ones that need quick fixes
18:42:40 <ajmitch> the queue length is long, I'm been meaning to work from the top down
18:42:47 <wendar> so, a lot of what's left is either valid source packages (with no debian packaging)
18:42:55 * ajmitch has some spare time this weekend
18:43:03 <wendar> or debian packages that need validating for ARB requirements
18:44:00 <wendar> some exceptions to that are the Community Lens
18:44:01 <ajmitch> packages like zeroballistics needs a careful rejection sent, as it looks to be a nice game, gpl source, but it depends on a non-free library
18:44:41 <wendar> ah, yeah, that would be out
18:44:53 <ajmitch> wendar: what's the state of the music lenses in the queue there?
18:45:11 <wendar> I've got a patch back from the developer to fix the final problems
18:45:25 <wendar> so, I just need to integrate that, test, and put them up for vote
18:45:30 <ajmitch> ok
18:45:33 <wendar> I could do that today or tomorrow
18:45:47 <wendar> the community lens is for precise, so no hurry on that one
18:46:02 * ajmitch would like to be able to get rid of these 'pending qa' items from the list
18:46:15 <wendar> yeah, that's one of the active bugs, isn't it?
18:46:20 <ajmitch> yep
18:46:28 <ajmitch> the bug is fix committed (iirc)
18:46:43 <wendar> so, just waiting for release?
18:47:07 <wendar> (where release is their server rollout schedule, rather than related to Ubuntu releases)
18:47:15 <ajmitch> I assume so, stgraber may know a few more details about how these bits interact
18:47:49 <wendar> https://bugs.launchpad.net/developer-portal/+bug/914667
18:47:51 <ubottu> Launchpad bug 914667 in Developer registration portal "Packages in the ARB process should go directly to Published without going to "Ready to Publish"" [High,Fix committed]
18:49:04 <ajmitch> fix committed 6 weeks ago, maybe it has been rolled out & we can mark them as published :)
18:50:02 <wendar> maybe check with achuni?
18:50:11 <wendar> or, ask in the ticket?
18:50:27 <ajmitch> I'll do that
18:50:36 <wendar> of all the bugs, this one is probably the biggest irritant at the moment
18:50:42 <wendar> cool, thanks
18:50:56 * ajmitch would probably put that on par with the needs info submissions not showing
18:51:16 <ajmitch> any other comments on the state of the queue, apart from 'just do it'?
18:51:33 <wendar> a whole bunch of them are new submissions with no packaging
18:51:49 <wendar> but, we agreed a few months ago to only accept new submissions from PPAs
18:51:57 <ajmitch> I'll check for a bug on developer-portal about requiring PPAs at submit time
18:52:05 <wendar> it does now
18:52:06 <wendar> http://developer.ubuntu.com/publish/my-apps-packages/
18:52:13 <wendar> or, at least the instructions are right now
18:52:37 <wendar> I totally think we should do the packaging for the old apps that were submitted before we said we required PPAs
18:52:38 <ajmitch> right, but at the point you submit, does it require a PPA be given?
18:52:47 <wendar> nope, not yet
18:52:55 <wendar> so, I wouldn't reject the apps with no PPA
18:52:59 <ajmitch> ok, I'll check for that one
18:53:18 <wendar> but, I'm thinking it would be a better use of my time to write a step-by-step set of instructions on how to package new apps
18:53:29 <wendar> than to manually do the packaging for the new submissions
18:53:45 <ajmitch> it can be a bit time-consuming :)
18:54:00 <wendar> Aye, and it'll only get more time-consuming as we go on
18:54:05 <wendar> it doesn't scale
18:54:35 <wendar> but, if we could give them a really polite and helpful way to do the packaging themselves, that'd make a difference
18:54:44 <wendar> and would scale better
18:54:58 <ajmitch> the packaging guide still confuses quite a few people
18:54:58 <wendar> also, I think a guide on how to make a tarball would be helpful
18:55:27 <ajmitch> that would help, people are still submitting .jar files
18:55:30 <wendar> the packaging guide is also for the main Ubuntu archives, and not for the ARB requirements
18:56:02 <wendar> so, even when we do get proper debian source packages, we still have to manually edit them
18:56:09 <ajmitch> yep
18:56:45 <wendar> I figure if I condense the instructions I've already sent out individually to a bunch of devs into a few simple wiki pages, it could help us a lot
18:57:10 <ajmitch> it'd help us as well
18:57:15 <ajmitch> thanks for offering to do that
18:57:30 <wendar> cool, I'll do that this weekend
18:57:51 <wendar> and, if you're doing packaging work this weekend, focus on the older submissions, from before the PPA requirement
18:58:04 <ajmitch> I realised I skipped the 'review updated text', but iirc that was an agenda meeting from last time which we resolved?
18:58:29 <wendar> it was new... just a sec let me check what it was...
18:58:59 <wendar> It might have been https://wiki.ubuntu.com/AppReviewBoard/Review
18:59:22 <wendar> specifying the right URL for screenshot images
18:59:46 <ajmitch> the agenda item was about https://wiki.ubuntu.com/AppReviewBoard/Review/Guidelines, depending on backported libraries which are new
18:59:50 <wendar> Oh, no, it was backported libraries
18:59:51 <wendar> yeah
19:00:24 <wendar> after discussion on IRC, I added the text:
19:00:25 <wendar> (We're open to considering dependencies on backported libraries, on a case-by-case basis, but only if the backport is a new library and not an updated version of an existing library.)
19:00:40 <wendar> and I just wanted a quick double-check that other folks were okay with that
19:00:50 <ajmitch> imho the text that's been added there is fine
19:01:17 <ajmitch> stgraber, highvoltage: ^ if you have a sec :)
19:02:11 <stgraber> sounds good
19:02:35 <ajmitch> ok
19:02:39 <stgraber> not sure we can assume everyone has -backports in their /etc/apt/sources.list, but since oneiric we do it by default so I guess it'll be fine
19:02:58 <highvoltage> no strong feelings about it here :)
19:03:06 <ajmitch> ok then
19:03:13 <ajmitch> are we up to the AOB point?
19:03:51 <wendar> NOB from here
19:04:26 <ajmitch> the main thing I have is the meeting time - it's that time of year with daylight saving time messes with us
19:05:03 <ajmitch> from next month the meeting time will end up at 6AM on a saturday morning for me, which is a little painful :)
19:05:20 <wendar> that's pretty awful
19:05:43 <ajmitch> it was hard enough getting up for a 7AM meeting this morning, I should have gone to sleep before 2 :)
19:05:47 <highvoltage> ouch
19:06:12 <ajmitch> do we want to sort out a new time here, or on the list so our other team members can comment?
19:06:31 <wendar> probably finalize it on the list, but a first guess here could speed things up
19:06:35 <wendar> http://www.timeanddate.com/worldclock/fixedtime.html?msg=App+Review+Board+Meeting+&iso=20120330T18
19:06:44 <wendar> ^ the link to the current meeting time
19:08:01 <ajmitch> an hour or two later works for me
19:08:13 <ajmitch> so 1900UTC or 2000
19:08:18 <wendar> stgraber, where are you?
19:08:48 <highvoltage> stgraber is on east coast, est time
19:09:02 <ajmitch> highvoltage: you're in the same place, right?
19:09:05 <highvoltage> yep
19:09:38 <wendar> so a little later would probably be fine for both of you
19:09:45 <stgraber> I'm happy with both 1900 or 2000 UTC
19:09:49 <highvoltage> yep
19:10:10 <ajmitch> I think if coolbhavi is able to make it, he's indicated that a slightly later time is better
19:10:10 <stgraber> I'll be in Europe for our next meeting but will probably skip it anyway, so that's fine :)
19:10:18 <wendar> Bhavani doesn't usually make it to the meetings, so I think it's okay not to plan them around Calcutta time
19:10:28 <ajmitch> stgraber: skip it? how could yo? :)
19:10:52 <stgraber> :)
19:11:20 <ajmitch> ok, I'll mail the list about the new suggested time & ask for feedback
19:11:22 <wendar> hmmmm... ajmitch: how about flipping the meeting around to Friday afternoon your time?
19:11:30 <wendar> Friday morning US time?
19:11:51 <ajmitch> wendar: it'd need to be after work for me
19:11:55 <wendar> sorry, backwards
19:12:11 <ajmitch> so from 0500UTC onwards
19:12:19 <wendar> ugh, timezones
19:12:21 <ajmitch> yeah
19:12:25 <wendar> just a sec I'll do meeting planner
19:12:38 <wendar> http://www.timeanddate.com/worldclock/meeting.html
19:12:41 <ajmitch> I didn't think it'd work well for east coast people then
19:12:51 <ajmitch> UTC+12 is at least easy to convert :)
19:13:10 <wendar> http://www.timeanddate.com/worldclock/meetingtime.html?iso=20120427&p1=137&p2=179&p3=22
19:13:38 <wendar> ajmitch: it's actually easy enough, as long as you're not also trying to accommodate Europe
19:14:13 <ajmitch> well, we have fagan in europe, but I haven't even seen him on irc for a couple of months
19:14:44 <wendar> yeah, the meetings aren't critical, so might as well optimize the time for the people who attend
19:14:53 <wendar> ajmitch: is Saturday easier than Friday for you?
19:14:57 <ajmitch> yes
19:15:00 <wendar> ajmitch: just not so early?
19:15:06 <ajmitch> just not 6AM
19:16:06 <wendar> ajmitch: like Saturday at 10/11am?
19:16:13 <ajmitch> fine by me
19:16:40 <wendar> that's pushing into Friday night for the US Eastern folks
19:16:59 <wendar> maybe a bit of a drag for personal life
19:17:05 <highvoltage> ok by me if I know about it in advance
19:17:16 <wendar> 9am Auckland is 5pm Eastern
19:17:28 <wendar> 10am Auckland is 6pm Eastern
19:18:00 <wendar> that's late enough for a Saturday sleep in Auckland, but early enough to still go out in US Eastern
19:18:12 <stgraber> hmm, 6pm on a Friday... not sure I'll be around. 5pm is fine though
19:18:21 * ajmitch doesn't mind 7 or 8 AM
19:18:52 <ajmitch> so that's why I was suggesting just 1900/2000 if it still suited others
19:18:57 <wendar> http://www.timeanddate.com/worldclock/meetingdetails.html?year=2012&month=4&day=27&hour=21&min=0&sec=0&p1=137&p2=179&p3=22
19:19:27 <ajmitch> 2pm ok for you?
19:19:54 <wendar> yeah, 2pm is fine for me
19:19:58 <wendar> (pacific time)
19:20:00 <ajmitch> ok
19:20:04 <wendar> 5pm eastern
19:20:10 <wendar> 9am auckland
19:20:14 <ajmitch> seems to work
19:20:26 <ajmitch> last thing is to volunteer a chair for next month
19:21:17 <ajmitch> it'll be about a day after the precise release, fwiw
19:22:23 <wendar> so not stgraber
19:22:33 <wendar> highvoltage? or I'm happy to do one
19:22:43 <ajmitch> up to the 3 of us I think
19:22:55 <stgraber> yeah, I'll be in Europe and I took the post-release Friday off, so definitely not arund :)
19:23:10 <wendar> ajmitch: we shouldn't make you do two in a row
19:23:20 <ajmitch> stgraber: have a drink for us then ;)
19:23:39 <wendar> put me in
19:23:47 <ajmitch> ok, thank you
19:23:58 <ajmitch> with that, I think we're done
19:24:13 <ajmitch> thanks everyone :)
19:24:18 <stgraber> thanks!
19:24:25 <ajmitch> #endmeeting