18:00:47 <AlanBell> #startmeeting ircc meeting
18:00:47 <meetingology> Meeting started Sun Mar 25 18:00:47 2012 UTC.  The chair is AlanBell. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
18:00:47 <meetingology> 
18:00:47 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
18:01:09 <AlanBell> agenda is over here https://wiki.ubuntu.com/IRC/IrcCouncil/MeetingAgenda
18:01:54 <AlanBell> so who is here for the meeting o/
18:02:13 <topyli> o/
18:02:23 <funkyHat> รด//
18:02:28 <bioterror> \o
18:02:33 <Pici> cogito, ergo sum.
18:02:40 <topyli> heh
18:03:01 <AlanBell> #topic Review last meetings action items
18:03:08 <AlanBell> #progress Pici to send mail to the list about the guidelines document to encourage edits and fixes to the FIXMEs
18:03:15 <MrChrisDruif> o/
18:03:48 <Pici> I put together an email about the wrong thing. Sooo.. I didn't send that, but should have this email out either today or tomorrow.
18:03:55 <AlanBell> ok, that would be great
18:04:03 <topyli> good
18:04:10 <AlanBell> I did a bit of tinkering with the guidelines etherpad
18:04:26 <AlanBell> I think it is nearly ready to go
18:04:33 <Pici> great
18:05:04 <topyli> AlanBell: so you left few FIXMEs to fix? :)
18:05:27 <AlanBell> I removed a few of them
18:05:46 <AlanBell> I think there are a couple left
18:06:04 <topyli> ok, good progress
18:06:23 <AlanBell> lets have another go at finishing that off this week and get it published at the next meeting if possible
18:06:48 <topyli> yes, would be nice to close this bug
18:06:48 <AlanBell> another pici action now
18:06:51 <AlanBell> #progress Pici to work on the list of expired members
18:06:57 <AlanBell> get anywhere with that?
18:07:36 <Pici> Not really. I'll take care of it though.
18:07:38 <Pici> .30
18:08:01 <AlanBell> ok
18:08:08 <AlanBell> #progress oCean to edit the guide to add advice on support questions in -offtopic
18:08:26 <AlanBell> hmm, which guide was that supposed to be?
18:09:09 <AlanBell> that was relating to the supporters guide
18:09:17 <Pici> Was it?
18:09:28 <Pici> I think we asked this same question about this item last time too...
18:09:44 <AlanBell> https://wiki.ubuntu.com/IRC/SupportersGuide
18:09:53 <AlanBell> at the very bottom
18:09:56 <AlanBell> so this item is done
18:10:04 <topyli> great
18:10:34 <AlanBell> ok, that concludes the actions from the last meeting
18:10:40 <AlanBell> #topic Open items in the IRCC tracker
18:10:46 <AlanBell> we have no open items \o/
18:10:49 <topyli> more than that, it's done well
18:10:56 <topyli> woo!
18:11:00 <MrChrisDruif> Hurray
18:11:16 <AlanBell> #topic Review Bugs related to the Ubuntu IRC Council
18:11:23 <AlanBell> no new bugs
18:11:29 <AlanBell> #subtopic bug 788503 IRC Guidelines too #ubuntu centric - tsimpson
18:11:31 <ubottu> Launchpad bug 788503 in ubuntu-community "IRC Guidelines too #ubuntu centric" [Undecided,In progress] https://launchpad.net/bugs/788503
18:11:46 <AlanBell> this is in progress and we want to sort it out for the next meeting
18:11:53 <Pici> indeed.
18:12:05 <AlanBell> #subtopic bug 884671 Ubuntu IRC operator recruitment is slow and ungainly - jussi
18:12:07 <ubottu> Launchpad bug 884671 in ubuntu-community "Ubuntu IRC operator recruitment is slow and ungainly" [Undecided,In progress] https://launchpad.net/bugs/884671
18:12:34 <topyli> i'm not convinced that jussi has had the chance to really look into this
18:12:52 <topyli> he recently gained a real life :)
18:12:55 <ikonia> it's odd that this has been raised since jussi was one of the main people who pushed the existing process
18:13:03 <Pici> heh
18:13:15 <AlanBell> yeah, but thats fine, I just put the person who raised the bug in the agenda
18:13:17 <Tm_T> ikonia: that only means he cares of the process
18:13:24 <topyli> ikonia: it's good to have him lead fixing it then. he agrees with the premise
18:13:39 <ikonia> what's actually looking at being changed though ?
18:13:49 <AlanBell> we have had a few people apply for ops in #ubuntustudio, great to see that project reanimated
18:13:54 <Pici> Nothing wrong with taking another look at the process as a whole.
18:14:07 <ikonia> more so as ubuntustudio is understaffed
18:14:26 <AlanBell> ikonia: well for one, we are doing applications from existing ops as they happen, and we did process all the applications in all the queues from existing ops
18:14:28 <topyli> ikonia: we want to be able to appoint ops without the process, when we know the people to be good
18:14:45 <ikonia> topyli: wasn't that how it was before the existing process was put in place ?
18:15:02 <ikonia> AlanBell: yeah, it was nice to see that
18:15:04 <AlanBell> the other thing we are doing is batching recruitment a bit and doing the induction thing a bit differently
18:15:05 <topyli> the current process makes it easier for us to evaluate people whom we don't know
18:15:48 <ikonia> AlanBell: the post-acceptence stuff is really good, I'm looking at the application and post acceptence as two seperate things
18:17:23 <Pici> We should really reach out to our new ops as we get them and ask them if they think the process could have been done better.
18:17:54 <MrChrisDruif> So like asking me? ;-)
18:18:10 <topyli> ikonia: i think the current thinking is that we should have both ways at our disposal. the current process for people we don't know, and the "just do it" approach to people that we do know
18:18:26 <topyli> Pici: yeah, what did they find difficult or annoying, and what was useful
18:18:35 <ikonia> seems sensible
18:18:47 <Pici> Aye.
18:18:53 <AlanBell> well I think at the time of the precise launch we want to kick off another intake of ops across a wider selection of channels
18:18:59 <ikonia> the current new guys may not be the best measure as lots of it was being setup as they where being brought on board
18:19:22 <MrChrisDruif> The current process is that a op first gets approved, then after two months evaluated for continuation?
18:19:53 <topyli> three months iirc, but yeah
18:20:05 <AlanBell> three months, but yes, that is part of it, but this is more about how we find ops and when we process the applications etc
18:20:10 <pangolin> only two months? I've been an op for a year or so now and still being evaluated
18:20:11 <AlanBell> anyhow, lets move along
18:20:27 <AlanBell> #subtopic bug 892500 eir is still not fit for purpose in #ubuntu -ikonia
18:20:29 <ubottu> Launchpad bug 892500 in ubuntu-community "eir is still not fit for purpose in #ubuntu" [Undecided,In progress] https://launchpad.net/bugs/892500
18:20:30 <topyli> pangolin: everybody's being evaluated anyway :)
18:20:35 <pangolin> topyli, :)
18:20:51 <MrChrisDruif> Alright, clear
18:20:52 <AlanBell> would like to see a bit more on the eir like functionality from other bots
18:21:08 <AlanBell> there has been a bit of a trial of ubottu-fr
18:21:17 <AlanBell> how has that been going?
18:21:24 <topyli> how much did moving the eir nagging out of -ops-team help?
18:21:37 <ikonia> the ubottu-fr stuff seems good
18:21:58 <pangolin> topyli, there is less nagging in -ops-team, that is the only difference I have seen
18:22:07 <funkyHat> It means -ops-team is usable, not sure how it's affected the banlist in #u though ;)
18:22:08 <Pici> I for one am very glad that -ops-team can actually be used instead of it being nearly flooded by eir.
18:22:35 <ikonia> eir as a tool does not effect the ban list
18:22:36 <ikonia> it adds value auto-removing the floodbots
18:22:40 <Pici> Also, I don't think that ubotu-fr is in #ubuntu anymore, or at least its not doing any reporting in -monitor.
18:22:43 <ikonia> they where the main cause of the ban list filling up
18:22:52 <ikonia> Pici: it's been pm'ing
18:22:57 <Pici> Ah.
18:23:08 <Myrtti> Pici: it's been pm'ing, and it's also muted in #ubuntu, by me
18:23:25 <Myrtti> as a Ubuntu copy it was responding to factoid requests
18:23:26 <Pici> I haven't been able to do alot of opping in #ubuntu lately (work = busy)
18:23:35 <ikonia> the overall functionality of it has been good though
18:23:37 <ikonia> been a little confusing as I keep forgetting which bot we are meant to be using
18:23:54 <ikonia> in my view pushing forward with ubottu-fr is worth while as out of the box it beat eir for usability
18:24:00 <AlanBell> so what does ubottu-fr do exactly?
18:24:18 <ikonia> pretty much the base functionality of eir
18:24:18 <pangolin> it does everything eir does + ubottu
18:24:42 <ikonia> you get banned it asks you to set a comment on it, updates BT with a relevent comment in the right ban id etc etc
18:24:55 <ikonia> if it can auto remove floodbot bans I think it will be pretty much perfect
18:25:16 <ikonia> the main thing for me is the auto removal of floodbot bans, keep the ban list ok, then functionality that feeds into BT,
18:25:35 <ikonia> it seems a solid base to move forward from
18:25:39 <topyli> fresh comments on the bug would be useful, so we can get some tangible indication of progress
18:26:03 <ikonia> I'll put some feedback in on it,
18:26:06 <AlanBell> so it updates the ubottu bantracker?
18:26:10 <ikonia> AlanBell: correct
18:26:15 <AlanBell> yay
18:26:17 <topyli> ikonia: thanks
18:26:28 <AlanBell> yeah, feedback on the bug would be perfect
18:26:35 <ikonia> AlanBell: so when you query a ban, it reads from the same ban id
18:26:37 <ikonia> all in sync etc.
18:26:42 <ikonia> it's not %100 spot on, but it's a solid base for me
18:26:56 <ikonia> the sooner we can use that and dump eir, then move on with ubottu as a base, the better it will be in my view
18:27:05 <oCean> these bugs are filed against eir, but probably still exist when using ubottu-fr
18:27:06 <AlanBell> if people could put their thoughts there, or on the mailing list or elsewhere that would be great, then we can talk about the next steps at the next meeting
18:27:08 <ikonia> at the moment we are using a ton of bots so it's hard to get real usage
18:27:11 <oCean> err these bugs: https://bugs.launchpad.net/ubuntu-bots?field.searchtext=[eir
18:27:53 <ikonia> oCean: some of them are resolved in ubottu-fr
18:27:53 <Pici> agreed having only 1 tool is better
18:28:05 <topyli> absolutely
18:28:07 <ikonia> I think we've been in ubottu/ubottu-fr/eir limbo for a while
18:28:21 <ikonia> be nice to start pushing ubottu/ubottu-fr merge and start using it and fix bugs going forward
18:28:25 <AlanBell> yup
18:28:52 <pangolin> can't we just run our own instance of ubotu-fr?
18:28:55 <Pici> how doed ubotu-fr handle floodbot bans?
18:29:11 <ikonia> Pici: from what I've seen - nothing yet but nico was saying it can do it
18:29:19 <ikonia> Pici: I don't think it's doing it as it would cause a fight with eir
18:29:35 <ikonia> Pici: (not certain on that)
18:29:37 <ikonia> that's why I'm saying dump eir, get ubottu merged and running, then fix going forward
18:30:18 <AlanBell> pangolin: sure, but we had to try it out for a bit first
18:30:20 <Pici> are we going to have to do manual removals in batches like we did previously?
18:30:35 <ikonia> Pici: I'd check the functionality with nico
18:30:48 <pangolin> AlanBell, I don't know that anyone has actually used it for actual ban handling
18:31:07 <pangolin> it is there but has anyone set comments with u-fr?
18:31:12 <Pici> i'll check with him and look at the code myself
18:31:14 <AlanBell> #action people to provide feedback on the ubottu-fr trial on bug 892500
18:31:14 * meetingology people to provide feedback on the ubottu-fr trial on bug 892500
18:31:16 <ubottu> Launchpad bug 892500 in ubuntu-community "eir is still not fit for purpose in #ubuntu" [Undecided,In progress] https://launchpad.net/bugs/892500
18:31:38 <topyli> heh
18:32:18 <AlanBell> #subtopic bug 913541 there are a number of people with Ubuntu IRC cloaks who have expired from the ubuntumembers group - AlanBell
18:32:20 <ubottu> Launchpad bug 913541 in ubuntu-community "there are a number of people with Ubuntu IRC cloaks who have expired from the ubuntumembers group" [Undecided,In progress] https://launchpad.net/bugs/913541
18:32:37 <AlanBell> oh, we talked about this one already
18:32:43 <AlanBell> #subtopic bug 916247 devel wiki on ubottu.com needs some attention - AlanBell
18:32:45 <ubottu> Launchpad bug 916247 in ubuntu-community "devel wiki on ubottu.com needs some attention" [Undecided,In progress] https://launchpad.net/bugs/916247
18:33:07 <AlanBell> it did get fixed, we were just keeping this bug around for a bit in case anyone felt like migrating the content to wiki.ubuntu.com
18:33:27 <AlanBell> I tried a bit, but it does require quite a lot of manual reformatting to moin syntax
18:34:00 <AlanBell> #topic Set all operators to renew at same time via LP so people can plan to deal with the renewals nicely
18:34:29 <AlanBell> I did some tinkering with lplib to find out when people do expire, I will did that out in a sec
18:34:42 <AlanBell> anyone think this is a startlingly good idea?
18:35:11 <Pici> I think it'll fill up my inbox fast ;)
18:35:21 <pangolin> who clicks on the renew link for this?
18:35:29 <funkyHat> It would mean I could more easily mass-archive all of the renewal emails I get
18:35:43 <topyli> less regularly too
18:35:51 <Pici> But seriously, it would be nice to deal with everthing at once
18:36:03 <topyli> well, more regularly but less often
18:37:11 <topyli> there will be cases where people have just renewed and will have to do it again
18:38:04 <funkyHat> Unless we set everyone's renewals a year from now
18:38:34 <AlanBell> well we could set them all to two years from now
18:38:53 <AlanBell> or set them to all expire one week into the term of the next IRCC if we were feeling evil
18:39:07 <Pici> tsk tsk
18:39:07 <funkyHat> haha
18:39:12 <topyli> hehe
18:39:45 <AlanBell> I know one IT manager who set all the certificates in the business to expire one week after his 65th birthday
18:40:10 <funkyHat> hahaha
18:40:17 <topyli> nice farewell :)
18:40:57 <AlanBell> anyhow, back to the topic, is harmonising renewal dates a good idea?
18:41:11 <ikonia> I see benifit, I see pain
18:41:19 <funkyHat> I'm not especially concerned either way
18:41:29 <Pici> me either
18:41:38 <AlanBell> personally I can't see a net reduction in pain
18:41:39 <topyli> it is a good idea. the problem is how we do it in practice. give it a year for everybody sounds good
18:42:03 <Pici> i think we'll have issues qhen setting it for new ops
18:42:05 <AlanBell> in practice someone sits down with lplib and a python script for an hour or two then presses a button
18:43:54 <topyli> meh, i'm failing to have a clear opinion
18:44:51 <Pici> perhaps staggering the potential loss of ops would be better....
18:45:01 <AlanBell> https://docs.google.com/spreadsheet/ccc?key=0Ankl5FhsdSiZdEtaNkRRM0xIdWtrTnBKalhZUkdxLXc
18:46:52 <Pici> I dont really see an overwhelming need to change it right now.
18:46:58 <AlanBell> that is it, now sorted by expiry date
18:48:16 <AlanBell> yeah, right now I don't really see the problem that it solves
18:48:39 <topyli> maybe we should shelf this. nobody seems to be able to come up with a problem we would solve... yeah
18:48:43 <AlanBell> I guess we could give everyone a longer countdown, right now people have one week to press the button
18:48:55 <AlanBell> and if they don't then they miss it, and we can sort it out
18:48:55 <Myrtti> "here remember to set an alarm on your calendar"
18:49:19 <AlanBell> given that I just made a spreadsheet with all the dates on we could do that bit anyway
18:50:04 <pangolin> already spent more time on this than the bots issue
18:50:13 <Pici> heh
18:50:18 <AlanBell> ok, I think we should close this agenda item for the moment, it isn't remotely urgent and it is of questionable value
18:50:23 <pangolin> I'm sure this is important but how important?
18:50:27 <SilverLion> o/
18:50:30 <Pici> Sounds good
18:50:34 <AlanBell> #topic Any Other Business
18:50:47 <AlanBell> does anyone have anything else they would like to raise?
18:51:10 * Pici thinks
18:51:11 <topyli> salaries don't count
18:51:14 <AlanBell> we should do some membership applications at some point, not done any of those yet
18:51:21 * AlanBell doubles topyli's salary
18:51:31 <topyli> still 0 :(
18:51:45 * pangolin thinks
18:51:57 <Pici> do we have any apps ine the queue?
18:52:02 <AlanBell> nope
18:52:11 <topyli> we're still not advertising irc membership enough
18:52:11 <Myrtti> do we have a schedule for harmonizing the channel access lists?
18:52:49 <Pici> Comparing with LP, or?
18:52:56 <AlanBell> Myrtti: good question, I was going to try and do that in April sometime, I was pondering a semi-automatic way of doing so
18:52:58 <pangolin> s/harmonizing/cleaning up/
18:53:16 <Myrtti> Pici: and other means of communication
18:53:35 <ikonia> question, is it worth revisiting (next meeting) the possability of merging some of the offtopic channels ?
18:53:45 <ikonia> or is it a dead waste ?
18:54:21 <AlanBell> yeah, we could talk about that
18:54:27 <Pici> I think it would be a good discussion
18:54:32 <pangolin> ikonia, I think it is a non-issue really. people want to relax in k-ot or whatever I don't see a reason to force them all into one channel.
18:54:36 <topyli> theoretically, i'd like a single offtopic channel. but i'm not sure what the other 'flavors' would think
18:54:37 <ikonia> if so I'll do an agenda item and put some points to/against it
18:54:44 <AlanBell> ok
18:54:50 <topyli> ikonia: good, thanks
18:54:51 <ikonia> if people think it's worth while
18:54:51 <Pici> a diacuasion fir another meeting.....
18:55:23 <AlanBell> ok, all done?
18:55:24 <Pici> topyli, me as well
18:55:26 <Pici> yep
18:55:35 <ikonia> I'll raise it then
18:55:44 <AlanBell> #endmeeting