18:03:05 <AlanBell> #startmeeting
18:03:05 <meetingology> Meeting started Sun Feb 26 18:03:05 2012 UTC. The chair is AlanBell. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
18:03:05 <meetingology>
18:03:05 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
18:03:16 <AlanBell> hi all, who is here for the IRCC/IRC team meeting?
18:03:21 <Silverlion> o/
18:03:21 <Pici> Howdy!
18:03:25 <h00k> hello
18:03:26 <LjL> hi
18:03:39 <Pici> Could someone paste the agenda? I don't have my email handy on this computer.
18:03:39 <funkyHat> ô/
18:03:55 <funkyHat> https://wiki.ubuntu.com/IRC/IrcCouncil/MeetingAgenda
18:03:59 <Pici> Thanks
18:04:04 <Myrtti> _o/
18:04:23 <oCean> hey
18:04:59 <AlanBell> ok, thanks for coming, lets get started then
18:05:06 <AlanBell> #topic Review last meetings action items
18:05:21 <AlanBell> hmm, sure there were some
18:05:39 <bazhang> hi
18:05:46 <AlanBell> there were
18:06:01 <AlanBell> #progress AlanBell to sort out fridge calendar entries
18:06:14 <AlanBell> not done yet, will sort it before the next meeting
18:06:29 <AlanBell> #progress AlanBell to mail the list asking for help to add ban timeout removal to ubottu
18:06:49 <AlanBell> done, I mailed the list proposing a bots hack day for the global jam weekend
18:07:22 <AlanBell> #topic Open items in the IRCC tracker
18:07:58 <AlanBell> well we didn't raise an item in the tracker, but we are dealing with one issue where a user has made a complaint about a ban
18:08:15 <Silverlion> any details?
18:08:38 <AlanBell> it would have been a lot simpler if they had just gone to the -ops channel to get it resolved, it was quite routine
18:09:29 <h00k> Oh. was this the issue raised to me in a /query?
18:09:41 <AlanBell> no, don't think so h00k
18:10:06 <Pici> They went outside the resolution process so we've just been talking to the ops that dealt with the user first.
18:10:37 <AlanBell> ok, lets move on to bugs
18:10:39 <AlanBell> #topic Review Bugs related to the Ubuntu IRC Council
18:10:52 <AlanBell> #subtopic bug 788503 IRC Guidelines too #ubuntu centric - tsimpson
18:10:53 <ubottu> Launchpad bug 788503 in ubuntu-community "IRC Guidelines too #ubuntu centric" [Undecided,In progress] https://launchpad.net/bugs/788503
18:11:36 <AlanBell> this is the one with a new draft here: http://notes.kde.org/ubuntuguidelines
18:11:58 <AlanBell> they look pretty good to me, I think we need to wikify it and get it published
18:12:08 <Pici> I think its making good progress myself
18:12:17 * h00k concurs
18:12:26 <AlanBell> we might also review it a bit in light of the supporters guidelines that we were working on this week
18:12:59 <AlanBell> would be nice to have them as a pair of documents that focus on different audiences
18:13:19 <Pici> Agreed.
18:13:42 <LjL> i think maybe we should put some of the more important factoids in the guidelines in addition, to me it seems sometimes the guidelines mention things that aren't an issue often, while those that are are relegated to factoids...
18:13:50 <LjL> but that could easily turn into guideline-creep, so not sure
18:15:03 <Pici> LjL: Do you have an example?
18:15:04 <AlanBell> what would be a good next step on this, I want to do an #action item for it
18:15:56 <LjL> Pici: well, for instance see !etiquette - the fact that we (well, i) felt the need to consolidate a few "good behavior" factoids into one comes close to a set of guidelines
18:17:53 * Silverlion agrees with LjL
18:17:55 <LjL> Pici: maybe we should do it with method, i.e. grep and find which factoids are most often used, and if they're guideline-like factoids, include them
18:18:31 <ikonia> a common sense review of the factoids DB in general may be in order
18:18:33 <Pici> Sounds doable
18:18:34 <ikonia> it's not been done for a while
18:18:35 <ikonia> doing things like trying to link to official wiki pages etc
18:18:44 <AlanBell> http://ubottu.com/factoids.cgi?db=ubuntu&search=&order=popularity%20DESC&page=0 popular factoids
18:19:39 <h00k> oh look, how convenient
18:19:46 <AlanBell> anyhow, next steps? is it ready to go on the wiki?
18:20:08 <LjL> well it can't be ready, there are still some "FIXME's" in it
18:20:09 <AlanBell> that doesn't mean it can't be edited still, just gets edits at a slower pace and people can subscribe to updates
18:20:30 <Pici> I think we should send out the whole thing to the list to enourage edits.
18:20:56 <AlanBell> sounds good
18:20:56 <h00k> the whole thing wiki, or as-is in the...multi-user-editor that I can't remember the name of?
18:21:24 <AlanBell> #action Pici to send mail to the list about the guidelines document to encourage edits and fixes to the FIXMEs
18:21:24 * meetingology Pici to send mail to the list about the guidelines document to encourage edits and fixes to the FIXMEs
18:21:53 <LjL> maybe it should be put on the wiki provisionally and an email sent out, that way it's probably easier to track changes than with the current "editpad"?=
18:21:53 <AlanBell> #subtopic bug 884671 Ubuntu IRC operator recruitment is slow and ungainly - jussi
18:21:54 <ubottu> Launchpad bug 884671 in ubuntu-community "Ubuntu IRC operator recruitment is slow and ungainly" [Undecided,In progress] https://launchpad.net/bugs/884671
18:22:01 <Pici> h00k: whichever is more up-to-date. I'd prefer to keep things on the wiki though, I like seeing edits as the come in.
18:22:51 <AlanBell> yes, lets put it on the wiki then. Etherpad is good for fast uncontrolled edits and drafting things, the wiki is good for more controlled edits
18:23:02 <h00k> etherpad. that's it.
18:23:24 <AlanBell> ok, IRC recruitment, I did some scripty things to look at the queues
18:26:00 <AlanBell> bother, can't find the pastebin link I did, will have to run it again later
18:26:11 * Silverlion pays attention now as a recruit
18:26:20 <AlanBell> unless anyone can find it in -ops-team from last week
18:26:30 * h00k checks
18:26:44 <AlanBell> anyhow, I listed everyone in the queues, and highligted those who are existing operators
18:27:13 <AlanBell> most of the existing ops who are in a queue are lined up for #ubuntu-server
18:27:34 <AlanBell> I think we should just process all existing core ops applications for additional channels
18:27:35 <Pici> I thought we processed that queue already?
18:27:49 <funkyHat> http://paste.ubuntu.com/847836/
18:27:54 <h00k> AlanBell: http://paste.ubuntu.com/847836/
18:28:03 <h00k> d'aw. funkyHat wins.
18:28:13 * funkyHat does a dance
18:28:21 <AlanBell> thats the one I was looking for, thanks
18:28:27 <Myrtti> hold on, how do I read that
18:28:56 <h00k> My method not so efficient. cat, grep > alan, cat grep paste, review.
18:29:02 <AlanBell> so **** Team **** channel name marks a new channel, those under it are in the pending queue
18:29:09 <Pici> Myrtti: If theres a !! in front of your nick then you're already an op somewhere.
18:29:14 <AlanBell> !! marks someone already a member of an ops team somewhere
18:29:15 <ubottu> AlanBell: I am only a bot, please don't think I'm intelligent :)
18:29:30 <AlanBell> silly ubottu
18:29:47 <Myrtti> ah alright
18:30:02 <Pici> I don't have any issues approving people who are already an op somewhere.
18:30:15 <Pici> They're already vetted imo.
18:30:22 <Myrtti> got me worried there for a few minutes, there's some nicks on those lists that I'd be worried about
18:30:34 <Myrtti> nice way to raise my heartrate :-P
18:31:13 <AlanBell> Myrtti: yeah, I am just proposing we do the !! ones without further delay
18:32:00 <AlanBell> the rest I think we should do in batches to line up with training
18:32:04 <Pici> Shall we vote on it?
18:32:11 <AlanBell> yeah, lets
18:32:20 <AlanBell> #voters AlanBell Pici funkyHat
18:32:20 <meetingology> Current voters: AlanBell Pici funkyHat
18:33:09 <funkyHat> +1
18:33:11 <AlanBell> #vote channel op applications from existing operators should be processed as and when they are received and the existing applications should be processed without further delay
18:33:11 <meetingology> Please vote on: channel op applications from existing operators should be processed as and when they are received and the existing applications should be processed without further delay
18:33:11 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
18:33:18 <AlanBell> +1
18:33:18 <meetingology> +1 received from AlanBell
18:33:19 <funkyHat> Oops
18:33:20 <funkyHat> +1
18:33:20 <meetingology> +1 received from funkyHat
18:33:23 <Pici> +1
18:33:23 <meetingology> +1 received from Pici
18:33:24 <AlanBell> you are just too fast today funkyHat
18:33:28 <AlanBell> #endvote
18:33:28 <meetingology> Voting ended on: channel op applications from existing operators should be processed as and when they are received and the existing applications should be processed without further delay
18:33:28 <meetingology> Votes for:3 Votes against:0 Abstentions:0
18:33:28 <meetingology> Motion carried
18:33:34 <funkyHat> hehe
18:33:40 <h00k> that was a close one.
18:33:51 <AlanBell> :)
18:33:52 <Pici> :P
18:34:03 <AlanBell> #subtopic bug 892500 eir is still not fit for purpose in #ubuntu -ikonia
18:34:04 <ubottu> Launchpad bug 892500 in ubuntu-community "eir is still not fit for purpose in #ubuntu" [Undecided,In progress] https://launchpad.net/bugs/892500
18:34:19 * Myrtti rubs her hands
18:34:23 <AlanBell> yeah, we will be addressing that on the bot-jam day
18:34:33 <AlanBell> #subtopic bug 913541 there are a number of people with Ubuntu IRC cloaks who have expired from the ubuntumembers group - AlanBell
18:34:34 <Pici> mmm... robot jam
18:34:34 <ubottu> Launchpad bug 913541 in ubuntu-community "there are a number of people with Ubuntu IRC cloaks who have expired from the ubuntumembers group" [Undecided,In progress] https://launchpad.net/bugs/913541
18:34:44 <AlanBell> I have not done any more on this
18:34:59 <Pici> I think some launchpad scripting could show us this quickly.
18:35:04 <AlanBell> Pici: funkyHat: got some time to work on this?
18:35:11 <Pici> Actually, I think someone might already have a script.
18:35:14 <AlanBell> Pici: yes, we have the list
18:35:15 <Pici> AlanBell: I'll take it.
18:35:36 <AlanBell> #action Pici to work on the list of expired members
18:35:36 * meetingology Pici to work on the list of expired members
18:35:41 <Pici> We just need someone to go throug it with a staffer?
18:35:50 <LjL> Pici: too late, you've got it now
18:35:56 <funkyHat> :D
18:36:00 <Pici> s/someone/me/
18:36:14 <AlanBell> yeah, I did a few, you have to try to contact them, then get an unaffiliated cloak, or do a membership renewal as appropriate
18:36:57 <AlanBell> #subtopic bug 916247 devel wiki on ubottu.com needs some attention - AlanBell
18:36:58 <ubottu> Launchpad bug 916247 in ubuntu-community "devel wiki on ubottu.com needs some attention" [Undecided,In progress] https://launchpad.net/bugs/916247
18:37:35 <AlanBell> this was despammed and locked down, we were going to transfer some of the content and close the wiki, just keeping the bug open whilst that happens, but it isn't a high priority
18:37:42 <AlanBell> ok, that is the end of the bugs
18:38:07 <AlanBell> #topic Why would we allow recommending PPA's in a support channel? Background - oCean
18:38:16 <AlanBell> ok, oCean, you have the floor
18:38:22 <oCean> Right, I already started at https://wiki.ubuntu.com/IRC/IrcCouncil/IRCteamproposal
18:39:26 <oCean> In addition: I would prefer we would stop recommending PPA's altogether, instead of saying "recommend software sources in a logical order" as seen in the recent Supporters Guide
18:39:51 <AlanBell> I like the idea of a ratings system for PPAs
18:39:56 <oCean> Or we would still have these ambivalent situation where factoids and guides claim PPA's are not officially supported, but one can still go ahead, use any PPA, wreck their system, and use good time from helpers in the channels to get the PPA issues sorted
18:39:57 <Pici> Me too
18:40:33 <LjL> I really don't think we should put a blanket ban on PPAs. They are an important part of the ecosystem, and additionally, just like it's always been ok to suggest, say, compiling something from source - BUT ONLY AFTER pointing out its availability in repositories, if any, and ONLY WHILE giving appropriate disclaimers - I think it should be ok to suggest a PPA. It's bad to just "randomly recommend" a PPA, but that's another story. I don't think we should
18:40:34 <LjL> be conflating the two.
18:40:35 <tsimpson> some PPAs are supported, and #kubuntu will definitely still recommend some PPAs
18:40:42 <popey> I find it disappointing that PPAs are rejected en-masse and words like "wrecked" are being used about them
18:40:47 <Pici> LjL: +1
18:41:01 <oCean> popey: are you in #ubuntu a lot?
18:41:02 <popey> LjL: +1
18:41:02 <funkyHat> +1
18:41:13 <Silverlion> afk for short
18:41:24 <popey> oCean: what bearing does that have on the question?
18:41:47 <oCean> popey: then you would notice that a large number of PPA's do wreck people's systems
18:41:57 <oCean> it's not something I just came up with
18:42:19 <Pici> Lets not make the mistake of saying that "since there are some bad PPAs that all PPAs are bad"
18:42:27 <popey> there are many PPAs that are not problematic
18:42:35 <oCean> Pici, there are >10,000 active PPA's
18:42:36 <h00k> It's true, PPAs can be very bad(tm), but there are some good PPAs that aren't problematic
18:42:45 <popey> many PPAs which are in fact maintained by the upstream developers, like unity for example
18:42:58 <bazhang> including the link to the PPA for gnome3 with the fact that a reinstall is the only way to fix was not a good idea
18:43:23 <Myrtti> I very rarely use PPA's and it is impossible for me to know which PPA's are problematic and which are not. Even if upstream developers maintain them, they may not be well versed with packaging for Ubuntu...
18:43:50 <popey> alan@deep-thought:/etc/apt/sources.list.d$ ls -l *.list | wc -l
18:43:51 <Myrtti> I just really, really hope that the rating system suggested by popeys bug is implemented soon
18:43:51 <LjL> oCean, it's always possible for a helper to refuse helping someone if they feel they're wasting their time while doing that. I rather think we've been too strict with the "not supported" lately; even if a user "wrecked" their system by doing something unsupported, does that really entitle us to actively stop people from helping with that?
18:43:51 <popey> 17
18:43:59 <popey> some of us use PPAs a lot and they dont break at all
18:44:24 <Pici> popey: Those present are hardly a representative group of Ubuntu users.
18:44:27 <Myrtti> popey: you know yourself WFM isn't a valid answer...
18:44:41 <popey> i was merely pointing out a counter position
18:44:50 <popey> based on some evidence of a long time ubuntu user
18:44:53 <oCean> LjL: I know, sure I want to help them too, but I'd rather have them not install the PPA's at all
18:45:09 <oCean> Please realize that PPA's are suggested _all the time_
18:45:20 <bazhang> hourly
18:45:28 <oCean> little under 1000 mentions of PPA's in the last 3 months for #u alone
18:45:36 <bazhang> and webupd8 is the top o the list
18:45:38 <oCean> that's without ubottu's explaining what ppa is
18:45:47 <h00k> oh, that place :(
18:45:47 <Pici> I think we need to remind folks that PPAs don't receive the same amount of testing that packages in the repositories do.
18:45:54 <LjL> oCean: the root of the problem is that the official repositories contain 30000 packages. That's a lot, but it's hardly enough for a lot of users. Some users simply need/want packages that aren't there. Are we going to instantly mark a system as "not supported" as soon as something not from the official repositories is installed? Isn't that a very "app store" mentality?
18:46:12 <LjL> Pici: we need to do that, and we need to point it out to helpers who neglect to mention that.
18:46:24 <LjL> Pici: but that's a long shot from *banning* them.
18:46:30 <LjL> (the PPAs, not the users)
18:46:36 <Pici> LjL: Agreed. A blanket ban on PPAs isn't going to a) work, or b) be followed
18:46:37 <bazhang> PPA have effectively turned Ubuntu into a rolling release distro
18:46:55 <oCean> LjL: I realize that, and of course I use PPA's myself. But there is a difference, because I know how to use them, judge them etc
18:47:06 <AlanBell> lets review a few factoids
18:47:08 <AlanBell> !ppa
18:47:09 <ubottu> A Personal Package Archive (PPA) can provide alternate software not normally available in the offical Ubuntu repositories - Looking for a PPA? See https://launchpad.net/ubuntu/+ppas - WARNING: PPAs are unsupported third-party packages, and you use them at your own risk. See also !addppa
18:47:14 <AlanBell> !ppa-purge
18:47:14 <ubottu> To disable a PPA from your sources and revert your packages back to default Ubuntu packages, install ppa-purge and use the command: « sudo ppa-purge ppa:<repository-name>/<subdirectory> » – For more information, see http://www.webupd8.org/2009/12/remove-ppa-repositories-via-command.html
18:47:27 <h00k> for reference,
18:47:29 <popey> oCean: so teach people who to use them and judge them, rather than use them yourself and reject the use for others
18:47:35 <popey> thats a very elitest attitude to have
18:47:36 <h00k> oh, never mind, AlanBell beat me.
18:48:01 <Pici> I heartily agree with popey and LjL here.
18:48:26 <Myrtti> I just wish 11.04 would go EOL quicker
18:48:34 <h00k> ^ this
18:48:41 <bazhang> no!
18:48:47 <AlanBell> why 11.04?
18:48:57 <oCean> Pici: that would still leave us with the ambivalence of saying "is not supported", but you can do what you like and ask for help again
18:48:58 <funkyHat> Buggy unity?
18:49:04 <h00k> Unity there is :(
18:49:30 <Myrtti> because either people install it to use Gnome2, or then they use a PPA to install Gnome3 on it, and it breaks.
18:49:41 <LjL> oCean: well, there are various levels of "not supported", and just making it black and white is simply impossible
18:49:52 <LjL> oCean: Backports is an official thing, yet it's less supported than the main repos, for instance.
18:49:57 <Myrtti> either way it's the fall-between-cracks version that is infinite source of pain
18:50:09 <Pici> oCean: And? For the majority of people who use PPAs, the PPA that they've used isn't the issue that they've come to #ubuntu to have solved.
18:50:13 <oCean> LjL: ok, I understand not everything is black and white, so we have to be more explicit in what the levels of support mean
18:50:15 <AlanBell> well this is what I mean about pointing to upgrades in a sensible order, if you are running 11.04 then upgrading through the release numbers is better than a mass of hybrid backports from PPAs
18:50:18 <bazhang> PPA are an important issue, and agreeing to help fix issues with / related to them
18:51:18 <bazhang> get it on webupd8, and it's part of the Ubuntu rolling release
18:51:38 <Myrtti> I don't have problems helping people who have PPA's. But if problems are caused by PPA stuff or there's explicit problem with stuff from PPA, then it gets hairy
18:52:06 <bazhang> so what if Mintmenu is part of the PPA
18:52:11 <popey> From a personal perspective some of the work my team does at Canonical is put into PPAs. I'd be kinda annoyed if #ubuntu refuses to allow users to discover that work, by banning the primary method my team has to deliver it.
18:52:14 <LjL> oCean: you have to rely on people's common sense a little. People can and will start recommending to do thing the "reasonable" way if we actively point out the issues when we encounter them in the channel. Ops are not just there to ban people, they're also there to give the channel a direction, and that not only by means of guidelines and meetings, but also by means of what they say in the channel day-to-day.
18:52:26 <tsimpson> PPAs are not the only thing that cause those problems, any non-Canonical repository could. should be ban anything that isn't 100% official (as defined by Canonical)?
18:52:44 <tsimpson> I don't see a solution, other than simply educating users
18:53:32 <Pici> Educating our helpers will go a long way in getting people to understand the risks of PPAs and benefits of PPAs.
18:53:34 <tsimpson> maybe someone messes things up, and they need to reinstall. we help them backup their data and get a working system again. they gain experience
18:53:39 <bazhang> relying on common sense when some users will not even read the channel topic
18:54:09 <oCean> bazhang: +1
18:54:17 <LjL> bazhang, oCean: if users are all idiots, then we might as well give up.
18:54:29 <LjL> I thought the idea why we're still here is that we think they aren't.
18:54:41 <oCean> LjL: no, but we might try our best to limit them in the possiblities to ruin their systems
18:54:41 <AlanBell> I kind of favour providing more information for people to make decisions about what they do with their systems
18:54:49 <bazhang> I have no problem with Ubuntu being a rolling release distro, buts let be honest, thats what the floodgate of PPA is doing
18:54:50 <oCean> That's why the rmrf command is an alias, right?
18:55:14 <Pici> Again, its not the users we need to convince, its our helpers. The people who are there every day are the best people to educate about this sort of thing. They'll do all the legwork when it comes to telling the users who can't manage to read our channel topic.
18:55:18 <popey> i disagree with bazhangs assertion
18:55:38 <bazhang> that did not highlight me
18:55:38 <oCean> Pici: yes, but there are many "drive-by" helpers
18:55:42 <popey> there's a chasm between ubuntu plus a bunch of PPAs, and a rolling distro
18:55:43 <LjL> oCean: but that command being an alias doesn't really stop them from doing on their systems what they need. Likewise, "sudo" instead of root doesn't, because they can do everything with "sudo". They simply CAN'T do everything by ONLY using the official repositories.
18:55:59 <tsimpson> it's not our place to decide what "users" should and should not be able to do with their system. we can warn, inform, and educate. but we can't tie their hand and stop them from doing what they choose to do
18:56:09 <LjL> oCean: and there are many regular helpers and ops who will correct them.
18:56:21 <bazhang> there's a new kernel, I'm on Lucid, I want it
18:56:38 <AlanBell> ok, I wonder if we are going round in circles at this point, perhaps we should draw this topic to a close
18:56:48 <oCean> LjL: yes, sure. But would an explicit statement, more then just "not supported" be valuable?
18:56:49 <bazhang> et voila there is a PPA for it
18:57:08 <funkyHat> oCean: how is drive by helpers suggesting bad PPAs going to be stopped by banning suggesting PPAs?
18:57:12 <oCean> So, if we're not about to say "don't use PPA's" we definitely need to be more explicit with that
18:57:19 <Pici> bazhang: And I'm sure that we'll all tell you that you're probably going to have issues with it, but you're going to install it anyway.
18:57:24 <LjL> oCean: no, as it would completely destroy the possibility for experienced helpers to suggest reasonable PPAs when appropriate.
18:57:35 <oCean> funkyHat: because then we would have means to tell them "please don't suggest ppa's"
18:57:54 <bazhang> LjL, please explain where the reasonable PPA are
18:58:04 <phillw> there are some times when adding a PPA for a specific problem is warranted
18:58:12 <oCean> LjL: yes, that's true, that's what happens when one uses Ubuntu. Not everything is in the repositories
18:58:24 <LjL> oCean: you can still tell them "please don't suggest PPAs without first having informed them about the software availability in the repositories, and without giving the due disclaimers about PPAs not being part of Ubuntu"
18:58:27 <bazhang> they all look good to me. and some are very very tempting to install to be honest
18:58:35 <LjL> you could always do that, it's always been done, with all things, even before PPAs existed
18:58:51 <oCean> Root cause might be that the ubuntu distribution does not provide everything a users wishes. Too bad
18:58:51 <AlanBell> #vote set a new policy to ask helpers to not recommend PPAs in #ubuntu
18:58:51 <meetingology> Please vote on: set a new policy to ask helpers to not recommend PPAs in #ubuntu
18:58:51 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
18:58:54 <AlanBell> -1
18:58:54 <meetingology> -1 received from AlanBell
18:59:02 <funkyHat> -1
18:59:02 <meetingology> -1 received from funkyHat
18:59:13 <Pici> -1
18:59:13 <meetingology> -1 received from Pici
18:59:17 <AlanBell> #endvote
18:59:17 <meetingology> Voting ended on: set a new policy to ask helpers to not recommend PPAs in #ubuntu
18:59:17 <meetingology> Votes for:0 Votes against:3 Abstentions:0
18:59:17 <meetingology> Motion denied
18:59:33 <Pici> PPAs are more accountable than random source packages out there as well.
18:59:45 <AlanBell> ok, I think we should focus on providing more information about the types of PPA out there
18:59:51 <Myrtti> you could have just vetoed on Snowball
19:00:00 <bazhang> that would be great. how to rate them
19:00:11 <popey> Do we have any stats for which PPAs are "bad" from #u experience?
19:00:17 <oCean> All 11.000 of 'em :(
19:00:23 <bazhang> hehe
19:00:41 <bazhang> 10999 (handbrake is ok)
19:01:03 <AlanBell> #topic Support in -offtopic? Background - oCean
19:01:20 <oCean> Also on https://wiki.ubuntu.com/IRC/IrcCouncil/IRCteamproposal
19:01:40 <funkyHat> I seem to recall discussions about ppa ratings at least a year ago either on -devel@ or one of the launchpad lists... I wonder if there is progress
19:01:41 <oCean> This is an other matter we discussed in -ops or -team, but I don't think there was consensus
19:01:56 <AlanBell> yeah, and I have a mail from Mark that relates to this a little
19:02:31 <AlanBell> so yesterday we discussed a separate topic of canonical sending people to #ubuntu to discuss the android hybrid thing
19:02:51 <AlanBell> that is going to be addressed, but one of the things from sabdfl's response was . . .
19:03:01 <AlanBell> * if there is a better IRC channel for general "hello, I'm interested in X with Ubuntu, where should I go?", then let me know and I'll update the team to use that for the cases where they do judge the audience to be developer or at least highly technical in nature.
19:03:21 <AlanBell> is #ubuntu-offtopic that place?
19:03:28 <Pici> no.
19:03:39 <Pici> Or at least not in -offtopic's current state.
19:03:42 <bazhang> #ubuntu-phone ?
19:03:49 <AlanBell> I didn't think so either, is there a place for it?
19:03:50 <Myrtti> bazhang: not really
19:03:53 <Tm_T> bazhang: that's not general channel (:
19:04:02 <Tm_T> AlanBell: -irc?
19:04:06 <Myrtti> no
19:04:08 <Pici> no
19:04:22 <AlanBell> bazhang: it is plausibly a reasonable place for it in this specific instance, but Mark was asking in general terms
19:04:22 <Tm_T> shortly put, we currently don't have such place
19:04:41 <bazhang> AlanBell, ok
19:05:02 <Pici> I don't think we currently have a place, and if we want to, we need the participation of our developers to make it work.
19:05:10 <ikonia> sorry - but what is the point of sending people to a channel with no info ?
19:05:24 <Tm_T> ikonia: a very good point
19:05:26 <LjL> Pici: yes, sabdfl can't just expect us to come up with places to discuss things nobody knows about out of a hat
19:05:31 <ikonia> "hi I'm interested" - ok "sit there in this dead channel...."
19:05:44 <ikonia> why not ask people to subscibe to an announce mail list so they get news when there is news
19:05:46 <Myrtti> ikonia: zombie channel is more to the point
19:05:55 <Myrtti> or undead
19:06:07 <Pici> ikonia: People want to interact and ask questions.
19:06:27 <Myrtti> it's worse than dead, it's just users pingponging questions and rumours around, possibly making things worse than if there were no such discussion at all
19:06:31 <ikonia> but there is no answer
19:06:34 <ikonia> Hi, tell me more about this product"
19:06:36 <ikonia> There is nothing to tell
19:06:49 <ikonia> why can't we say "there is nothing to tell at this time, subscribe to the accounce mailing list"
19:06:56 <ikonia> why point people to a channel full of nothing
19:07:07 <Pici> Again, we would need the people in-the-know to be present before we could tell users to go there.
19:07:11 <AlanBell> well they are going to stop doing that
19:07:57 <Pici> Unless the tech board (or whatever) wants us to start funneling into -devel to ask questions, I don't see another way of fixing this.
19:07:58 <Tm_T> "if there is a better IRC channel for general "hello, I'm interested in X with Ubuntu, where should I go?", then let me know"
19:08:05 <Pici> and I dont want to point people to -devel
19:08:05 <AlanBell> in fact, this wasn't really a private email, you might as well see all of it
19:08:06 <Tm_T> that is question we can figure out an answer
19:08:15 <AlanBell> -devel don't know about it either
19:08:24 <AlanBell> http://paste.ubuntu.com/858209/
19:08:43 <ikonia> just feed back to canonical "IRC is useless without information, I suggest setting up a mailing list for people to subscrive to so you can make an annoucment when you have something to announce"
19:08:57 <AlanBell> ikonia: I did, basically
19:08:58 <Tm_T> so let's keep "discussion of nonexistant products" issue separate from general place-to-go channel issue
19:09:06 <LjL> I have to go now. I just wanted to say about #ubuntu-offtopic that I don't think we should have a "no support" policy because EVEN WITHOUT having such a policy yet, I've already seen people going to extremes by shutting discussions down as they were remotely support-like. #ubuntu-offtopic shouldn't discourage talking about Ubuntu. Instead, let the people there NICELY suggest "have you tried asking in #ubuntu?", let's enforce a stricter "no repeating"
19:09:08 <LjL> rule than in #ubuntu, and let's not allow banned people to obtain support in #ubuntu-offtopic.
19:09:31 <h00k> ^ I concur with this
19:09:34 <AlanBell> yeah, I agree with not supporting banned people, certainly
19:09:44 <Pici> Agreed.
19:09:51 <ikonia> AlanBell and the response i better than I understood when you mentioned it, so thank you
19:10:18 <Pici> I don't think I understand what you just said ikonia, but okay ;)
19:10:35 <AlanBell> I think #ubuntu-offtopic should be the place for discussion about ubuntu that isn't support, or we should have #ubuntu-discuss or #ubuntu-chat or something for that
19:10:40 <ikonia> Pici: it was in relation to the android email
19:10:58 <ikonia> AlanBell: I've aksed for this many times and it's just a non-starter
19:11:14 <AlanBell> why?
19:12:07 <Myrtti> I've grown to dislike -offtopic as a channel name
19:12:10 <ikonia> AlanBell: people want -offtopic to be random stuff
19:12:31 <ikonia> to do what ever you feel like saying inside the !o4o and !coc guidelines
19:13:01 <Tm_T> that's what "offtopic" means?
19:13:03 <ikonia> I wanted to bring the offtopic channels together and have a bit of community discussion around ubuntu as a project
19:13:13 <ikonia> technical/non-technical, just "stuff"
19:13:27 <Pici> As much as the channel sometimes annoys me, I think that -offtopic is fine and another Ubuntu-centric discussion channel would be better.
19:13:31 <Silverlion> folks: wouldn't it be better to have just ONE Offtopic chan?
19:13:31 <ikonia> rather than having 4 - 5 offtopic channels of people just saying words
19:13:40 <Silverlion> like the community cafe on the forums?
19:13:58 <Pici> Silverlion: IRC can't be separated into threads like forums can.
19:14:16 <Pici> Not without creating separate channels
19:14:20 <h00k> #ubuntu-ubuntu-discussion, #ubuntu-what-you-had-for-lunch, #ubuntu-break-from-support,
19:14:25 <h00k> :(
19:14:29 <funkyHat> People like their spaces, and having more than one offtopic channel doesn't seem to be hurting
19:14:32 <Tm_T> Silverlion: one?
19:14:32 <bazhang> h00k, heh
19:14:43 <Myrtti> or going to the other direction - #x-ot, #k-ot, #u-ot, #l-ot
19:14:53 <Myrtti> should there be ONE CHAN TO RULE THEM ALL?
19:14:55 <Myrtti> :-P
19:14:56 <tsimpson> the point of offtopic is that it's not one topic, it's the exception to the "an IRC channel has a specific topic" rule
19:15:03 <Silverlion> Tm_T: i wanted to "melt" the -offtopic chans together and name it "community cafe"
19:15:23 <Pici> tsimpson: good point.
19:15:31 <ikonia> funkyHat: it's also not building anything, there are people spread out in each channel that are "quality" yet there have little to say mixed in with people just saying radonom stuff
19:15:37 <ikonia> tsimpson: there should be tons of topics, fully agree
19:16:01 <AlanBell> ok, some interesting suggestions there, but I think we are not going to make any decisions on this today
19:16:05 <h00k> It's nice to have a place to talk about $stuff, and not $ubuntu-stuff all the time,
19:16:11 <Silverlion> that way we do have a better overview and can create some community feeling
19:16:26 <Pici> h00k: +10
19:16:52 <h00k> which is nice to take a break from #ubuntu in there, but also included are people who don't help
19:16:52 <Tm_T> Silverlion: not going to happen, it's been considered for years, and see where we are (:
19:16:53 <phillw> the -ot channels are already the cafe for each group?
19:16:56 <Pici> Silverlion: I've suggested that before, it didn't go over well. (although that was a lonjg time ago)
19:17:05 * popey returns to see #ubuntu-phone stuff
19:17:15 <pangolin> I don't see why -offtopic can't have multiple topics going on at the same time. Just like in #ubuntu where you don't answer every questions asked.
19:17:19 * popey would like to help fix the issues there. Suggestions welcome.
19:17:56 <AlanBell> popey: get the people who know what they are talking about to engage with the channel
19:18:43 <popey> well.
19:18:58 <AlanBell> yeah, I know that might not be possible
19:19:00 <popey> the problem there is that #ubuntu-phone was never supposed to be for the current announced convergence device
19:19:03 <tsimpson> we do have a (dead) #ubuntu-mobile going unused
19:19:18 <popey> it was meant for discussion of a phone running ubuntu
19:19:31 <AlanBell> yes, we do appreciate that
19:19:31 <popey> not the converged device that you've been talking about
19:19:45 <Silverlion> do we need to channels to discuss topics that should be discussed here?
19:19:47 <popey> so directing people there means they dont actually get to talk to the 'right people'
19:19:52 <AlanBell> popey: did you see the email that is going out to people who register an interest in the hybrid thing?
19:20:02 <popey> i only saw your pastebin above
19:20:03 <Myrtti> popey: but it was the best channel for example I could think out quickly when people started asking about "where can I discuss"
19:20:12 <popey> Myrtti: sure, i appreciate that
19:20:28 <h00k> so, before I forget, where are we with -offtopic?
19:20:38 <AlanBell> popey: http://paste.ubuntu.com/858223/
19:21:15 <popey> ok, and mark has said that will be fixed?
19:21:48 <AlanBell> popey: yes, I brought it up here because mark was asking about a general channel to send people to for discussions
19:21:53 <Pici> popey: Since you're more on the developer side of things for this, would you prefer users/power users/non-ubuntu developers dropping in on a team channel (like -devel, -kernel -x, whathaveyou) or a separate technically focussed discussion channel?
19:22:25 <Pici> Purely for asking questions about new ubuntu tech, not tech support.
19:22:42 <popey> well, i setup -phone, -tablet and -tv for exactly that kind of thing
19:23:15 <oCean> h00k: :) Yeah, I raised two points: 1) don't shut down support questions, just suggest a regular support chan might be more appropriate 2) don't support banned users in -ot
19:23:26 <popey> I'm happy for people to ping me in those channels if there are questions that have not been answered
19:23:45 <popey> and would like to help create a FAQ for each to help direct people to the 'right' answers
19:23:50 <popey> would that help?
19:23:55 <AlanBell> it would, yes
19:24:04 <Pici> popey: And if those channels already have developers who are willing to answer user questions present, then I think we just need to work out a way to publicize those channels.
19:24:12 <popey> they do
19:24:18 <h00k> also, operators there?
19:24:21 <popey> -tv has had lots of discussion with the guys who actually wrote it
19:24:51 <Pici> I think we sorted out some of the op stuff the other day.
19:25:26 <h00k> cool.
19:26:21 <AlanBell> ok, lets deal with the specific points oCean raised in this topic
19:26:36 <AlanBell> 1) don't shut down support questions, just suggest a regular support chan might be more appropriate
19:27:00 <oCean> just suggest *that*
19:27:26 <AlanBell> 2) don't support banned users in -ot (which is a sensible exception/enhancement to #1)
19:27:34 <bazhang> including crossposting?
19:27:54 <oCean> bazhang: crossposting should be avoided
19:28:12 <bazhang> I post in #ubuntu , wait 2 mins, then to -ot
19:28:40 <Pici> I think the only time where it is reasonable for support to be answered in -ot is when a user casually mentions some annoyance and someone has an idea to fix it.
19:29:27 <bazhang> there are often jokey answers when support is asked in -ot
19:29:37 <tsimpson> well "support" is such a wide subject that it's difficult to simply say "no support questions"
19:29:47 <AlanBell> I am struggling to figure out what change is being requested here, it seems like a request for a common sense approach
19:30:28 <Tm_T> AlanBell: that, there's currently no common sense applied consistently as far as I can see
19:30:47 <Tm_T> "no support" is slapped hardhandedly occasionally
19:30:50 <oCean> there is actually support in -ot, for example on subjects which are offtopic for #u, but as soon as someone asks an ubuntu question, we jump on him saying "don't ask support here"
19:31:25 <Tm_T> oCean: yeah, soft redirect is better approach when its reasonable in the first place
19:31:46 <oCean> I'll say after LjL "let the people there NICELY suggest "have you tried asking in #ubuntu?", let's enforce a stricter "no repeating"
19:31:58 <AlanBell> maybe this should be something added to the supporters guide, what to do if someone asks a question in the wrong channel
19:32:31 <ikonia> oCean but there also has to be common sense the other way
19:32:49 <ikonia> oCean: users like bullgard who just don't want to play by the rules use -offtopic as #ubuntu
19:33:16 <ikonia> I have no issue with support discussion in #ubuntu-offtopic, it would be a welcome uplift from random stuff
19:33:20 <phillw> whilst we are the new kids on the block, maybe some thing like Welcome to the general chat area | Please use #lubuntu for support | ?
19:33:34 <ikonia> but I think if we have a support channel, guiding users to it for support is the better option for proper "I need help" issues
19:33:35 <oCean> ikonia: true. We should be stricter, especially with such users
19:33:45 <AlanBell> oCean: perhaps you could add some bits to the guide advising helpers how to deal with support requests in offtopic channels
19:33:59 <ikonia> oCean: a better balance to actually help support discussion, while "questions" or specific issues can be guided to the support channel
19:34:01 <oCean> AlanBell: fine with me
19:34:05 <AlanBell> are there any factoids that might need changing?
19:34:16 <Myrtti> 90 minutes mark btw
19:34:29 <Tm_T> Myrtti: halfway then (:
19:34:31 <ikonia> what's the point of having a support channel to use offtopic and an offtopic channel to not do support, to be asked support questions
19:34:35 <AlanBell> #action oCean to edit the guide to add advice on support questions in -offtopic
19:34:35 * meetingology oCean to edit the guide to add advice on support questions in -offtopic
19:34:47 <AlanBell> Myrtti: yes, I am aware, the last bits won't take long at all
19:35:00 <Myrtti> AlanBell: I know you are aware, just reminding others ;-)
19:35:00 <AlanBell> ok, next item we have already addressed
19:35:08 <tsimpson> hmm, actually there probably should be a "Support questions in #ubuntu" in the -ot topic
19:35:08 <AlanBell> #topic Ops applications from existing ops - Alan Bell
19:35:13 <tsimpson> I though it was there, but apparently not
19:35:17 <AlanBell> we are going to deal with that, moving straight on
19:35:25 <AlanBell> #topic Supporters Guide document - Alan Bell
19:35:36 <ikonia> tsimpson: I'll fix now
19:35:54 <AlanBell> https://wiki.ubuntu.com/IRC/SupportersGuide
19:36:19 <AlanBell> we put this together this week, still accepting edits and improvements, an email went to the list about it
19:36:28 <phillw> an excellent resource. thanks for making it.
19:36:38 <oCean> ikonia, tsimpson we might consider the wording, since "support in #u" does shut down the possibility for a question in -ot
19:36:43 <AlanBell> I think a factoid pointing at it would be a good idea, we can try and come up with one later (not right now)
19:36:48 <LjL> yeah
19:36:57 <LjL> the #ubuntu-offtopic topic already had "non-support" in it
19:37:02 <LjL> why the need for this stronger wording
19:37:04 <ikonia> oCean: check topic now
19:37:12 <LjL> when many are saying here we should have all BUT a stronger thing against support there
19:37:19 <AlanBell> and we should probably blog about the supporters guide so planet readers see it (yes jussi, I know)
19:37:20 <oCean> ikonia: I saw it, fine with me now
19:37:38 <AlanBell> thanks ikonia :)
19:37:54 <ikonia> LjL: hopefully nothing too harsh in there now, just a little more clarify ?
19:37:54 <AlanBell> ok, thats all I want to say on the supporters guide for now
19:38:02 <ikonia> clarity even
19:38:05 <AlanBell> #topic Any Other Business
19:38:11 <LjL> Whatever
19:38:18 <AlanBell> does anyone have any other burning topics (I know we are over time)
19:38:25 <Myrtti> I'm still writing the ops guide...
19:38:33 <Myrtti> brain turns into mush.
19:38:41 <Tm_T> I had something in mind, but as usual, have forgotten it already /:
19:38:44 <Pici> I think we'll need to go back and discuss some of these other issues at a later time, but that was rather obvious anyway.
19:38:45 <AlanBell> Myrtti: can we decide a date (I don't want you spending too much time on it)
19:38:51 <LjL> ikonia: so now let's expect some people to say "NO GO AWAY SUPPORT IN #ubuntu" even louder than before.
19:38:59 <ikonia> LjL: hopefully not
19:39:04 <LjL> *shrug*
19:39:26 <Pici> We'll face that when we see it.
19:39:26 <Tm_T> LjL: "support questions might be better served in #u" ...lenghty one but softer tone /:
19:39:32 <Myrtti> AlanBell: you're allowed to kick me about it on Wednesday, if I'm not done by then, I give up and let someone else continue on writing it.
19:39:59 <Myrtti> it's in Etherpad and I'll toss the link around for a selected few then
19:40:04 <Myrtti> either way
19:40:23 <AlanBell> can't possibly kick you, but will tickle you on wednesday :)
19:40:39 <Tm_T> Myrtti: let me know if you need any help
19:40:43 <AlanBell> ok, any more . . .
19:40:59 <Myrtti> Tm_T: you I might poke with the URL in the next half hour
19:41:05 <Tm_T> (:)
19:41:06 <AlanBell> next meeting will be on a week day evening in a couple of weeks
19:41:15 <AlanBell> #endmeeting