15:02:04 <NCommander> #startmeeting
15:02:04 <meetingology> Meeting started Thu Feb 23 15:02:04 2012 UTC.  The chair is NCommander. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:02:04 <meetingology> 
15:02:04 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
15:02:09 <NCommander> Sorry, wasn't looking at the clock
15:02:11 <ogra_> ah
15:02:11 <mahmoh> hi
15:02:21 * davidm waves at NCommander
15:02:23 <NCommander> who's here
15:02:28 * med_ waves
15:02:31 * ogra_ sneezes
15:02:31 <rbasak> o/
15:02:37 <ahs3> \o
15:02:55 <NCommander> So
15:02:58 <ogra_> do we wnat need an agenda today ?
15:03:02 * GrueMaster meh
15:03:04 <NCommander> Not really
15:03:10 <NCommander> [topic] Important Annoucement
15:04:04 <NCommander> As part of an effort to keep ARM development more inline with the rest of the ubuntu community, the ARM team is intergrating directly into the platform team
15:04:18 <ppisati> :O
15:04:29 * ppisati wasn't aware
15:04:44 <NCommander> ppisati: there was a reason I said it was the final meeting on the reminder
15:04:45 <ogra_> i would actually like to propose to still have arm meetings to coordinate arm work ... not as frequent, not with burndown etc but occasionally (i.e. once a month or every two or on whatever schedule) to get people doing the arm work in ubuntu to talk ...
15:05:08 <NCommander> [vote] Continue ARM meetings?
15:05:08 <meetingology> Please vote on: Continue ARM meetings?
15:05:08 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
15:05:14 <ppisati> +1
15:05:14 <meetingology> +1 received from ppisati
15:05:21 <GrueMaster> But I like the broken burndown chart.
15:05:23 <med_> +1
15:05:23 <meetingology> +1 received from med_
15:05:25 <rbasak> +1
15:05:25 <meetingology> +1 received from rbasak
15:05:25 <ogra_> +1 (since i proposed it)
15:05:25 <meetingology> +1 (since i proposed it) received from ogra_
15:05:28 <GrueMaster> +1
15:05:28 <meetingology> +1 received from GrueMaster
15:05:34 <NCommander> ogra_: you broke the bot
15:05:44 <NCommander> +1
15:05:44 <meetingology> +1 received from NCommander
15:05:55 <ogra_> NCommander, how could i ? :)
15:06:01 <NCommander> 10:05:26 < meetingology> +1 (since i proposed it) received from ogra_
15:06:04 <davidm> Who is going to host the meetings?
15:06:28 * NCommander looks at the person who proposed it
15:06:28 <rbasak> Good question
15:06:32 * rbasak nominates davidm :-)
15:06:37 <davidm> ogra_, it just wants +1 0 or -1 on a line nothing else
15:06:45 <NCommander> #endvote
15:06:45 <meetingology> Voting ended on: Continue ARM meetings?
15:06:45 <meetingology> Votes for:6 Votes against:0 Abstentions:0
15:06:45 <meetingology> Motion carried
15:06:51 <davidm> rbasak, not sure what I'll be doing going forward
15:07:15 <davidm> So it needs to be someone else
15:07:17 <ogra_> davidm, nah, we use the comment feature in every rmb meeting to comment on people we vorte for
15:07:34 * ogra_ will do it then, we can rotate it or so
15:07:35 <NCommander> So we'll continue the meetings in some form, not sure how often or when
15:07:43 <NCommander> [action] ogra to determine new meeting schedule
15:07:43 * meetingology ogra to determine new meeting schedule
15:07:58 <ogra_> infinity, proposal was to still have arm coordination meetings at a looser schedule and with less agenda
15:08:06 <infinity> I'm not convinced we need meetings for the sake of meetings.
15:08:19 * NCommander proposes we have a meeting to discuss meetings
15:08:27 <NCommander> >:-)
15:08:31 <ogra_> infinity, no,. for the sake of communitcation of people working on arm stuff
15:08:52 <ogra_> it shouldnt be strict and optional anyway
15:08:59 <rbasak> We have to be careful with a loose schedule though
15:09:03 <rbasak> The risk is that it stops happening
15:09:04 <infinity> ogra_: Well, the idea here is that people should instead be communicating about "kernel stuff" or "desktop stuff" (etc).  We don't have "amd64 meetings".
15:09:14 <ogra_> just to give an opportunity to communicate on arm specific tasks
15:09:33 <ogra_> hmm, true indeed
15:09:39 <ogra_> nor do we have ppc ones
15:09:41 <infinity> ie: If you have an arm kernel issue, being it up in the kernel-team meeting.
15:09:48 <infinity> s/being/bring/
15:10:00 <NCommander> Here's the official meeting calendar
15:10:01 <NCommander> http://fridge.ubuntu.com/calendars/fridge/
15:10:13 <NCommander> Server team is 16:00 UTC on Tuesdays
15:10:17 <ogra_> infinity, though there was a vote before you joined, and that looked like there might still be demand
15:10:22 <NCommander> ]Kernel is 17:00 UTC on Tuesday
15:10:29 <ogra_> Votes for:6 Votes against:0 Abstentions:0
15:10:53 <rbasak> We don't need "amd64 meetings" because everyone is de-facto amd64. We need arm meetings because most people are still developing against non-arm, IMHO.
15:10:54 * ogra_ would like to hear from the people that +1'ed if they could get along with that
15:10:54 <infinity> I propose a discussion period before nostalgia-based voting biases kick in. ;)
15:11:07 <ppisati> i definitely can, since i'll be there anyway :)
15:11:07 <infinity> rbasak: Right, but that's what we're trying to change.
15:11:21 <infinity> rbasak: And it won't change if we keep having ARM stuff in separate meetings.
15:11:22 <ogra_> rbasak, infinity is right here
15:11:25 <victorp> you could always have a rotating chair
15:11:44 <ogra_> victorp, right, i would just have kicked it off
15:12:01 <ogra_> with chair nominations at the end of every meeting
15:12:15 <rbasak> infinity: we're not in a position to change it, IMHO, because it's based on what hardware engineers are using on their own machines. Until ARM/Intel reach a 50/50 split on that, ARM will be the minority and those working on it need to have a focus
15:12:42 <infinity> rbasak: Yeah, that's kinda the attitude we're trying to kill here.  That's my point. :)
15:12:53 <infinity> rbasak: People should care about it, even if it's not their laptop's arch.
15:13:05 <victorp> rbasak, unless you count their phone
15:13:07 <infinity> rbasak: And if it's not discussed in open channels and "normal" teams, that won't happen.
15:13:07 <rbasak> I'm sure they do care about it
15:13:19 * ogra_ uses arm 24/7 on his lappie :)
15:13:28 <victorp> I would suggest that keeping this meeting going forward for at least until the next cycle
15:13:32 * NCommander has an arm (and two legs)
15:13:36 <victorp> and then re-review it at uds?
15:13:42 <rbasak> I'm not saying that we shouldn't integrate with "normal" teams. I'm saying that ARM-specific issues that come up from there should be collaborated on in once place.
15:13:47 <rbasak> *one place
15:14:02 <rbasak> victorp: +1
15:14:12 <infinity> rbasak: Perhaps.  Generally, kernel people don't attend desktop meetings for a reason, though. :)
15:14:20 <infinity> (And most of us hate duplicated work/meetings)
15:14:28 <victorp> infinity, doesnt mean we cant do both
15:14:31 <infinity> But yeah, keeping the status quo for a little longer while we integrate won't kill us.
15:14:40 <ogra_> infinity, prob here is that we dont have an arm person in every team atm
15:14:51 <ogra_> else i would fully agree
15:14:55 <victorp> for certification we have a meeting to cover cert and then we have a person attending the kernel meeting to raise issues there too
15:15:03 <ogra_> but there is likely arm work that has to be done cross team atm
15:15:14 <infinity> ogra_: It's not (ultimately) about having "arm people" on every team, but having every team actually work on ARM.
15:15:23 <victorp> infinity, isnt a bit like QA
15:15:29 <GrueMaster> infinity: No one is forcing you to attend either.
15:15:33 <ogra_> how would they do that without HW or knowledge about the HW
15:15:41 <victorp> everyone does its own qa - there is still a qa meeting to discuss common things?
15:15:43 <ogra_> GrueMaster, ++
15:15:46 <NCommander> We did have a PowerPC for a long time.
15:15:50 <infinity> The HW is almost never necessary, except for kernel and installer hacking.
15:15:53 <NCommander> er
15:15:53 <NCommander> wow
15:15:55 <NCommander> grammar fail
15:16:02 <victorp> GrueMaster, that is the attitude  - lol
15:16:02 <infinity> Anyhow.
15:16:18 <infinity> I'll withdraw my objections for now.  But I'm working on integration here in the long run.
15:16:19 <ogra_> as i said before, optional, less frequent
15:16:31 <NCommander> PowerPC had a dedicated channel that people could go for porting help. We have #ubuntu-arm for much the same purpose
15:16:38 <ogra_> once a month should suffice surely
15:16:45 <victorp> infinity, can you take an action to setup a discussion at UDS around this?
15:17:14 <victorp> since you do have valid points - if I take the action it will never happen
15:17:17 <victorp> :(
15:17:29 <infinity> victorp: Will do.
15:17:39 <infinity> victorp: Rick's already tasked me informally with more or less the same thing. :P
15:17:45 <NCommander> [action] infinity to discuss ARM meeting existance at UDS
15:17:45 * meetingology infinity to discuss ARM meeting existance at UDS
15:17:58 <victorp> great minds and all that
15:18:01 <infinity> (Though less about meetings, and more about deeper integration)
15:18:30 <NCommander> integration can largely be solved with large amounts of beer and duct tape
15:18:37 <SeaJay> I'm for continuing the meetings but not so much for status quo but rather to help with the transition to the new org and build cross team cooperation.
15:19:14 <infinity> To be fair, cross-team cooperation already exists, ARM's just not seen it as much, because we've been in our own weird bubble.
15:19:23 <ogra_> ++
15:19:25 <infinity> Scatter us to the winds, and we might see how the rest of the distro works. ;)
15:19:39 <SeaJay> Yeh, cooperation wasn't the right word.
15:19:41 <ogra_> they will forward their probs to linaro then :P
15:19:49 <ogra_> instead of us
15:19:56 <infinity> Anyhow.  Moving on.  I'll make sure this all gets solid discussion at UDS.
15:20:00 <infinity> And I'll bring blunt objects.
15:20:03 <infinity> Or wiffle bats.
15:20:16 <ogra_> k, so should i still schedule it in a month from now ?
15:20:21 <med_> yes
15:20:35 <ogra_> ok
15:20:52 * rbasak votes two weeks
15:21:02 <ogra_> (will only be 3 or 4 meetings until UDS anyway on that schedule)
15:21:06 <infinity> ogra_: You could even register a foundations-uds-q-arm-integration (or whatever the right format is) blueprint, and assign it to me. ;)
15:21:07 <SeaJay> Yeh, I'd like more frequently than monthly for now myself.
15:21:12 <davidm> IS there any action items from last week that should be reviewed before just dropping the old agenda?
15:21:36 <rbasak> The point being that we don't know how it'll go. If there's persistently little to discuss, we could make it less frequent then, but going in the other direction involves a long wait.
15:21:39 <ogra_> infinity, feel free to create it :)
15:22:13 <infinity> ogra_: I was hoping I could trick you into being my personal assistant.  I'll set it up.
15:22:14 <ogra_> NCommander, any actions from last week ?
15:22:24 * NCommander checks
15:22:28 <ogra_> infinity, lol, then you have to say so !
15:22:40 <ogra_> just ask and you will be served :P
15:23:03 <NCommander> [topic] rsalveti to follow with riku to see if chromium will get fixed
15:23:18 <ogra_> (we have to talk about the amount of salary you have to transfer indeed )
15:23:23 <infinity> micahg: What's the latest on chromium?
15:23:31 <ogra_> it built !
15:23:36 <NCommander> does it run?
15:23:39 * ogra_ got it with a dist-upgrade today
15:23:43 <ogra_> didnt try
15:23:47 <NCommander> ogra_: best try :-).
15:23:50 <ogra_> just saw the package passing by
15:23:51 <infinity> Wait, it built?
15:23:54 <ogra_> not now
15:23:54 <NCommander> I remember openoffice built, but didn't run
15:24:11 <infinity> No, chromium's still broken on armhf.
15:24:12 <ogra_> will do when i dont actually use this machine :)
15:24:20 <ogra_> oh, crap i run el here
15:24:29 <ogra_> but even that is a novum
15:24:33 <infinity> Some multiarch annoyance.
15:24:40 <ogra_> it didnt buold on any arm for years
15:25:11 <infinity> I'll work with micahg to see if we can resolve that.
15:25:28 <ogra_> i'll test after the meeting if it actually runs on my tegra
15:25:40 * ogra_ has all ram used up atm
15:26:43 <infinity> janimo`: Oh hai.
15:26:46 <ogra_> heh
15:26:52 <janimo`> I forgot what the itme was
15:26:56 <janimo`> and noone pinged me!
15:27:05 <janimo`> and hi :)
15:27:11 <ogra_> we just assumed your mic was broken
15:27:17 <janimo`> funny guy
15:27:17 * GrueMaster hasn't seen an itme in a while.
15:27:19 <ogra_> oh, wait that was the other meeting :P
15:27:31 <infinity> NCommander: Was there anything else from last meeting?
15:27:39 <janimo`> GrueMaster, did you say 'itme?
15:27:42 <NCommander> [topic] rsalveti to follow with koen at ELC to see if we'll get armhf drivers for sgx (omap3)
15:27:44 <janimo`> I would if I were near you
15:28:02 <ppisati> NCommander: how about omap4?
15:28:08 <ogra_> ppisati, in the works
15:28:10 <rsalveti> he'll be publishing the drivers in the following weeks
15:28:11 <ppisati> ok
15:28:12 <rsalveti> hope still in time for the release
15:28:14 <rsalveti> with a ffe
15:28:15 <ogra_> waiting for ndecs team
15:28:57 <infinity> rsalveti: Given that armel is unsupported, and armhf doesn't have the driver, the FFe will be a no-brainer.
15:29:06 <ogra_> yeah
15:29:08 <infinity> rsalveti: But have them talk to me about it when it's time.
15:29:18 <rsalveti> FFe to include the driver for armhf
15:29:29 <infinity> Yeah, like I said, no-brainer.
15:29:48 <infinity> Hardware enablement FFes are more closely tied to kernel freeze, which is quite a way out.
15:29:58 <infinity> At least, IMO.
15:30:07 <rsalveti> that's fine then :_)
15:30:09 <rsalveti> :-)
15:30:29 <janimo`> is there an action item to ping nvidia about tegra-armhf or it happens whenever they get to it?
15:30:46 <ogra_> good question
15:30:48 <rsalveti> I talked with a few nvidia folks at elc
15:30:50 <janimo`> so ac100 is not the only armel image
15:30:53 <infinity> A few different people talked to nvidia engineers at Connect.
15:30:56 <infinity> And ELC, apparently. :P
15:30:56 <rsalveti> they said the have the armhf driver internally
15:31:01 <infinity> And yeah, that.
15:31:11 <rsalveti> guess we just need to ping the folks to make it available for us
15:31:15 <infinity> The Engineers are building them, the release managers haven't let them be set free yet.
15:31:17 <ogra_> then they should just open the gates
15:31:29 <infinity> Red tape ahoy.
15:31:33 <ogra_> heh
15:32:05 <ogra_> well, with the current xorg ABI i get green bg on notification bubbles and the panel fonts look like rainbows
15:32:06 * janimo` : look for tegra-armhf drivers on thepiratebay.org
15:32:11 <ogra_> camnt be worse i guess
15:32:35 <ogra_> oh, and firefox CSS is acting up too
15:33:07 <ogra_> o it would be good to have something new for release
15:33:08 <janimo`> well the driver itself is still buggy but at least it should not hold up armhf images taking over
15:33:18 <ogra_> yeah
15:34:04 <rsalveti> and for imx53 we're still waiting feedback from freescale
15:34:06 <ogra_> but with xorg updates it got a lot more buggy over the last weeks
15:34:13 <rsalveti> seems we can have the drivers, but we can't distribute them
15:34:23 <rsalveti> so, useless :-)
15:34:26 <ogra_> so i dont even know if it makes sense to keep artmel around for ac100
15:34:30 <ogra_> *armel
15:34:33 <janimo`> rsalveti, was that not the case even before with mx53?
15:34:39 <infinity> rsalveti: Yeah, I'd love to be able to, but such is life. :/
15:34:49 <rsalveti> janimo`: yeah
15:35:04 <ogra_> even with imx51 (babbage) we had that
15:35:12 <GrueMaster> rsalveti: Anyone working on the usb issue with the imx53 Start-R rev?
15:35:13 <rsalveti> but anmar is working hard at linaro to make freescale to release a distributable driver
15:35:37 <rsalveti> GrueMaster: not atm, unfortunately
15:35:40 <rsalveti> GrueMaster: have the bug?
15:35:42 <infinity> rsalveti: I suppose if someone has some spare time they wanted to waste, they could design an installer package that required the user to first download the tarball from Freescale.
15:35:44 <rsalveti> the team is focused on imx6
15:36:15 <GrueMaster> I'll file a bug later today.  Everytime I got ready to file one before, I was told to wait as a new kernel was coming.
15:36:21 <rsalveti> infinity: that would probably work, just need someone with some spare time to do the magic script
15:36:35 <rsalveti> GrueMaster: please open it and let me know about the bug number
15:36:42 <rsalveti> will forward it to the LT
15:37:05 <infinity> rsalveti: Yeah, probably not worth the time, but if someone's feeling like a keener on private/community time.
15:37:41 <rsalveti> yeah
15:38:50 <ogra_> oh, btw is anyone sending out a more official announcement that the arm dem wont exist anymore ... or is NCommander's note that this was the final meeting enough ?
15:38:56 <ogra_> s/dem/team/
15:39:01 * ogra_ glares at his fingers
15:39:31 <NCommander> Sorry, power interruption
15:39:38 <NCommander> cable model takes a good five minutes to powercycle
15:39:41 <NCommander> *modem
15:40:18 <NCommander> ogra_: I can drop a second email to ubuntu-armel announcing the former disillusion of the team.
15:40:31 <infinity> ogra_: I think we'll want to wait a week or three until we have a better idea of the state of things.
15:40:36 <NCommander> the LP group though shoul dstill be subscribed so ARM related bugs can be easily felt
15:40:41 <NCommander> infinity: fair enough
15:40:46 <ogra_> infinity, yeah, sounds sane
15:41:02 <infinity> I'd like to send something more formal to ubuntu-announce in a while, but I want to make sure it's carefully worded to be positive, rather than panic-inducing.
15:41:15 <GrueMaster> NCommander: Actually, tags are the preferred method for bugs.
15:41:20 <ogra_> infinity, ++
15:41:30 <ogra_> and also blessed by managers7teamleads
15:41:51 <infinity> ogra_: Yeahp.
15:42:30 <infinity> ogra_: I've been talking with Rick and Steve about what this all "means" for platform/Ubuntu, so I might take an action item here to draft up a formal announcement and get it reviewed and rubber-stamped.
15:42:45 <ogra_> k
15:42:47 <infinity> But, like I said, I think it should wait a couple weeks.
15:42:47 <NCommander> anyway
15:42:52 <NCommander> I have one final announcement
15:42:52 <rsalveti> having a group can still be useful as we have people that only cares about arm atm
15:42:57 <rsalveti> like the folks working with linaro
15:43:09 <rsalveti> so easier to parse the bugs and such, but guess that a tag would also be useful
15:43:11 <infinity> rsalveti: The LP group and ubuntu-arm channel are still valuable, IMO.
15:43:17 <ogra_> rsalveti, the ubuntu-arm LP team will still exist
15:43:20 <rsalveti> great then
15:43:25 <rsalveti> :-)
15:43:33 <ogra_> we already share it across different teams
15:43:56 <ogra_> (which made our burndown chart look funny in the past)
15:44:35 * ogra_ has nothing anymore
15:45:03 <NCommander> good news everyone
15:45:08 <NCommander> armadaxp netboot images are up
15:45:19 <infinity> NCommander: \o/
15:45:20 <mahmoh> yay
15:45:20 <rbasak> \o/
15:45:25 <ogra_> great
15:45:27 <cmagina> woot
15:45:38 <ogra_> when will we see alternates ?
15:45:47 <mahmoh> it even should reboot on its own now too!
15:45:54 <NCommander> ogra_: wasn't planning on buildin gthem
15:46:11 <NCommander> Kinda pointless when the bootloader can't load from USB
15:46:16 <ogra_> oh, i thought you did
15:46:25 <mahmoh> it might be able to btw
15:46:27 <NCommander> I was waiting until we got a fixed bootloader from Marvell
15:46:36 <NCommander> mahmoh: did that get magically fixed cause I couldn't get it to work
15:46:37 <ogra_> ah, indeed
15:46:58 <mahmoh> if you tried a powered usb device then no
15:47:35 <GrueMaster> mahmoh: We tried a usb stick at the rally.
15:47:43 <NCommander> and a SD card too
15:48:02 <mahmoh> sd didn't work?!
15:48:21 <GrueMaster> If it did, we wouldn't be having this discussion.
15:48:34 <mahmoh> heh
15:49:19 <NCommander> Anyway
15:49:22 <NCommander> I think its time to close
15:49:26 <mahmoh> well reboot now works and there's a bug for unmount hanging
15:49:26 <NCommander> One final annoucement
15:49:28 <GrueMaster> At any rate, we have 12 minutes left, and I have no idea where in the agenda we are anymore.
15:49:31 <NCommander> I would just like to say
15:49:37 <NCommander> So long, and thanks for all the fish
15:49:39 <ogra_> GrueMaster, which agenda ?
15:49:39 <NCommander> #endmeeting