20:05:13 <gilir> #startmeeting Lubuntu Team Meeting
20:05:13 <meetingology> Meeting started Wed Feb 22 20:05:13 2012 UTC.  The chair is gilir. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
20:05:13 <meetingology> 
20:05:13 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
20:05:41 * gilir looks for people around :)
20:05:45 <MrChrisDruif> o/
20:05:45 <phillw> o/
20:05:55 <wxl> …o/
20:05:58 <david_j_r> `°  (back row)
20:06:21 <gilir> agenda : https://wiki.ubuntu.com/Lubuntu/IRC%20Meetings/Agenda
20:06:27 <Yorvyk> o/
20:06:58 <gilir> no actions from previous meeting, so we can move to the next item :)
20:07:48 <gilir> if you have a weekly report planned for the meeting, but nothing to say, just ping me outsite the room, so I can skip the item
20:08:13 * gilir tries to make the meeting faster :)
20:08:42 <gilir> #topic phillw - Weekly report - Update from QA meeting and team
20:08:47 <phillw> Because of confusion caused by re-spins during testing, an email will be sent out to the qa mailing list when re-spins happen. When lubuntu iso's are re-spun, I'll forward them to the main lubuntu mailing list in order to keep the chat down :)
20:09:32 <wxl> respins hm?
20:09:53 <phillw> when a fault in the iso requires it to be re-issued.
20:10:01 <wxl> oh like them being too big ;)
20:10:09 <phillw> such as a major bug.
20:11:06 <phillw> wxl: the milestone releases are always on-size, it is just the dailys that suffer. Now we aer post-freeze, this also should mean the dailies are CD sized.
20:11:12 <phillw> s/aer/are
20:11:36 <wxl> delightful as i'd like to do some ppc/ubuntu testing to compare to issues with lubuntu testing
20:12:57 <gilir> beta 1 is next week, testing for it should start shortly :)
20:13:43 <gilir> phillw, anything more for QA ?
20:13:55 <MrChrisDruif> Just an educated guess: after their released?
20:13:56 <phillw> it is for that reason they're going to let us know when the Release Candidates for the beta 1 are up. If one of them has a major problem, it will be re-spun in time for beta.
20:14:03 <phillw> that's all from QA :)
20:14:11 <MrChrisDruif> they're*
20:15:03 <phillw> MrChrisDruif: the test versions of each mile-stone is put on test a few days before the mile stone is released. in this case it will be for beta 1
20:16:42 <gilir> if people want to start ISO testing for beta 1
20:16:52 <phillw> MrChrisDruif: the rather involved proceedure is documented at https://wiki.ubuntu.com/Lubuntu/Testing#QA_testing_of_Milestone_releases
20:16:53 <gilir> they can probably ask question on IRC when they start
20:17:18 <MrChrisDruif> *noted* (by meetingology)
20:17:31 <gilir> or read documentation send by phillw :)
20:18:01 <StephenSmally> Damn, i'm always late
20:18:05 <phillw> I do ask that testers do join the lubuntu-qa team, even if just until final release
20:18:23 <gilir> ok thanks phillw :)
20:18:45 <phillw> https://launchpad.net/~lubuntu-qa
20:18:52 <gilir> nothing to report for the next items, so I move directly to dev team report
20:19:31 <gilir> #topic gilir - Weekly report - Update from Devs teams
20:19:45 <gilir> a few thinks to report
20:19:50 <gilir> thinks / things
20:20:08 <gilir> ISO are under 700 Mo :)
20:20:24 <gilir> and maximised windows by default is turn off
20:20:41 <Yorvyk> \o/
20:20:56 <gilir> artwork was updated, but there is still issue with the theme
20:20:56 <david_j_r> :D
20:21:14 <gilir> no need to report bugs so far, we are working on it :)
20:21:34 <gilir> any questions ?
20:22:45 <gilir> ok, moving to next item :)
20:23:00 <gilir> #topic Yorvyk - Guidelines for alternative apps in distro
20:23:10 <StephenSmally> This is interesting
20:23:16 <StephenSmally> (if i got what that means)
20:23:40 <gilir> Yorvyk, you want to start with it ?
20:24:11 <Yorvyk> OK
20:25:08 <Yorvyk> People keep suggesting apps for Lubuntu or replacement apps some of whichg are suitable possibilities others are not.
20:26:23 <Yorvyk> I would like to set up somewherre to keep track of them so they can be looked at in more detail but we could do with some sort of guidelines for suitable apps to be considered.
20:26:42 <MrChrisDruif> I agree
20:27:15 <StephenSmally> Yep, for example some people want LibreOffice on Lubuntu by default, which is clearly not possible (or not useful)
20:27:16 <Yorvyk> Is this a good idea and should we through it open to the mailing list forum?
20:27:52 <gilir> IMO, testing and considering new application by default is very time consuming, for not so much advantages
20:28:17 <MrChrisDruif> It's not suitable for a default installation, but that isn't the current subject ^_^
20:28:18 <jmarsden|work> If you care enough to do it, you write the guidelines and manage a wiki page listing the suggestions.  Keep this kind of "suggstions" away from the devs...
20:28:47 <gilir> I like the idea to make a page with some advises, balcklisted apps, and already discussed apps
20:29:12 <david_j_r> Yes: "already discussed apps" helpful for new users (like me)
20:29:54 <jmarsden|work> david_j_r: Why?  As an end user, you can install any app you choose.  The issue is what to *include* on the Lubuntu CD and install by default.
20:30:06 <gilir> Yorvyk, maybe you can start to gather some ideas on a wiki page ?
20:30:08 <Yorvyk> The problem is apps have been discussed and a re 'lost' in the mailing list somewhere.
20:30:14 <MrChrisDruif> jmarsden|work; why would the user-base suggestions be kept from the devs? If they are properly supported by factual tests etc?
20:30:20 <wxl> what happened to that whole voting idea?
20:30:37 <jmarsden|work> MrChrisDruif: RIght, once a cycle the devs can look at the list, but the devs should not deal with all the suggestions as they flow in...
20:30:41 <StephenSmally> Consider that a list of suitable apps for Lubuntu (for example how to choose a photo manager) would be a good idea for newcomers
20:30:44 <david_j_r> jmarsden|work: That's what I mean: new types might want something in distro that is already crossed off for good reason
20:31:06 <Yorvyk> THis isn't for the ISO.  Unless some app is no longer supported and we need a replacement.
20:31:13 <jmarsden|work> david_j_r: OK... new types shouldn't want things "in the distro", they should just add what they themselves want :)
20:31:23 <david_j_r> yep :)
20:31:58 <david_j_r> (apologies if I am confusing "ISO" with "distro" -  my bad)
20:32:07 <gilir> Yorvyk, ok, so the subject is only on application suitable to be used on Lubuntu (not to be installed by default)
20:32:14 <jmarsden|work> Yorvyk: if it isnt for the ISO, then every app is perhaps suitable for *some* user out there... so the list of apps is the entire set of apps in the repositories :)
20:32:16 * gilir didn't understant too :-/
20:32:40 <gilir> jmarsden|work, but you know some apps is not really recommends for Lubuntu users :)
20:33:10 <jmarsden|work> gilir: Well, maybe some Lubuntu users run on a 8 core machine with 32GB RAM... for them, every app could be "suitable" :)
20:33:46 <gilir> jmarsden|work, sure, but such people doesn't need the advises :)
20:34:14 <jmarsden|work> It's pointless having a list of things that are not suitable for inclusion, but may be OK for some users... you'd have to define a list for "users with 2GB", "users with 4GB", users with quad cores... etc etc...
20:34:17 <gilir> I still think Lubuntu is primary for people with computers with low specs
20:34:22 <jmarsden|work> I agree.
20:34:29 <jmarsden|work> and for them, the included apps are suitable.
20:34:36 <Yorvyk> My thought was to try and gather a list of truly lightweight apps somewhere. so that we can offer a suiable alternative if somebody would like to use something that won't run on a low resouce machine.
20:35:07 <MrChrisDruif> I *thought* the list was for proposal of inclusion into the default installation? What other use would there be for such a list?
20:35:11 <phillw> Yorvyk: I think, as suggested, a wiki page would be excellen t for that.
20:35:15 <gilir> jmarsden|work, maybe just adding a note on this page, like "If you want to keep Lubuntu fast on your old computer ..."
20:35:16 <jmarsden|work> Yorvyk: if an app is truly lightweight, then it *will* run on a low resource machine...
20:35:35 <Yorvyk> After some testing and maybe a vote suitable apps could be highlighted in LSC
20:36:30 <wxl> Yorvyk: this is similar to a suggestion that i made before. it requires us to define what makes an app "suitable" and then it requires a lot of work testing apps.
20:36:31 <StephenSmally> Definitively possible
20:36:38 <jmarsden|work> Yorvyk: If you want to do a wiki page listing such apps, go for it.
20:36:54 <StephenSmally> well, is not so difficult define if an app is light
20:36:58 <wxl> yeah in the end i think something like a wiki page like jmarsden|work is suggesting makes the most amount of sense
20:37:28 <gilir> Yorvyk, yes, I think you have to start this page, before futher discussion can happen :)
20:37:29 <wxl> StephenSmally: if you have 256mb of ram versus 1.5gb i'm thinking you probably have a different definition :D
20:37:59 <StephenSmally> well, anyway if doesn't have too much dependencies and not use too much ram
20:38:06 <Yorvyk> I'll get something set up and thenm I think what I want may make more sense.
20:38:21 <wxl> StephenSmally: but what's "too much?
20:38:34 <StephenSmally> it depends on the application
20:38:38 <gilir> #action Yorvyk to start the suggested apps wiki page
20:38:38 * meetingology Yorvyk to start the suggested apps wiki page
20:39:05 <StephenSmally> a simple utility (as a text editor) shouldn't use more that 15 Mb RAM on an i386 machine
20:39:12 <StephenSmally> *than
20:39:19 <MrChrisDruif> An other suggestion might be an AskUbuntu question, where people could vote on answers (like "What is the best lightweight app?")
20:39:38 <wxl> i still think the voting idea is best
20:39:44 <gilir> MrChrisDruif, but you have to do it for each type of application ...
20:39:49 <wxl> of course one can vote with edits on a wiki :D
20:39:51 <StephenSmally> And also a light app is an app written in a compiled language (C is the lighter)
20:40:15 <StephenSmally> that's the main reason why i'm (and michael) porting lsc to vala
20:40:22 <gilir> StephenSmally, you have to consider the memory, cpu and disk usage, depencencies ...
20:40:48 <jmarsden|work> Take the definition of what is small enough/light enough outside this meeting... :)
20:40:50 <gilir> there are many aspects to consider when you talk about lightweight applications
20:41:07 <StephenSmally> yep, but look at the dependecies is a good hint
20:41:13 <gilir> Yorvyk, anything to add ?
20:41:26 <wxl> i think maybe we should move on, eh? we've beat this idea to death in the past. i think the action will move it forward if it happens. i'd be happy to add to the wiki personally.
20:41:29 <StephenSmally> for example, compare goobox and asunder (cd ripper), goobox depends on Gnome, so out
20:41:38 <Yorvyk> I think what is wanted is
20:41:46 <gilir> ok thanks Yorvyk :)
20:41:57 <StephenSmally> Yorvyk: i am available to do some test
20:42:02 <gilir> #topic StephenSmally - Lsc in Vala and Elementary Os team collaboration
20:42:11 <StephenSmally> Well
20:42:13 * gilir is curious about this one :)
20:42:23 <Yorvyk> StephenSmally: OK
20:42:40 <StephenSmally> I asked the elementary os team to "steal" some code from slingshot for lxlauncher
20:43:02 <StephenSmally> obviously is GPL, but anyway i wanted to ask the permission
20:43:36 <StephenSmally> they were very kind and fine
20:44:04 <StephenSmally> and they asked me if there is something we (lubuntu team and eos team) can collaborate on
20:44:09 <gilir> as long as the copyright attribution and the licence is fine, it should not be a problem
20:44:21 <gilir> but it's nice to ask :)
20:44:39 <StephenSmally> so we decided to write a common backend for lubuntu software center and elementary app center
20:44:49 <StephenSmally> so the next lsc version will be written in vala using PackageKit
20:44:59 <gilir> StephenSmally, sounds good :)
20:45:12 <StephenSmally> i also plan to modify the UI
20:45:30 <StephenSmally> (as somebody may has seen on facebook)
20:45:32 <gilir> StephenSmally, as long as it will not bring gnome depends, it's ok to work with them :)
20:45:44 <StephenSmally> no one, gilir
20:45:50 <StephenSmally> ;-)
20:46:29 <StephenSmally> here a mockup of what i think http://imagebin.org/index.php?mode=image&id=200267
20:46:37 <gilir> StephenSmally, UI freeze should be in effect tomorow for 12.04
20:46:51 <StephenSmally> of course, i'm planning for precise+1
20:46:59 <gilir> StephenSmally, ok :)
20:47:21 <StephenSmally> i asked rafaellaguna for some hints
20:47:59 <StephenSmally> anyway, i think a collaboration with the two teams would be a good thing
20:48:01 <gilir> StephenSmally, you can also ask alexander, he worked on UI stuff also
20:48:51 <StephenSmally> anyway, only the core of the apps will be the same, the UI is absolutely under our control XD
20:49:09 <MrChrisDruif> Re on the previous topic: I was just throwing it out there ^_^
20:50:23 <StephenSmally> anyway, the team guys are very available, so if you want to ask something i think you can ask at elementary-dev-community@lists.launchpad.net
20:50:26 <gilir> StephenSmally, sounds good, keep us informed about the progress :)
20:50:43 <StephenSmally> i'll absolutely do
20:50:56 <wxl> oh!
20:51:12 <wxl> sort of side note but StephenSmally have you seen the lsc crash bug on boot in precise?
20:51:13 <MrChrisDruif> I also saw a post on Lubuntu Official facebook page about LSC
20:51:35 <gilir> wxl, bug number ?
20:51:46 <wxl> one sec there's a few of them
20:51:54 <MrChrisDruif> StephenSmally; ^
20:52:22 <StephenSmally> yes?
20:53:34 <wxl> aw shoot
20:53:37 <wxl> they're darn private bugs
20:53:38 <MrChrisDruif> I thought the outset of LSC was creating a lightweight edition of USC? Now the "developer preview" was without icons at all?
20:54:07 <wxl> there's one public https://bugs.launchpad.net/ubuntu/+source/lubuntu-software-center/+bug/938399
20:54:09 <ubottu> Error: Bug #938399 is a duplicate of bug #934537, but it is private (https://launchpad.net/bugs/934537)
20:54:39 <wxl> lubuntu-software-center-build-db crashed with KeyError in /usr/sbin/hostname-software-center-build-db: 'ppc'
20:54:46 <wxl> seems to be ppc specific
20:54:49 <StephenSmally> MrChrisDruif: only the categories are without icons, we can add it if we want
20:54:57 <wxl> always on boot
20:55:01 <StephenSmally> wxl: gosh! got it, i'll fix it
20:55:03 <wxl> after updating, it goes away
20:55:25 <gilir> wxl, bug is not private anymore
20:56:07 <gilir> StephenSmally, anything to add ?
20:56:41 <StephenSmally> mmm, no, the bug should be fixed in an half hour
20:56:50 <wxl> thx StephenSmally :)
20:57:25 <StephenSmally> is there anybody on ppc right now?
20:57:45 <wxl> right now, no, but my machine is at home and can test in ~+6 hours
20:58:14 <StephenSmally> thank you
20:58:19 <wxl> phillw: have we ever got anywhere re: running ppc in qemu?
20:59:00 <phillw> wxl: I asked a few people, never got a reply :/ I will have another dig around to see what I can find.
20:59:02 <wxl> StephenSmally: i see it with the live system and the resulting install but after updating it is gone. so the next iso that comes out from your update, i can test
20:59:19 <StephenSmally> thanks
20:59:30 <StephenSmally> well, i'm done.
20:59:46 <wxl> thx
20:59:48 <gilir> wxl, to test, you have to remove lsc, and re-install it
21:00:07 <gilir> StephenSmally, ok, thanks :)
21:00:18 <wxl> gilir: i can try that too but i want to see how it works in situ ;)
21:00:30 <gilir> #topic other question ?
21:00:37 <phillw> o/
21:00:51 <david_j_r> o/
21:00:56 <gilir> phillw, ok
21:01:04 <phillw> not a question... the new draft for ubuntu.net is coming along well - heck, they've even got volunteer translators already. Well done!
21:01:16 <phillw> *lubuntu,net*
21:01:59 <phillw> it is at http://www.whiteboar.info/ for those interested.
21:02:14 * gilir have to read the entire thread on the mailing list ...
21:02:49 <phillw> fortunately, it is being kept on one email subject now, instead of several :)
21:03:05 <gilir> yes, it's nice :)
21:03:20 <gilir> maybe a topic to discuss next meeting
21:03:27 <gilir> david_j_r, yes ?
21:03:30 <david_j_r> Did Leszek get for LXKeymap, and did "obkey" make it in for 12.04? (Multilingual computing something of interest to me.)
21:03:36 <david_j_r> *help for...
21:04:03 <david_j_r> Maybe that should have been question for dev part of agenda.
21:04:06 <gilir> david_j_r, not yet, some bugs still need to be fixed in the new version
21:04:21 <david_j_r> OK - thanks!
21:04:22 <gilir> nothing new since last week
21:04:39 <gilir> ok, no more question, time to end :)
21:04:50 <gilir> thanks everyone :)
21:05:00 <gilir> #endmeeting