16:00:48 <roadmr> #startmeeting Ubuntu Friendly meeting
16:00:48 <meetingology> Meeting started Mon Feb 13 16:00:48 2012 UTC.  The chair is roadmr. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:00:48 <meetingology> 
16:00:48 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:01:02 <roadmr> Hi everyone, welcome to the Ubuntu Friendly meeting!
16:01:12 <roadmr> Today we have the following topics to talk about:
16:01:20 <roadmr> * Checkbox 0.13.1 - call for testing (roadmr)
16:01:20 <roadmr> * Submitting test results anonymously (cr3)
16:01:21 <roadmr> * Any Other Business
16:01:42 <roadmr> As usual, you're welcome to participate, to do so, indicate you want to speak by raising your hand (o/). Don't forget to also signal when you're done using ..
16:01:53 <cr3> o/
16:02:03 <roadmr> hey cr3!
16:02:04 <cr3> hello everyone!
16:02:05 <cr3> ..
16:02:13 <roadmr> Let's get started with the agenda!
16:02:21 <roadmr> [TOPIC] Checkbox 0.13.1 - call for testing (roadmr)
16:02:35 <roadmr> Checkbox version 0.13.1 was just accepted in Ubuntu, with lots of fixes and new goodies.
16:02:57 <roadmr> We'd like to ask for everyone's help in running it and reporting any bugs you may find (by running ubuntu-bug checkbox, for instance).
16:03:09 <roadmr> This will allow us to start focusing on fixing those bugs in time for the 12.04 release.
16:03:32 <roadmr> Installing it should be as simple as applying available updates in your Ubuntu Precise installation.
16:04:03 <roadmr> That's all on this topic, as it was basically just an announcement :) Any questions or comments?
16:05:05 <roadmr> nothing? :) Let's move on then...
16:05:21 <roadmr> * [TOPIC] Submitting test results anonymously (cr3)
16:05:25 <roadmr> [TOPIC] Submitting test results anonymously (cr3)
16:05:40 <roadmr> cr3, go ahead!
16:05:45 <cr3> The new checkbox-qt interface provides a button to submit test results and hardware information anonymously.
16:05:48 <cr3> The problem is that Launchpad does not like anonymous information on the basis that information not linked to anyone is useless.
16:05:51 <cr3> We could workaround this problem by providing a dummy email address when users click on the button to submit anonymously.
16:05:54 <cr3> Or, we can remove the button to submit anonymously. Note that the interface prompts for an email address which doesn't need to exist in Launchpad.
16:05:57 <cr3> If a user eventually creates an account in Launchpad with the same address, the submissions will be linked to the new user retroactively.
16:06:00 <cr3> So, should we vote on removing the button to submit anonymously?
16:07:05 <mlegris> +1 -> yes
16:07:17 <roadmr> sounds OK to me, anyone want to comment anything before we vote?
16:08:10 <roadmr> let's go then
16:08:12 <roadmr> #vote remove the "submit anonymously" button from Checkbox? (+1 means "yes, remove it")
16:08:12 <meetingology> Please vote on: remove the "submit anonymously" button from Checkbox? (+1 means "yes, remove it")
16:08:12 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
16:08:19 <cr3> +1
16:08:19 <meetingology> +1 received from cr3
16:08:21 <jedimike> +1
16:08:21 <meetingology> +1 received from jedimike
16:08:21 <bladernr_> +1
16:08:21 <meetingology> +1 received from bladernr_
16:08:40 <mlegris> +1
16:08:40 <meetingology> +1 received from mlegris
16:08:51 <roadmr> +1 but we need to let the user know that any email address can be specified, to avoid "oh, do I have to create a launchpad account?" questions
16:08:51 <meetingology> +1 but we need to let the user know that any email address can be specified, to avoid "oh, do I have to create a launchpad account?" questions received from roadmr
16:09:08 <cr3> roadmr: +1, but I don't think we need to vote on that :)
16:09:14 <ara> -1
16:09:14 <meetingology> -1 received from ara
16:09:24 <ara> I think it is better to use a dummy email
16:10:26 <cr3> ara: people could provide a dummy address themselves if they really want, but at least it wouldn't make bad behavior as common
16:10:44 <ara> but it would make the UI messy
16:10:58 <cr3> ara: we're removing a button, how's that messy?
16:11:26 <ara> what will be the label for the email text box
16:11:35 <ara> currently is Launchpad ID email
16:11:40 <ara> (or something along the lines)
16:11:43 <roadmr> cr3: but will the text that explains that even a non-launchpad email address be briefer than the button?
16:12:15 <roadmr> cr3: people aren't too good at those "implicit" behaviors, so we *need* to spell it out
16:12:22 <cr3> ara: whether we have the anonymous button or not, I think the email input field will need the same text
16:13:01 <roadmr> that's a good point
16:13:03 <ara> I don't think so
16:13:24 <cr3> ara: please explain, I'm not sure I follow
16:13:33 <ara> Right now you can:
16:13:44 <ara> * Submit anonymously
16:13:49 <ara> * Submit with your Launchpad email
16:14:11 <ara> that implies that you need a Luanchpad account to submit with the email text box
16:14:18 <ara> if we remove the submit anonymously
16:14:44 <ara> we will need to remove the Launchpad all together, to avoid confusion
16:14:50 <ara> Launchpad label, I mean
16:15:17 <ara> or add a too lengthy explanation about the eamil
16:15:42 <cr3> * Submit with your email, optional
16:15:51 <cr3> so, if you click on submit without anything, it submits anyways?
16:16:15 <cr3> in other words, remove the big red button to encourage bad behavior and still support your use case?
16:16:58 <ara> I will need to see a mock up to get the idea
16:17:21 <cr3> ara: I'm thinking the same as it was which we now works with Launchpad requirements
16:17:31 <cr3> s/now/know/
16:18:31 <ara> I don't see why submitting anonymously should be consider "bad behaviour"
16:19:02 <ara> but I will be happy to see other mock ups
16:19:27 <cr3> ara: if it weren't bad behavior, why should we prompt for an email address at all?
16:22:04 <roadmr> so maybe this feature needs a bit more thinking?
16:22:43 <roadmr> let me close the vote, I think despite the clear majority this still merits some discussing
16:22:46 <roadmr> #endvote
16:22:46 <meetingology> Voting ended on: remove the "submit anonymously" button from Checkbox? (+1 means "yes, remove it")
16:22:46 <meetingology> Votes for:5 Votes against:1 Abstentions:0
16:22:46 <meetingology> Motion carried
16:22:53 <roadmr> ignore meetingology :)
16:23:32 <cr3> roadmr: agreed, but we might not have that luxury. I'd say try to propose a way to submit both anonymously and with an email address with as little confusion as possible, or fallback to the previous behavior in time for FF
16:23:57 <cr3> ara: ^^^ how does that sound to you?
16:24:47 <roadmr> checkbox-deluxe
16:25:20 <cr3> roadmr: if we name it checkbox-++, does one minus cancel one plus?
16:25:26 <roadmr> cr3: yes I guess
16:25:44 <cr3> checkbox+, just like google+, we'd be trendy!
16:26:06 <roadmr> ok so 1- user has a launchpad account and wants to submit with his email address
16:26:16 <roadmr> 2- user has NO launchpad account and wants to submit with his email address
16:26:22 <cr3> roadmr: it seems that we dispensed with the whole raising hand practice
16:26:53 <roadmr> 3- user wants to submit but not give his email address
16:26:58 <roadmr> 4- user doesn't want to submit at all
16:27:05 <cr3> roadmr: +1
16:27:52 <roadmr> so coming up with a UI that makes all those cases easy, with as little implicit behavior as possible (i.e. no "if you leave the email address blank and click "submit" we will make up an address and submit anonymously")
16:28:12 <roadmr> ..
16:28:30 <cr3> roadmr: should that be an action item?
16:29:05 <roadmr> cr3: ideally, but it has to be a quick action as FF is in a couple of days
16:29:37 <roadmr> [ACTION] Propose a way to handle the four use cases (see above) - preferrably with a mockup, maybe send to UF mailing list
16:29:37 * meetingology Propose a way to handle the four use cases (see above) - preferrably with a mockup, maybe send to UF mailing list
16:29:57 <roadmr> [ACTION] Decision made based on clearness and ease of implementation (due to time constraints)
16:29:57 * meetingology Decision made based on clearness and ease of implementation (due to time constraints)
16:30:24 <roadmr> sounds about right? I didn't put anyone in particular since at this point we'd be looking at any proposals that come in
16:31:48 <roadmr> OK anything else on this topic? ara, are you OK with this course of action?
16:32:20 <cr3> roadmr: sounds right to me
16:33:01 <ara> roadmr, yes
16:33:07 <ara> (I am OK)
16:33:22 <ara> roadmr, who are the owners of the action items?
16:33:47 <roadmr> ara: since it's about making proposals, I guess anyone who has an idea :)
16:34:02 <cr3> roadmr: I should take it since I opened the can
16:34:28 <roadmr> ok thanks!
16:34:57 <roadmr> ok then let's continue with this
16:35:10 <roadmr> Next on the agenda... the beloved...
16:35:11 <roadmr> [TOPIC] Any Other Business
16:35:28 <roadmr> Got anything Ubuntu Friendly-related you'd like to discuss or bring to the team's attention? now's your chance!
16:36:26 <roadmr> any takers? :)
16:38:12 <roadmr> ok then...
16:38:23 <roadmr> Well I guess this wraps things up for today. Thanks for attending! Remember the mailing list is open to all your UF-related comments and inquiries.
16:38:38 <roadmr> Thanks! have a good day!
16:38:55 <roadmr> #endmeeting