20:02:35 <AlanBell> #startmeeting
20:02:35 <meetingology> Meeting started Thu Feb  9 20:02:35 2012 UTC.  The chair is AlanBell. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
20:02:35 <meetingology> 
20:02:35 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
20:02:41 <oCean> o/
20:03:00 <AlanBell> #meetingtopic IRCC team meeting
20:03:07 <AlanBell> #meetingtopic IRCC team
20:03:11 <pangolin> o/
20:04:12 <AlanBell> hi all and welcome to the IRCC and team meeting
20:04:26 <Pici> hi!
20:04:26 <AlanBell> agenda is over here: https://wiki.ubuntu.com/IRC/IrcCouncil/MeetingAgenda
20:04:52 <AlanBell> and I think we can go fairly swiftly through the first section and on to some of the topics deferred from the last meeting
20:04:58 <AlanBell> so lets start
20:05:03 <AlanBell> #topic Review last meetings action items
20:05:10 <AlanBell> #progress AlanBell to call for helpers to implement eir-like functionality in ubottu
20:05:41 <AlanBell> yeah, I kind of failed to do that, however EvilResistance has just been talking about experimenting with some very relevant code
20:06:02 <AlanBell> I will do the mail to the list this evening and we can discuss that further in an agenda item down the list
20:06:09 <AlanBell> #progress meeting timeslots to be taken to the mailing list, 11:00UTC slot is in danger of being dropped
20:06:24 <Pici> sounds good
20:06:43 <AlanBell> we did discuss other times and picked this time for todays meeting
20:06:53 <theadmin> 11:00 UTC isn't really a comfortable time I beleive, sounds good for me too
20:06:56 <AlanBell> I kind of need to sort out the fridge calendar properly
20:07:14 <AlanBell> theadmin: yeah, we tried and couldn't find *anyone* who liked that slot
20:07:35 <Unit193> Jussi did though
20:08:04 <AlanBell> I am currently thinking we should have a predictable one every other sunday evening as it is now, and a less predictable one that bounces about
20:08:49 <AlanBell> not every other Sunday, every third or fourth sunday or something
20:09:18 <AlanBell> #action AlanBell to sort out fridge calendar entries
20:09:18 * meetingology AlanBell to sort out fridge calendar entries
20:09:44 <AlanBell> ok, any other comments on timings?
20:09:48 <Tm_T> yeah, meeting times could move a bit occasionally
20:10:07 <AlanBell> #topic Open items in the IRCC tracker
20:10:19 <AlanBell> there has been no activity to report
20:10:27 <AlanBell> #topic Review Bugs related to the Ubuntu IRC Council
20:10:46 <AlanBell> not much bug activity since the last meeting either, so lets whip through them fairly quick
20:10:52 <AlanBell> #subtopic bug 788503 IRC Guidelines too #ubuntu centric - tsimpson
20:10:54 <ubottu> Launchpad bug 788503 in ubuntu-community "IRC Guidelines too #ubuntu centric" [Undecided,In progress] https://launchpad.net/bugs/788503
20:11:32 <theadmin> That kind of makes sense. I think separate guidelines for -offtopic, -irc and -ops are required.
20:11:36 <AlanBell> there is a draft that should be linked to from the bug
20:11:59 <Tm_T> theadmin: there will be one guideline to rule them all
20:12:02 <pangolin> theadmin: I disagree the guidelines should be the same for all ubuntu* channels.
20:12:13 <Pici> aye
20:12:14 <LjL> i don't think separate guidelines are required, guidelines are guidelines, we have bot factoids for more specific things
20:12:15 <pangolin> I disagree, *
20:12:30 <theadmin> Well, either that or rule out the current guideline to be suitable for all the channels. Yeah, that sounds better.
20:12:47 <AlanBell> someone have a link to the draft handy?
20:12:48 <pangolin> what is the hold up on the draft?
20:13:10 <pangolin> hmm, it is on a kde.pad somesuch link
20:13:42 <Tm_T> I thought the draft was already approved and implemented :o
20:14:23 <pangolin> Tm_T: hasn't been changed on the wiki
20:14:43 <Tm_T> hohum
20:14:48 <Unit193> http://notes.kde.org/ubuntuguidelines
20:15:01 <Pici> The draft should be on the wiki in /irc/ somewhere imo.
20:15:28 <AlanBell> thanks Unit193, I added that to the bug
20:15:38 <AlanBell> ok, will have a look at that later
20:15:47 <AlanBell> #subtopic bug 884671 Ubuntu IRC operator recruitment is slow and ungainly - jussi
20:15:49 <ubottu> Launchpad bug 884671 in ubuntu-community "Ubuntu IRC operator recruitment is slow and ungainly" [Undecided,In progress] https://launchpad.net/bugs/884671
20:16:07 * Pici makes a note to look over the guidelines document
20:16:43 <AlanBell> recruitment is ongoing, we need to look at the other channel queues perhaps
20:16:58 <theadmin> That xD I'm here because I'm a wannabe op so that's of major interest for me. I'd be happy to help out really.
20:17:21 <AlanBell> great
20:17:32 <AlanBell> anyone know any channels in need of a call for ops?
20:17:40 <EvilResistance> i've put my name in for consideration for op on #ubuntu, so this was one of the items on the list that piqued my interest ;P
20:17:48 <EvilResistance> (for the record)
20:18:01 <Pici> When?
20:18:10 <pangolin> Doesn't the IRCC only do calls for the core channels?
20:18:17 <AlanBell> pangolin: yes
20:18:17 <EvilResistance> Pici:  last 7 days, dont bother with putting me onto any ops list without further vetting
20:18:22 <theadmin> Stuff which happens on #ubuntu nowadays is annoying, too many ciao-!list-italians (nothing we can do with them though), and huge mass of spambots and trolls :(
20:18:29 <theadmin> Ops care about that, but not always around
20:18:51 <EvilResistance> theadmin makes a point, there have been times i've seen spam occurring, pulled !ops, and it wasnt dealt with for a significant period of time
20:19:04 <EvilResistance> generally when freenode staffers are also not around, so going to them for emegency help doesnt work
20:19:04 <Tm_T> AlanBell: eh, we had this kind of discussion going on too?
20:19:16 <AlanBell> Pici: just asking if there is an urgent need in any particular area
20:19:22 * Tm_T needs to follow things more closely it seems
20:19:30 <pangolin> AlanBell: not at this time IMO
20:19:34 <oCean> I think -server probably still lacks op coverage every now and then
20:19:34 <Pici> AlanBell: I know.  My question was directed at EvilResistance.
20:19:47 <Tm_T> oCean: I don't see ops calls there happening
20:20:18 <AlanBell> Tm_T: well the general bug is about how we do recruitment, which we are in the process of doing with the #lubuntu channel and others will follow
20:20:31 <Pici> An ops responsibilities are more than just answering ¡ops calls.
20:20:43 <EvilResistance> Pici:  i've put my name into the queue on the launchpad site just 4 days ago, i removed it about 17 days before that after putting myself in for consideration because of several issues that occurred simultaneously in that same time period
20:20:45 <Tm_T> AlanBell: yeah, just that it's hidden in bug report (not mailinglist)
20:20:54 <AlanBell> anyhow, lets move on, I want to get to a bunch of the main topics
20:21:01 <Tm_T> Pici: I aknowledge, just wondering the need (:
20:21:02 <Pici> Aye
20:21:10 <theadmin> Hm, aye. Even though this one is important.
20:21:32 <AlanBell> Tm_T: well it is a bug report which is discussed in every meeting, so not very well hidden
20:21:52 <Tm_T> AlanBell: I know, I just haven't been following meetings, only mailinglist
20:21:56 <EvilResistance> (including but not limited to family issues)
20:22:01 <Tm_T> and poorly that too
20:22:03 <EvilResistance> s/issues/emergency items/
20:22:04 <pangolin> AlanBell: I think the current process is fine. IRCC makes a call, people apply, ask current ops opinions?? ,IRCC makes a decision .
20:22:11 <AlanBell> Tm_T: the one that I post the minutes to :)
20:22:19 <AlanBell> anyhow, lets crack on
20:22:27 <AlanBell> #subtopic bug 913541 there are a number of people with Ubuntu IRC cloaks who have expired from the ubuntumembers group - AlanBell
20:22:28 <ubottu> Launchpad bug 913541 in ubuntu-community "there are a number of people with Ubuntu IRC cloaks who have expired from the ubuntumembers group" [Undecided,In progress] https://launchpad.net/bugs/913541
20:22:52 <AlanBell> no further progress on this one, down to about 15 I think, we will do more on that soon
20:22:59 <AlanBell> #subtopic bug 916247 devel wiki on ubottu.com needs some attention - AlanBell
20:23:00 <ubottu> Launchpad bug 916247 in ubuntu-community "devel wiki on ubottu.com needs some attention" [Undecided,In progress] https://launchpad.net/bugs/916247
20:23:27 <Pici> Are we still going to move this to wiki.u.c?
20:23:34 <AlanBell> it was cleaned up which is great, and it would be nice to migrate the content on to wiki.ubuntu.com still
20:24:16 <theadmin> I think that'd be a good point... I didn't even know ubottu had it's own wiki o_o
20:24:29 <AlanBell> I think moving it is a low priority now that it has been de-spammed
20:25:56 <Pici> k
20:25:56 <AlanBell> theadmin: it only has a small number of pages http://ubottu.com/devel/wiki/Special:AllPages
20:26:15 <AlanBell> ok, lets get on to the main topics now
20:26:17 <theadmin> In that case, merging it with the main wiki makes most sense
20:26:23 <AlanBell> #topic The plan for the bots
20:26:25 * funkywhat grumbles. Sorry I'm late everyone
20:26:30 <AlanBell> hi funkywhat o/
20:26:41 <theadmin> ohai
20:27:22 <Pici> This is a rather vauge topic.
20:27:24 <AlanBell> so EvilResistance has some plans for eir-like ban timeout removals which is great
20:27:28 <funkywhat> My cheap VPS picked a choice time to decide to die
20:27:31 <AlanBell> it is a vauge topic
20:28:05 <EvilResistance> AlanBell:  you should, in fact, be giving niko the credit.
20:28:25 <pangolin> what is the plan?
20:28:39 <EvilResistance> i started looking for eir-like bantracker and ban removal functionality about a month ago for #trekweb, my group's channel, and niko presented the ubotufr code.
20:28:51 <EvilResistance> Bundled up in it is a Channel plugin that has integrated bantracker and ban removal
20:29:05 <LjL> EvilResistance: so this would replace the existing bantracker entirely?
20:29:45 <EvilResistance> LjL:  its been a while since i've dug around in the current structure of #ubuntu and related channel bantrackers, but it could indeed.
20:30:03 <EvilResistance> thus far, i've tested the +q and +b tracking functionality with success
20:30:12 <EvilResistance> and confirmed autoremoval of bans does operate
20:30:14 <LjL> I'll just say, keep in mind that things need to scale. #ubuntu is big, and it's possible that something that works for smaller channels does not for it...
20:30:15 <pangolin> I think we need something that would use the existing bantracker
20:30:30 <AlanBell> yeah, I think so too
20:30:36 <EvilResistance> pangolin:  if i might inquire, what is the current bantracker?
20:30:42 <LjL> pangolin: well, the existing bantracker does have its own set of issues, and there have been previous attempts to replace it.
20:30:52 <theadmin> Agreed. The current one seems to work fine, though I've seen accidents (like it unbanning people ops have just banned)
20:31:05 <LjL> theadmin: that's not the bantracker, that's eir
20:31:08 <theadmin> Oh
20:31:12 <theadmin> What is eir if I may ask
20:31:14 <theadmin> ?
20:31:19 <pangolin> LjL: my concern is to not lose the data we have gathered in the bantracker.
20:31:20 <EvilResistance> eir's freenode's utility bot
20:31:25 <LjL> The bantracker is have is a private website that we use to keep logs of bans.
20:31:31 <theadmin> EvilResistance: Ah, thanks.
20:31:35 <LjL> pangolin: yes, that should be migrated in case of a replacement.,
20:31:37 <EvilResistance> it has bantracker functionality built in.
20:31:39 <EvilResistance> theadmin:  see #defocus :P
20:31:46 <EvilResistance> its also the voice-bot there
20:31:52 <Pici> EvilResistance: any new bantracker will need to have the old bans migrated into it.
20:32:18 <EvilResistance> indeed.
20:32:36 <niko> i doubt sqlite can handle that :)
20:32:42 <theadmin> That too, and that might be a problem depending on database structures.
20:33:37 <AlanBell> I am mainly thinking that ubottu needs to grow some code for ban timeouts, which might well be releated to code existing in ubottufr
20:33:41 <AlanBell> or might not
20:33:51 * Pici too
20:33:58 <pangolin> +1
20:34:03 <theadmin> I apologize for my lack of knowledge (is my first time here), but isn't ubottu mainly just a factoid bot?
20:34:05 <AlanBell> plus there are a heap of other plugins in the ubottufr codebase which do interesting things
20:34:13 <Myrtti> theadmin: no, not really
20:34:23 <AlanBell> theadmin: that is the tip of a fairly substantial iceburg
20:34:30 <pangolin> theadmin: the user facing part of it yes.
20:34:31 <EvilResistance> theadmin:  if i'm not mistaken, its also got bugtracker modules in it, amongst other supybot modules which are available
20:34:40 <theadmin> Ah yeah the bugtracker
20:34:43 <theadmin> I see
20:35:01 <Pici> And the package info stuff.
20:35:07 <Tm_T> it also nags to us
20:35:13 <Tm_T> nagity nagity nag
20:35:15 <AlanBell> and the floodbot integration
20:35:16 <Tm_T> <3
20:35:43 <Unit193> Generally, http://ubottu.com/devel/wiki/Plugins
20:35:54 <LjL> Anyway, I'd personally be looking for a short term solution right now, i.e. hacking ban removal into ubottu.
20:35:57 <pangolin> I think the best thing would be to implement fresh code or translate some of niko's code if applicable and make it work with what we have.
20:36:08 <LjL> Then replacing the bantracker would still be something to be considered (because it *is* old).
20:37:03 <AlanBell> yup, agreed
20:37:12 <AlanBell> ok, so some actions arising from this?
20:37:28 <pangolin> ask for help from the users
20:37:50 <pangolin> email the users list and see who is willing to hack at ubottu
20:37:58 <pangolin> or help hack it
20:38:20 <AlanBell> ok. I will do that this evening
20:38:45 <AlanBell> #action AlanBell to mail the list asking for help to add ban timeout removal to ubottu
20:38:45 * meetingology AlanBell to mail the list asking for help to add ban timeout removal to ubottu
20:38:49 <pangolin> include what channel and who to talk to :)
20:39:10 <theadmin> ubottu is python right?
20:39:10 <ubottu> theadmin: I am only a bot, please don't think I'm intelligent :)
20:39:12 <AlanBell> in the email, right
20:39:12 * theadmin considers
20:39:18 <AlanBell> theadmin: yes, she is
20:39:19 <EvilResistance> theadmin:  ubottu's supybot if i remember right...
20:39:20 <pangolin> theadmin: yeah
20:39:23 <LjL> Remember there is still #ubuntu-bots-team. I think even though it's little used, people who want to brainstorm *should* do it there.
20:39:48 <AlanBell> LjL: yes, that is where I was going to say in the mail
20:40:06 <AlanBell> ok, lets move on for now
20:40:10 <EvilResistance> forgive the ignorance, but which mailing list is the users mailing list?
20:40:16 <AlanBell> #topic Definition of where official announcements from the IRCC will be made for those with a need for no discussion but announcements - jussi
20:40:50 <AlanBell> ubuntu-irc@lists.ubuntu.com
20:40:50 <pangolin> EvilResistance: ubuntu-users@list.ubuntu.com iirc
20:40:54 <pangolin> ah that
20:41:15 <Pici> Isn't there a news/fridge thing on the planet too?
20:41:23 <jussi> well, Im here...
20:41:28 <pangolin> jussi: :)
20:41:29 <AlanBell> so this item from jussi was asking where we announce things
20:41:35 <AlanBell> jussi: \o/
20:41:35 <pangolin> Pici: asking planet is a good idea also
20:41:44 <LjL> Last time, someone (maybe me) was saying that those of you who blog, could agree on a "tag" to use for IRCC-related stuff...
20:42:27 <AlanBell> personally I am kind of keen on announcing things in meetings so they are minuted, and sending to the mailing list and or news team as appropriate
20:43:08 <jussi> as I said in the background, I would like to have a central place all these things are - the problem with ircc'ers individual blogs are that they change, if you were looking for all the announcements now, where would you need to go, my blog, topyli's, elkys etc etc
20:43:22 <LjL> jussi: hence a tag
20:43:23 <Tm_T> AlanBell: meetings good, but should never be that alone (:
20:43:26 <Pici> A dedicated place on the wiki could be used then
20:43:32 <LjL> jussi: if you're aggregated on the planet, one could search for that, no?
20:43:32 <jussi> I think we can learn from freenodes successful blogging here
20:43:33 <AlanBell> yeah, I don't think blogs are so great
20:43:36 <theadmin> A tag for all blog's and then a central aggregator, sure
20:44:21 <Tm_T> in the end, best way to catch irc people is, tadaa, irc /:
20:44:28 <theadmin> Then again I don't blog lol
20:44:40 <AlanBell> Tm_T: yes, which is why I like IRC meetings :)
20:44:55 <Tm_T> AlanBell: that way there's mailing list trace too
20:45:03 <theadmin> Yeah IRC
20:45:06 <jussi> Tm_T: but irc sucks for this kinds of stuff. its hard to parse, hard for finding old stuff
20:45:11 <Tm_T> but nothing stops doing blogs too
20:45:15 <Tm_T> jussi: I know
20:45:19 <jussi> doesnt suit longer announcements.
20:45:22 <LjL> But I do kind of agree with AlanBell, the actual/official/whatever-you-call-it place to announce things should be on the mailing list (which can come on its turn from meeting minutes), the rest being accessory.
20:45:26 <theadmin> Mailing lists are need, although... Say, are Ubuntu's mailing lists available as RSS feeds?
20:45:38 <LjL> jussi: but you have minutes from the meetings on the mailing list
20:45:38 <funkyHat> Planets don't keep reasonable amount of history, I don't think, so that's probably not ideal
20:45:39 <Tm_T> jussi: don't ask how often I grep through my multigigabyte logs...
20:45:57 <AlanBell> https://wiki.ubuntu.com/MeetingLogs/IRCC
20:47:15 <AlanBell> I think there is a disconnect here, between "the official place to announce stuff" and "places to get announcements read and archived by lots of people"
20:47:21 <Tm_T> irc meetings covers irc and mailinglist, people can write longer announcements to mailinglist after/before the meeting and the same message can be blogged...
20:47:34 <AlanBell> and it isn't just announcements I think
20:48:00 <jussi> AlanBell: minutes are one thing, blog posts are another. the blog posts are supposed to have the deeper explanation of what the ircc has done, and perhaps why. Its announcements, but with reason as well.
20:48:13 <AlanBell> so things like a call for ops gets announced in a meeting, gets mailed to the list, goes to the news team
20:48:19 <Pici> I don't think that there can be only one place for announcements.
20:49:29 <Tm_T> Pici: I agree
20:49:48 <AlanBell> jussi: are you proposing specifically that the IRCC set up a blog somewhere?
20:49:49 <Tm_T> but there has to be one starting point, from where you then spread it further
20:50:09 <Pici> The wiki makes the most sense to me.
20:50:17 <jussi> AlanBell: yes, I am. making a multi user blog is minimal work.
20:50:19 <theadmin> Agreed. Mailing lists aren't central, blogs have the same problem to a degree... I guess if we had a central blogs/news site it would work
20:50:52 <jussi> we could have one up on ubottu.com in a short time
20:51:02 <Pici> I think the IRC team landing page on the wiki is the best place.
20:51:07 <AlanBell> jussi: it is minimal work, but an empty blog is a sad sad thing, we need to know if it is something we can love and care for
20:51:45 <AlanBell> this page Pici? https://wiki.ubuntu.com/IRC/IrcTeam
20:51:46 <Unit193> I have found more info in blogs in the past
20:51:56 <jussi> AlanBell: yes, agreed. that of course is something for the ircc to decide if thwey can maintain.
20:52:17 <theadmin> Then again blogging usually means more or less long announcements
20:52:25 <jussi> AlanBell: what Im proposing is somethign like the freenode blog
20:52:34 <theadmin> For something short we could probably set up a status.net setup or something...
20:52:38 <theadmin> I dunno even
20:52:40 <AlanBell> http://blog.freenode.net/
20:53:13 <theadmin> jussi: We know :) AlanBell tries to make a point that not all members would care for it
20:53:21 <theadmin> jussi: Maybe, that is
20:53:35 <AlanBell> well we could post meeting minutes there at least
20:54:12 <Myrtti> freenode does have a facebook/google+/twitter/identica-accounts for quick "oh noes, verne kicked the bucket" messages...
20:54:17 <jussi> Im really sorry, need to go tend to the little one, I think Ive made my point though
20:54:27 <AlanBell> thanks jussi
20:54:37 <Tm_T> Myrtti: and wallop (so irc)
20:54:50 <Tm_T> jussi: give a hug from me
20:54:57 <AlanBell> so it wouldn't be much effort to set up a blog, but it is one more thing to have and maintain
20:55:10 <Myrtti> Tm_T: if something on freenode side is broken, people don't have access to it necessarily...
20:55:16 <AlanBell> and probably wouldn't get used massively often
20:55:23 <Myrtti> so it has to be offsite as well
20:55:25 <Tm_T> Myrtti: yup, thus not relying on just one
20:55:34 <Tm_T> medium
20:56:22 <AlanBell> gah, we need to move on, I think we need to consider this and decide next meeting
20:56:25 <pangolin> I think I agree with AlanBell that irc stuff should be done on irc and also with pici in backing it up with w.u.c
20:56:37 <Tm_T> anyway, I think things should be said on irc meeting, thus mailinglist, and if there's anything worth a blog post, then do that too
20:56:40 <Tm_T> but in this order
20:56:45 <AlanBell> yes
20:56:47 <LjL> agreed
20:56:51 <theadmin> Sounds great for me
20:56:57 <Pici> yes
20:57:02 <pangolin> yup
20:57:03 <funkyHat> ok
20:57:06 <LjL>20:57:17 <pangolin> we have consensus.
20:57:24 <pangolin> the Borg prevail
20:57:24 * funkyHat asplodes
20:57:27 <AlanBell> so I think we can agree that "the definition of where official announcemnets will be made" is in an IRCC meeting
20:57:35 <Tm_T> yes
20:57:36 <theadmin> Yeah :)
20:57:47 <AlanBell> and then we communicate out from there, in routes which may or may not include a team blog at some point
20:58:23 <AlanBell> #agreed official announcements from the IRCC will be made in IRCC meetings on IRC with minutes and articles distributed as appropriate
20:58:35 <AlanBell> #topic Using bots to inform users about #ubuntu-ops (and their expected behavior there) when they are banned - LjL
20:58:46 <AlanBell> yeah, lets do that :)
20:58:54 <LjL> ok so my proposed announcement for the bot to give would be
20:59:07 <LjL> You have been banned from #ubuntu. If you believe this ban was in error or want to appeal it, join the channel #ubuntu-ops and discuss it. Please be calm and patient and avoid being confrontational while there. Your ban will only be resolved if the operators can be convinced you can act reasonably.
20:59:15 <LjL> like yes/no
20:59:26 <theadmin> Replace #ubuntu with $channel or something like that.
20:59:36 <theadmin> But otherwise looks good heh
20:59:54 <LjL> sure
20:59:58 <theadmin> Should be in a privmsg imo
21:00:03 <pangolin> I would remove "Your ban will only be resolved if the operators can be convinced you can act reasonably."
21:00:10 <theadmin> Otherwise the user might not notice it.
21:00:19 <LjL> it would certainly be in PM
21:00:22 <funkyHat> pangolin: why?
21:00:26 <AlanBell> theadmin: it would have to be, they have just been kicked out of the channel
21:00:38 <pangolin> might invite some to act as if they will follow the guidelines only to have the ban removed and continue trolling/whatever got them banned.
21:00:41 <theadmin> AlanBell: My point -- most clients close the window on part/kick
21:01:01 <LjL> if the floodbots are going to do this, though, it will only work for #ubuntu. otherwise ubottu could do it I guess, but in that case I'm not sure I could implement it myself.
21:01:16 <AlanBell> ah, good point
21:01:53 <theadmin> Hm yeah
21:02:05 <oCean> I agree with pangolin, not sure how to rephrase that last part yet
21:02:18 <AlanBell> I think it would probably be best done by ubottu (or the floodbots would have to figure out which one is doing the messaging)
21:02:31 <pangolin> otherwise I like the idea and we should get it started asap
21:02:39 <LjL> AlanBell: that shouldn't be a problem, the floodbots already decide that among themselves with other kinds of messages
21:02:45 <AlanBell> ok
21:03:12 <LjL> The thing is, with the floodbots, I could do it within the next 10 minutes in all likelihood, with ubottu, who knows.
21:03:16 <AlanBell> anyhow, having it in ubottu makes sense to me, could be useful for all the lubotu clones but sending to #ubuntu-irc
21:03:30 <pangolin> I need to step away. thanks for the good meeting folks.
21:03:49 <AlanBell> #agreed private message from bots on ban explaining how to get to #ubuntu-ops would be a good feature
21:04:02 <AlanBell> #topic Concerns about using goo.gl short links in the topic/bot due to Google's privacy policy changes - LjL
21:04:17 <AlanBell> ok, for this one I believe we are all sorted LjL?
21:04:26 <Pici> Are we?
21:04:39 <Pici> Or can the rest of us be enlightened?
21:04:42 <AlanBell> and yeah, we are running slightly over time
21:04:52 <LjL> About this one, in case anyone missed the news, Google are changing their privacy policy, and they will aggregate all data from users among their various services.
21:05:04 <LjL> I don't like us supporting that aggregation, and I would rather switch to a different shortener.
21:05:15 <LjL> I've set up one on ubottu.com that could serve our purpose.
21:05:31 <theadmin> That sounds great, I wanted to suggest using our own as well.
21:05:52 <theadmin> Because that will never change rules without our approval.
21:05:54 <Pici> I'd prefer something that doesn't break if ubottu.com goes down.
21:06:01 <LjL> Advantages are: it has detailed statistics we can use; it can allow things like http://ubottu.com/y/gl for the Guidelines URL, i.e. our custom shortcuts
21:06:22 <LjL> Pici: anything can go down, can it not?
21:06:42 <theadmin> Yeah that's just paranoia pici, anything goes down. Sorry, no offense but >.<
21:06:44 <AlanBell> Pici: well if ubottu.com goes down then ubottu won't be handing out factoids with links in them
21:06:55 <LjL> AlanBell: although there is still the channel topic
21:07:06 <LjL> which is where most "short" links are currently found
21:07:41 <AlanBell> yeah, it isn't a general purpose public shortening service, just for topic links and factoid contents, with links being created by any ops
21:08:10 <theadmin> What's the point of shortening links anyway? Most lead to pages with pretty short URLs anyway, I don't really see long ones. Then again it's good to have things like that at handy
21:08:17 <LjL> But I do think when ubottu.com goes down, we have worse concerns than the links
21:08:24 <LjL> like missing the bot, the bantracker and ALL THE THINGS
21:08:35 <Pici> Beacuse the topic and factoids are limited by the number of characters they can be
21:08:42 <LjL> theadmin: http://help.ubuntu.com/community/Blah is not very short ;)
21:08:59 <theadmin> LjL: Not really, much shorter than URLs I keep accidentally pasting from Google searches
21:09:07 <AlanBell> I was tempted to get a really short URL for it by I couldn't find a nice one available
21:09:22 <AlanBell> anyhow, lets move on as this topic is mostly resolved I think
21:09:35 <AlanBell> #topic Rename "probation" to "induction" in the IRC operator recruitment process - AlanBell
21:09:41 <theadmin> Agreed, let's decide on ubottu.com shortener for that one and move on
21:09:42 <AlanBell> what do you think of this?
21:09:54 <LjL> what's in a name
21:10:07 <theadmin> hhmmmm... In my opinion it should be just called "testing period" :/ Neither "probation" nor "induction" make much sense to me
21:10:07 <AlanBell> I think probation is a bit negative sounding
21:10:28 <Tm_T> theadmin: testing?
21:10:41 <theadmin> Tm_T: Isn't it just that? Testing the new op?
21:10:43 <LjL> well, as a speaker of not-English as a native language, I understand neither "probation" nor "induction", so no difference for me :P
21:10:43 <AlanBell> it is more of an introductory/training period
21:10:54 <Pici> probationary period makes sense too though
21:10:58 <AlanBell> theadmin: well that would be probation
21:11:08 <Tm_T> theadmin: we don't do any tests
21:11:12 <funkyHat> probation makes sense but I agree it does sound somewhat negative. I would prefer induction
21:11:24 <EvilResistance> theadmin:  perhaps "observation period"?  if you want to get rid of the potential condescending nature of the word "probation"
21:11:34 <theadmin> EvilResistance: That actually sounds good
21:11:36 <Tm_T> introduction?
21:11:40 <theadmin> That too
21:11:47 <theadmin> Actually much a wide topic xD
21:11:50 <Tm_T> I did read induction first as introduction
21:11:52 <theadmin> Could call it anything
21:12:01 <LjL> I do suspect it originally was intended as a period when you not only train the op, but also decide whether they're quite ready to be an op. Not sure that has ever been spelled out explicitly, but...
21:13:13 <AlanBell> LjL: well to me "induction" emphasises training and introductory stuff, "probation" emphasises observation and testing and the possible failing to be accepted
21:13:44 <AlanBell> when that isn't really what we want to be doing, we want people to be helped to be good ops
21:14:15 <Pici> Its a hand-holding period. I think thats more that just observation.
21:14:23 <AlanBell> yes
21:14:55 <theadmin> I still wish we'd use something which'd be obvious to non-native speakers *without* google translate :D
21:15:05 <theadmin> "induction" is not a word you hear often
21:15:18 <Myrtti> apart from induction stoves
21:15:22 <Myrtti> :-|
21:15:22 <Tm_T> ^
21:15:55 <AlanBell> ok, it is pretty standard terminology in the UK, I don't know what it is called in other countries when you get a job
21:16:08 <oCean> probation
21:16:16 <EvilResistance> AlanBell:  probationary or introductory period
21:16:16 <Tm_T> probation here atleast
21:16:56 <LjL> "introductory period" sounds good to me
21:17:17 <AlanBell> yeah, that is OK
21:17:23 <oCean> yep, sounds fine
21:17:38 <Tm_T> I'll slip to my other duties, bye all
21:17:41 <theadmin> Sounds good although doesn't point out the "may get rejected" part
21:18:14 <AlanBell> yeah, I don't think we need to point that out quite so loudly :)
21:18:33 <Pici> I'm sure if the situation comes to that the wording of the period will be the least of our worries.
21:18:42 <Myrtti> in theory all of us could be demoted if we decide to act up and burn the channel with us
21:18:59 <AlanBell> indeed, we can deal with those kind of situations, I am just seeking to use more positive language
21:19:21 <AlanBell> Myrtti: you could indeed ;)
21:19:24 <elky> "support may be withdrawn"
21:19:32 <LjL> Yeah but on the other hand, if it's clear that the possibility exists especially during that period, maybe it'll make it easier if it does happen, I don't know
21:19:36 <funkyHat> Ok, I'm happy with introductory perido too
21:19:44 <theadmin> Yeah. Let's have that :)
21:19:48 <AlanBell> ok, I think a vote is in order
21:19:59 <AlanBell> #voters Pici AlanBell funkyHat
21:19:59 <meetingology> Current voters: AlanBell Pici funkyHat
21:20:29 <AlanBell> #vote change op recruitment terminology from "probation" to "introductory period"
21:20:29 <meetingology> Please vote on: change op recruitment terminology from "probation" to "introductory period"
21:20:29 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
21:20:37 <AlanBell> +1
21:20:37 <meetingology> +1 received from AlanBell
21:20:37 <Pici> +1
21:20:37 <meetingology> +1 received from Pici
21:20:39 <theadmin> +1
21:20:41 <funkyHat> +1
21:20:41 <meetingology> +1 received from funkyHat
21:20:45 <AlanBell> #endvote
21:20:45 <meetingology> Voting ended on: change op recruitment terminology from "probation" to "introductory period"
21:20:45 <meetingology> Votes for:3 Votes against:0 Abstentions:0
21:20:45 <meetingology> Motion carried
21:20:46 <Pici> theadmin: you're not funkyHat!
21:20:54 <oCean> AlanBell: I would not mind moving the other agenda items to next meeting..
21:21:03 <AlanBell> oCean: great, I was going to suggest that
21:21:05 * Pici too
21:21:14 <theadmin> Pici: Indeed I'm not... Sorry, didn't realize I may not cast a vote
21:21:20 <AlanBell> oCean: I will mention them in the minutes mail so people see them before the next one
21:21:33 <oCean> great
21:21:34 <AlanBell> theadmin: don't worry its fine, the bot is clever like that and ignored you
21:21:37 <Pici> theadmin: its fine :P
21:21:49 <AlanBell> next meeting is on Sunday the something or other at 6PM
21:22:00 <funkyHat> I've been impersonated before, and I'll be impersonated again ;)
21:22:00 <oCean> thanks all o/
21:22:12 <EvilResistance> funkyHat:  it happens to all of us :P
21:22:21 <AlanBell> Sunday 26th I think
21:22:27 <AlanBell> #endmeeting