20:02:06 <gilir> #startmeeting Lubuntu Team Meeting
20:02:06 <meetingology> Meeting started Wed Feb  8 20:02:06 2012 UTC.  The chair is gilir. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
20:02:06 <meetingology> 
20:02:06 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
20:02:14 * wxl just added one last item…
20:02:20 <gilir> hi :)
20:02:41 <Yorvyk> o/
20:02:46 <phillw> o/
20:02:53 <leszek> :)
20:03:04 <gilir> as usual, agenda available on https://wiki.ubuntu.com/Lubuntu/IRC%20Meetings/Agenda
20:03:16 <wxl> _/\o/\_
20:03:19 <wxl> ;)
20:03:54 <gilir> and as a quick note, sorry for being quite this past few days, it should be ok now :)
20:04:54 <rafaellaguna> Everybody has personal life
20:05:11 <Yorvyk> OK the rest of us managed to make enough noise to compensate :)
20:05:21 <gilir> phillw, I don't see any actions items from last meeting, so I'm moving to the items :)
20:06:14 <gilir> #topic phillw - Weekly report - Update from QA meeting and team
20:06:46 <phillw> I brought up that the ppc alternate vanished from alpha2 area. It appears a misunderstanding
20:07:08 <wxl> did it vanish now?
20:07:12 <wxl> i thought it was just huge :D
20:07:12 <phillw> they thought no-one was testing it. They're going to try an get us a CD sized alternate for ppc built :)
20:07:24 <leszek> its playing seek and hide :P
20:08:00 <gilir> phillw, alpha2 was a bit messy :/
20:08:04 <wxl> we have at least 5 potential testers. would be nice to have more. i noticed today that qemu can emulate ppc if others are interested
20:08:08 <phillw> one of the tresters did actually install onto a ppc - but I've not had any further news yet.
20:08:36 <gilir> wxl, what is the actual state of ppc daily (alternate and live) ?
20:09:04 <wxl> gilir: daily-live is cd sized but is buggy and will not install successfully in my experience
20:09:05 <phillw> gilir: the normal one is on-size, alternate is over-size.
20:09:27 <wxl> gilir: as for alternate it is too large-- which makes no logical sense but is what it is (in fact last time i checked ALL the alternates were oversized)
20:09:57 <gilir> #action gilir to reduce size of ppc alternate daily
20:09:57 * meetingology gilir to reduce size of ppc alternate daily
20:09:57 <leszek> wxl: maybe taskel issue here
20:10:36 <phillw> wxl: has an update on testing the 'norma' installation.
20:10:39 <wxl> gilir: check http://cdimage.ubuntu.com/daily/current/ -- they are ALL oversized still, not just ppc
20:10:41 <gilir> I should be able to reduce the size, if there is a bug on another part, we will have time to find it
20:10:58 <gilir> ouch :/
20:11:29 <wxl> downloaded the latest x86 daily-live and it would not boot. seems like the same old crashing dm issue-- not the one where the greeter fails and you can still log in
20:11:31 <leszek> My guess the alternative iso stores too many packages. Even uneeded ones
20:11:51 <gilir> there is still unity on the alternate :/
20:12:04 <leszek> that might be it
20:12:05 <gilir> ok, I'll check this
20:12:34 <wxl> in any case, the lightdm-gtk-greeter and/or unity-greeter issue is still not resolved :(
20:12:39 <rafaellaguna> (sorry, back to PC)
20:13:40 <gilir> wxl, I can't tell now, need to check what's wrong, I'm still not up-to-date with precise recent chenges
20:13:59 <wxl> gilir: no prob, just make an action ;)
20:14:11 <gilir> phillw, anything else from QA ?
20:14:24 <rafaellaguna> there're still people asking if we're using unity or lxdm greeters
20:14:50 <phillw> gilir: nothing to add.
20:15:01 <gilir> rafaellaguna, the goal is to used the lightdm-gtk-greeter, no unity-greeter, no lxdm
20:15:14 <gilir> and of course, no unity by default :)
20:15:34 <gilir> phillw, thanks :)
20:15:34 <StephenSmally> sorry i'm late
20:15:35 <rafaellaguna> I know, that's a thing to control, the rumours even fall into Unity
20:15:50 <phillw> 918401 had the most recent news I am aware of.
20:15:50 <rafaellaguna> there is a lot of noise with these alphas
20:16:09 <gilir> Unit193 doesn't seem here, moving to next item
20:16:35 <gilir> #topic phillw - Weekly report - Update from comms team
20:17:25 <phillw> the comms team is restructuring, I'll have more news hopefully, next week.
20:17:31 <wxl> :)
20:18:28 <gilir> phillw, IMO it's something we have to discuss in private with all the members of the team
20:18:56 <phillw> indeed.
20:19:32 <gilir> phillw, let's move to the next item if you don't have anything to add
20:19:57 <gilir> #topic Unit193 - Weekly report - Update from IRC OP's team
20:20:48 <Unit193> Right, there's been a problem user that hasn't listened to rules, the IRC team stuff is still pending as far as I know
20:21:56 <Unit193> There was some thought about adding us on the site to clean up spam there too though
20:22:23 <gilir> Unit193, which site ?
20:22:49 <Unit193> lubuntu.net, but that may have been a thought
20:23:18 <phillw> mario did request some extra eyes.
20:23:34 <gilir> Unit193, not sure it's should be the job of IRC team, but if you want to help, I'm sure it will be appreciate :)
20:23:39 <Unit193> Anything else I'm missing, others here?
20:24:04 <wxl> i'll say one thing
20:24:21 <wxl> since i was the innocent recipient of the "dialogue" from this problem user
20:24:38 <wxl> it might be good to have a published plan of action on what to do for the support folks
20:24:52 <wxl> cuz i would have prolly just let it slide/forgotten about it
20:25:44 <Unit193> He's been a problem with us quite a few times, and in another channel too
20:26:36 <leszek> so they are only two possible ways, either ignore him or act and warn/kick maybe ban him
20:26:48 <wxl> i don't mean that kind of action
20:27:16 <wxl> more about reporting it to the appropriate parties which phillw was kind enough to alert me to but i suspect there are others in support (and the future support team) that may not have this knowledge
20:28:16 <Unit193> leszek: When he tries to join, he'll be redirected to #ubuntu-ops
20:28:28 <leszek> ah ok
20:29:23 <gilir> Unit193, anything to add ?
20:29:39 <Unit193> Nothing more unless someone else can think of it
20:29:53 <gilir> ok thanks Unit193 :)
20:30:12 <phillw> Unit193: can we put our heads together to get something for support after the meeting.
20:30:22 <gilir> amjjawad doesn't seem to be here, moving to next
20:30:45 <gilir> #topic gilir - Weekly report - Update from Devs teams
20:31:12 <gilir> alpha 2 was released, but only for alternate
20:31:38 <phillw> just for the record, amjjawad is away for a month, I'll try and keep up with what is going on for him. any of the support team can give me a ping / email.
20:31:39 <gilir> the live ISO was fixed just the day of the release
20:31:56 <gilir> phillw, ok, thanks for the news
20:31:57 <wxl> um, "fixed?" ;)
20:32:30 <gilir> wxl, yes but maybe it's another problem
20:32:50 <gilir> also, we are now very close to Feature Freeze
20:33:22 <gilir> it means, no new feature, no new version (unless bug fixes only) can be added after this freeze
20:33:34 <MrChrisDruif> Aloha
20:33:40 <leszek> yep and I hope the new lxkeymap will make it in time
20:33:56 <gilir> so after February 16th, it's closed ! :)
20:34:00 <rafaellaguna> sure yes, unlike lxlauncher
20:34:06 <MrChrisDruif> I thought there could be made exceptions to this Feature Freeze?
20:34:21 <StephenSmally> rafaellaguna: i wasn't planning a release for precise
20:34:25 <wxl> lxlauncher won't make it? :(
20:34:32 <gilir> leszek, please give us some time for the packaging also :)
20:34:43 <leszek> :)
20:34:48 <rafaellaguna> StephanSmally: it would be crazy, better next release
20:35:07 <gilir> for now, only lsc and lxkeymap (the previous version) are on time for feature freeze
20:35:20 <MrChrisDruif> rafaellaguna; it *could* always be backported if it's important enough
20:35:35 <gilir> it means, no lxfind, no lxlauncher v2 by default
20:35:52 <StephenSmally> and no lxscreenshot i think
20:35:54 <gilir> MrChrisDruif, yes, exception are possible, but it should be really exceptions :)
20:35:59 <leszek> gilir: but we can package lxkeymap 0.7.99 and then fix it up til release I hope
20:36:02 <rafaellaguna> agree with gilir about changes
20:36:03 <gilir> StephenSmally, yes also
20:36:30 <StephenSmally> ok, both lxscreenshot and lxlauncher needs to be improved, so no problem
20:36:30 <gilir> leszek, you don't plan to add more features ?
20:36:47 <leszek> no its feature complete basically
20:36:58 <leszek> it only needs bugfixing
20:37:09 <StephenSmally> (anyway i can't get this ubuntu love for feature freeze ;-P )
20:37:21 <gilir> leszek, ok, so we can update it as if for feature freeze, but it needs to be fixed for Beta 1 (01/03)
20:37:27 <rafaellaguna> leszek: (cof) and (cof) icon remapping (cof)
20:37:31 <leszek> StephenSmally: its a necessasity
20:38:11 <gilir> StephenSmally, it's not a love :) Just a rule :)
20:38:13 <MrChrisDruif> Btw, at which topic are we?
20:38:18 <StephenSmally> well, i get it speaking about software on the os iso, but i don't get it with the software in the repo
20:38:25 <leszek> gilir: yeah it needs to be fixed thats the problem right now, because I don't have much time fixing it
20:38:49 <StephenSmally> leszek: i can help in bug fixing if necessary
20:39:05 <leszek> StephenSmally: that would be really great
20:39:19 <StephenSmally> are all the bug listed on launchpad?
20:39:34 <StephenSmally> (or git or something similar)
20:39:35 <leszek> no not yet
20:40:29 <leszek> I will list them, but you can also see the bugs in this short video I made: http://www.youtube.com/watch?v=xXIMOsYG6h4
20:41:21 <MrChrisDruif> Maybe I've got something for the current topic
20:42:00 <MrChrisDruif> It's what you could call a "bug" of the lubuntu-core meta-package
20:42:03 <StephenSmally> ok, i will take a look, are only graphic bug or also keymap handling bugs?
20:42:29 <leszek> StephenSmally: keymap handling is fine
20:42:46 <MrChrisDruif> If you look at the depends and recommends diffs between oneiric and precise, you'll be surprised
20:42:49 <StephenSmally> so graphic refining
20:43:03 <gilir> StephenSmally, we can have a look at it after feature freeze, priority IMO is to release lsc ;)
20:43:17 <gilir> StephenSmally, but we can talk about it later or after the meeting
20:43:20 <leszek> so only graphical bug so far. The profile manager I added is also misbehaving somehow when you are deleting keymap profiles
20:43:23 <StephenSmally> yep
20:43:39 <MrChrisDruif> Alright, just ignore what I just said ^_^
20:43:42 <leszek> k
20:44:12 <gilir> and to finish the dev report
20:44:37 <gilir> unfortunatly, the new session manager will probably not be ready for next week :/
20:44:55 <leszek> xD
20:45:00 <rafaellaguna> :|
20:45:26 <gilir> I'm not sure I'll be able to fix it (and the other part of LXDE) before the release, so it's probably safer to keep the current one for 12.04
20:45:50 <gilir> sorry :(
20:46:08 <MrChrisDruif> gilir; will we then be seeing a lightweight solution to the heated discussion of the mailing-list?
20:46:10 <wxl> yikes
20:46:19 <MrChrisDruif> The clipboard manager issue?
20:46:33 <wxl> MrChrisDruif: https://wiki.ubuntu.com/Lubuntu/IRC%20Meetings/Agenda#preview
20:46:38 <gilir> MrChrisDruif, there is a specific item for this ;)
20:47:07 <gilir> any other questions ?
20:47:16 <Yorvyk> I was only going to ask the same thing
20:47:36 <gilir> #topic MrChrisDruif - Weekly report - Update from Docs team
20:47:39 <anliot> i'm getting some random crashes w/ a daily build from saturdy.  someone help me report them or identiy them?
20:48:18 <MrChrisDruif> Ah, missed all those topics
20:48:28 <gilir> anliot, you can ask on #lubuntu chan when you are testing
20:48:38 <anliot> k
20:49:07 <MrChrisDruif> Anyhow, nothing serious to report from the Docs team, other then that Ali is working on different pages of the wiki
20:49:42 <gilir> ok thanks MrChrisDruif :)
20:49:42 <MrChrisDruif> We've still have to get our game-plan defined
20:49:58 <gilir> that's the fun part :)
20:50:07 <MrChrisDruif> Ghehe, yeah....right ;-)
20:51:17 <gilir> #topic Yorvyk - Inclusion of clipboard manager or similar. Bug #926893
20:51:18 <ubottu> Launchpad bug 926893 in lubuntu-default-settings (Ubuntu) "There is NO Clipboard Manager in Lubuntu - a basic feature yet very important" [Undecided,Opinion] https://launchpad.net/bugs/926893
20:51:30 <MrChrisDruif> Anyhow, we've been mailing a bit on some ideas so we hope to have something more concrete next week, but real life is intervening all the time with me
20:51:37 <wxl> uh oh
20:51:42 * wxl puts on his flameproof suit
20:52:00 <gilir> MrChrisDruif, ok, sorry I was a bit too fast
20:52:07 <Yorvyk> Is there a solution to this bug?
20:52:09 <MrChrisDruif> It's alright ^_^
20:52:25 <MrChrisDruif> Yorvyk; according to the mailing-list several
20:52:26 <wxl> there are many solutions :D
20:52:27 <gilir> Yorvyk, yes :)
20:52:57 <leszek> I don't really get the problem of the clipboard manager . CTRL+C and marking and pasting with middle mouse button works fine. Other desktops don't bring clipboard managers by default, so why should we or do we need one ?
20:53:01 <gilir> the question is, which is the best :)
20:53:24 <gilir> leszek, well, there is still an issue with leafpad for example
20:53:27 <wxl> gilir: i don't want to make more work for anyone but i like the idea of lxclippy
20:53:50 <gilir> try copy on leafpad, close leafpad, and try to paste
20:53:52 <anliot> control+c clipboard gets destroyed when an app closes.
20:54:04 <rafaellaguna> it's an X problem?
20:54:11 <anliot> its an x feature
20:54:28 <wxl> xclip (was that it?) seems like a good starting point. memory usage is small. not entirely sure of its footprint disk space-wise because its part of that whole gaggle of x11 apps.
20:54:45 <gilir> wxl, but we don't need all the feature of a clipboad manager (like parcelite)
20:54:48 <Yorvyk> I prefer it to disappear when the app closes
20:54:50 <leszek> ah ok so the bug should be against lxsession than, correct ?
20:54:58 <MrChrisDruif> wxl suggested clipit at one time
20:55:02 <wxl> gilir: right that's what i'm saying-- just make it simple. just enough to protect
20:55:18 <wxl> MrChrisDruif: as i pointed out on the ml clipit's memory usage is a little bit larger than xclip
20:55:19 <gilir> leszek, yes, I think lxsession should handle basic clipboard management
20:55:34 <rafaellaguna> agree, in osx the clipboard contents stay. imagine it with a 16 mb image
20:55:37 <wxl> gilir leszek +1 i like that idea the best
20:55:50 * MrChrisDruif didn't finish reading all the post of the thread yet
20:55:57 <gilir> wxl, clipit is a fork of parcelite I think, so it's the same case than parcelite
20:56:35 <wxl> gilir: as i said, i wasn't suggesting clipit. i was just saying i use it :D but i'm not suggesting lubuntu needs it. i'm saying we make something very simple. just enough to protect.
20:57:11 <rafaellaguna> wxl: for that purpose we don't need an app, just modify the session
20:57:31 <wxl> rafaellaguna: didn't realize that was an option until now which is also why i said i like that idea the best :D
20:57:48 <anliot> when you run xclip in --daemon mode it has no user interface period.
20:57:59 <anliot> it just sits as a daemon and saves the clipboard
20:58:06 <wxl> of course it seems there are other people who dislike the idea altogether. maybe this should be one of those pre-freeze voting kind of things
20:58:08 <anliot> like you would expect windows or linux mint to do
20:58:27 <anliot> i meant to say clipit
20:58:30 <leszek> one thing that we could do for sure is install an clipboard manager like parcelite (wasn't it in back in an old version ?) but disable it by default. So that the user has to decide if he/she wants to use this feature
20:58:32 <StephenSmally> anyway we can just "steal" the base xclip code and add it to lxsession
20:58:53 <wxl> if we're going forward i think StephenSmally hit the nail on the head
20:59:00 <gilir> leszek, we done this in the past, parcelite was by default, but not started
20:59:04 <rafaellaguna> StephanSmally: yesss
20:59:24 <leszek> gilir: yeah exactly. So why don't do this again ?
20:59:25 <gilir> StephenSmally, could be a solution also :)
20:59:29 <MrChrisDruif> anliot; is the same with parcellite?
20:59:41 <MrChrisDruif> "parcellite --deamon --no-icon"?
20:59:41 <anliot> yeah
21:00:01 <wxl> we need a vote
21:00:06 <wxl> we could argue about this all day
21:00:53 <MrChrisDruif> I don't know memory usage differences when running it like a daemon?
21:01:10 <gilir> ok, I'll make a summarize of the options for thi sissue
21:01:22 <Yorvyk> I think a bit of benchmarking is needed
21:01:31 <anliot> no we don't need benchmarking
21:01:33 <MrChrisDruif> And which is more supported xclip vs parcellite
21:01:38 <anliot> its 2-5 megs of memory
21:01:40 <gilir> we can decide what to do before the next meeting, or during the meeting
21:01:56 <anliot> so the --daemon = 2-5 megs of memory
21:01:58 <anliot> period
21:02:03 <gilir> Yorvyk, and any benchmarking / testing will be appreciate :)
21:02:10 <wxl> gilir: sounds good. make an action and move on ;)
21:02:12 <Yorvyk> OK
21:02:44 <gilir> #action gilir to summarize and document clipboard issue on the mailing list
21:02:44 * meetingology gilir to summarize and document clipboard issue on the mailing list
21:03:00 * MrChrisDruif is off again
21:03:04 <gilir> the meeting should be finished now :/
21:03:05 <wxl> ok </stupid-clipboard-manager-topic> ;)
21:03:06 <Unit193> 16:03
21:03:09 <MrChrisDruif> See y'all later
21:03:13 <wxl> what?
21:03:18 <wxl> there's more to do
21:03:21 <gilir> Yorvyk, can we move your other item to next meeting ?
21:03:22 <wxl> i guess we'll skip it eh
21:03:45 <wxl> Yorvyk, StephenSmally and me you mean gilir :D
21:03:48 <Yorvyk> Yes, as I have to go very soon anyway
21:03:50 <gilir> StephenSmally, we can look at lsc release tomorow evening ?
21:04:33 <StephenSmally> yep
21:04:34 <rafaellaguna> ok, leaving. Good night, boys
21:04:48 <Yorvyk> Bye all.
21:04:50 <gilir> ok, thanks everyones :)
21:04:54 <wxl> oh well
21:04:54 <gilir> #endmeeting