17:01 <slangasek> #startmeeting
17:01 <meetingology> Meeting started Tue Nov 22 17:01:39 2016 UTC.  The chair is slangasek. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
17:01 <meetingology> 
17:01 <meetingology> Available commands: action commands idea info link nick
17:01 <slangasek> oh good, we at least have 3 :)
17:02 <slangasek> [TOPIC] Apologies
17:02 <slangasek> none sent
17:02 <slangasek> [TOPIC] Action review
17:02 <slangasek> infinity: are you here?
17:03 * slangasek infinity to follow up with maas SRU exception
17:03 * slangasek infinity to play with seed/maint-check changes on dogfood to build a new xenial release pocket for support length auditing (ETA: 16.04.2 release)
17:03 * slangasek slangasek to draft a proposed AA policy to ubuntu-release about removing powerpc binaries that hold up migrations
17:03 * slangasek Infinity to gather up powerpc community before next TB meeting
17:03 <slangasek> mail was sent to ubuntu-release
17:03 * doko is looking ...
17:04 <slangasek> [LINK] https://lists.ubuntu.com/archives/ubuntu-release/2016-November/003971.html
17:04 <doko> any feedback on this?
17:05 <slangasek> no feedback sent to the list
17:05 <slangasek> so I consider it the de facto policy right now ;)
17:06 <doko> well, this doesn't help for new toolchain versions failing to build without yet hitting the archive
17:06 <slangasek> as a data point, so far I spent 32 minutes as AA removing binaries for 20 packages from the archive on powerpc
17:06 <slangasek> doko: which we discussed at last meeting, and did not have agreement that it's the responsibility of the porters to fix pre-release toolchain builds in a ppa
17:07 <doko> ok
17:08 <slangasek> if it's prerelease and it FTBFS, that's what it is.  If it hits the archive and it FTBFS, then it's the porters' problem to fix it or be dropped
17:08 <slangasek> anyway, no infinity so I think that's all for the action review topic
17:09 <slangasek> I see an agenda item for 're-discuss powerpc port', but I think that was from before last meeting?
17:09 <slangasek> I'm not sure there's anything new to discuss this week
17:09 <mdeslaur> we wanted to re-discuss it based if people stepped up or not
17:09 <doko> no, the last meeting was the first one to discuss
17:10 <mdeslaur> but infinity isn't here with the results of his attempt to gather up volunteers
17:10 <doko> please can we have a time line for this?
17:11 <slangasek> doko: for which part?
17:11 <slangasek> doko: infinity was supposed to stand up the porter mailing list and gather porters, with a deadline of today.  But there was no concrete next step for the TB to take after that
17:12 <doko> well, if the result from missing-in-action is to keep the port, then something is wrong
17:12 <slangasek> I don't think "there is a porter mailing list" is the condition for keeping the port.  The condition for keeping the port is "the port is shown to be in good health".
17:12 <slangasek> doko: so if you find evidence that it is not, please let us know
17:13 <slangasek> ideally this feedback should be sent directly to the porter list, but if there's no porter list it falls to us
17:13 <doko> sic
17:14 <slangasek> the powerpc and i386 ports were also discussed in a UOS session last week
17:14 <doko> outcome?
17:15 <slangasek> I haven't seen a write-up yet from Bryan Quigley, but I think we can say that the desktop flavors are going to drop powerpc this cycle
17:16 <slangasek> I don't think there's anything more to say on this topic currently; we're mostly in data-gathering phase right now
17:16 <slangasek> so
17:16 <slangasek> [TOPIC] Scan the mailing ist archive for anything we missed
17:16 <slangasek> [LINK] https://lists.ubuntu.com/archives/technical-board/2016-November/thread.html
17:17 <slangasek> rbasak raised the question of how to track DMB requests to the TB
17:17 <slangasek> stgraber favored email
17:17 <slangasek> I suggested using the bug tracker :)
17:17 <slangasek> but then I saw on one of the bugs rbasak filed that he doesn't have the ability to assign community bugs to us
17:18 <slangasek> should we switch to using a tag for our community bug list?
17:18 <slangasek> or should we just stick with email?
17:18 <mdeslaur> I have no preference, as long as we can pull up a list during meetings to make sure requests have been handled
17:19 <slangasek> I think pulling up a list is easier with the bug tracker
17:19 <slangasek> hard to know for sure from a mailing list view what's "pending" vs. "resolved"
17:19 <slangasek> stgraber: what do you think?
17:19 <mdeslaur> good point
17:20 <stgraber> well, lets just say that I saw rbasak's e-mail to the ML but I didn't see his bug report until you closed it :)
17:20 <slangasek> indeed
17:20 <stgraber> so one is very visible in a low-traffic mailbox, the other isn't so visible in the massive bucket of LP bugs
17:21 <slangasek> well, unless you're already subscribed to all ubuntu-community bugs, you wouldn't have seen it at all
17:21 <stgraber> if he could have assigned it to us, it'd have shown up in a more visible mailbox for me and I guess I can setup yet another filter for that specifically
17:21 <stgraber> but that's more work than just looking at the existing TB mailbox :)
17:21 <slangasek> right, I guess that's a point - can we set up a filter on behalf of ~techboard so that the tagged bugs go to the mailing list automatically?
17:22 <slangasek> how about if I take an action to try to figure that out, and if it can't be done, we fall back to the mailing list approach?
17:22 <stgraber> we can add a subscription for ~technical-board for a specific LP tag
17:23 <slangasek> stgraber: if we do that, does the bugs approach work for you?
17:24 <stgraber> I guess it'd be vaguely more visible at least. I don't think we can have it land on the list without getting stuck in moderation since LP shows the reporter as the sender, so it'd just show up as regular bugmail for us which we'd need to setup filters for
17:24 <slangasek> and actually we would have to get sabdfl to set up the subscription
17:24 <slangasek> or have him give us all administrator rights :)
17:25 <slangasek> mailing list moderation should also allow us to auto-approve based on specific LP headers
17:25 <stgraber> so we have two options 1) have the DMB file bugs with the right tag, have sabdfl setup a filter to send that tag to ~technical-board and have us all setup mail filters to catch said tags or 2) have the DMB e-mail the TB list
17:26 <stgraber> ultimately both give us the same result, we get an e-mail with a bunch of commands to run (though badly wrapped if coming from LP)
17:26 <slangasek> why would you need to set up additional mail filters, if the mail goes to the list?
17:26 <slangasek> which AIUI is where ~techboard mail would go
17:27 <stgraber> ah yeah, contact is indeed the list
17:27 <stgraber> so instead of setting up filters, we'll have to go through mailman moderation queue regularly
17:27 <slangasek> or fix mailman config to auto-approve based on LP headers
17:27 <slangasek> (and I already process the moderation queue daily)
17:27 <stgraber> yeah, that'd work too
17:28 <stgraber> anyway, sure, if we ultimately get those requests on the TB list, I'm fine with it. It does seem to be quite a bit of extra work just to get another e-mail saying it's "Fix released" but if you're willing to do that work, fine
17:28 <slangasek> [ACTION] slangasek to investigate getting tagged ubuntu-community bugs automatically forwarded to technical-board, and if not feasible, fall back to DMB sending signed emails to list for ACL requests
17:28 * meetingology slangasek to investigate getting tagged ubuntu-community bugs automatically forwarded to technical-board, and if not feasible, fall back to DMB sending signed emails to list for ACL requests
17:28 <slangasek> agreed :)
17:29 <slangasek> [TOPIC] Check up on community bugs
17:29 <slangasek> [LINK] https://bugs.launchpad.net/ubuntu-community/+bugs?field.assignee=techboard
17:29 <slangasek> oh look there's one there now ;)
17:29 <slangasek> anyone want to claim it?
17:29 <slangasek> [LINK] https://bugs.launchpad.net/ubuntu-community/+bug/1643648
17:31 <slangasek> alright, then I'll claim it and follow up after the meeting
17:31 <slangasek> :)
17:31 <slangasek> [TOPIC] Select a chair for the next meeting
17:31 <mdeslaur> I'm not sure how to do that, someone would need to walk me through it or point me at some docs
17:32 <slangasek> mdeslaur: edit-acl in lp:~ubuntu-archive/ubuntu-archive-tools/trunk/
17:32 <mdeslaur> slangasek: ah! thanks
17:32 <slangasek> rbasak didn't supply the specific command in this case, so I'll follow up with him regardless to confirm exactly what he's asking for
17:34 <slangasek> next up: stgraber, backup: infinity
17:34 <slangasek> ^^ correct?
17:35 <stgraber> sounds right
17:35 <slangasek> [AGREED] next chair: stgraber, backup: infinity; next meeting 2016-12-06 @ 17:00 UTC
17:35 <slangasek> ok
17:35 <slangasek> anything else?
17:35 <stgraber> not sure I'll be around though since we'll be sprinting that week
17:36 <slangasek> right, maybe it'll be a quick meeting then :)
17:36 <slangasek> #endmeeting