16:59 <dsmythies> #startmeeting Ubuntu Docs
16:59 <meetingology> Meeting started Tue Oct  6 16:59:55 2015 UTC.  The chair is dsmythies. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:59 <meetingology> 
16:59 <meetingology> Available commands: action commands idea info link nick
17:00 <dsmythies> #chair dsmythies GunnarHj
17:00 <meetingology> Current chairs: GunnarHj dsmythies
17:00 <GunnarHj> Hi all!
17:01 <dsmythies> Tead asked (repeating just to log it): who updates the links at the top of the webchat window? the fridge and meeting logs links are outdated
17:01 <dsmythies> Teadmcox, there is no specific person assigned to that task. Someimtes I do it, sometimes Peter Matulis...
17:02 <dsmythies> Who is here for the doc team meeting? so far I have Gunnar, Ted, myself
17:02 <tedmcox> this appears to be the current fridge/calendar link: http://fridge.ubuntu.com/calendars/
17:03 <GunnarHj> Small meeting.
17:04 <dsmythies> tedmcox, sorry I misunderstood. The banner when you join this room is maintained by, I think, pleia2
17:04 <tedmcox> OK, I'll ping pleia2
17:04 <GunnarHj> Hi pmatulis!
17:05 <tedmcox> Oh, and hello, everyone :)
17:05 <pmatulis> hi GunnarHj and dsmythies and tedmcox
17:05 <dsmythies> GunnarHj: pmatulis is on the road. However he did mention he might be here in the background.
17:05 <dsmythies> Oh, missed that
17:06 <dsmythies> moving onto the agenda...
17:07 <dsmythies> quiet cycle for docs for 15.10. Not much to say really.
17:07 <dsmythies> tedmcox thanks for your work on serverguide while at the openhelp conference.
17:08 <tedmcox> dsmythies, thank you for your help during the sprints!
17:09 <tedmcox> hi, shaunm!
17:09 <dsmythies> tedmcox: did you notice that it seems to be the much older serverguide bug reports that we don't seem to get to? They are the harder ones, that need subject matter experts to help with.
17:09 <tedmcox> yes, i noticed that
17:10 <shaunm_> hi tedmcox
17:10 <dsmythies> Anything esle before we move onto help.ubuntu.com?
17:11 <tedmcox> some older items may also need to be marked as wishlist, but i don't have the ability to do that
17:11 <dsmythies> GunnarHj: Thanks for splitting out launchpad help.ubuntu.com into its own project, It was very annoying before.
17:12 <GunnarHj> Yeah, and it allows us to have a separate bug tracker for those issues.
17:12 <dsmythies> tedmcox: Probably a good idea.
17:13 <dsmythies> There was a way before to have bugs specific to help.ubuntu.com, but it was very strange and I could never remember how.
17:14 <dsmythies> which is why I tended to have under ubuntu-docs
17:15 <GunnarHj> I have nothing more to say about help.ubuntu.com.
17:15 <dsmythies> By the way, I'll probaly start soon on the preliminary adding of 15.10 to help.ubuntu.com, but only on my test site at first.
17:16 <GunnarHj> dsmythies: Excellent. But wait until I have updated the translations (probably Friday).
17:16 <dsmythies> I'll hope to keep an open, but unsubmitted bzr branch during that time.
17:17 <dsmythies> GunnarHj: O.K. will wait until after translations update.
17:17 <dsmythies> moving on...
17:18 <dsmythies> Misc: 3 are just statements, really. Fourth is time / day for meeting, which I suggest we handle on the e-mail list. We will have a conlfict next month again.
17:19 <dsmythies> Oh, any followup for ted from his openhelp e-mail
17:20 <dsmythies> svetlana isn't here, for her take on things.
17:20 <GunnarHj> tedmcox: Thanks for your list email about the conference!
17:20 <dsmythies> yes, thanks ted.
17:21 <tedmcox> there are a few ideas i will probably post on the list in the next couple of weeks
17:21 <dsmythies> And thanks shuanm_ for putting the whole thing together
17:21 <tedmcox> creating a to-do list of some kind for contributors
17:21 <GunnarHj> +1
17:21 <dsmythies> tedmcox: O.K. great.
17:21 <GunnarHj> tedmcox: Sounds awesome.
17:22 <tedmcox> setting up some kind of feedback box on our html pages for easier feedback from readers
17:22 <tedmcox> the big one: how feasible is it to use a lightweight doc tool (markdown, asciidoc, etc) for our docs?
17:23 <GunnarHj> There is one idea, which pmatulis brought up a while ago, I'd like to add: We should explicitly offer mentors to persons who want to get started.
17:23 <tedmcox> that last one would take considerable effort
17:24 <GunnarHj> tedmcox: I thought that Mallard was a lightweight markup language. And now I hear something about lightweight Mallard...
17:24 <tedmcox> +1 for mentors
17:25 <dsmythies> tedmcox: We do seem to often talk about changing the markdown language. It would be a massive project, and I tend to think underestimated.
17:26 <tedmcox> gunnarHj: yes, ducktype . that's shaunm's project.
17:27 <GunnarHj> shaunm_: Are you planning to switch to that for the GNOME docs?
17:27 <tedmcox> switching from Docbook to something lighter would be a huge undertaking. i don't know if making that effort would pay off with more community contributions.
17:28 <GunnarHj> tedmcox: I do agree on the doubt.
17:28 <dsmythies> tedmcox: I also agree on the doubt.
17:29 <shaunm_> GunnarHj: I don't know if gnome will switch to ducktype
17:29 <tedmcox> i'll look around. there may be some tool out there that helps automate that conversion process.
17:29 <dsmythies> I am going to copy something from #ubuntu-doc to here, since Ted isn't in that room:
17:30 <GunnarHj> shaunm_: Ok.
17:30 <dsmythies> anyone with an ubuntu member cloak can change the topics in meeting channels, but lmk what's wrong and I can help fix things post-meeting as needed (that was from pleia2)
17:31 <dsmythies> tedmcox: it sin't the conversion process that is the show stopper. It is the translations workflow that is typically the show stopper.
17:31 <shaunm_> GunnarHj: I view both mallard xml and ducktype as viable, with different strengths and weaknesses. I don't think everybody will choose to go lightweight.
17:32 <GunnarHj> shaunm_: I see. Personally I like Mallard. Reasonably simple, and preventing you from overcomplicating things.
17:34 <dsmythies> tedmcox: For your thread "Committing multiple branches to Launchpad": Does the feedback all make sense now?
17:34 <GunnarHj> dsmythies: But the translations workflow doesn't affect all contributors, does it? It's typically handled by one or two persons.
17:35 <tedmcox> dsmythies: yes, i'll commit multiple smaller changes to one branch from here on
17:36 <dsmythies> GunnarHj: Yes, but the entire workflow has to be considered, and estimated, when considering fundamental changes. That is where I felt we fell short in past conversations.
17:37 <GunnarHj> dsmythies: We can talk more about it past meeting, if you like.
17:37 <pmatulis> tedmcox: i've already gone through a test process of converting from docbook to RST markdown. it works but resulted in a lot of broken hyperlinks
17:37 <shaunm_> basically, for any format you're considering, you need to make sure there are good tools to round-trip with po files
17:38 <shaunm_> because po files are how translators get work done
17:38 <shaunm_> ideally, there'd be a way to communicate extra information about the document that's useful to translators
17:38 <GunnarHj> shaunm_: Indeed. Realizing now that that's what dsmythies was talking about.
17:38 <pmatulis> tedmcox: ahoneycutt (spelling?) is also interested in this project
17:39 <dsmythies> shaunm_, yes agreed.
17:39 <dsmythies> I did hear from ahoneycutt (spelling?) that he couldn't get away from work to attend this meeting.
17:39 <tedmcox> cool. i'll talk to aaron.
17:40 <dsmythies> Hannie also said she was unable to attend.
17:40 <GunnarHj> ahoneybun (correct spelling!) seems to be connected to this room.
17:41 <tedmcox> any chance any of you know of other projects that made a big switch similar to what we're discussing? i can reach out for their feedback.
17:42 <dsmythies> I do not know of other projects.
17:43 <GunnarHj> tedmcox: A few years ago the desktop guide switched from DocBook to Mallard. But it was because GNOME used Mallard, and not to make it easier to contribute. I think the difference in the latter respect is minimal.
17:45 <dsmythies> Are there any action items? tedmcox to do some followup e-mails with some ideas from the openhelp conference, for example.
17:46 <GunnarHj> dsmythies: That would be a suitable action item IMO. Then we can keep talking on the list.
17:47 <tedmcox> that sounds good
17:47 <dsmythies> #action dsmythies to start (yet another) team meeting date / time change e-mail thread.
17:47 * meetingology dsmythies to start (yet another) team meeting date / time change e-mail thread.
17:47 <dsmythies> #action tedmcox to do some followup e-mails with some ideas from the openhelp conference
17:47 * meetingology tedmcox to do some followup e-mails with some ideas from the openhelp conference
17:48 <dsmythies> Anything else?
17:49 <dsmythies> tedmcox: Will you follow up with your banner issues with pleia2?
17:49 <tedmcox> yes
17:49 <dsmythies> I think we are done.
17:50 <GunnarHj> Thanks everyone!
17:50 <dsmythies> I'll wait one minute, then terminate
17:50 <dsmythies> Yes, thanks everyone.
17:51 <dsmythies> #endmeeting