16:05 <pitti> #startmeeting
16:05 <meetingology> Meeting started Tue Sep 15 16:05:32 2015 UTC.  The chair is pitti. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:05 <meetingology> 
16:05 <meetingology> Available commands: action commands idea info link nick
16:05 <pitti> #topic action review
16:06 * pitti taps foot for meetbot
16:06 * pitti slangasek to forward complaint to Canonical legal
16:06 <pitti> as this has been quiet for so long, is this still actually relevant?
16:07 <slangasek> well
16:07 <slangasek> feel free to drop it from the carry-over actions so we don't have to keep spending time discussing the non-action?
16:08 <pitti> ok; let's just silently bury that then :)
16:08 <slangasek> I think it should still be done but obviously it's not the top of my priority list for the reason you say
16:08 * pitti slangasek to document maas, juju, docker exceptions on https://wiki.ubuntu.com/StableReleaseUpdates#Special_Cases
16:08 <slangasek> carry over :/
16:08 <pitti> this might actually get better resolved (or resolved by itself) after the changing of the policy?
16:08 <slangasek> I don't think so
16:08 <infinity> I would hope not.
16:09 <infinity> If the policy becomes so open that what the maas team does is "okay" without an exception, I think we've gone too far in the free for all direction.
16:09 <mdeslaur> those aren't "micro" :P
16:09 <slangasek> they're exceptions to the policy on updating existing features, and I don't think are covered by the proposed changes to policy?
16:09 <pitti> TBH, I don't know how "special" these are; I was hoping that with the generalization, allowing new features and generally allowing new microreleases this would be covered
16:09 <pitti> ah, ok
16:09 * pitti Everyone to review pitti's SRU policy ammendments and +1/-1 on-list
16:10 <pitti> we got feedback from mdeslaur for the first one, and from slangasek and stgraber for the second patch
16:10 <infinity> pitti: Can we carry that for another cycle, if you're not in a rush to commit?  I want to re-read, and read some IRC backscroll I had with ScottK and rebut a bit.
16:10 <pitti> not sure if we interpret that as silent consent from the others now?
16:10 <pitti> infinity: sure
16:10 <mdeslaur> oh, meant to +1 the second
16:10 <infinity> Obviously, if I fail to respond sanely in the next 2 weeks, assume silent approval from me due to being a derp. :P
16:11 <pitti> FWIW, I think ScottK's amendment is fine as it has been the  existing policy so far anyway
16:11 <infinity> Yeah, that wasn't the only discussion I had with Scott.  We had a long, CoC-breaking drinking session one night. :P
16:11 <mdeslaur> lol
16:11 <pitti> not sure about stgraber's addition -- the policy already states that any change must be present in the devel series first, so it woudl be redundant
16:11 <pitti> (I don't mind adding it, though)
16:11 <infinity> I need to distill that into something publicly-acceptable.
16:12 <mdeslaur> pitti: well, it's not just devel if it's a new feature
16:12 <pitti> and slangasek's addition *should* be obvious, but I also don't mind adding that as a clarification
16:12 <pitti> mdeslaur: how do you mean?
16:12 <pitti> we wouldn't introduce a new featuer *only* into an LTS without it also landing in devel?
16:12 <pitti> at least that's specifically not my intention
16:12 <infinity> pitti: If it's a new feature in 14.04, it might be missing entirely in 15.04 as well, and upgrades need to be vaguely supportable.
16:13 <mdeslaur> pitti: if it's a new feature, rather than just a bug fix, we need to have it in interim releases also
16:13 <infinity> pitti: So, it's not just about devel and stable, but devel and all supported stables in between your target and devel.
16:13 <pitti> ah, I see
16:13 <pitti> so this is not devel, it's for newer stables
16:13 <pitti> stgraber proposed "preferably", this should maybe become stronger then?
16:13 <infinity> Probably should, yes.
16:13 <pitti> i. e. "should preferably" → "must"?
16:13 <infinity> Do we properly use RFC language anywhere in that document?
16:13 <infinity> Maybe we should start.
16:14 <mdeslaur> ah, yeah, stronger would be better
16:14 <infinity> (Maybe we must start?)
16:14 <pitti> yeah, we are using "should" a lot in the current policy which ought to be a "must"
16:15 <stgraber> infinity: I think you meant "Maybe we MUST start?" :)
16:15 <pitti> ok, so I'll send a v2 of both amendments with the proposals and the above "strongification"
16:15 <infinity> A must/should/may cleanup of whatever docs we're responsible for wouldn't go amiss.
16:15 <mdeslaur> #define should must
16:15 <pitti> and I keep prodding infinity over the next two weeks :)
16:15 <infinity> #define 2 1.999999
16:15 <slangasek> #define must volatile
16:16 <pitti> ok, I think we're done with this topic :)
16:16 <mdeslaur> hehe
16:16 <pitti> no other agenda items
16:16 <stgraber> :)
16:16 <pitti> nothing new on the ML
16:16 <pitti> ah, for meetbot (if it works at all):
16:16 <infinity> It works, it just doesn't have topic permissions on this channel.
16:16 <pitti> #action pitti to update SRU policy amendment proposals and gather feedback
16:16 * meetingology pitti to update SRU policy amendment proposals and gather feedback
16:17 <infinity> And no one's ever bothered to fix that.
16:17 * pitti infinity to respond to that
16:17 <pitti> zarro community bugs
16:17 * infinity pitti to stop using ambiguous pronoun backreferences in actions
16:17 <pitti> next chair is slangasek, then (or fallback) stgraber, ok?
16:17 * slangasek nods
16:17 <stgraber> fine with me
16:18 <infinity> Glad we all agree about pitti's grammar.
16:18 <infinity> (And the chair)
16:18 * pitti infinity to replace his grammar lambastion with something much more peaceful, like a nice round of Halo or whatnot
16:18 <infinity> pitti: :)
16:19 <pitti> c'est ça, mes amis
16:19 <pitti> #topic AOB?
16:19 <slangasek> "ça" - there you go with those dangling relative pronouns again
16:19 <infinity> Oh, there's one thing I wanted to get an informal "yeah, that's sane" from people before I move on it.
16:20 <infinity> At Plumbers, Kate stated that she was going to officially step down from ~ubuntu-release (I need to prod her about that) and, once she does, -release, -archive, and -sru will all be core-devs.
16:20 <pitti> slangasek: J'écris "Je suis mauvais" 100 fois..
16:20 <slangasek> infinity: yeah that's sane
16:20 <infinity> I'd like to move to boith take over ownership of those teams by the TB where that's not currently true, and document a policy that teams that confer queue permissions shouldn't give people queue permissions more elevated than their upload rights.
16:20 <slangasek> oh sorry were you still talking
16:20 * pitti assumes that there's still some question coming?
16:20 <infinity> (So, core-dev only for those teams)
16:21 <pitti> big +1
16:21 <mdeslaur> infinity: you said "should"
16:21 <mdeslaur> yeah, +1 from me
16:21 <slangasek> +1
16:21 <infinity> The reason for the strict permission match wording, rather than explicity "must be core-devs" is that it also opens the possibility of a motu-release with universe queue permissions or whatever.
16:21 <slangasek> mdeslaur: lol
16:22 <stgraber> +1
16:22 <infinity> mdeslaur: Right, so I did.  s/should/must/ where I meant it. :P
16:23 <infinity> Okay, so thanks for the informal vote.  After I poke Kate and get her to deactivate (trying to avoid drama there by doing it myself), I'll move on the policy and owenership bits.
16:23 <pitti> nice, thanks infinity
16:23 <pitti> #action AOB, take II
16:23 * meetingology AOB, take II
16:23 <pitti> err, #topic, sorry
16:24 <infinity> Hahaha.
16:24 <infinity> DRUNKEN MEEEEEETING!
16:24 <pitti> #makethisend
16:24 <infinity> I think we're done. :P
16:24 <pitti> then, thanks everyone!
16:24 <stgraber> :)
16:24 <pitti> #endmeeting