16:02 <infinity> #startmeeting
16:02 <meetingology> Meeting started Tue Sep  1 16:02:50 2015 UTC.  The chair is infinity. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:02 <meetingology> 
16:02 <meetingology> Available commands: action commands idea info link nick
16:03 <infinity> [TOPIC] Action review
16:03 <infinity> slangasek: Looks like you had two.
16:03 * infinity slangasek to forward complaint to Canonical legal
16:03 * infinity slangasek to document maas, juju, docker exceptions on https://wiki.ubuntu.com/StableReleaseUpdates#Special_Cases
16:04 <slangasek> infinity: both carried over
16:04 <infinity> pitti: ACTION: pitti to propose amendment to general SRU policy for new features in LTS
16:05 <pitti> yay! done
16:05 <pitti> (after some 4 times bouncing)
16:05 <pitti> https://lists.ubuntu.com/archives/technical-board/2015-September/thread.html
16:05 <infinity> \o/
16:05 <mdeslaur> \o/
16:05 <pitti> I also used the opportunity to propose and clean up the SRU policy at large
16:05 <pitti> the actual "new features" amendment is rather small
16:06 <pitti> but admittedly I only sent this an hour or so ago, so I don't expect anyone to have read it yet and thought about it
16:06 <pitti> so maybe replies on the list?
16:06 * stgraber waves
16:06 <pitti> ça va stgraber !
16:06 <mdeslaur> I skimmed it, but haven't thought it through yet
16:06 <infinity> Right, let's take that to the list, and if we don't get anywhere, discuss it at the next meeting.
16:07 <infinity> [ACTION] Everyone to review pitti's SRU policy ammendments and +1/-1 on-list.
16:07 * meetingology Everyone to review pitti's SRU policy ammendments and +1/-1 on-list.
16:07 <stgraber> pitti: très bien, merci! Sorry for being a bit late, was changing location.
16:07 <mdeslaur> pitti: this basically removes the need to get an explicit tech-board ack for SRU microreleases, right?
16:07 <slangasek> hadn't seen the mail until just now
16:08 <infinity> Do we need to tackle jcastro's driver update stuff in the meeting, or is the healthy list debate working for everyone.
16:08 <infinity> ?
16:08 <pitti> mdeslaur: that's the intention -- as we basically always ask the same question etc.
16:08 <mdeslaur> pitti: ok, was just making sure I parsed it correctly
16:08 <pitti> so I'd rather generalize the principles, and stop this (IMHO rather unmaintainable) list
16:08 <mdeslaur> infinity: I think jcastro was ok with the discussion
16:08 <pitti> Alberto had some followup with some new points (short-lived drivers)
16:09 <pitti> but I'm still firmly opposed to enabling random PPAs with some driver GUI
16:09 <infinity> Ditto.
16:09 <stgraber> yup
16:09 <infinity> I had some rather strong opinions off-list about that.
16:09 <mdeslaur> yeah, I'd rather see more driver updates in the actual archive
16:10 <slangasek> full agreement
16:10 <stgraber> short-lived test drivers can go to a PPA. Production-ready drivers can go in as SRUs.
16:10 <infinity> Alright, let's keep this discussion on-list, since there's plenty there already, and it's nice to keep the discussion in the same spot.
16:10 <stgraber> and said PPA would have to be manually added by any user/tester of said driver
16:10 <pitti> yeah, nothing wrong with having PPAs, just don't use them as SRU bypasses
16:10 <jcastro> yes the plan is for us to iterate in the PPA, and then people can steal that into distro as necessary
16:10 <mdeslaur> I have no objection to perhaps making the SRU waiting period shorter in the future if we're trying to get day-one drivers for specific games in though
16:11 <jcastro> just in case people missed my email withdrawing the PPA proposal
16:11 <infinity> mdeslaur: Given past quality of those updates, I object to that until there's a better history.
16:11 <pitti> I do belive that we have stalled SRU/NEW queues, but enabling PPAs by default doesn't sound like the answer
16:11 <infinity> mdeslaur: They introduce packaging regressions often.
16:11 <jcastro> pitti: agree 100%
16:11 <mdeslaur> infinity: yes, I agree. hence the "in the future"
16:11 <slangasek> I didn't get a chance to point this out on the list yet, but one factor in NEW being slow for SRUs is that it's a different queue
16:12 <slangasek> I think for jcastro's use case the packages should be continuous SRUs of a single source package, to avoid this
16:12 <pitti> yeah, hardly ever looked at
16:12 <slangasek> (technical details etc)
16:12 <pitti> or at least we need to plant the "look at NEW" idea into ~ubuntu-sru's habits
16:12 <infinity> I'm training a couple of new AAs to try to help the queue depth issue, but it might help to get formal about driver updates, much like I did for kernel SRUs when they were having issues a few years ago.
16:12 <stgraber> right, that'd also mean getting potentially reviewable diffs instead of the unreviewable monstrosity we get today
16:12 <slangasek> pitti: planting in habits won't change the problem of multiple queues + queue starvation, really
16:13 <pitti> TBH, the nvidia driver is comparatively hard to source-NEW, as it's such a complex package (both license-wise and packaging-wise)
16:13 <slangasek> anyway, the TB doesn't need to micromanage this part I think, sorry for bringing it up :)
16:13 <infinity> Heh.
16:13 <infinity> [TOPIC] Mailing list archives
16:14 <pitti> nothing new aside from the driver thingies that I can see
16:14 <infinity> Anything else interesting that we've been missing?
16:14 * pitti pats his mutt filters marking TB email green
16:15 <infinity> [TOPIC] Community bugs
16:15 <infinity> Nada.
16:15 <infinity> [TOPIC] Next chair
16:15 <pitti> next time: me, then slangasek ?
16:15 <infinity> The wiki claims pitti, which is oddy out of order if today was me.
16:15 <infinity> But sure, pitti, then slangasek.
16:16 <slangasek> infinity: was yours a catch-up?
16:16 <pitti> hm, can't remember the history; we might have swapped due to non-attendance or whatnot
16:16 <slangasek> anyway
16:16 <infinity> slangasek: Might have been.
16:16 <infinity> [TOPIC] AOB
16:16 <infinity> Anybody have any OB?
16:16 <pitti> nothign from me
16:17 <mdeslaur> nope
16:17 <stgraber> nope
16:17 <slangasek> no
16:17 <infinity> Alright, off to edit the wiki.
16:17 <infinity> #endmeeting