16:00 <dsmythies> #startmeeting Ubuntu Docs
16:00 <meetingology> Meeting started Tue Jun  2 16:00:16 2015 UTC.  The chair is dsmythies. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:00 <meetingology> 
16:00 <meetingology> Available commands: action commands idea info link nick
16:00 <dsmythies> #chair dsmythies pmatulis
16:00 <meetingology> Current chairs: dsmythies pmatulis
16:01 <dsmythies> #topic Old stuff
16:01 <dsmythies> Any old issues or action points or whatever? (None on the agenda?
16:02 <dsmythies> Who is here for the Docs meeting? I am aware of GunnarHj, pmatulis, tedmcox
16:02 <raub> I am
16:02 <bregma> O/
16:03 <GunnarHj> The item about Ubuntu Manual is still pending. I for one think it's an important one, not least considering the Unity 8 prospects.
16:03 <dsmythies> raub, bregma: O.K. thanks. Any particular area(s) of interest?
16:04 <bregma> the Unity 8 desktop is in a radical state of flux right now, it would be madness to start documenting it at this point
16:04 <dsmythies> GunnarHj: I think Kevin is focused on his discertation (sp?), How to move the action itme along?
16:04 <dsmythies> item
16:06 <GunnarHj> bregma: I wasn't suggesting we should start writing right now. The Ubuntu Manual is a separate project which deals with desktop docs (as the Desktop team does). Duplication. Shoud be reconsidered.
16:06 <GunnarHj> dsmythies: Yeah, let's move it forward.
16:08 <dsmythies> #action: put Ubuntu Manual back on the agenda, as a carry forward item. Perhaps contact Kevin in the background as to where he is at these days.
16:08 * meetingology : put Ubuntu Manual back on the agenda, as a carry forward item. Perhaps contact Kevin in the background as to where he is at these days.
16:08 <dsmythies> Was that O.K.? I can contact kevin.
16:08 <GunnarHj> dsmythies: Quite ok.
16:09 <dsmythies> #topic New Business: Desktop: Unity 8.
16:09 <dsmythies> Note: I jumped ahead, will go back later.
16:11 <dsmythies> Anybody? Myself, I have both not interest nor any capacity for this one.
16:11 <GunnarHj> bregma: Can you possibly give us a couple of update hints?
16:12 <bregma> well, Unity 8 does not (generally) use GTK or Gnome aplications, so pretty much all of the desktop documentation will need to be written from scratch
16:13 <bregma> also, the doc viewer itself will probably not be available
16:13 <GunnarHj> That's pretty radical stuff. Is there a consensus about it?
16:14 <pmatulis> i'm confused. what is the Desktop-Next/Unity8-Desktop user guide? how does it differ from our doc project?
16:15 <GunnarHj> pmatulis: There is no such guide yet. It will come.
16:15 <pmatulis> GunnarHj: ok, but why another guide? why not just update our existing stuff?
16:16 <bregma> we can try to leverage as much as possible from what's in the ubuntu-docs projects, but Desktop Next is going to have alll different default apps and ways of doing things
16:17 <bregma> currently the working term is 'Ubuntu Personal' to connotate the convergence of desktop and phone
16:17 <GunnarHj> bregma: Ok, thanks. We can get back to possible details later.
16:17 <pmatulis> bregma: i'm worried more about the 'container' of the docs, not the content
16:18 <bregma> pmatulis, yes, this is one of my concerns
16:18 <GunnarHj> bregma: Did I you say that yelp won't be available in Unity 8?
16:19 <bregma> I suspect that may be the case
16:20 <GunnarHj> ok
16:20 <bregma> of course, all it would take is for someone to make sure it gets properly ported and packaged, probably
16:21 <GunnarHj> bregma: One thing is that we could ship yelp without the (redundant) gnome-user-guide.
16:21 <dsmythies> Is there any action items or whatever from this, or is it to be deferred until the "state of flux" dies down?
16:22 <GunnarHj> dsmythies: Suppose the lattes is true, right bregma? ;)
16:23 <bregma> yes, for at least another meeting
16:23 <pmatulis> i think getting clarification on the "guide/framework" is important
16:24 <GunnarHj> pmatulis: The general goal is to produce a set of docs that will contain everything Unity 8 - desktop, phone and tablet.
16:24 <pmatulis> GunnarHj: alright, but will this all go into our existing desktop guide?
16:25 <GunnarHj> pmatulis: No, the existing guide will stay as long as it's needed. We are talking about new docs.
16:27 <dsmythies> #action leave the agenda item as is, carry forward to next meeting. Everyone knows resources are an issue.
16:27 * meetingology leave the agenda item as is, carry forward to next meeting. Everyone knows resources are an issue.
16:27 <pmatulis> yeah let's move on. we'll eventually see what happens and who will do what
16:27 <dsmythies> #topic Open Help Conference
16:28 <dsmythies> Anybody?
16:28 <tedmcox> i would love to attend
16:30 <GunnarHj> tedmcox: Would be great if you did.
16:30 <pmatulis> hi tedmcox!
16:30 <tedmcox> hello!
16:30 <dsmythies> Ted, yes it would be great.
16:31 <dsmythies> I guess it is up to you to proceed from desire to attend to making it happen.
16:31 <tedmcox> i see there's a possibility to apply for funding for travel, but i'm not an ubuntu member
16:31 <pmatulis> tedmcox: yeah, i saw that too
16:31 <GunnarHj> tedmcox: We can help with that.
16:32 <dsmythies> One has to be an Ubuntu member?
16:32 * pmatulis really needs to apply for ubuntu membership!
16:32 <GunnarHj> tedmcox: I recently got some funding for a Swedish LoCo project, so I'm updated about the procedure.
16:33 <dsmythies> GunnarHj: Are you offering to help Ted with process?
16:33 <GunnarHj> pmatulis, tedmcox: A member (or, I think, a project like this team) can make the application for tedmcox.
16:33 <tedmcox> i have read the steps to apply for membership and will start working on that
16:34 <GunnarHj> dsmythies: Ok, I am. Please state it as an action item.
16:35 <dsmythies> #action GunnarHj to help Ted Cox with process to have Ted attend Open Help Conference
16:35 * meetingology GunnarHj to help Ted Cox with process to have Ted attend Open Help Conference
16:35 <dsmythies> Done here?
16:36 <dsmythies> #topic help.ubuntu.com
16:36 <dsmythies> pmatulis, go ahead
16:36 <pmatulis> yep, so i am putting together a change to the main landing page
16:37 <pmatulis> #link http://help.papamike.ca:8081/
16:37 <dsmythies> As you know from our off-list emails we like your proposed new page.
16:37 <pmatulis> this i believe makes things clearer and simpler to maintain
16:38 <GunnarHj> Indeed it does. Nice work!
16:38 <pmatulis> yes, i informed dsmythies and GunnarHj in a separate email
16:38 <pmatulis> since we are the ones maintaining this stuff
16:39 <GunnarHj> I read dsmythies email before this meeting, and agree on the notes he made.
16:39 <pmatulis> dsmythies: to address your question on MAAS and Juju links, they are separate projects
16:39 <pmatulis> separate from 'Ubuntu Cloud' i mean
16:40 <pmatulis> the latter is like a run-through of various technologies
16:40 <dsmythies> O.K. but there is MASS and Juju content included. Are your saying what was included was just what was needed for Ubuntu Cloud?
16:40 <pmatulis> yes
16:41 <dsmythies> Aghhh. O.K. this was my fundamental misunderstanding.
16:41 <pmatulis> there are many ways to build a cloud. 'ubuntu cloud' is one way
16:42 <dsmythies> I would still suggest to put "ubuntu cloud" into the cool table.
16:42 <pmatulis> ok, but there is the question of maintainership
16:43 <GunnarHj> The question is whether the cloud docs will be updated on a release basis.
16:43 <pmatulis> putting it all under 'maintained by the doc project' implies strongly that the same processes and procedures are used throughout all the stuff
16:43 <pmatulis> but maas and juju do not even use LP
16:44 <pmatulis> GunnarHj: yes they will
16:45 <pmatulis> but that brings up another important point about putting cloud stuff in the table
16:45 <dsmythies> O.K. I see. We used to have that distinction down a level, the level we are trying to get rid of.
16:46 <GunnarHj> Maybe we could skip the "maintained by" part? The installation guide isn't maintained by us anyway...
16:47 <dsmythies> So, you are wanting to separate by maintinership. O.K. I  understand (finally).
16:47 <pmatulis> cloud these days is a fast moving project where the modus operendi is to backport cloud stuff into other releases. so you cannot say 'ubuntu cloud' is tied to a specific ubuntu release. hence won't fit properly in the table, which is release-based
16:48 <pmatulis> what really matters is what version of cloud software you're running
16:49 <dsmythies> GunnarHJ: Good point about the installation guide. Altough I would just leave it in the table as is.
16:49 <pmatulis> there is the special cloud-archive . and PPAs for MAAS and Juju are the standard right now
16:49 <GunnarHj> dsmythies: Ok, as you wish. ;)
16:50 <pmatulis> who is responsible for the installation-guide again?
16:50 <pmatulis> (at least nominally?)
16:51 <dsmythies> well, I have been doing the last few installation guides.
16:51 <dsmythies> but it is a mess.
16:51 <pmatulis> dsmythies: meaning full of inaccuracies?
16:52 <GunnarHj> pmatulis: As regards the contents, it's Debian based. Think that cjwatson had something to do with it, but he quit.
16:52 <dsmythies> no, meaning Matt and Jermey couldn't figure out how to move it to the new theme, nor could I.
16:53 <pmatulis> dsmythies: whoah ok!
16:53 <GunnarHj> dsmythies: But we don't really know how up-to-date it is, do we?
16:54 <pmatulis> dsmythies: maybe i could get someone on the web team to help
16:55 <dsmythies> It is realtively unmaintined, yes. However, it does contain useful information, that does seem current. Matt and Jermey did suggest to drop it, but it does contained more detail for specific cases. And it does have several links from the severguide.
16:56 <GunnarHj> Tricky situation.
16:57 <dsmythies> pmatulis: someone from the web team would be welcome. The other option is to drop it, the serverguide links would not be that hard to drop (going from memory, as I have looked into it before0.
16:57 <pmatulis> dsmythies: you said you helped with it in the past but does it fall under the doc team?
16:58 <GunnarHj> pmatulis: Are you in a position to figure out who is responsible for maintaining the (contents of) the installation guide? Might be useful to know as a base for decision.
16:58 <pmatulis> GunnarHj: yep
16:58 <GunnarHj> pmatulis: Sounds great.
16:58 <dsmythies> Luanchpad shows the respobsible team.
16:59 <pmatulis> dsmythies: who? :)
16:59 <dsmythies> Peter, I'll look it up after the meeting, O.K.?
17:00 <pmatulis> "Ubuntu Installer Team"
17:00 <pmatulis> #link https://launchpad.net/ubuntu/+source/installation-guide
17:00 <GunnarHj> Not a big surprise...
17:01 <pmatulis> oof: https://launchpad.net/~ubuntu-installer-lists
17:02 <GunnarHj> pmatulis: My wish that you ask someone stands.
17:02 <pmatulis> #action pmatulis find out who is responsible for the instalation-guide
17:02 * meetingology pmatulis find out who is responsible for the instalation-guide
17:02 <pmatulis> #action pmatulis seek help for applying theme to installation-guide
17:02 * meetingology pmatulis seek help for applying theme to installation-guide
17:02 <dsmythies> I see several recent edits by someone.
17:03 <pmatulis> mathieu, yeah, i know him
17:03 <dsmythies> I think we are done here. Anybody anything else?
17:04 <pmatulis> done for the meeting you mean?
17:04 <dsmythies> Yes.
17:04 <GunnarHj> pmatulis: Are you going to submit the help.ubuntu.com page as a MP?
17:04 <pmatulis> GunnarHj: yep
17:04 <pmatulis> whatever happened to trying to improve the search facility in the server guide dsmythies?
17:05 <pmatulis> wasn't that a project a while back?
17:05 <dsmythies> Got stuck in a disagreement with Dustin Kirkland. Still on my list to dump his CSE and replace it with one we have access to .
17:06 <pmatulis> ah that reminds me of another thing
17:06 <pmatulis> i got manpages.ubuntu.com updated for vivid
17:07 <pmatulis> dsmythies: shall we give you an action item for that?
17:07 <dsmythies> O.K., but it will carry forward.
17:08 <pmatulis> #action dsmythies contact kirkland to improve the search facility in the server guide
17:08 * meetingology dsmythies contact kirkland to improve the search facility in the server guide
17:08 <pmatulis> i also wanted to mention that ahoneybun, a kubuntu doc person, has mentioned a few times that he's interested in resurrecting the conversion-to-RST project for the server guide. he sent an email saying he could not make it to today's meeting
17:09 <dsmythies> I thought you were no longer insterested in RST and were now suggesting something else.
17:09 <GunnarHj> pmatulis: What's RST?
17:10 <pmatulis> dsmythies: RST or similar, call it "markdown" for now
17:10 <pmatulis> GunnarHj: ReStructurd Text
17:10 <pmatulis> a form of markdown
17:10 <GunnarHj> What would the advantage be compared to DocBook?
17:11 <pmatulis> GunnarHj: it's a lot simpler
17:11 <tedmcox> it's much easier to read/write
17:11 <dsmythies> My input is: without a complete project plan, including trranslations and overall workflow, it is a non-starter.
17:11 <pmatulis> but now i'm wondering if we could not first try markdown out on the installation guide first, since its format is mucked up anyway
17:11 <GunnarHj> pmatulis, tedmcox: Ok.
17:12 <dsmythies> installation guide is not translated either, so goiod candidate.
17:12 <pmatulis> dsmythies: another good point
17:12 <GunnarHj> dsmythies: I also agree with dsmythies about the translation implications. Switching markup language isn't just done like that.
17:12 <dsmythies> Note: installation guide is a "package" though.
17:13 <dsmythies> Myself, I only know how to maintain what we currently have. I have no clue how to start a new project.
17:14 <pmatulis> i'm a bit lost on how the format is related to translations. how does LP understand format? obviously it can digest both DocBook and Mallard
17:14 <dsmythies> ... back in one minute...
17:15 <GunnarHj> pmatulis: LP handles PO/MO files. xgettext is capable of extracting translatable strings from a lot of formats.
17:16 <pmatulis> GunnarHj: so prolly markdown too? and shouldn't PO files be format agnostic?
17:17 <GunnarHj> pmatulis: Yes, they should. So maybe it wouldn't be a huge change, after all.
17:19 <dsmythies> Is there an action?
17:19 <pmatulis> #action talk to ahoneybun and LP people about applying a form of markdown to the installation-guide
17:19 * meetingology talk to ahoneybun and LP people about applying a form of markdown to the installation-guide
17:19 <pmatulis> shoot, does that go to me by default?
17:20 <dsmythies> Yes.
17:20 <pmatulis> ok
17:20 <pmatulis> #action longer-term, figure out how existing PO files can get recycled to apply a new format (markdown) to the source of existing docs (serverguide)
17:20 * meetingology longer-term, figure out how existing PO files can get recycled to apply a new format (markdown) to the source of existing docs (serverguide)
17:22 <dsmythies> Meeting done? Anybody anything else?
17:22 <GunnarHj> Nothing else here.
17:23 <dsmythies> #endmeeting