17:04 <stgraber> #startmeeting Technical Board meeting
17:04 <meetingology> Meeting started Tue Mar 17 17:04:02 2015 UTC.  The chair is stgraber. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
17:04 <meetingology> 
17:04 <meetingology> Available commands: action commands idea info link nick
17:04 <stgraber> #topic Action review
17:04 <stgraber> infinity: speaking of dodging, what's up with MAAS SRU? :)
17:04 <infinity> I just had an hour long chat with roaksoax about it.
17:04 <infinity> And why their request on the list was not even remotely okay.
17:04 <infinity> And how to deal with 1.2's security issues.
17:04 <infinity> Etc.
17:05 <infinity> I'll try to get them to a more sane formal position and have them send something to the list stating their intended policy going forward.
17:05 <stgraber> sounds good
17:06 <stgraber> #topic mailing-list threads
17:06 <stgraber> so I see MAAS which infinity just mentioned, so sounds like we'll just wait for a new proposal to hit the list.
17:06 <stgraber> and the DMB election results which I've processed already.
17:07 <stgraber> #topic community bugs
17:07 <infinity> Yeahp, congrats on being re-elected, captain manyhats.
17:07 <stgraber> still nothing
17:07 <stgraber> infinity: I'm still waiting for the day where we have enough quality applicants that I don't have to...
17:07 <mdeslaur> hehe
17:07 <slangasek> Captain Manyhats, of the HMS Ostentatious
17:08 <infinity> stgraber: I had planned to run, but forgot to nominate before it was closed. :P
17:08 <stgraber> the past two times, I've waited until we were past the nomination period and didn't have enough candidate before running again... so there's clearly a problem there
17:08 <infinity> Not that that solves the ManyHats issue.
17:09 <stgraber> and a few other DMB members have done the same, so yeah, ManyHats is a problem and it's not because people keep voting for the same folks, it's mostly because we don't have enough people interested in being on those boards to begin with...
17:09 <infinity> We need some more good core-devs who are secure enough in their knowledge that they feel qualified to review applicants.
17:09 <stgraber> yep
17:09 <infinity> I'm not positive it's a lack of interest, but perhaps a lack of confidence.
17:10 <infinity> When your job is giving people the keys to the kingdon, you don't want to be the guy who did it wrong.
17:10 <infinity> kingdom, too.
17:10 <stgraber> could be. Also people being overly busy of late and not necessarily wanting to take the time that's needed (though it's one hour every two weeks + some e-mails, so really not that bad)
17:10 <slangasek> from my perspective, one of the concerns is that doing a good job of reviewing candidates is a significant time committment
17:10 <infinity> slangasek: It certainly is when you don't know the applicants, yes.
17:11 <infinity> core-dev applications are probably easier to come to a quick yes/no on, based on their activity and quality of work not blowing up your laptop every two days.
17:11 <stgraber> that's true that it does imply that you're keeping up with Ubuntu development, watch the upload mailing-list and keep up with IRC so you can have a good idea of the candidate
17:12 <infinity> PPU, while a lower bar, is probably harder to review for, cause you lack the same large scale "well, duh, his stuff doesn't break all the time" view.
17:12 <slangasek> so this is an interesting and important topic; did we have any other TB business we needed to attend to first?
17:12 <stgraber> nope, agenda is empty. Next thing is select chair for next meeting and wrap.
17:13 <slangasek> ok
17:13 <kees> infinity is next in alpha order?
17:13 <infinity> Yeahp.
17:13 <stgraber> yeah, I just wasn't sure who covered for the two meetings I missed
17:14 <infinity> stgraber: We just kept skipping meetings so you wouldn't miss out.
17:14 <kees> heh
17:14 <stgraber> :)
17:14 <stgraber> alright, then
17:14 <slangasek> in that case, wouldn't I be next?
17:14 <stgraber> #action infinity to chair next meeting
17:14 * meetingology infinity to chair next meeting
17:14 <stgraber> slangasek: nope, unicode alphabetical order says I'm after you :)
17:14 <infinity> slangasek: You come before stgraber on https://launchpad.net/~techboard/+members
17:15 <infinity> It's that pesky accent.
17:15 <slangasek> how cute, you're suggesting there is such a thing as alpha sorting in Unicode
17:15 <slangasek> ok I see that you're right :)
17:15 <kees> ♥ is greater than everything
17:15 <mdeslaur> heh
17:15 <infinity> Argh.  Unity broke my compose key AGAIN.
17:16 <infinity> I can't type stgraber's name properly.  Oh well.
17:16 <slangasek> 💩
17:16 <infinity> I thought unicode sorting was meant to treat accented vowels as lexically equivalent to their base.
17:17 <infinity> Maybe LP disagrees.
17:17 <stgraber> infinity: well, there's also the issue that é has two unicode code points
17:17 <slangasek> I think we can just go with whatever LP does here and skip getting existential about locale-independent lexical sorting
17:17 <infinity> slangasek: But then we wouldn't be us.
17:17 <stgraber> infinity: it's either a single 8bit char or a composed e + accent. The former is the most common and doesn't sort properly, the latter would sort fine
17:18 <slangasek> Was it worth further discussion about the DMB staffing question?  We're obviously a way out from the next election, but should we try to do something to encourage more people to stand?
17:19 <stgraber> I think it's a problem we've got across the board, it's hardly DMB specific. Looking around, most boards had to issue two calls for nominations because they didn't get enough applicants (just noticed that with some other board earlier this week)
17:19 <infinity> The TB had no shortage of applicants the last couple of times, IIRC.
17:19 <stgraber> it's also something we've raised with the CC in the past, though it's not obvious how to fix that. So far, for the DMB what we had the most luck with was nagging potential candidate on IRC directly.
17:19 <infinity> At least, before Mark curated the list.
17:20 <infinity> Perhaps the call for nominations could include a bit more info about what the job entails and why people might want to run.
17:20 <infinity> Not that we'll remember this conversation in 2 years.
17:20 <stgraber> in 1 year actually :)
17:21 <stgraber> DMB term are two years long but we have half the board expiring every year
17:21 <infinity> Oh, well, much better.  I remember everything for 12.5 months.
17:21 <infinity> How very US senate of you.
17:22 <stgraber> can't remember how we ended up in that situation, possibly some members leaving half way through or some like that, but anyway, it's convenient
17:22 <stgraber> #topic AOB
17:22 <stgraber> anything else or should we wrap?
17:22 <slangasek> seems like that's it
17:22 <infinity> I don't have anything.
17:23 <mdeslaur> I don't have anything either
17:23 <stgraber> #endmeeting