17:29 <dsmythies> #startmeeting Ubuntu Docs
17:29 <meetingology> Meeting started Tue Feb  3 17:29:41 2015 UTC.  The chair is dsmythies. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
17:29 <meetingology> 
17:29 <meetingology> Available commands: action commands idea info link nick
17:30 <dsmythies> #chair dsmythies
17:30 <meetingology> Current chairs: dsmythies
17:30 <dsmythies> Anybody here for Ubuntu Docs team meeting?
17:31 <imnichol> as an observer
17:31 * PaulW2U says me too
17:32 <dsmythies> O.K. this could be a real quick meeeting.
17:33 <dsmythies> Myself, I am quite unprepared for this meeting, and the adgenda is out of date.
17:35 <pmatulis> hello, i'm here
17:36 <pmatulis> although currently in a work meeting :)
17:36 <dsmythies> I'm just reviewing the minutes from last time and any still relveant adgenda items...
17:37 <pmatulis> dsmythies: i would love to remove stuff but i don't know if people are still working on them
17:37 <dsmythies> Does anybody have anything they want to bring up?
17:38 <pmatulis> the cloud docs are up, that's something
17:39 <dsmythies> Clouddocs: I thought I would post an announment on the Ubuntu forums sub-forum you set up. I can not recall if we announced them on the mail list, but if not we should.
17:40 <dsmythies> #action dsmythies make some announcements about the Canonical Clouddocs
17:40 * meetingology dsmythies make some announcements about the Canonical Clouddocs
17:42 <dsmythies> On Sunday night, I made a mistake on an update for help.ubuntu.com that left the new Canonical clouddocs site without any .css file for one day. Sorted out now.
17:43 <dsmythies> reference: https://help.ubuntu.com/lts/clouddocs/en/Intro.html
17:43 <pmatulis> dsmythies: your proposal for the sg was to change trunk away from 14.04 when 14.04.1 came out.  that was july 24th.  what do you want to do?
17:44 <pmatulis> (and 14.04.2 is in a couple of days)
17:47 <dsmythies> I'd have to remind myself, but I still do not see any reason to deviate the trunk from 14.04 yet. i.e. I haven't yet observed any non-backwards compatible changes. (which doesn't mean they don't exist, I just don't know about them if they do.)
17:48 <dsmythies> We never did do a 14.10 non-stable release, and I don't know about 15.04, but why bother?
17:50 <pmatulis> well eventually we are going to get bit
17:51 <pmatulis> i still don't like the idea but i can understand the convenience
17:52 <pmatulis> especially since we get so little contributions
17:52 <dsmythies> Yes, so at that point we lock down the 14.04 series branch and the trunk continues. But until then why double the work of maintaining two branches?
17:53 <dsmythies> The thinking was if you or, some other champion, wanted to start towards some other markup language, then would lock down 14.04 and the trunk would become the devleopment branch with a good long time until 16.04 lts.
17:55 <dsmythies> Peter: I was typing and didn't see your last two comments. Yes, I am always trying to minimize labour, becuase there isn't any labout available.
17:55 <pmatulis> dsmythies: do you use bzr 'shared repositories' when you do your committing work?
17:56 <dsmythies> I guess not because I don't know what you mean. I use "bzr commit -m 'bla bla bla' then bzr push
17:58 <pmatulis> dsmythies: well with shared repos things go a lot faster b/c the changes metadata is shared.  you should try it.  it might make the labour easier if by labour you mean having a lot of dowload waiting time
17:59 <pmatulis> http://wiki.bazaar.canonical.com/SharedRepositoryTutorial
18:01 <pmatulis> dsmythies: btw, a colleague of mine is contributing an ActiveDirectory/SSSD sub-chapter.  it's based on 14.04 so no worries about compat. problems
18:02 <dsmythies> I mean doing the same thing twice, once for each branch. Is this "shared" thing something that could have been used for backporting your reporting bugs patch to precise?
18:03 <pmatulis> dsmythies: no
18:04 <pmatulis> dsmythies: thanks for reminding me of that.  and i really did that oopsies way to quick.  sorry about that one
18:05 <dsmythies> imnichol and/or PaulW2U: please chime in or whatever if you want. We are just discussing stuff.
18:05 <pmatulis> dsmythies: btw, was 12.04 updated on help recently?
18:05 <pmatulis> dsmythies: i know i merged quite a few fixes for 12.04
18:06 <dsmythies> Peter: Let me catch up via the reference you gave. (Not now, but afterwards).
18:06 <dsmythies> Peter: I did do a point release of 12.04, but I don't think since some of your recent changes.
18:06 <pmatulis> dsmythies: ok
18:07 <dsmythies> I think we should do a much more advertised point releaae of both 12.04 and 14.04. By "advertiesed" I mean post on the translators e-mail list that it is pending and give them a few weeks to do their stuff.
18:09 <dsmythies> for example. the italian serverguide had 0 string to translate and then it went to 50 or so, but how would they know if we don't tell them? (since it isn't on their list, why I do not know)
18:09 <pmatulis> dsmythies: agreed.  and i would like to do the 12.04/14.04 updates but i'm still a little shell-shocked from what happened during my last attempt
18:11 <dsmythies> we will just work more closly this time, and do a merge proposal for help.ubuntu.com. I would like to try to implement my relative URL thing, instead of absolute, also.
18:11 <pmatulis> dsmythies: yep
18:12 <pmatulis> dsmythies: having introduced nick to you and gunnar was good
18:13 <dsmythies> #action dsmythies pmatulis prepare for and execute point releases for serverguides 12.04 and 14.04 quickly before 15.04 crunch time.
18:13 * meetingology dsmythies pmatulis prepare for and execute point releases for serverguides 12.04 and 14.04 quickly before 15.04 crunch time.
18:14 <dsmythies> Peter, I was already working with Nick via problem reports I had entered. But yes, thanks.
18:15 <pmatulis> dsmythies: should we be stating on the s/g focus page for contributors to be using 14.04?  then the onus would be on us to see whether 14.04 stuff works with a newer release instead of the more dangerous 'hope that 15.04 works on 14.04' option
18:15 <pmatulis> dsmythies: i would be more comfortable with the former
18:18 <dsmythies> Good idea. However, the build tools should be at least 14.10 based, until my yelp-tools and telp-xsl backport request gets somewhere. It seems to have stalled. As far as I know I have completed the testing requirements.
18:19 <pmatulis> dsmythies: right, it's easier to manage 3 people
18:20 <pmatulis> dsmythies: yep, ubuntu backports is a mechanism but there is no promise of that working at all
18:21 <dsmythies> Well, it is a year now that I have wanted yelp-tools and yelp-xsl to be more recent.
18:21 <dsmythies> imnichol and/or PaulW2U: Can we help you with anything?
18:21 <pmatulis> dsmythies: i think we should either use at least 14.10 as a build server or use a PPA
18:22 <pmatulis> dsmythies: did you give me an action to send a help request to the mailing lists (ubuntu-doc and ubuntu-server)?
18:23 <dsmythies> The PPA exisits. Gunnar made it. Since I always forget how, I made web notes to include and later on remove the PPA. Servers work different than desktop for PPA stuff.
18:25 <dsmythies> #action pmatulis send a help request to the mailing lists (ubuntu-doc and ubuntu-server)
18:25 * meetingology pmatulis send a help request to the mailing lists (ubuntu-doc and ubuntu-server)
18:26 <dsmythies> I'll send anyone a link to y PPA web notes, if they ask. But I will include it herein.
18:27 <dsmythies> I'll send anyone a link to y PPA web notes, if they ask. But I will NOT include it herein.
18:27 <dsmythies> Are we done?
18:28 <pmatulis> dsmythies: i am making changes to the focus page re contributors using 14.04
18:29 <dsmythies> #action pmatulis make changes to the focus page re contributors using 14.04
18:29 * meetingology pmatulis make changes to the focus page re contributors using 14.04
18:30 <pmatulis> dsmythies: updated the page.  want to check and get it over with?
18:30 <dsmythies> I'll close the meeting after I find and include a link to the yelp stuff PPA.
18:30 <dsmythies> Peter: I'll do that off-line. Give me a bit.
18:34 <dsmythies> Reference for the yelp stuff ppa: https://launchpad.net/~ubuntu-core-doc/+archive/ubuntu/ppa
18:34 <dsmythies> #endmeeting