17:03 <slangasek> #startmeeting
17:03 <meetingology> Meeting started Tue Jan 20 17:03:02 2015 UTC.  The chair is slangasek. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
17:03 <meetingology> 
17:03 <meetingology> Available commands: action commands idea info link nick
17:03 <pitti> slangasek: https://wiki.ubuntu.com/TechnicalBoardAgenda updated
17:03 <slangasek> [LINK] https://wiki.ubuntu.com/TechnicalBoardAgenda
17:04 <slangasek> [TOPIC] Apologies
17:04 <slangasek> I think you said mdeslaur and infinity sent their apologies today
17:04 <slangasek> stgraber seems to be here
17:04 <slangasek> no sign of kees?
17:05 <stgraber> yeah, I'm around
17:05 <pitti> right, infinity apol'ed on IRC, mdeslaur on the ML
17:05 <slangasek> ok
17:06 <slangasek> [TOPIC] Action review
17:06 <slangasek> * infinity to review and respond to MAAS SRU thread
17:06 <slangasek> I don't recall if this was still carried over from last time?
17:06 <slangasek> I assume it is, without infinity here to tell us otherwise
17:07 <pitti> it is, yes; he expressed is refreshed intent to reply two weeks ago
17:07 <pitti> (sorry for lag, still in QA team meeting hangout)
17:08 <slangasek> mailing list topics...
17:08 <slangasek> there's a docker question on the mailing list
17:08 <slangasek> anything we should discuss on that?
17:09 <pitti> oh, you mean https://lists.ubuntu.com/archives/technical-board/2014-December/002062.html
17:10 <slangasek> yes
17:11 <pitti> I'm not very happy about that, TBH
17:11 <slangasek> should we discuss it here? or follow up on the list?
17:11 <pitti> either major versions do keep backwards compat, then a docker-latest package would be eaiser to maintain than letting intermediate major versions in -updats just bitrot
17:12 <pitti> and if they don't keep backwards compat AND fixes are hard to backport, then it's even worse: it essentially means that we claim that we can't support that package at all
17:12 <pitti> and then it shouldn't be in a stable release at all, but people should rather get it from a PPA, or charm, or whatever
17:12 <pitti> (but I don't quite believe that just yet)
17:14 <slangasek> there are various well-known problems with using ppas as a distribution mechanism, particularly for servers
17:14 <slangasek> yes, I think we are saying we can't support docker in the LTS according to our usual model
17:15 <pitti> and the proposal in that above mail would combine the disadvantages
17:15 <slangasek> but as the package is already in the LTS, we should figure out what to do with this fast-moving, high-profile package
17:15 <pitti> a lot of packages to maintain, and users have to choose between "reproducability of installations but insecure" and "secure, latest release, breaks backwards compat"
17:16 <slangasek> "a lot of packages to maintain" - I'm not sure that's the TB's problem, however?
17:16 <pitti> well, "LTS" -- it's in universe, so ceratinly not a 5 year support thing
17:16 <pitti> it's not, but I don't quite see how it would help the problem
17:16 <slangasek> the maintenance (or lack thereof) falls on the team pushing for this; if the server team thinks this is the right tradeoff for them...
17:16 <pitti> if they break compat, we can't obviously upgrade existing users automatically
17:16 <pitti> so we'd have to backport fixes anyway
17:17 <slangasek> ok
17:17 <slangasek> I think this probably warrants more discussion on the mailing list, then?
17:17 <pitti> yeah, I think so
17:17 <slangasek> [TOPIC] docker in 14.04
17:18 <slangasek> [ACTION] pitti to follow up on the mailing list regarding his concerns about upgradeability
17:18 * meetingology pitti to follow up on the mailing list regarding his concerns about upgradeability
17:18 <slangasek> there's also this on the mailing list: https://lists.ubuntu.com/archives/technical-board/2014-December/002061.html
17:18 <slangasek> looks like the ball is in the Kubuntu team's court however
17:19 <slangasek> so probably nothing further needed on our side, except perhaps a gentle ping to Riddell / ScottK
17:19 <pitti> from my POV we are waiting for some SRU test plan?
17:19 <slangasek> right
17:20 <slangasek> I don't see anything else on the list
17:20 <slangasek> [TOPIC] Check up on community bugs
17:20 * pitti neither
17:20 <slangasek> https://bugs.launchpad.net/ubuntu-community/+bugs?field.assignee=techboard is empty
17:21 <slangasek> that seems to be everything, then
17:21 <slangasek> chair for next meeting should be stgraber
17:21 <slangasek> [TOPIC] Next meeting
17:21 <slangasek> [INFO] Chair for next meeting is stgraber
17:22 <stgraber> note that I may not be available two weeks from now
17:22 <slangasek> oh, indeed
17:22 <stgraber> as slangasek, infinity and I will be at a sprint in Cape Town and may be in meetings or other social things at the time
17:22 <slangasek> 7pm, hopefully not in meetings :)
17:23 <pitti> slangasek: famous last words!
17:23 <pitti> anyway, I can do that
17:23 <slangasek> [INFO] Next meeting date: 2015-02-03 @ 1700 UTC
17:23 <pitti> I'll be back home from Brussels then
17:23 <slangasek> [INFO] pitti possibly to chair in stgraber's place due to sprint
17:23 <slangasek> anything else?
17:24 <slangasek> #endmeeting