19:05 <knome> #startmeeting
19:05 <meetingology> Meeting started Wed May  7 19:05:52 2014 UTC.  The chair is knome. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:05 <meetingology> 
19:05 <meetingology> Available commands: action commands idea info link nick
19:05 <knome> #chair belkinsa
19:05 <meetingology> Current chairs: belkinsa knome
19:06 <belkinsa> godbyk, and pmatulis_
19:06 <knome> #unchair knome
19:06 <meetingology> Current chairs: belkinsa knome
19:06 <belkinsa> #chair godbyk pmatulis_
19:06 <meetingology> Current chairs: belkinsa godbyk knome pmatulis_
19:06 <belkinsa> #unchair knome
19:06 <meetingology> Current chairs: belkinsa godbyk knome pmatulis_
19:06 <godbyk> knome: You were awfully spry with meetingology.. sure you don't want to be a chair? :-)
19:06 <knome> yeah, i'm running in 5
19:06 <godbyk> Anyway..
19:07 <knome> heh, the #unchair command doesn't work
19:07 <godbyk> We were discussing polling to see who users the docs and how often, etc.
19:07 <belkinsa> #topic Desktop: Finding a driver
19:07 <godbyk> knome: Guess you're stuck with it!
19:07 <knome> ;)
19:07 <knome> will contact people who'll fix the bot! :P
19:07 <belkinsa> #topic Desktop: Making poll for Doc Team
19:08 <belkinsa> Maybe this could be worked out via the mailing-list and brought up again in the next meeting?
19:09 <godbyk> That's fine with me. Has anyone volunteered to start that discussion?
19:12 <pmatulis_> i brought it up but it should really come from a desktop person
19:12 <belkinsa> Well, it could be all forms of the docs.
19:12 <belkinsa> it = poll.
19:12 <godbyk> pmatulis_: There's no reason you can't send an email to the list about it, though. :)
19:12 <pmatulis_> godbyk: i can send an email, no biggie
19:12 <godbyk> pmatulis_: (I don't think there's are any toes to be stepped on. ;-))
19:12 <belkinsa> #action pmatulis_ Send e-mail to the List about making a poll
19:12 * meetingology pmatulis_ Send e-mail to the List about making a poll
19:12 <GunnarHj> pmatulis_: Thanks. :) (There are not so many desktop people around, that's where we began the discussion.)
19:13 <knome> bbl.
19:13 <belkinsa> See ya knome
19:13 <pmatulis_> GunnarHj: well, there's only one server people around :)
19:13 <belkinsa> Moving on...
19:14 <belkinsa> ;topic Desktop: Stable release update before 14.04.1?
19:14 <belkinsa> #topic Desktop: Stable release update before 14.04.1?
19:14 <pmatulis_> and if you guys don't mind, i need to pick up a certain small person at a certain school bus stop or a certain person is going to get into a whole heap of certain trouble.  be back in 10 for the server part
19:14 <belkinsa> Sure, pmatulis_
19:15 <GunnarHj> The bot seems to be off.
19:15 <GunnarHj> My item anyway.
19:15 <belkinsa> No, it's normal.  It only works like that in the meeting channel.
19:15 <GunnarHj> Ok..
19:16 <belkinsa> I think we will need it since there will many upgrading from 12.04 LTS to this one.
19:17 <GunnarHj> I thought that since 14.04 is a LTS, we should make it possible to improve the desktop guide compared to what was shipped in April. But considering the item we just discussed, I'm currently not very inclined to open up ubuntu-docs for trusty.
19:18 <belkinsa> Yeah, I agree until we know how many are really using the docs.
19:18 <godbyk> Is there are to do list for desktop docs for 14.04.1?
19:18 <GunnarHj> godbyk: No.
19:19 <GunnarHj> godbyk: There are a few bug reports, that's all.
19:19 <belkinsa> Maybe a to do list is needed to keep the sub-team on track
19:20 <GunnarHj> Indeed. That's why a driver would have been nice to have. ;)
19:20 <GunnarHj> I suggest that we leave it as is for now.
19:20 <belkinsa> Maybe I can be the temp one to just get a task list going?
19:21 <GunnarHj> belkinsa: Are you volunteering as a temporary desktop guide driver?
19:22 <belkinsa> GunnarHj, yeah, but I  think I might be barking up the wrong tree here
19:25 <GunnarHj> Actually, as long as we are only talking about fixing known bugs, we don't need a todo list.
19:25 <belkinsa> Let's just leave it here until we know the usage of the docs
19:26 <GunnarHj> +1
19:26 <godbyk> brb
19:26 <belkinsa> Okay.
19:26 <belkinsa> We will be skipping to Ubuntu Manual since pmatulis_ is not here yet.
19:27 <belkinsa> #topic Ubuntu Manual
19:27 <belkinsa> godbyk, I know there was some talk in the mailing-list about the manual but do you have anything to bring up?
19:30 <pmatulis_> back
19:30 <belkinsa> Welcome back
19:30 <belkinsa> We skipped your items but they will be next once godbyk gets back.
19:32 <belkinsa> Or not.
19:32 <belkinsa> #topic Server: Revisit option of moving from XML Docbook to RST Markdown
19:33 <belkinsa> Objective: lowering barrier to contribution; a common complaint
19:33 <belkinsa> We have lots of time since the Server Guide is only officially published every LTS
19:33 <belkinsa> I've already gone over the main machinations to do this
19:33 <belkinsa> Primary issue is fixing all the broken stuff caused by the conversion (lots of broken hyperlinks)
19:33 <belkinsa> Secondary issue is settling on the appearance/theme; example here: http://serverguide.papamike.ca:8081/
19:33 <belkinsa> Discuss changes in workflow for translators as part of changing to Markdown
19:33 <belkinsa> What changes in workflow are needed to create the PDF version. Will pandoc do the job? Effectively YES
19:34 <belkinsa> Also is there another other server person here along with pmatulis_?
19:35 <pmatulis_> nope, just me to my knowledge
19:35 <belkinsa> Then I think this could be talked in the list of this team and the Server team, if possible,
19:36 <pmatulis_> er, ok
19:36 <belkinsa> If that is okay with you.
19:36 <GunnarHj> belkinsa: Why are you so reluctant to use the meeting to talk about things?
19:36 <pmatulis_> it's fine, i'll send another email :)
19:37 <belkinsa> Because we lack people and it's impossible to get anything done now.  And we are going to the 120 minute mark.
19:38 <belkinsa> The start was fine.
19:38 <pmatulis_> it's ok
19:38 <GunnarHj> Ok.. Maybe this will improve when we meet more often.
19:38 <belkinsa> I think it will.  ;)
19:39 <belkinsa> And also I think when we know how many are really using the docs.
19:39 <pmatulis_> the upshot is that i'm all alone with the server guide in terms of driving/reviewing/committing
19:40 <GunnarHj> Re using the docs, personally I think that's part of a huge topic. But I'll comment on the list.
19:40 <GunnarHj> pmatulis_: Upshot? ;)
19:40 <pmatulis_> and contributions are dwindling to record low levels
19:41 <pmatulis_> GunnarHj: s/upshot/summary
19:41 <GunnarHj> ok
19:41 <belkinsa> I see.
19:41 <belkinsa> I think it's happening in most teams, losing numbers.
19:41 <pmatulis_> i send emails out and get replies.  i take the time to reply, but nothing *ever* comes back
19:42 <GunnarHj> So basically the situation for the server is just as poor as for the desktop guide. :(
19:42 <pmatulis_> hence the agenda of moving to a more palatable format, markdown
19:42 <belkinsa> And i think is the same for Ubuntu Manual and the wiki.
19:43 <GunnarHj> I think we should highlight this at the vUDS.
19:43 <belkinsa> +1
19:43 <pmatulis_> we do every time
19:44 <GunnarHj> Then let's do it louder. :)
19:44 <belkinsa> Might not help.
19:44 <knome> hmph.
19:45 <pmatulis_> it's hard to compete with the likes of google/askubuntu/forums.  if readership is low (people tend towards 'gimme the answer'), people do not sense a big importance
19:45 <belkinsa> I thought you were gone, knome.
19:45 <knome> to be honest, i don't think any markup is the blocker.
19:45 <knome> i'm back.
19:45 <belkinsa> Welcome back.
19:45 <belkinsa> knome, I agree, it's the readership.
19:45 <knome> if there aren't people to guide the new contributors with whatever issues they have, they are not going to contribute
19:46 <knome> most might have problems or be unsure with even reporting bugs
19:46 <belkinsa> I think we are in that cultural sense of just give me the answer.
19:47 <pmatulis_> knome: you feel that people do not contribute b/c of a lack of support/guidance?
19:47 <knome> yeah.
19:47 <pmatulis_> i don't think people even get far enough to know
19:47 <knome> that's part of it
19:48 <GunnarHj> I tend to agree with pmatulis_ on that one.
19:48 <pmatulis_> they just look at the procedures and close the tab, or at best go to the wiki instead
19:48 <belkinsa> I'm just chaning the topic since we are talking about already.
19:48 <belkinsa> #topic Any other Business
19:48 <knome> if we think the procedures page is a bit too daunting, rewrite it
19:48 <belkinsa> We could.
19:48 <knome> tbh, why point any new people to specific procedures anyway?
19:49 <belkinsa> Didn't balloons say something about it?
19:49 <knome> why not tell them "you can help us and it's easy (lies!)"
19:49 <balloons> ^-^
19:49 <knome> then point them to a resource where they can talk with people
19:49 <pmatulis_> anyway, based on the last 4 or so UDSs, people keep mentioning lowering the barrier by replacing XML with something simpler.  it is definitely a PITA to deal with
19:49 <knome> ...and get enough people to talk with them
19:49 <knome> pmatulis_, who people?
19:49 <knome> pmatulis_, the people who contribute?
19:50 <pmatulis_> knome: the people who decide to show up to the UDS sessions or remotely on irc
19:50 <belkinsa> And not do any work for the team?
19:50 <GunnarHj> pmatulis_: Which are probably not prospective contributors.
19:50 <belkinsa> or the project.
19:50 <pmatulis_> if *those* people are saying this, you need to wonder about how the average joe feels
19:51 * knome shrugs
19:51 <knome> we recently rewrote the whole xubuntu documentation
19:51 <knome> while i converted most of the stuff to docbook, others have done that as well and it has been no problem
19:51 <knome> there are enough examples around.
19:51 <knome> in the documentation, that is
19:52 <pmatulis_> interesting.  you get enough contributions for xubuntu?
19:52 <knome> want to know how something is done? look that up in the source.
19:52 <belkinsa> And readership.
19:52 <godbyk> Sorry, guys. I had a phone call and I need to get back to some other work now. I'll read the logs of this conversation later, though.
19:52 <pmatulis_> knome: look what up in the source?
19:52 <GunnarHj> We would probably need more of that community spirit as you apparently have in xubuntu.
19:52 <godbyk> belkinsa: Thanks for setting up and chairing the meeting today!
19:52 <belkinsa> godbyk, alright/
19:52 <belkinsa> Not a problem
19:52 <knome> pmatulis_, look up how it's done.
19:53 <pmatulis_> knome: how what is done?
19:53 <knome> ~xubuntu-doc is 9 members, of which pretty much everybody are either active or were active when we did the rewriting
19:53 <knome> pmatulis_, well, anything you want to know...
19:53 <pmatulis_> knome: about writing XML?
19:53 <belkinsa> Look, I think we *need* to first figure out the readership then work on lowering that barrier to entry to change something.
19:53 <knome> pmatulis_, "hey, there's a cool infobox there"
19:53 <knome> pmatulis_, -> go see the source and copypaste, change the content
19:54 <knome> pmatulis_, "i wonder how to add that kind of header"
19:54 <knome> pmatulis_, -> go see the source and copypaste
19:54 <knome> i understand some people are not interested in doing things like that, or learn low-medium -difficulty things
19:55 <knome> but hey... maybe docs is not for them then.
19:55 <knome> maybe they prefer giving irc support
19:55 <knome> but to my original point...
19:55 <knome> i don't think any markup is a problem
19:55 <knome> if people are motivated to help, they will
19:56 <knome> we can't motivate them to help by telling how easy our markup is.
19:56 <pmatulis_> there are degrees of motivation
19:56 <knome> that's not a marketing point.
19:56 * belkinsa sighs.
19:56 <knome> it's cool and nice that it is easy
19:56 <belkinsa> I think I want to end this and just have it in a non-meeting setting.
19:56 <knome> but it itself won't gather contributors
19:56 <knome> belkinsa, why?
19:57 <knome> belkinsa, aren't the meetings for discussion?
19:57 <belkinsa> Good point but I think it's just you two now.
19:57 <belkinsa> And we are at the two hour makr.
19:57 <belkinsa> mark
19:57 <GunnarHj> belkinsa: me too
19:58 <belkinsa> Oh, sorry, GunnarHj.
19:58 <knome> i imagine the logs for the meeting will be specifically up on the meetings page
19:58 <belkinsa> They will.
19:58 <knome> regular irc logs arent'.
19:58 <belkinsa> Good point.
19:58 <knome> or they are, but you really have to dig deep to find anything
19:58 <GunnarHj> And this discussion is indeed important.
19:58 <knome> seems like pmatulis_ went quiet though
19:58 <belkinsa> FIne.
19:58 <pmatulis_> i'm here
19:59 <knome> pmatulis_, so if we had a simpler markup, contributors would flood in from doors and windows? :)
19:59 <pmatulis_> pretend you are a horse
19:59 <pmatulis_> and you see some obstacles up ahead
20:00 <pmatulis_> you will tend to shy away from the really talls ones, unless you are a super horse
20:00 <knome> now you are saying the markup is the first obstacle
20:00 <knome> it shouldn't
20:01 <knome> (be)
20:04 <GunnarHj> knome: Well, you mentioned 9 active contributors to the xubuntu docs. If we had just half of that for standard Ubuntu we could accomplish a lot.
20:04 <knome> exactly
20:05 <pmatulis_> if we presume an interest in contributing, then, yes, the procedures presents an obstacle that the person either overcomes or does not
20:05 <knome> the average contributor doesn't mind *any* procedures
20:05 <knome> it makes contributing sound like a lot of work
20:06 <knome> if they could chat with somebody who explained them some of the procedures while they were asking questions, the barried would be a lot lower
20:06 <knome> "oh btw, we have these procedures, but you know half of them already"
20:06 <knome> and if people do something "wrong"... what does it matter?
20:06 <knome> the procedures should hardly be the starting point
20:08 <pmatulis_> well, answer me this then.  why is the wiki & askubuntu & forums an evergrowing pile of contributions while those that depend on docbook are not?  because it's easy as hell, that's why
20:09 <knome> they are different kind of projects to begin with
20:09 <knome> the point is human interaction
20:09 <GunnarHj> Well, I for one think the main problem is a lack of people with a true interest in contributing. People with a true interest in contributing are not intimidated by a few procedures. They understand that they are needed.
20:09 <knome> except in wikis, where the point is "everybody acan edit"
20:10 <knome> the documentation is different by design
20:10 <knome> whether it was in docbook or markdown
20:12 <GunnarHj> pmatulis_: I think I have an answer to why it's easier to make people contribute to askubuntu and forums: By answering there you instantly shows how skilled you are. People like that. :)
20:12 <pmatulis_> GunnarHj: there is some of that isn't there.  good point
20:13 <knome> yeah, social acceptance too
20:14 <belkinsa> It is a today's culture thing.
20:15 <GunnarHj> OTOH askubuntu, forums and such are ineffective. The same questions and answers are posted multiple times at multiple places. That's why a core set of docs is a good thing.
20:15 <belkinsa> That's why I think we need to figire out readership.
20:15 <pmatulis_> GunnarHj: you mean inefficient prolly
20:15 <belkinsa> Indeed, GunnarHj and that's why I questioned why the need of AskUbuntu/Forums.
20:16 <pmatulis_> GunnarHj: but, they supply what the people want
20:16 <GunnarHj> pmatulis_: Yeah, I probably mean inefficient. Sorry.
20:16 <pmatulis_> GunnarHj: a quick answer to their problem
20:16 <GunnarHj> pmatulis_: True.
20:17 <belkinsa> #link https://lists.ubuntu.com/archives/ubuntu-doc/2013-December/018229.html
20:18 <GunnarHj> Which leads me to the conclusion that our difficulties in recruiting contributors depends on the fact that there are far too many willing answerers in the forums. :)
20:18 <pmatulis_> so we are weak at both the readership level and the contributor level (boring anonymous xml drudgery)
20:18 <belkinsa> +1
20:18 <belkinsa> Yes.
20:19 <pmatulis_> difficult for sure
20:21 <pmatulis_> not to mention the fact that our own doc contributor pool is splintered into wiki.ubuntu.com, help.ubuntu.com/community, help.ubuntu.com, ubuntu manual
20:22 <knome> wiki.ubuntu.com shouldn't be documentation.
20:22 <belkinsa> Yeah, more for team pages and that such things/
20:22 <knome> if there are documentation bits there, they should be directed at developers and at most, testers
20:22 <pmatulis_> i stand corrected
20:23 <knome> it's likely that there is some documentation there though... if you bump into it, notice it on the channel
20:23 <pmatulis_> quick check gave me
20:23 <pmatulis_> https://wiki.ubuntu.com/Kernel/Support
20:23 <pmatulis_> and it didn't take long
20:24 <knome> that's borderline
20:24 <pmatulis_> anyway, i made my point!
20:24 <knome> and the kernel team probably prefers to maintain it there
20:24 <belkinsa> I agree with knome.
20:26 <pmatulis_> they evidently do prefer to keep their documentation there
20:26 <pmatulis_> anyway, i'm fried.  anything else to the meeting?
20:26 <GunnarHj> The big challenge is that there are few "average Joes" among the Linux users. "Average Joe" does not run his own server per se, and most desktop users are power users who don't mind googling around to get their expert questions answered.
20:27 <belkinsa> Nothing.  I'm not in the mood to talk about the Wiki sub-team item since no one of the PopularsPages are here.
20:27 <belkinsa> I think we just need to try to get monthly meetings going and a poll about readership up.
20:28 <belkinsa> And network with developers.
20:29 <belkinsa> And sorry for my mood shift.
20:29 <GunnarHj> I'm going to problematize that readership poll. But let me do so on the list.
20:30 <belkinsa> Sure.
20:30 <belkinsa> ANd it's pmatulis_ action item to bring it up.
20:30 <GunnarHj> right
20:30 <knome> i'm sure he doesn't mind if GunnarHj brings it up.
20:30 <knome> just get things done
20:31 <belkinsa> #action GunnarHj Be the back up of pmatulis_'s item
20:31 * meetingology GunnarHj Be the back up of pmatulis_'s item
20:31 <GunnarHj> ok, I can be backup. :)
20:31 <belkinsa> Okay!  I'm calling this meeting to an end.  Thanks for all for coming.
20:32 <belkinsa> #endmeeting