10:01:17 <jaddi27> #startmeeting UGJ Mar 2012 - Australian Localisation
10:01:17 <meetingology> Meeting started Fri Mar 2 10:01:17 2012 UTC. The chair is jaddi27. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
10:01:17 <meetingology>
10:01:17 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
10:01:31 <jaddi27> #chair sagaci
10:01:31 <meetingology> Current chairs: jaddi27 sagaci
10:01:39 <jaddi27> Hi everyone
10:02:13 <jaddi27> This is not a formal meeting, but is an easy way to keep track of what happens
10:03:25 <jaddi27> We are going to discuss localising Ubuntu for Australia
10:03:25 <jaddi27> https://bugs.launchpad.net/ubuntu/+bug/872839
10:03:27 <lubotu2> Ubuntu bug 872839 in Ubuntu "no localised Australian CD ISO" [Undecided,Confirmed]
10:04:14 <jaddi27> The current status is tracked in a Blueprint under the Ubuntu project on Launchpad
10:04:14 <jaddi27> https
10:04:28 <jaddi27> https://blueprints.launchpad.net/ubuntu/+spec/ubuntu-au-iso-l10n
10:05:01 <jaddi27> And for some background on localisation, check out these pages:
10:05:02 <jaddi27> https://blueprints.launchpad.net/ubuntu/+spec/desktop-o-cd-localization
10:05:34 <jaddi27> https://wiki.edubuntu.org/DesktopTeam/Specs/Oneiric/LocalizedCDImageTools
10:06:30 <jaddi27> https://wiki.ubuntu.com/OneiricOcelot/LocalizedImagesRollout
10:09:32 <jaddi27> First, I think we should look through the localisation blueprint, and the brainstorming on pad (link on the blueprint page)
10:10:54 <jaddi27> http://pad.ubuntu.com/s5Asqt2GWm
10:11:30 <jaddi27> Starting with the Browser customisations
10:16:06 <sagaci> relog
10:16:47 <jaddi27> I think that the suggested browser settings should be used
10:17:15 <jaddi27> Maybe we should not change the home page though (unless we can set multiple home pages)
10:17:57 <jaddi27> Canonical receive money for people using the default Ubuntu start page, so we should probably leave it there
10:19:05 <jaddi27> The Bookmarks list is certainly a good start, and I think that we could come up with a more definitive list for inclusion
10:20:27 <jaddi27> What do you all think of bookmarks and home page?
10:20:50 * benonsoftware thinks the homepage should be left to the Ubuntu start page
10:21:02 <sagaci> just bringing up the pad
10:22:07 <jaddi27> Ok. I just found another section that says the browser start page should not be changed
10:26:51 <jaddi27> my apologies for that
10:27:10 <jaddi27> Maybe we should move on to the next section
10:27:56 <jaddi27> I think the mailing list would be useful, but it might be better to link to a wiki page about the mailing list
10:28:19 <benonsoftware> Ok
10:29:23 <benonsoftware> jaddi27: So use https://wiki.ubuntu.com/AustralianTeam/MailingLists instead of lists.u.c?
10:29:56 <jaddi27> benonsoftware: Yes, I think that would be better
10:30:00 <benonsoftware> Ok
10:30:22 <jaddi27> Just so that people have an idea about what it is - the lists.u.c page is very non-descriptive and confusing for new people
10:30:33 <benonsoftware> Yeah
10:31:12 <jaddi27> Moving on to the Language Pack
10:32:04 <jaddi27> We have now translated 99.9% of packages into en_AU
10:32:20 <jaddi27> so we should be fine setting the default pack to en_AU
10:32:39 <jaddi27> If we can set a fallback, I think it should be en_GB, as it is a much closer language to our own
10:33:34 <jaddi27> Desktop Wallpaper
10:34:36 <sagaci> iirc, you can only set one
10:34:44 <jaddi27> I am not entirely sure, but I have a feeling I read somewhere that they did not want the default wallpaper to be changed, as they wanted people to have the main desktop experience for that version of Ubuntu
10:35:47 <jaddi27> Maybe we could make a image pack with images that can be used as desktop wallpapers, even if they are not included in the main localisation package
10:38:08 <benonsoftware> Ok then
10:38:50 <jaddi27> I like the idea of a competition to select images for the pack, as this will assist with getting good quality images for inclusion
10:38:57 <jaddi27> Radio Stations
10:39:09 <benonsoftware> Ok, what types of images would be good?
10:39:19 <sagaci> there's a difference between the localised image and localised package that is added via the install process
10:39:37 <sagaci> the latter isn't happening yet
10:39:38 <jaddi27> I think landscapes, pictures of prominent landmarks (maybe one for each state or major city)
10:39:47 <benonsoftware> Ok then
10:39:57 * benonsoftware will try and get a few snaps
10:40:15 <jaddi27> Yes. I think we could still look at doing the image package though, even if we host it in a ppa
10:40:31 <sagaci> yep
10:42:05 <jaddi27> I am not sure if any of you have used Tunein, but it would probably provide a good list of radio stations available online
10:42:05 <jaddi27> http://tunein.com/
10:42:30 <jaddi27> We could probably use this to compile a list for inclusion in Rhythmbox
10:43:25 <sagaci> yep, a bit of this and that
10:44:38 * jaddi27 thinks that is what you get for using IRC on windows
10:45:17 <benonsoftware> jaddi27: Browsing the net is harder on Windows when no browsers work
10:45:44 <jaddi27> benonsoftware: That is true. Last night our internet was out, so at least we don't have that problem tonight
10:46:13 <benonsoftware> Yeah
10:46:29 <jaddi27> So were there any applications that should be added to the launchers list?
10:46:50 <sagaci> nothing en_AU specific
10:47:15 <jaddi27> ok
10:47:41 <jaddi27> I think that just leaves Extra Packages/PPA/etc
10:48:03 <jaddi27> I don't think we have any packages that we depend on
10:48:34 <jaddi27> There is a list of recommended packages on the pad - what are your thoughts/reasons for including them in the list?
10:49:16 <sagaci> i think the main difference between the depends and recommends is that if you try to uninstall the depends you can remove metapackages like ubuntu-desktop down with it
10:49:18 <jaddi27> myspell and mythes (if they are still called that) make sense to ensure the user has the appropriate language files for Australia
10:50:03 <sagaci> the rationale for the en_AU image is to reach out to those who don't necessarily have the bandwidth to download ubuntu and/or commonly used packages
10:50:04 <jaddi27> I hadn't thought of that issue. I think that means we should only include recommended packages then
10:50:54 <benonsoftware> How big would the image be at the moment?
10:50:58 <jaddi27> Precise beta 1 is already sitting at 703mb, so I don't think we will have a lot of room
10:51:11 <benonsoftware> Ouch
10:51:23 <sagaci> none of this will affect users that download the normal iso, like me... although those on slower connections could opt to take this respin under ubuntu.net.au if they choose, since it will have the main ubuntu packages plus a few extras that help
10:51:38 <sagaci> the cd image itself is being pushed over 700 anyway
10:51:42 <jaddi27> translations and dictionarys are useful, other packages might have to be more strictly considered
10:51:50 * benonsoftware will use ubuntu.net.au as his connection is slow
10:52:33 <jaddi27> benonsoftware: does your ISP have unmetered disc images?
10:52:49 <benonsoftware> Not that I know of (Telstra Pre-Paid)
10:53:25 <jaddi27> Ok. If you were using bigpond wireless you definitely would have unmetered access to http://mirror.aarnet.edu.au/
10:53:57 <jaddi27> but I am not sure about Telstra Pre-paid. You could check by downloading a small file from there and then checking your usage
10:54:06 <benonsoftware> Yeah, I think its counted
10:54:20 <benonsoftware> Yeah, I'm hoping to convince my mum to change to iiNet or Internode but we are in a very sticky stage at the moment
10:54:40 <sagaci> wvdial for certain dial-up modems as 3G dongles, build-essential for compiling wireless/device drivers, usb-modeswitch for some wireless dongles
10:55:49 <sagaci> or to InterNet once the merger takes place
10:55:59 <jaddi27> Ok. Those make sense then. How much are they used? I know the bigpond wireless stick works out of the box, but haven't tried others
10:56:27 <benonsoftware> btw the USB modem I have didn't work out of the box :/
10:56:49 <sagaci> well it's just coming from the point of view of someone without a decent/fast/reliable connection
10:57:34 <sagaci> if the iso comes preinstalled with some of the bread and butter applications that we taken for granted, it may make their lives a hell of a lot easier if the 254kB wvdial is install
10:57:36 <sagaci> ed
10:57:56 <jaddi27> Ok. Just thought I would ask to understand better
10:58:45 <sagaci> a lot of wiki pages still have configure; make; make install instructions and on a vanilla ubuntu install, it'll come up as make, command not found unless you have the build-essential package installed
11:02:53 <jaddi27> So is there anything else to add for the localisation?
11:03:57 <jaddi27> I think we should start to compile all of the information into a pack, which I am happy to start off
11:04:15 <jaddi27> Once I have got it started, I presume I will be able to push it to a repo on launchpad
11:04:43 <benonsoftware> Ok then
11:04:48 <jaddi27> Will I be able to make a repo under ubuntu-au on launchpad, or would it have to be under my name?
11:05:19 <sagaci> either way, if you make it under your name, you can only change it
11:05:22 <head_victim> Just catching up on the reading, got back home sooner than expected.
11:05:53 <benonsoftware> How is it going head_victim ?
11:06:09 <jaddi27> sagaci: What process would I go through to make it then?
11:06:14 <head_victim> As far as where to host the code I'd look at what others are doing but I don't see a problem hosting it on the au team or a subteam of the au team.
11:06:22 <jaddi27> ok
11:06:23 <head_victim> benonsoftware: not too shabby, just very tired.
11:07:08 <sagaci> jaddi27, mkdir ~/localiso; cd ~/localiso; ubuntu-defaults-template en_AU; cd en_AU
11:07:26 <sagaci> preceded by sudo apt-get install ubuntu-defaults-builder
11:07:36 <jaddi27> sagaci: Oh, you have already done it and uploaded it to ubuntu-au on launchpad
11:08:01 <sagaci> yeah but I'd start from scratch
11:08:22 <sagaci> that was a test ages ago as a proof of concept
11:08:34 <jaddi27> Ok. I will do that and upload it to a new branch
11:08:53 <jaddi27> sagaci: what does the '+junk' in the repo name?
11:09:46 <sagaci> it means you haven't filed it under a project
11:10:17 <jaddi27> ok. that makes sense then. I should get it done over the weekend hopefully
11:10:43 <sagaci> iirc, branches use /username/projectname/branchname
11:11:24 <head_victim> Are any special accesses required to make this happen?
11:11:27 <jaddi27> so it should be something like: ubuntu-au/localisation/en_au ?
11:11:35 <sagaci> head_victim, nope
11:11:43 <head_victim> sagaci: cool just checking :)
11:12:06 <jaddi27> sagaci: I might enlist your assistance when I go to upload, seeing as you have done it before
11:13:51 <jaddi27> #action jaddi27 to create a new localisation project and upload to launchpad
11:13:51 * meetingology jaddi27 to create a new localisation project and upload to launchpad
11:13:55 <sagaci> either under ubuntu-au or ubuntu-en-au-translators
11:14:13 <sagaci> ubuntu-l10n-en-au, rather
11:14:59 <jaddi27> Which one would be better? I think it could easily fit in either
11:15:21 <sagaci> jaddi27, bzr'ise the en_AU/ directory and upload that, then you upload the resulting source package to a ppa
11:16:04 <jaddi27> ok. I will investigate it a bit more before uploading
11:17:13 <jaddi27> Is there anything else to add to this localisation discussion?
11:17:47 <sagaci> not really, we can build the en_AU defaults package whenever but you won't actually build the live image until after the release
11:18:06 <benonsoftware> Well if no one objects I can go out soon to get a few landscape pictures
11:18:18 <jaddi27> I think it would be good to get the package done soon so we can start testing it out
11:18:31 <jaddi27> benonsoftware: I think that would be good
11:18:53 <benonsoftware> Ok, I'll try to find a weekend to go out hunting :D
11:18:56 <head_victim> We already have a flickr account so maybe share them with the group and tag them as possible inclusions :)
11:19:09 <benonsoftware> head_victim: Ok, what's the group name?
11:19:50 <sagaci> benonsoftware, is the moon out
11:19:57 <head_victim> http://www.flickr.com/groups/ubuntuau/
11:20:08 <benonsoftware> sagaci: Yeah, I should go to bed soon
11:21:06 * benonsoftware is going to sleep in :(
11:21:27 <jaddi27> #action benonsoftware to take photos for local photos package
11:21:27 * meetingology benonsoftware to take photos for local photos package
11:22:10 <jaddi27> #idea email the mailing list asking for websites and images to include in a local package
11:22:37 <benonsoftware> I gotta go now, well done jaddi27, sagaci and head_victim with this!
11:22:45 <jaddi27> #endmeeting