18:54 <tsimonq2> #startmeeting Lubuntu Meeting - April 2017
18:54 <meetingology> Meeting started Fri Apr 14 18:54:44 2017 UTC.  The chair is tsimonq2. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
18:54 <meetingology> 
18:54 <meetingology> Available commands: action commands idea info link nick
18:54 <tsimonq2> #chair tsimonq2 wxl
18:54 <meetingology> Current chairs: tsimonq2 wxl
18:54 <tsimonq2> Hello everyone!
18:55 <tsimonq2> Welcome to the first Lubuntu meeting we've had in a while. :)
18:55 <sudodus> Hello chairmen!
18:55 <tsimonq2> #topic Attendance
18:55 <tsimonq2> Please wave if you're here to show attendance
18:55 <wxl> oh
18:55 <wxl> um agenda
18:55 <wxl> https://wiki.ubuntu.com/Lubuntu/IRC%20Meetings/Agenda
18:56 <wxl> o/
18:56 <tsimonq2> o/
18:56 <sudodus> o/
18:56 <lyn||ian> o/
18:56 <tsimonq2> redwolf, gilir: Here? :)
18:57 <tsimonq2> I'm assuming they're around given that they've been recently active here.
18:57 <tsimonq2> Moving on...
18:57 <gilir> o/
18:57 <tsimonq2> :)
18:57 <tsimonq2> #topic lubuntu.me
18:57 <tsimonq2> I'm going to give this one to wxl and redwolf
18:58 <tsimonq2> What's new with lubuntu.me?
18:58 <tsimonq2> Are we still going with Canonical's hosting? Where is it hosted now?
18:58 <lyn||ian> it is linked to by the slideshow in the installer now
18:58 <wxl> the plan is to go with their hosting
18:58 <wxl> they have the domain, but we haven't got sysadmins to move the system over. i'll be honest, i haven't touched this in a while. i'll get on it and hopefully have a timeline next meeting
18:59 <tsimonq2> wxl: Have we hard back from certain people regarding .me vs. .net?
18:59 <tsimonq2> *heard
18:59 <wxl> no
18:59 <tsimonq2> Ok.
18:59 <wxl> i have tried to check in a couple times
18:59 <wxl> including a time when .net was done
18:59 <wxl> s/one/own/
18:59 <wxl> no response.. :/
19:00 <tsimonq2> wxl: Would you be willing to give them one last poke and maybe talk to one of those certain people over IRC?
19:00 <wxl> yes, i'll check in with the cc :)
19:01 <wxl> meanwhile redwolf has been constantly picking away at dressing things up
19:01 <tsimonq2> #action wxl to check in with the CC regarding lubuntu.net versus lubuntu.me
19:01 * meetingology wxl to check in with the CC regarding lubuntu.net versus lubuntu.me
19:01 <wxl> you'll see new download buttons on the homepage
19:01 <wxl> they actually work, not just the text
19:01 <wxl> #action wxl to get Canonical hosting for lubuntu.me
19:01 * meetingology wxl to get Canonical hosting for lubuntu.me
19:01 <tsimonq2> wxl: So where is it hosted now, then?
19:02 <wxl> marcoceppi has graciously given us hosting on a machine he has access to
19:02 <wxl> which is where it has been
19:02 <tsimonq2> Ok.
19:02 <sudodus> There are problems go download from http://cdimage.ubuntu.com/lubuntu/releases/17.04/release/lubuntu-17.04-alternate-amd64.iso and http://cdimage.ubuntu.com/lubuntu/releases/17.04/release/lubuntu-17.04-alternate-i386.iso
19:03 <sudodus> s/go/to
19:03 <redwolf> I'm here :)
19:03 <gilir> do we know how other flavors deals with their website hosting ?
19:03 <gilir> just curious :-)
19:03 <tsimonq2> Interesting question gilir :)
19:03 <wxl> what problems, sudodus ?
19:03 <tsimonq2> flexiondotorg: Would you be able to shed some light on how you do this? ^
19:03 <marcoceppi> \o
19:04 <wxl> gilir: they either have canonical do it or host themselves. my concern with the latter is over the last time hosting was in the hands of one member
19:04 <tsimonq2> Hey marcoceppi :)
19:04 <sudodus> website error I think
19:04 <wxl> hi marcoceppi didn't mean to ping you :)
19:04 <marcoceppi> no worries cheers o/
19:04 <tsimonq2> marcoceppi: You wear various relevant hats if you want to chime in at all? :)
19:04 <tsimonq2> wxl: Yeah, I'd rather have it in a neutral location.
19:05 <gilir> wxl, ok, so hosting by canonical is not special for us
19:05 <wxl> i see the problem, sudodus. thanks for pointing that out. i'll check with release on that
19:05 <tsimonq2> gilir: No, I don't think it is.
19:05 <wxl> gilir: correct, although some folks get sick of their slowness :)
19:05 <tsimonq2> And while we're talking about the website, redwolf has made this awesome little page right here that I want to point out: http://lubuntu.me/about/
19:05 <redwolf> O.O
19:06 <tsimonq2> If you feel you're on the Lubuntu team and want on that page, let us know :)
19:06 <gilir> well, perfect solution is to have hosted by us, but I don't think we have the time / ressources to do it properly :-/
19:06 <lyn||ian> oops shows old website on that image
19:06 <wxl> gilir: yes, especially sysadmin time
19:06 <redwolf> and changing buttons (in progress): http://lubuntu.me/downloads/
19:06 <tsimonq2> Absolutely gilir
19:06 <wxl> omg, lyn||ian that is so ironic
19:06 <lyn||ian> if you look at the url
19:06 <gilir> did I say I love this website ? :-)
19:07 <tsimonq2> redwolf: Fix it? :D
19:07 <redwolf> awww, stop it you, gilir ^^
19:07 <wxl> does gilir's image load for you guys?
19:07 <tsimonq2> gilir: I know, it's a great website :D
19:07 <redwolf> gilir has no avatar
19:07 <tsimonq2> wxl: Which?
19:07 <tsimonq2> oic wxl
19:07 <gilir> yes, the image is fine ;-)
19:08 <redwolf> gilir, do you like the new buttons? pure CSS. simpler. more effective
19:08 <tsimonq2> So do we have anything else to discuss about the website besides redwolf being a top notch web designer? :D
19:08 <redwolf> our site was looking weird on Gnome's browser and other webkit ones (like Safari)
19:08 <wxl> oh there was nothing for me because privacy badger was blocking launchpad. nevermind. blank works :)
19:08 <gilir> redwolf, buttons on the top ? yes :-)
19:08 <gilir> redwolf, except that it's double underlined
19:08 <redwolf> yup, blue ones. I'm removing beveled ones
19:08 <tsimonq2> ^
19:09 <redwolf> the menu. yes, I have to fix that
19:09 <gilir> great :-)
19:09 <lyn||ian> didn't still shows lubuntu-software-center as well on website but in 17.04 isn't that not seeded
19:09 <tsimonq2> #action redwolf to review and fix screenshots
19:09 * meetingology redwolf to review and fix screenshots
19:09 <wxl> since we don't have a section for it, maybe we should talk about other graphic design stuff?
19:10 <tsimonq2> wxl: We do have a section
19:10 <redwolf> noted that: update screenshots
19:10 <wxl> nevermind :)
19:10 <tsimonq2> But I think I'd like to move on if that's OK ;)
19:10 <tsimonq2> Oh shoot, I forgot an item.
19:10 <tsimonq2> #topic Team role shift
19:11 <tsimonq2> We've had some time since the last meeting, and since then, wxl has passed the torch to me for being Release Manager.
19:11 <tsimonq2> wxl: Would you like to give us more details on this?
19:12 <wxl> well, tsimonq2 has been apprenticing under me for quite a while
19:12 <wxl> i let him take over much of the controls and he did a darn good job
19:12 <wxl> he really wanted the role, too :)
19:12 <redwolf> we're all agreed, I think
19:12 <wxl> i tried to make him bug manager but he wasn't having it :)
19:12 <wxl> so that's what i'm going to try to do
19:12 <tsimonq2> ^ XD
19:13 <wxl> although my personal life has really increased the gap between what i want to do and what i have done :(
19:13 <sudodus> OK
19:13 <lyn||ian> wxl mine too somewhat
19:13 <tsimonq2> wxl: So what are you doing now then for Lubuntu? Give us details on your new positions?
19:13 <gilir> yeah, good job tsimonq2 :-)
19:13 * wxl hugs lyn||ian
19:13 <tsimonq2> Thanks gilir :)
19:13 <wxl> my ultimate goal is to stay on top of bugs
19:13 * tsimonq2 also hugs lyn||ian
19:13 <gilir> wxl, real life sucks :-p
19:14 <wxl> yeah..
19:14 <redwolf> what's real life? XD
19:14 <wxl> i'd like to create a bug team
19:14 <wxl> i'm not sure how to do that yet :)
19:14 <wxl> meanwhile, i'm going to try shuffling through our bugs
19:14 <wxl> weeding out the dupes and the invalids
19:14 <wxl> confirming the ones that are for real
19:15 <wxl> etc.
19:15 <gilir> wxl, first, you need people to make a team :-)
19:15 <wxl> EXACTLY
19:15 <tsimonq2> wxl: AbiWord is 10 hours in and of itself
19:15 <wxl> so for now we have a team of 1 :)
19:15 <lyn||ian> I will likely join
19:15 <tsimonq2> SO MANY BUGS
19:15 <gilir> 1 is not a team :-)
19:15 <wxl> tsimonq2: i'm going to start with LXDE stuff first, thank you very much :)
19:15 <sudodus> I have to spend more time with real life, so I must step down (have already started, as you might have noticed).
19:15 <tsimonq2> Me too, if I have the time (which I have less of)
19:15 <tsimonq2> wxl: XD
19:15 <tsimonq2> sudodus: I saw that.
19:16 <tsimonq2> Speaking of that, does anyone have anything else to add on this topic before we move on? Any opinions?
19:16 <wxl> just one other thing from me
19:16 <tsimonq2> Sure :)
19:16 <wxl> i've also been working with kubuntu in the recent past on packaging
19:17 <wxl> when i get caught up on bugs, i hope to help somewhat with some of the trivial packaging needs
19:17 <wxl> that way gilir can work on actual bug fixes!
19:17 <tsimonq2> Me as well.
19:17 <redwolf> O.O
19:17 <tsimonq2> I set a goal for myself - by Feature Freeze of this release, I'd like to apply for MOTU.
19:18 <gilir> thanks, you let me the hardest stuff to fix :-(
19:18 <tsimonq2> (notice I don't say "get" because they may not approve me)
19:18 <tsimonq2> XD gilir
19:18 <tsimonq2> gilir: Well you have a really good amount of packaging skills, so simple stuff is just wasting time if others can do it. ;)
19:19 <wxl> besides that, gilir, none of us are really well equipped to deal with c++
19:19 <tsimonq2> ^
19:19 <wxl> i can read it, generally, but there are some subtlties that make it hard for me to really help with
19:19 <lyn||ian> I kind of know C++ but have troubles working with other codebases and have not done much
19:19 <gilir> wxl, me either, you know ...
19:20 <gilir> I only deal with C, and it's not easy every day :-(
19:20 <wxl> oh my
19:20 <wxl> well even c sometimes..
19:20 <redwolf> gilir, now you talk about coding... I have a question, but maybe it needs to be another topic
19:20 <tsimonq2> Which reminds me...
19:21 <lyn||ian> I should get bug control but need to apply
19:21 <tsimonq2> lyn||ian: same
19:21 <wxl> i'll get there eventually, but we need to have some of this other stuff taken care of
19:21 <tsimonq2> +1 wxl
19:21 <tsimonq2> Anyways...
19:21 <tsimonq2> #topic ARTWORK!!!
19:21 <gilir> bug control is a good start for dealing with bugs :-)
19:21 <redwolf> O.O!
19:21 <tsimonq2> redwolf: Your turn!
19:21 <tsimonq2> redwolf: Tell us all about your whereabouts!
19:22 <redwolf> well, dunno. first thing: the site
19:22 <redwolf> I'm doing changes. but I'll showed you all this, so no need for chatting about
19:22 <wxl> brb
19:22 <tsimonq2> redwolf: One thing I want to ask you about.
19:22 <tsimonq2> wxl: ack
19:22 <redwolf> icons and glyphs: gilir and I keep regular contact if any app (specially Qt ones) need some artwork
19:23 <redwolf> do ask, tsimonq2
19:23 <tsimonq2> redwolf: So you know how the Ubuntu Design Team has their palette?
19:23 <tsimonq2> https://design.ubuntu.com/brand/colour-palette
19:23 <redwolf> yes
19:23 <redwolf> why?
19:23 <tsimonq2> redwolf: How hard would it be for you to make something similar?
19:23 <tsimonq2> I see myself more frequently wanting one of these.
19:23 <redwolf> https://wiki.ubuntu.com/Lubuntu/Marketing#Colour_palette
19:24 <tsimonq2> OH
19:24 <tsimonq2> Huh
19:24 <tsimonq2> Ok
19:24 <redwolf> :|
19:24 <Night_Stranger> Hello everyone! Can I ask a question about LXDE development? Or it'll be off-top?
19:24 <redwolf> smaller items, because we don't need such a wide range to cover
19:24 <tsimonq2> Wellllllllllllllllllllll it's not advertized good enough then XD
19:24 <redwolf> tsimonq2, :)
19:24 <redwolf> tsimonq2, you can even download it
19:24 <tsimonq2> Night_Stranger: Give me just a sec
19:25 <tsimonq2> redwolf: Anything else to talk about here?
19:25 <redwolf> yes, but it's regarding future development (desktop)
19:25 <tsimonq2> Ok.
19:25 <redwolf> not artwork
19:25 <tsimonq2> #topic Development
19:26 <redwolf> my turn!
19:26 <tsimonq2> Night_Stranger: Ask your question now :)
19:26 <redwolf> :|
19:26 <Night_Stranger> Well, do you have a plan to add old parts of LXDE from git.lxde.org to github.com/lxde ? Because there is only LXTerminal remains. I wanted to make a pull request for libfm but it's impossible, because of lack of majority of LXDE parts on github. Sorry English is not my native language.
19:26 <tsimonq2> gilir: If you want to address all of your meeting items now, you can.
19:26 <tsimonq2> Night_Stranger: I don't believe we're the right people to ask about this. Try #lxde on freenode?
19:27 <gilir> Night_Stranger, github is not where LXDE parts are maintained
19:27 <gilir> Night_Stranger, you shoudl look at https://git.lxde.org/gitweb/
19:28 <tsimonq2> #subtopic 17.04 and before
19:28 <tsimonq2> Grr is that not a thing, meetingology ?
19:28 <gilir> and currently it's not planned to have all of them on github ... but you can publish your changes to github, and post on the bugtracker the link
19:29 <tsimonq2> That works too. :)
19:29 <tsimonq2> gilir: So then whenever you're ready.
19:29 <gilir> ok
19:30 <gilir> first, there was a couple of changes on the last releases
19:30 <Night_Stranger> gilir, but LXTerminal is there on github. Yes, I know about git.lxde.org, and I tried even to send an e-mail with PR to one of main developers about a half year ago, but he doesn't answer me. I know he may bust, but not to answer about a half year... I don't know what to do.
19:30 <redwolf> gilir, are you going to set the Lubuntu theme by default? last image had Frost activated
19:30 <Night_Stranger> *busy
19:30 <gilir> for exemple, pulseaudio by default, or the software center
19:31 <gilir> Night_Stranger, I'll check with you after the meeting :-)
19:31 <gilir> I just wanted to have your opinions on those changes, are the feedbacks from the users are good, bad ...
19:32 <gilir> I'm kind of disconnected since a while :-)
19:32 <Night_Stranger> Thanks, gilir, I'll be here then till the end of discussion.
19:32 <lyn||ian> I actually have not heard any problems with pulseaudio
19:32 <sudodus> I like pulseaudio. (I do not use Software Centers, but command line or Synaptic.)
19:33 <wxl> the only problems i have heard, at all, have surrounded snd_hda_intel, but that's not because of pulseaudio :)
19:33 <tsimonq2> Well, we have had problems with Lubuntu 16.04 LTS. Since only alsa is used, it broke Firefox's audio since they disabled alsa in the default build.
19:33 <tsimonq2> s/disabled alsa/disabled alsa support/
19:33 <gilir> tsimonq2, but well, not really our fault :-)
19:34 <tsimonq2> gilir: Yeah I agree, not really. :)
19:34 <lyn||ian> Yes I know about that
19:34 <tsimonq2> But it's unfortunate.
19:34 <wxl> the thing we have to realize, too, is that taking up additional resources is not necessarily a bad thing. the "old computers" that people are using are getting newer as time goes by :)
19:35 <lyn||ian> yeah I am not using my pentium IV anymore really
19:35 <tsimonq2> wxl: And I'd like to discuss that in a different topic. ;)
19:35 <gilir> wxl, yes, but I really would like to add stuff only if it's really necessary
19:35 <sudodus> +1 (the ten year old limit is a moving target)
19:35 <tsimonq2> +1 gilir
19:35 <redwolf> +1
19:35 <wxl> yeah and pulseaudio SHOULD provide a better experience
19:35 <lyn||ian> +1
19:36 <tsimonq2> +1
19:36 <wxl> although i remember at one time when i first started following lubuntu, there was an argument about whether or not we should include a clipboard manager XD
19:36 <gilir> ok, also there any other topics on 17.04 ? Any big issues on dev part ?
19:36 <redwolf> I have a question
19:36 <redwolf> Wayland?
19:36 <tsimonq2> gilir: Not on 17.04 but on 16.04, actually.
19:36 <tsimonq2> redwolf: Go away. :)
19:36 <redwolf> the X server
19:37 <redwolf> all flavours agreed to move to Wayland (KDE already in work). does it affect us?
19:37 <tsimonq2> gilir: Should we consider replacing Firefox in 16.04 LTS? It's not entirely out of the question if we work with the release team.
19:37 <lyn||ian> well one thing is going to wayland will require a big change to lubuntu default settings
19:37 <sudodus> How do you like using a swapfile instead of a swap partition? And the size is below that necessary for hibernation.
19:37 <wxl> the only other thing affecting 17.04 is some networking issue(s?) that release team is working on. i haven't seen them personally, so don't know what to say
19:37 <gilir> redwolf, let's talk about when X will not be maintained on official repositories, ok ? :-)
19:37 <tsimonq2> Yeah wxl
19:38 <sudodus> The *default* size
19:38 <redwolf> okies, gilir :)
19:38 <tsimonq2> sudodus: I don't use swap or hibernation so others will have to answer that.
19:38 <wxl> going back to the firefox thing, i think we should stay with it
19:39 <wxl> i use a swapfile and i like it
19:39 <lyn||ian> I have a swapfile not sure I use swap really
19:39 <gilir> tsimonq2, not removing Firefox. If it can't be fix, we will have to add PA I'm afradi :-/
19:39 <tsimonq2> gilir: That's fair.
19:40 <sudodus> +1 for keeping Firefox
19:40 <lyn||ian> +1 keep firefox
19:40 <tsimonq2> #subtopic Discuss the replacement of gnome-mplayer (unmaintained) by gnome-mpv
19:40 <tsimonq2> What's this all about, gilir?
19:40 <redwolf> https://gnome-mpv.github.io
19:40 <gilir> ok, you may know (or not :-)) that gnome-mplayer is not maintained anymore
19:41 <gilir> it was removed from Debian, and I asked to keep it on Ubuntu until we have a solution
19:41 <lyn||ian> yes I do not think gnome-mplayer works well at all
19:41 <gilir> well, I think we have a solution :-)
19:41 <sudodus> I vote for using maintained software
19:41 <wxl> hahahah me too
19:41 <tsimonq2> ^
19:41 <gilir> lyn||ian, it's working, but yes people reported issues with it
19:41 <lyn||ian> I have had it crash on startup on opening an audio podcast
19:41 <redwolf> +1 for mpv
19:42 <lyn||ian> +1 mpv
19:42 <redwolf> what about codecs?
19:42 <wxl> i think this is a no-brainer. what *dis*advantage is there to using mpv?
19:42 <tsimonq2> +1
19:42 <gilir> redwolf, as far as I know, it used the same tech that gnome-mplayer
19:42 <redwolf> nice
19:42 <gilir> it's just the UI which change a bit
19:42 <tsimonq2> Just for record's sake...
19:43 <redwolf> it looks better. reminds me to newest Totem
19:43 <tsimonq2> #voters sudodus wxl redwolf lyn||ian tsimonq2
19:43 <meetingology> Current voters: lyn||ian redwolf sudodus tsimonq2 wxl
19:43 <gilir> redwolf, me too, I loved totem years ago ...
19:43 <redwolf> :)
19:43 <wxl> it might be good to know that mpv is a fork of mplayer2 and MPlayer https://mpv.io/
19:43 <lyn||ian> +1 mpv
19:43 <tsimonq2> #vote Move to mpv from gnome-mplayer
19:43 <meetingology> Please vote on: Move to mpv from gnome-mplayer
19:43 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
19:43 <tsimonq2> #votesrequired 4
19:43 <meetingology> votes now need 4 to be passed
19:43 <redwolf> +1
19:43 <meetingology> +1 received from redwolf
19:43 <wxl> +1
19:43 <meetingology> +1 received from wxl
19:43 <lyn||ian> +1
19:43 <meetingology> +1 received from lyn||ian
19:43 <tsimonq2> +1
19:43 <meetingology> +1 received from tsimonq2
19:43 <gilir> +1
19:44 <tsimonq2> #endvote
19:44 <meetingology> Voting ended on: Move to mpv from gnome-mplayer
19:44 <meetingology> Votes for:4 Votes against:0 Abstentions:0
19:44 <meetingology> Motion carried
19:44 <gilir> what ? I can't vote :-)
19:44 <tsimonq2> OH shoot
19:44 <redwolf> LOL
19:44 <sudodus> +1
19:44 <tsimonq2> Well it was carried anyways, I did that for record's sake.
19:44 <wxl> heheh
19:44 <redwolf> sorry, I have to leave now
19:44 <wxl> k
19:44 <wxl> :(
19:44 <tsimonq2> Bai redwolf :(
19:44 <gilir> well, I was going to do the change anyway :-p
19:44 <tsimonq2> gilir: :P
19:44 <redwolf> brb in 1 hour
19:44 <redwolf> o/
19:44 <tsimonq2> #subtopic Discuss the possible removal of blueman by a lxpanel applet
19:44 <tsimonq2> o/ redwolf
19:45 <sudodus> Bye redwolf
19:45 <tsimonq2> Explain this one, gilir?
19:45 <gilir> ok that's a more tricky one :-)
19:45 <lyn||ian> I do not use anything bluetooth so I am a bit ignorant on this front
19:45 <tsimonq2> ^
19:45 <gilir> there is a raspberry OS, using LXDE, and they added some new stuff
19:46 <gilir> including an applet to configure bluetooth stuff
19:46 <wxl> i do use bluetooth
19:46 <wxl> so i can test this out
19:46 <wxl> do we have it packaged or in a ppa or can i compile it myself?
19:47 <tsimonq2> gilir: So are you saying that we're looking to have this on by default?
19:47 <wxl> i have both output and input devices, too. several.
19:47 <gilir> I propose to add it earlier in 17.10, and to turn it on by default
19:47 <wxl> and several adapters
19:47 <wxl> assuming it provides a similar experience to blueman, i'm all for it
19:47 <gilir> we can keep blueman for a time, but I think it will not be so usefull with the applet enable
19:47 <wxl> what's upstream's take on this?
19:47 <tsimonq2> Then let's do it :)
19:48 <tsimonq2> Oh, yeah, +1 wxl
19:48 <gilir> wxl, well, it's a lot more ... simple :-)
19:48 <sudodus> What about the CD size issue of the alternate iso files?
19:48 <tsimonq2> sudodus: We have an agenda item for that.
19:49 <gilir> sudodus, that's another problem, the applet itself is small (not adding depends)
19:49 <wxl> sudodus: i think we just need to accept that as reality. core changes are pretty much beyond our control and very hard to keep up with. besides, are there many usable machines any more that can't handle dvd and/or usb?
19:49 <tsimonq2> Last thing here...
19:49 <tsimonq2> #subtopic
19:49 <tsimonq2> Discuss the possible replacement of network-manager by dhcpcd/dhcpcd-gtk
19:49 <sudodus> I mean what is the size of the new bluetooth applet?
19:49 <tsimonq2> Grrr
19:49 <wxl> sudodus: tl;dr it would be smaller
19:49 <tsimonq2> Oh, I get it sudodus
19:49 <tsimonq2> I agree with wxl, probably...
19:49 <sudodus> fine :-)
19:49 <tsimonq2> #subtopic Discuss the possible replacement of network-manager by dhcpcd/dhcpcd-gtk
19:50 <wxl> the change would just be an additional plugin in lxpanel (as i understand it)
19:50 <lyn||ian> I do not know what the ui of dhcpcd is
19:50 <gilir> ok, this one is the worst :-)
19:50 <wxl> but blueman has several requirements
19:51 <gilir> wxl, I hoped to remove it for a bit of space :-)
19:51 <wxl> im not familiar with dhcpcd either
19:51 <gilir> but I'm not sure it will be significant
19:51 <gilir> so, I found that there is actually a possible replacement for network-manager stack
19:52 <wxl> oh and it already has an lxde panel plugin? or is that just dhcpcd-ui
19:52 <gilir> wxl, there is a plugin (on raspberry OS), but it's not working very well
19:52 <wxl> ah ic that now
19:53 <gilir> wxl, but dhcpcd-gtk is a tray icon, so it's not mandatory to have the applet working
19:53 <wxl> nice
19:53 <gilir> it's better, but not mandatory :-)
19:53 <wxl> and requirements are next to none
19:53 <wxl> https://roy.marples.name/projects/dhcpcd-ui
19:53 <gilir> exactly :-)
19:53 <gilir> i tested also with wifi, it's working as expected
19:54 <wxl> nice
19:54 <wxl> what about vpn?
19:54 <lyn||ian> what about setting up bridged networking
19:54 <gilir> that's the problem :-) there is probably other uses cases to test :-)
19:54 <lyn||ian> I probably should be the one to test that
19:54 <wxl> i'll check on the vpn
19:55 <gilir> network-manager is nice, because the support is great, for many uses cases
19:55 <gilir> and changing the network stack is quite dangerous
19:55 <gilir> well, it's kind of critical :-)
19:55 <wxl> hahahah
19:55 <sudodus> I am happy with network-manager
19:55 <wxl> a little bit
19:56 <wxl> you should see the comments about the networking issues i aforementioned
19:56 <tsimonq2> So anything else on this?
19:57 <lyn||ian> If we do this this will require a lot of testing
19:57 <Unit193> And connman/cmst of course.
19:57 <tsimonq2> Unit193: That breaks every time I try to use it...
19:57 <gilir> Unit193, I'm not sure it's lighter than network-manager :-)
19:57 <gilir> and yes, you can't have both installed ...
19:58 <wxl> as long as it's not wicd XD
19:58 <gilir> so, there is 2 choices about that I think
19:58 <gilir> 1) switch ealier on 17.10, see the complains, and decide to stay or not
19:59 <gilir> 2) As for a lot of testing, and decide after, but I think it will be too late for the next LTS
20:00 <lyn||ian> gilir, I meant before 17.10
20:00 <wxl> i'm sure lyn||ian and i could do some testing before 17.10 really starts
20:00 <gilir> if we don't try the switch now, for this critical piece, I don't think it's safe to try it later
20:00 <lyn||ian> gilir, +1 on that
20:01 <gilir> yeah, when I say "for 17.10", I mean for 17.10 alpha 1 :-)
20:01 <wxl> judging by this it seems vpn shuld be ok https://roy.marples.name/archives/dhcpcd-discuss/0000074.html
20:01 <sudodus> OK, I see the point. Go ahead and good luck :-)
20:02 <wxl> yeah i think it's worth a shot
20:02 <wxl> if it fails, it will be easy to resolve
20:02 <tsimonq2> I think we should vote.
20:02 <tsimonq2> #voters sudodus wxl gilir lyn||ian tsimonq2 redwolf
20:02 <meetingology> Current voters: gilir lyn||ian redwolf sudodus tsimonq2 wxl
20:03 <sudodus> +1
20:03 <wxl> lyn||ian: https://roy.marples.name/archives/dhcpcd-discuss/0001047.html
20:03 <tsimonq2> #vote Move to dhcpcd for network management by 17.10 Alpha 1
20:03 <meetingology> Please vote on: Move to dhcpcd for network management by 17.10 Alpha 1
20:03 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
20:03 <wxl> +1
20:03 <meetingology> +1 received from wxl
20:03 <tsimonq2> +1
20:03 <meetingology> +1 received from tsimonq2
20:03 <sudodus> +1
20:03 <meetingology> +1 received from sudodus
20:03 <tsimonq2> #votesrequired 4
20:03 <meetingology> votes now need 4 to be passed
20:04 <gilir> +1
20:04 <meetingology> +1 received from gilir
20:04 <tsimonq2> #endvote
20:04 <meetingology> Voting ended on: Move to dhcpcd for network management by 17.10 Alpha 1
20:04 <meetingology> Votes for:4 Votes against:0 Abstentions:0
20:04 <meetingology> Motion carried
20:04 <lyn||ian> +1
20:04 <tsimonq2> Ok :)
20:04 <gilir> I like breaking stuff :-p
20:04 <wxl> sheesh tsimonq2
20:04 <tsimonq2> wxl: What, for voting constantly or ending it early? :P
20:04 <wxl> the latter
20:05 <tsimonq2> #action gilir to switch Lubuntu's network stack to dhcpcd for 17.10 Alpha 1
20:05 * meetingology gilir to switch Lubuntu's network stack to dhcpcd for 17.10 Alpha 1
20:06 <tsimonq2> #action gilir to switch to mpv from gnome-mplayer in the seed for 17.10
20:06 * meetingology gilir to switch to mpv from gnome-mplayer in the seed for 17.10
20:06 <wxl> we done yet? :)
20:06 <tsimonq2> Nope lol
20:07 <tsimonq2> #topic Donations
20:07 <tsimonq2> wxl: Status update?
20:07 <wxl> nothing
20:07 <tsimonq2> What are we waiting on?
20:07 <wxl> i need a lawyer to confirm we're doing everything right
20:07 <tsimonq2> Ok
20:08 <wxl> i've contacted the ummmm software freedom law center and they're slow as molasses
20:08 <wxl> maybe i'll try avvo and see if i can't get lucky that way
20:09 <tsimonq2> While we're on this item, I want to point out that getting this set up should be a priority. Projects like Ubuntu MATE are pulling in, what, $20000 monthly? We could fund a lot of different things with 1/20th of that.
20:09 <tsimonq2> I understand queues are long. And that really sucks. :)
20:09 <tsimonq2> So, moving on.
20:09 <wxl> #action wxl to look into other resources for legal help other than sflc
20:09 * meetingology wxl to look into other resources for legal help other than sflc
20:09 <tsimonq2> ^ bingo
20:10 <tsimonq2> #topic LXQt
20:10 <tsimonq2> I want to get opinions on Lubuntu's LXQt involvement as of now.
20:10 <tsimonq2> I understand gilir has doubts.
20:10 <tsimonq2> But, if we *want* to do anything, now is the time
20:10 <tsimonq2> (LTS coming up)
20:11 <gilir> I still have doubts :-)
20:11 * acheronUK goggles at https://www.patreon.com/ubuntu_mate
20:11 <tsimonq2> It seems like at this point I've been doing a good chunk of the development work. But, at this point, I'm under it's worth it if we aren't going to do it.
20:11 <tsimonq2> s/under/unsure/
20:11 <sudodus> What is the main problem with LXQt?
20:12 <lyn||ian> I like lxqt but have not done much recently
20:12 <wxl> we're not going to do it? or we're going to do it in a different way than originally discussed?
20:12 <tsimonq2> That's what I want to find out.
20:12 <lyn||ian> The getting all the default settings for lubuntu is where it mainly needs work
20:12 <tsimonq2> lyn||ian: Bingo.
20:12 <tsimonq2> I've been doing some work in ppa:lubuntu-next/unstable
20:12 <lyn||ian> I have had lxqt upstream default and that is quite good
20:13 <tsimonq2> But it's a good chunk of work.
20:13 <tsimonq2> I know, in my honest opinion, LXQt is stable enough for the end user.
20:13 <lyn||ian> hmmm tsimonq2 I wish I knew of this earlier
20:13 <tsimonq2> I want to know gilir's opinion specifically.
20:14 <tsimonq2> (since he's the development team head)
20:14 <gilir> well, I'm not afraid about LXQt itself
20:14 <gilir> I'm afraid about the others apps we have to add to make a decent distro
20:15 <tsimonq2> I see what you're saying.
20:15 <gilir> and I fear that the result will not be better that the LXDE one
20:15 <lyn||ian> I can use qpdfview ok but the new version is quite good
20:15 <wxl> well i mean there are other distros that are lxqt-only, right?
20:15 <tsimonq2> I've seen a good amount of improvement in that area, gilir.
20:15 <gilir> Also, my knowledge on Qt and C++ is ... limited
20:15 <lyn||ian> and with qupzilla 2.0 not being in the repos as 1.8.* is crashing more and more often
20:16 <tsimonq2> wxl: Sure, but those distributions don't get a lot of attention. I feel as if people are holding their breath for Lubuntu.
20:16 <Night_Stranger> Do you want to remove LXDE completely and replace it by LXQt?
20:16 <tsimonq2> Night_Stranger: tl;dr that was our original plan, yes.
20:16 <tsimonq2> But I'd like to take a vote here.
20:16 <wxl> that's my feeling, too
20:16 <wxl> that people are waiting for us
20:17 <Night_Stranger> I hope you'll make alternative builds with LXDE, I really like LXDE more
20:17 <wxl> i think that's more likely
20:17 <tsimonq2> I want to know if the Lubuntu team as a whole is still interested in this, and if so, then we can talk timing etc.
20:17 <gilir> maybe people are waiting for a LXQt version of L/Ubuntu
20:17 <lyn||ian> I think there are quite a few with irc coming in asking about it
20:17 <tsimonq2> ^
20:17 <gilir> but I think some want to keep a LXDE version :-)
20:18 <tsimonq2> So what should we do about that, guys?
20:18 <lyn||ian> gilir, yeah I think that too
20:18 <gilir> IMO, both version can be usefull
20:19 <gilir> I think it's a good idea to keep working on the lXQt version
20:19 <tsimonq2> Ok
20:19 <gilir> but as a parralele version for now, until it's working
20:19 <sudodus> I think we should keep LXDE. If there is time and energy for LXQt too, fine!
20:19 <gilir> and so, we can evaluate both, and maybe keep both :-)
20:19 <tsimonq2> Ok :)
20:20 <tsimonq2> #voters tsimonq2 wxl gilir lyn||ian sudodus redwolf
20:20 <meetingology> Current voters: gilir lyn||ian redwolf sudodus tsimonq2 wxl
20:20 <tsimonq2> #vote Should we keep working on an LXQt Lubuntu?
20:20 <meetingology> Please vote on: Should we keep working on an LXQt Lubuntu?
20:20 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
20:20 <wxl> +1
20:20 <meetingology> +1 received from wxl
20:20 <tsimonq2> +1
20:20 <meetingology> +1 received from tsimonq2
20:20 <sudodus> What do the votes mean?
20:21 <tsimonq2> sudodus: That you'd like the work on it to continue
20:21 <sudodus> I would vote '+2 for both'
20:21 <lyn||ian> +1
20:21 <meetingology> +1 received from lyn||ian
20:21 <sudodus> +1
20:21 <meetingology> +1 received from sudodus
20:22 <tsimonq2> gilir
20:22 <tsimonq2> ?
20:22 <tsimonq2> :)
20:22 <gilir> just to be clear, I'm for working on it, I not sure I'll have a lot of time to help on it
20:22 <tsimonq2> That's totally fair, gilir.
20:22 <gilir> +1, but it doesn't mean you should only count on me :-)
20:22 <meetingology> +1, but it doesn't mean you should only count on me :-) received from gilir
20:22 <tsimonq2> #endvote
20:22 <meetingology> Voting ended on: Should we keep working on an LXQt Lubuntu?
20:22 <meetingology> Votes for:5 Votes against:0 Abstentions:0
20:22 <meetingology> Motion carried
20:23 <tsimonq2> Ok
20:23 <tsimonq2> gilir: The impression that phillw gave was that this was completely your job...
20:23 <tsimonq2> But I digress, let's not get into that.
20:24 <tsimonq2> So, let's talk about timing.
20:24 <tsimonq2> I vote for having a Lubuntu LXQt image for Alpha 1, that's on cdimage
20:24 <tsimonq2> It could be completely useless, but as long as we have something that's bootable and can run programs.
20:24 <wxl> we can figure out all the apps by then????
20:24 <tsimonq2> wxl: No, that's not my point
20:25 <tsimonq2> It's to have an image that may be unfinished
20:25 <wxl> release team will alow that?
20:25 <tsimonq2> Yep.
20:25 <tsimonq2> We already have everything in place for it.
20:25 <tsimonq2> But I've been doing work in a PPA.
20:26 <tsimonq2> Seeing as I have no archive access to actually upload my results, it's pretty useless for working on the image.
20:26 <tsimonq2> At one point I talked to Adam about just adding the PPA to the image and giving me upload access to the PPA.
20:27 <tsimonq2> Adam was for it, given that I have a person that can vouch for me if something gets massively screwed up.
20:27 <gilir> tsimonq2, 17.10 will be open soon, so why just submit your change to official repo ?
20:27 <gilir> if you build it on the unstable PPA, it can be tested and review
20:28 <tsimonq2> gilir: Because the review process is an overhead of a few days... how do I know if I have an image which will build correctly?
20:28 <wxl> here's the only distro i can find where LXQt is the default desktop http://www.extix.se/?p=274
20:28 <tsimonq2> I do see your point, and it's a perfectly valid point.
20:29 <wxl> they seem to be including gtk apps, so they don't care about keeping it qt
20:29 <tsimonq2> gilir: That was the point with just adding a stable PPA to the image. Since it's an experimental image, and for now, we haven't decided to ship it "officially," it reduces overhead for getting fixes in.
20:29 <wxl> that said, we really have no one to base our decisions on apps on
20:30 <tsimonq2> wxl: So it's fair game, really.
20:31 <tsimonq2> But, I think that we've pretty much decided on what we've needed to decide on for this.
20:31 <tsimonq2> We're already 30 minutes over time.
20:31 <tsimonq2> #action tsimonq2 to get LXQt image for Alpha 1
20:31 * meetingology tsimonq2 to get LXQt image for Alpha 1
20:31 <tsimonq2> THat's not new :P ^
20:31 <tsimonq2> One more thing...
20:31 <tsimonq2> #topic mkusb
20:32 <tsimonq2> sudodus: The floor is yours. :)
20:32 <sudodus> I think the current version, mkusb 12 alias mkusb-dus is rather stable now,
20:33 <lubot> <wxl23> BRB again
20:33 <sudodus> But it seems difficult to get it accepted in a repository. What news have you got tsimonq2?
20:34 <tsimonq2> sudodus: I have a DD lined up and I was going to get it uploaded to Debian within a week of A cycle opening.
20:34 <sudodus> Also, I have to step down, partly because I am getting old and sick too. I must spend more of my time on real life issues.
20:35 <sudodus> What is 'a DD lined up'?
20:36 <tsimonq2> I have a Debian Developer who is willing to upload it for me.
20:36 <tsimonq2> sudodus: If you're stepping down and no longer leading the project, I can let him know not to review it?
20:37 <sudodus> I might be able to fix some bugs, but Israel Dahl, the developer of ToriOS intends to continue the development of mkusb.
20:37 <sudodus> So I think the Debian Developer should chat with Israel, you and me.
20:37 <tsimonq2> Ok
20:38 <tsimonq2> Let's talk after the meeting then.
20:38 <sudodus> OK
20:38 <tsimonq2> I think this has gone on for a long time. :P
20:38 <tsimonq2> #endmeeting