16:22 <blackboxsw> #startmeeting cloud-init status meeting
16:22 <meetingology> Meeting started Tue Jun 30 16:22:42 2020 UTC.  The chair is blackboxsw. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:22 <meetingology> 
16:22 <meetingology> Available commands: action commands idea info link nick
16:23 <blackboxsw> community notice: time for another bi-weekly (or semi-monthly if you prefer) cloud-init community status meeting
16:24 <blackboxsw> #chair smoser rharper Odd_Bloke
16:24 <meetingology> Current chairs: Odd_Bloke blackboxsw rharper smoser
16:25 <blackboxsw> welcome to another round of cloud-init upstream updates and discussion. We use this meeting as a time to gather to discuss current development of cloud-init, ask and answer questions, and generally expedite development be unblocking devs.  All questions. side-conversations and interruptions are welcome
16:25 <blackboxsw> last meeting minutes are at the link below
16:26 <blackboxsw> #link https://cloud-init.github.io/status-2020-06-16.html#status-2020-06-16
16:26 <blackboxsw> turns out I didn't update the topic for the next meeting time last session. Let's do that now
16:26 <blackboxsw> +2 weeks from now, same time
16:26 <blackboxsw> July 14th, same UTC time
16:27 <blackboxsw> now that that's out of the way, we typically cover the following topics.
16:27 <blackboxsw> Previous Actions, Recent Changes, In-progress Development, Community Charter, Office Hours (~30 mins).
16:27 <blackboxsw> additionally today, I'll discuss the current cloud-init SRU
16:28 <blackboxsw> #topic Previous Actions
16:28 <blackboxsw> topic #1. our previous meeting minutes logged two actions:
16:28 * blackboxsw file feature bug about refactoring startup services
16:30 <blackboxsw> I think in further discussion during last meeting, we talked with Odd_Bloke and meena and determined that we can't actually refactor startup services to live in the distro specifically, because these startup service templates actually get determined at cloud-init generator time (before distribution is determined in cloud-init's python code) so trying to specialize startup script content generation in the distro
16:30 <blackboxsw> python classes in cloud-init is too late
16:30 <blackboxsw> so this action is tabled as /wont-fix
16:31 <blackboxsw> that follows as well with the other ACTION: mailing list email requesting comment/concerns about a refactor of startup services
16:31 * blackboxsw isn't sure how to close out actions in meetingology syntax/cmds
16:31 <blackboxsw> #topic In-progress Development
16:33 <blackboxsw> The following is the set of  commits landed in 'master' of cloud-init upstream repo: found with git log --since 06-20-2020
16:33 <blackboxsw> #link ACTION: mailing list email requesting comment/concerns about a refactor of startup services
16:33 <blackboxsw> #link https://paste.ubuntu.com/p/fSvwRks86z/
16:34 <blackboxsw> heh paste error
16:34 <blackboxsw> #topic Recent Changes
16:34 * blackboxsw sets appropriate topic for this section
16:37 <blackboxsw> so recently Odd_Bloke and a number of BSD folks (meena igalic etc) have gone through a number of discussions and design regarding a refactor of cloudinit.net functions to a cloudinit.distro.networking module as most network-related functionality is highly distro-dependent
16:37 <blackboxsw> Odd_Bloke: created an overview of this current refactor work and published it to readthedocs
16:37 <blackboxsw> #link https://cloudinit.readthedocs.io/en/latest/topics/hacking.html#ongoing-refactors
16:38 <blackboxsw> This has been a big effort to get organized and started so many thanks for all those paricipating in this discussion, development and reviews.
16:39 <blackboxsw> there are many, functions that need to be refactored  from cloudinit.net into the distribution-specialized cloudinit.distro.networking classes.
16:40 <blackboxsw> It is work that can be easily done in parallel and there is a tag used to classify each refactor as a "net-refactor" bug in launchpad
16:40 <blackboxsw> #link https://bugs.launchpad.net/cloud-init/+bugs?field.tag=net-refactor
16:41 <blackboxsw> community notice: we encourage anyone interested in refactoring cloud-init networking functionality to grab and work any of those net-refactor bugs
16:41 <blackboxsw> there are a couple of example PRs up that give a good idea of how to get started
16:42 <blackboxsw> #link https://github.com/canonical/cloud-init/pull/457
16:42 <blackboxsw> and I can't seem to find the other at the moment.
16:48 <blackboxsw> besides net-refactor content landing, there have been fixes to Hetzner and RbxCloud datasources,  redhat's systemd generator templates, Centos copr build fixes to help RPM build runs and Azure datasource logging. Thanks smoser, paride Moustafa and otubo Adam Dobrawy for contributions this round
16:49 <blackboxsw> #topic In-progress Development
16:51 <blackboxsw> Generally the last two weeks have been sunk into upstream testing and validation of cloud-init for SRU (Stable release Update) into Ubuntu Xenial Bionic, Eoan and Focal.
16:52 <blackboxsw> 3 to 5 of us have been on verification tasks on various clouds for all Ubuntu releases targeted and all features which affect ubuntu.
16:52 <blackboxsw> A thousand thanks rharper Odd_Bloke factor lucasmoura and xiaofeng for working through and validating some of these SRU tasks.
16:54 <blackboxsw> Our job is done, and we are awaiting feedback from an automation CI from Canonical solutions QA at the moment which runs through a ton of Openstack networking customer-configurations.  It has been in the test queue for a week, and I just saw a successful run from that test harness this morning. That team has told us it looks for 3 successful runs to "pass" so I expect that pass to come shortly as the test runs
16:54 <blackboxsw> are currently inprogress.
16:55 <blackboxsw> as soon as this test passes we will mark the SRU bug verified and the SRU team will publish bits of cloud-init.
16:55 <blackboxsw> #link https://bugs.launchpad.net/ubuntu/+source/cloud-init/+bug/1881018
16:55 <ubot5> Ubuntu bug 1881018 in cloud-init (Ubuntu) "sru cloud-init (19.4.33 to 20.2-45) Xenial, Bionic, Eoan and Focal" [Undecided,In progress]
16:56 <blackboxsw> This SRU has taken about 1+ week longer than normal verification because we hadn't SRU'd cloud-init in around 6 months, so there was a lot more content to verify.
16:57 <blackboxsw> Hopefully additional SRUs will be more frequent and less heavy-weight. We are looking into reducing the overhead on this process and will pitch ideas to the cloud-init mailinglist for input
16:57 <blackboxsw> Beyond SRU work, the following other work is in progress:
16:58 <blackboxsw> * net-refactor formerly mentioned
16:58 <blackboxsw> * falcojr into Oracle integration test harness
16:58 <blackboxsw> * extending  json schema validation for remaining cloud-config modules for better error reporting around invalid user-data
17:00 <blackboxsw> Long term work: cloud-init standalone daemon to improve startup time by avoiding reloading python across each cloud-int boot  stage, initial networking hot-plug support to which datasources could "opt-in"
17:01 <rharper> blackboxsw: =)
17:01 <blackboxsw> I think that about wraps this topic.
17:01 <blackboxsw> yeah rharper, we've got it on our roadmap. We'd love to see that get in this round.
17:02 <blackboxsw> #topic community charter
17:03 <blackboxsw> We have a couple of general themes of features we are working toward as a community this year:
17:04 <blackboxsw> * json schema additions for cloudinit.config.cc_* modules to improve user-facing errors on invalid user-data
17:04 <blackboxsw> * datasource documentation improvements, updates and corrections
17:04 <blackboxsw> * cloudinit.net-refactor work
17:05 <blackboxsw> We encourage any interested developers to grab any of these work items related to these features.
17:06 <blackboxsw> We have two bug tags which enumerate each component of these work streams:
17:07 <blackboxsw> #link https://bugs.launchpad.net/cloud-init/?field.tag=bitesize
17:07 <blackboxsw> #link https://bugs.launchpad.net/cloud-init/+bugs?field.tag=net-refactor
17:08 <blackboxsw> #topic Office Hours (~20 mins)
17:08 <blackboxsw> This 'section' of the meeting is a time where a couple of upstream devs will be available in channel for any discussions, questions, bug work or PR reviews.
17:08 <blackboxsw> I think I spent most of the time typing, but will hit the review queue in the absence of any other discussion
17:17 <blackboxsw> merged https://github.com/canonical/cloud-init/pull/461
17:51 <blackboxsw> lucasmoura: one minor change request and description update on the PR requested https://github.com/canonical/cloud-init/pull/390#pullrequestreview-440241947
17:51 <blackboxsw> then we can land this one
17:51 <blackboxsw> ok folks, thanks for checking into the cloud-init status meeting. See you in 2 weeks.
17:51 <blackboxsw> #endmeeting