16:18 <blackboxsw> #startmeeting Cloud-init bi-weekly status
16:18 <meetingology> Meeting started Tue Oct  8 16:18:28 2019 UTC.  The chair is blackboxsw. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:18 <meetingology> 
16:18 <meetingology> Available commands: action commands idea info link nick
16:18 <blackboxsw> Welcome back folks o/ And thanks AnhVoMSFT for the ping to get us started
16:18 <blackboxsw> #chair rharper Odd_Bloke
16:19 <blackboxsw> #chair rharper Odd_Bloke
16:19 <meetingology> Current chairs: Odd_Bloke blackboxsw rharper
16:19 <blackboxsw> cloud-init upstream uses this meeting as a platform for community updates, feature/bug discussions, and an opportunity to get some extra input on current development.
16:19 <Odd_Bloke> o/
16:19 <Odd_Bloke> Thanks for the reminder, Anh.
16:19 <blackboxsw> Feel free to interject at any time. Our typical format is the following: Previous Actions, Recent Changes, In-progress Development, Office Hours (~30 mins).
16:21 <blackboxsw> For this, and subsequent, status meetings I proposed we add a new topic: Ongoing Community Charter  which would give context on the new trello lane we added at the cloud-init summit.
16:21 <blackboxsw> Odd_Bloke: rharper AnhVoMSFT does that sound good? We can then better advertise and remind about long-term community involvement projects that are available for anyone
16:22 <AnhVoMSFT> I would propose that the last agenda item of any status meeting would be to update the banner to reflect the next status meeting - and perhaps the next ETA for next release / SRU
16:22 <blackboxsw> +1 AnhVoMSFT that sounds good too.
16:22 <AnhVoMSFT> yep, sounds good on the Community Charter
16:22 <rharper> AnhVoMSFT: +1
16:22 <rharper> I think one topic each
16:22 <rharper> and end with the next status meeting
16:23 <blackboxsw> ok starting to turn the meeting crank
16:23 <blackboxsw> #topic Previous Actions
16:23 <blackboxsw> last meeting was 09/09/2019
16:23 <blackboxsw> #link https://cloud-init.github.io/status-2019-09-09.html#status-2019-09-09
16:23 <blackboxsw> meeting minutes at the link above ^
16:24 <blackboxsw> only action was  #action blackboxsw send email to the list notifying of status meeting day change.
16:24 <blackboxsw> which was done https://lists.launchpad.net/cloud-init/msg00224.html
16:24 <blackboxsw> no further outstanding actions from last meeting
16:25 <blackboxsw> #topic Recent Changes
16:25 <blackboxsw> The following branches have landed in tip since last meeting: via git log --since 2019-09-09
16:27 <blackboxsw> - Add RbxCloud datasource [Adam Dobrawy]
16:27 <blackboxsw> - get_interfaces: don't exclude bridge and bond members (LP: #1846535)
16:27 <blackboxsw> - Add support for Arch Linux in render-cloudcfg [Conrad Hoffmann]
16:27 <blackboxsw> - util: json.dumps on python 2.7 will handle UnicodeDecodeError on binary
16:27 <blackboxsw> (LP: #1801364)
16:27 <ubot5> Launchpad bug 1846535 in cloud-init "cloud-init 19.2.36 fails with python exception "Not all expected physical devices present ..." during bionic image deployment from MAAS" [Critical,Fix committed] https://launchpad.net/bugs/1846535
16:27 <ubot5> Launchpad bug 1801364 in cloud-init "persisting OpenStack metadata fails" [Undecided,Fix committed] https://launchpad.net/bugs/1801364
16:27 <blackboxsw> oopsie daisy
16:27 <AnhVoMSFT> :)
16:27 <blackboxsw> got kicked on flood. chunking that now
16:27 <blackboxsw> - Add RbxCloud datasource [Adam Dobrawy]
16:27 <blackboxsw> - get_interfaces: don't exclude bridge and bond members (LP: #1846535)
16:27 <blackboxsw> - Add support for Arch Linux in render-cloudcfg [Conrad Hoffmann]
16:27 <blackboxsw> - util: json.dumps on python 2.7 will handle UnicodeDecodeError on binary
16:27 <blackboxsw> (LP: #1801364)
16:27 <blackboxsw> - debian/ubuntu: add missing word to netplan/ENI header (LP: #1845669)
16:27 <blackboxsw> - ovf: do not generate random instance-id for IMC customization path
16:27 <ubot5> Launchpad bug 1845669 in cloud-init "The meaning of "Changes to it will not persist across an instance." in 50-cloud-init.yaml is unclear" [Undecided,Fix committed] https://launchpad.net/bugs/1845669
16:27 <blackboxsw> - sysconfig: only write resolv.conf if network_state has DNS values
16:27 <blackboxsw> (LP: #1843634)
16:27 <blackboxsw> - sysconfig: use distro variant to check if available (LP: #1843584)
16:27 <blackboxsw> - systemd/cloud-init.service.tmpl: start after wicked.service
16:27 <ubot5> Launchpad bug 1843634 in cloud-init (Suse) "cloud-init misconfigure the network on SLES" [Undecided,Incomplete] https://launchpad.net/bugs/1843634
16:27 <blackboxsw> [Robert Schweikert]
16:27 <blackboxsw> - docs: fix zstack documentation lints
16:28 <ubot5> Launchpad bug 1843584 in cloud-init "cloudinit/net/sysconfig.py lacks support for openSUSE 15.x and Tumbleweed" [Medium,Fix committed] https://launchpad.net/bugs/1843584
16:28 <blackboxsw> - analyze/show: remove trailing space in output
16:28 <blackboxsw> - Add missing space in warning: "not avalid seed" [Brian Candler]
16:28 <blackboxsw> - pylintrc: add 'enter_context' to generated-members list
16:28 <blackboxsw> - Add datasource for ZStack platform. [Shixin Ruan] (LP: #1841181)
16:28 <blackboxsw> - docs: organize TOC and update summary of project [Joshua Powers]
16:28 <blackboxsw> - tools: make clean now cleans the dev directory, not the system
16:28 <blackboxsw> - docs: create cli specific page [Joshua Powers]
16:28 <ubot5> Launchpad bug 1841181 in cloud-init "add datasource for ZStack" [Low,Fix committed] https://launchpad.net/bugs/1841181
16:28 <blackboxsw> - docs: added output examples to analyze.rst [Joshua Powers]
16:28 <blackboxsw> - docs: doc8 fixes for instancedata page [Joshua Powers]
16:28 <blackboxsw> - docs: clean up formatting, organize boot page [Joshua Powers]
16:28 <blackboxsw> - net: add is_master check for filtering device list (LP: #1844191)
16:28 <ubot5> Launchpad bug 1844191 in cloud-init "azure advanced networking sometimes triggers duplicate mac detection" [Critical,Fix committed] https://launchpad.net/bugs/1844191
16:28 <blackboxsw> - docs: more complete list of availability [Joshua Powers]
16:28 <blackboxsw> - docs: start FAQ page [Joshua Powers]
16:28 <blackboxsw> - docs: cleanup output & order of datasource page [Joshua Powers]
16:28 <blackboxsw> - Brightbox: restrict detection to require full domain match .brightbox.com
16:28 <blackboxsw> - VMWware: add option into VMTools config to enable/disable custom script.
16:28 <blackboxsw> [Xiaofeng Wang]
16:28 <blackboxsw> - net,Oracle: Add support for netfailover detection
16:28 <blackboxsw> - atomic_helper: add DEBUG logging to write_file (LP: #1843276)
16:28 <ubot5> Launchpad bug 1843276 in cloud-init "cloudinit.atomic_helper.write_file should have the same logging as util.write_file" [Low,Fix committed] https://launchpad.net/bugs/1843276
16:29 <blackboxsw> Thanks Brian, Shixin Ruan, Conrad Hoffmann, Adam Dobrawy and robjo for the contributions over the last month!
16:29 <blackboxsw> beyond tip commits to cloud-init the upstream team went through two SRUs of cloud-init
16:30 <blackboxsw> it's also excellent to see new datasources like the  RbxCloud datasource added
16:31 <blackboxsw> cloud-init just passed validation for Ubuntu Xenial, Bionic and Disco on the 2nd SRU 19.2-36-g059d049c-0ubuntu2
16:31 <blackboxsw> cloud-images today should have that updated revision in them I blieve
16:32 <blackboxsw> there are fixes for both Azure accelerated networking support and handling issues seen on MAAS network bridge configuration
16:32 <AnhVoMSFT> on that note the last Azure image we had published was early September, which still didn't have the first SRU
16:32 <AnhVoMSFT> is there something going on with the image publishing pipeline again?
16:33 <blackboxsw> AnhVoMSFT: the publishing pipeline paused while we sorted the 2nd SRU pass for maas network bridge issues introduced by 19.2-36-g059d049c-0ubuntu1
16:33 <AnhVoMSFT> i see - that makes sense
16:34 <blackboxsw> 19.2-36-g059d049c-0ubuntu2 was verified as fixing all support there for both Azure and MAAS datasources and the expectation is that image builds are continuing today but I'll verify that the box is ✔ there on images rebuilding
16:34 <Odd_Bloke> There may also be Azure-specific publication pipeline issues, which we wouldn't necessarily know about off-hand.
16:34 <blackboxsw> #action blackboxsw verify cpc image builds are unpaused/unblocked for Azure
16:34 * meetingology blackboxsw verify cpc image builds are unpaused/unblocked for Azure
16:34 <blackboxsw> thx Odd_Bloke right
16:35 <blackboxsw> looks like Odd_Bloke is already on that verification internally
16:35 <blackboxsw> ok so SRU is through verification on our side. cloudimages should be getting latest version of cloud-init for Xenial, Bionic and Disco imminently
16:36 <blackboxsw> I think that is *it* for Recent Changes
16:36 <blackboxsw> #topic In-progress Development
16:37 <blackboxsw> the SRU verification work took a bit of steam out of our current work in progress as it involved a lot of manual and upgrade scenario tests.
16:37 <blackboxsw> But, as always we try to track ongoing work in trello
16:37 <blackboxsw> #link https://trello.com/b/hFtWKUn3/daily-cloud-init-curtin
16:38 <blackboxsw> there are a number of branches in progress that are of interest:
16:39 <blackboxsw> Azure CI for one would be a great add for cloud-init's CI infrastructure
16:39 <blackboxsw> https://code.launchpad.net/~ahosmanmsft/cloud-init/+git/cloud-init/+merge/372957
16:39 <blackboxsw> we need to get eyes on that this week if we can
16:39 <blackboxsw> #action cloud-init upstream review https://code.launchpad.net/~ahosmanmsft/cloud-init/+git/cloud-init/+merge/372957
16:39 * meetingology cloud-init upstream review https://code.launchpad.net/~ahosmanmsft/cloud-init/+git/cloud-init/+merge/372957
16:39 <ahosmanmsft> That would be great
16:40 <blackboxsw> there are also a number of freebsd branches that need to close out.
16:40 <blackboxsw> and I know Odd_Bloke has started peeking at some initial github integration for CI.
16:40 <blackboxsw> Odd_Bloke: any details you want to add about github CI at the moment?
16:41 <Odd_Bloke> I've started iterating on a Travis configuration to run what we currently run in our CI pipeline.
16:41 <Odd_Bloke> Unsurprisingly, setting up linting/unit testing was easy.
16:42 <Odd_Bloke> The other thing we do is run some integration testing from a built deb file.  I got as far as being able to successfully sbuild the package in Travis, and ran into some initial stumbling blocks with running lxd.
16:42 <Odd_Bloke> That's as far as I've got, I expect to pick that work back up this week.
16:42 <blackboxsw> thanks Odd_Bloke , I've added the following card to trello for those interested.
16:43 <blackboxsw> #link https://trello.com/c/pqA1adVM/1195-investigate-adding-github-travis-ci-to-cloud-init
16:43 <blackboxsw> I think that about wraps in progress work. We'll tackle reviews a bit at the end of the meeting
16:43 <blackboxsw> ok next topic
16:44 <blackboxsw> #topic Community Charter
16:45 <blackboxsw> at the cloud-init summit we decided to highlight community work in trello so that any community member with some dev cycles and interest can join in and contribute to ongoing tasks
16:45 <blackboxsw> that lane is now in trello representing low-hanging-fruit content that upstream cloud-init is interested in completing, and that anyone can commit to.
16:45 <blackboxsw> #link https://trello.com/b/hFtWKUn3/daily-cloud-init-curtin
16:46 <blackboxsw> the lane is labelled "Community low-hanging-fruit" and currently contains a number of doc update work items  as well as json schema validation extensions for each cloud-init config module
16:47 <blackboxsw> we invite everyone to participate and feel free to grab those items as they have interest
16:47 <blackboxsw> we'll revisit this topic in each meeting so folks have context
16:47 <blackboxsw> #topic Upcoming meetings and releases
16:48 <blackboxsw> cloud-init upstream has just passed validation of cloud-init 19.2.36-*-ubuntu2  which should approved for upload into Xenial, Disco and Bionic (and queued for Eoan)
16:48 <blackboxsw> the cloud build team will be generating images for various clouds imminently and we will confirm that build pipelines are active so platforms get new bits asap
16:50 <blackboxsw> 19.3 upstream should by coming shortly, we will update the topic with the expected upstream release date and send an  email to the mailing list with the estimated upstream cut
16:51 <blackboxsw> #action upstream cloud-init email about 19.3 release date
16:51 * meetingology upstream cloud-init email about 19.3 release date
16:52 <blackboxsw> next meeting is Oct 22
16:52 <blackboxsw> same bat time same bat channel
16:52 <blackboxsw> #topic Office Hours (next ~30 mins)
16:52 <blackboxsw> we spend this time for reviews, bug triage and cloud-init discussions.
16:53 <blackboxsw> upstream devs should have eyes on this channel. Thanks everyone for tuning in
16:54 <AnhVoMSFT> have you had a chance to discuss about the python deprecation issue, or did the SRU verification take most of the time since the summit
16:58 <blackboxsw> AnhVoMSFT: last week was vacation plus the remainder of us on sru verification  .
17:00 <blackboxsw> But now we have cleared that hurdle we should we able to discuss it this week.
17:00 <AnhVoMSFT> yep, sounds good.
17:01 <blackboxsw> #action revisit python deprecation and report to mailinglist
17:01 * meetingology revisit python deprecation and report to mailinglist
17:01 <blackboxsw> Good meeting for actions
17:54 <blackboxsw> Thanks for the participation folks I'll publish minutes to github
17:54 <blackboxsw> #endmeeting