16:27 <blackboxsw> #startmeeting Cloud-init bi-weekly status
16:27 <meetingology> Meeting started Mon Feb 11 16:27:54 2019 UTC.  The chair is blackboxsw. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:27 <meetingology> 
16:27 <meetingology> Available commands: action commands idea info link nick
16:28 <rharper> o/
16:29 <blackboxsw> Sorry folk for the late start here.  Time for our cloud-init status meeting for updates.
16:30 <blackboxsw> Generally the topics we cover in this status meeting are: Previous Actions, Recent Changes, In-progress Development, and Office hours
16:30 <blackboxsw> #topic Previous Actions
16:31 <blackboxsw> looks like we were able to get this following merged per last meeting's action https://code.launchpad.net/~rjschwei/cloud-init/+git/cloud-init/+merge/356098
16:32 <blackboxsw> #action carry over blackboxsw close and land Openstack metadata handling bug https://bugs.launchpad.net/cloud-init/+bug/1801364
16:32 * meetingology carry over blackboxsw close and land Openstack metadata handling bug https://bugs.launchpad.net/cloud-init/+bug/1801364
16:32 <ubot5> Ubuntu bug 1801364 in cloud-init "persisting OpenStack metadata fails" [Undecided,Confirmed]
16:34 <blackboxsw> we'll have to carry that into this cycle to
16:35 <blackboxsw> I don't see any other actions we missed.
16:35 <blackboxsw> #topic In-Progress Development
16:35 <blackboxsw> Here are the commits that have landed since the last meeting
16:39 <blackboxsw> - netinfo: Adjust ifconfig output parsing for FreeBSD ipv6 entries
16:39 <blackboxsw> [Ryan Harper] (LP: #1779672)
16:39 <blackboxsw> - netplan: Don't render yaml aliases when dumping netplan
16:39 <blackboxsw> [Ryan Harper] (LP: #1815051)
16:39 <blackboxsw> - add PyCharm IDE .idea/ path to .gitignore [Dominic Schlegel]
16:39 <blackboxsw> - correct grammar issue in instance metadata documentation
16:39 <blackboxsw> [Dominic Schlegel] (LP: #1802188)
16:39 <ubot5> Launchpad bug 1779672 in cloud-init "netdev_pformat key error on FreeBSD with 18.3" [Medium,Fix committed] https://launchpad.net/bugs/1779672
16:39 <blackboxsw> - clean: cloud-init clean should not trace when run from within cloud_dir
16:39 <blackboxsw> [Chad Smith] (LP: #1795508)
16:39 <blackboxsw> - Resolve flake8 comparison and pycodestyle over-ident issues
16:39 <blackboxsw> [Paride Legovini]
16:39 <ubot5> Launchpad bug 1815051 in cloud-init (Ubuntu) "Bionic netplan render invalid yaml duplicate anchor declaration for nameserver entries" [High,In progress] https://launchpad.net/bugs/1815051
16:39 <blackboxsw> - opennebula: also exclude epochseconds from changed environment vars
16:39 <blackboxsw> [Chad Smith] (LP: #1813641)
16:39 <ubot5> Launchpad bug 1802188 in cloud-init "Documentation grammar issue" [Undecided,Fix committed] https://launchpad.net/bugs/1802188
16:39 <blackboxsw> - systemd: Render generator from template to account for system
16:39 <blackboxsw> differences. [Robert Schweikert]
16:39 <ubot5> Launchpad bug 1795508 in cloud-init "cloud-init clean from within /var/lib/cloud-init/instance" [Undecided,Fix committed] https://launchpad.net/bugs/1795508
16:39 <blackboxsw> - sysconfig: On SUSE, use STARTMODE instead of ONBOOT
16:39 <blackboxsw> [Robert Schweikert] (LP: #1799540)
16:39 <ubot5> Launchpad bug 1813641 in cloud-init "cloud-init on Disco, opennebula will intermittently fail unittests " [Undecided,Fix committed] https://launchpad.net/bugs/1813641
16:39 <ubot5> Launchpad bug 1799540 in cloud-init "ONBOOT not supported in SUSE distros" [Undecided,Fix committed] https://launchpad.net/bugs/1799540
16:40 <blackboxsw> notes of interest, Some FreeBSD and OpenSuse support is now pulled into upstream. Thanks  folks on the contribution
16:40 <blackboxsw> We also track our current work on the public trello board
16:40 <blackboxsw> #link https://trello.com/b/hFtWKUn3/daily-cloud-init-curtin
16:42 <blackboxsw> the biggest item in progress for us in cloud-init is SRU verification, we have begun testing for a release of 18.5-21 into xenial, bionic and cosmic. expectations are that we will finish that over the next  week
16:43 <blackboxsw> We have longer term work on OpenStack network hotplug support that is under development and will ultimately provide a platform for many datasources to add hotplug support in cloud-init. thanks rharper for that effort.
16:43 <blackboxsw> I think about wraps it up for today.
16:43 <blackboxsw> #topic Office Hours (next ~30 minutes)
16:44 <blackboxsw> During office hours a upstream cloud-initers will be watching the channel for active discussion of features, bugs or branches that need review
16:45 <blackboxsw> it's an open forum for discussion and anyone with a item to discuss can drop in and lob questions
16:47 * robjo and rharper need to at some point come to terms with the sysconfig rendering so I can drop the crazy routing patch from the SUSE package, but I am definitely not able to contribute any code until the first or second week in March
16:47 <robjo> there are 2 or 3 network setup related bugs open
16:47 <rharper> robjo: ack
17:41 <blackboxsw> ... forgot to end the meeting. Thanks for tuning in folks
17:41 <blackboxsw> #endmeeting