21:02 <bluesabre> #startmeeting Xubuntu Community Meeting
21:02 <meetingology> Meeting started Tue May 19 21:02:32 2020 UTC.  The chair is bluesabre. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
21:02 <meetingology> 
21:02 <meetingology> Available commands: action commands idea info link nick
21:02 <bluesabre> !team | Meeting time!
21:02 <ubottu> Meeting time!: bluesabre, knome, krytarik, ochosi, pleia2 and Unit193
21:02 <pleia2> o/
21:02 <bluesabre> #chair pleia2
21:02 <meetingology> Current chairs: bluesabre pleia2
21:03 <bluesabre> :)
21:03 <bluesabre> Agenda at https://wiki.ubuntu.com/Xubuntu/Meetings
21:04 <bluesabre> We'll wait a short few for everybody to show up. (and for me to close a bunch of tabs)
21:05 <jphilips> pleia2: glad to hear you're getting there and that you enjoyed the release video. it got featured on OMG Ubuntu :D
21:05 <pleia2> yes, I saw!
21:07 <jphilips> stumbled on your episode on linux spotlight, which i hope to watch soon
21:08 <bluesabre> Noticed the meeting minutes weren't added from the last meeting, so adding those right quick
21:08 <pleia2> I wish I had done it from my home office in california, I was sitting in my kitchen in pennsylvania and the backdrop is boring :)
21:09 <pleia2> jphilips: just now finally got to reviewing the video text for what is Xubuntu
21:10 <jphilips> pleia2: thanks
21:10 <bluesabre> Last meeting minutes added, so let's go ahead and start the meeting :)
21:10 <pleia2> thanks, bluesabre!
21:10 <bluesabre> #topic Open action items
21:11 <bluesabre> #info bluesabre and jphilips to send follow-up email/vote to the list
21:11 <bluesabre> That was in regard to the desktop changes. Now that 20.10 has started, I say lets get that vote out this week (along with the other votes we're going to have)
21:12 <bluesabre> #action bluesabre and jphilips to send follow-up vote for desktop changes to the ML
21:12 * meetingology bluesabre and jphilips to send follow-up vote for desktop changes to the ML
21:12 <bluesabre> #topic Updates and announcements
21:13 <jphilips> curious how to have people vote on every item suggested in the google doc?
21:13 <bluesabre> #info akxwi-dave and slickymaster have been deactivated from the team since they've been inactive for a while. Thanks for all the support you've given us over the years!
21:14 <bluesabre> jphilips: we'll need to consolidate some of those suggestions. I think we discussed how we were going to combine them in this meeting: http://ubottu.com/meetingology/logs/xubuntu-devel/2020/xubuntu-devel.2020-03-19-21.00.moin.txt
21:15 <bluesabre> #info jphilips put together a nice release video for 20.04, check it out if you haven't seen it (link below)
21:15 <bluesabre> #link https://www.youtube.com/watch?v=4a_uVSNnIGY
21:16 <pleia2> it's so good!
21:16 <bluesabre> Any other updates or announcements?
21:16 <jphilips> do we want to mention about the work going on with the documentation?
21:17 <bluesabre> Definitely
21:17 <jphilips> okay
21:17 <bluesabre> Maybe get some more contributors in the process :)
21:18 <jphilips> every week we are going through a single page of the documentation in google docs
21:18 <jphilips> announcing the editing of the google doc on social media and in the ML
21:18 <jphilips> we had a new contributor today for this week's 'What is Xubuntu?' page
21:19 <bluesabre> Oh nice
21:19 <pleia2> great :)
21:19 <jphilips> we have weekly meetings on Saturday at 3pm UTC for the finalization of the edits make on the google doc worked on each week
21:19 <jphilips> the weekly meeting happens on Zoom
21:20 <jphilips> its in audio
21:21 <jphilips> i think that's it for documentation
21:22 <bluesabre> Cool, thanks :)
21:22 <bluesabre> pleia2: anything else to add for U&A?
21:22 <pleia2> I don't think so
21:22 <bluesabre> Alrighty
21:23 <bluesabre> On to the next section :)
21:23 <bluesabre> #topic Discussion
21:23 <bluesabre> #subtopic GitHub Proposal
21:23 <bluesabre> I've been working on this one for a bit.
21:23 <bluesabre> Here's the proposal: https://wiki.xubuntu.org/proposals/github
21:24 <bluesabre> A demo Xubuntu-Team organization so we can see it in practice: https://github.com/Xubuntu-Team
21:24 <pleia2> does this cause any problems with iso building or any of the stuff Canonical does for us? (didn't see it in the Cons)
21:25 <bluesabre> It shouldn't affect anything of that nature.
21:25 <bluesabre> I also spoke with Wimpress of Ubuntu Mate (and Desktop) and he says everything works well for them there.
21:26 <pleia2> philosophically I'm sad to see us move from an open source platform for development and translations to proprietary ones (both github and transifex) but I do understand the practical considerations
21:26 <pleia2> it's probably worth moving just so it's easier on new developers we always need
21:26 <bluesabre> The one codebase we'd keep hosted on Launchpad is the seed, since AAs contribute directly to it.
21:26 <pleia2> gotcha
21:27 <Unit193> I'd imagine the seed has to remain on launchpad though.  I think turning off 'issues' on Github and leaving those on Launchpad (package bugs) makes sense though, since it's linked and more findable.
21:27 <bluesabre> Yeah, and that's definitely an option.
21:27 <pleia2> Unit193: good point re: bugs
21:28 <Unit193> Also: `ubuntu-bug` will work. :P
21:28 <bluesabre> :)
21:28 <pleia2> yeah, and all the related testing documentation
21:29 <ochosi> hi all
21:29 <ochosi> weird, i didn't see the ping for the meeting
21:29 <ochosi> sry to be late
21:30 <bluesabre> hey ochosi, glad you could make it
21:31 <bluesabre> Disabled issues and added a note on the readme @ https://github.com/Xubuntu-Team/xubuntu-default-settings/blob/master/README.md for that example
21:31 <jphilips> would moving to gitlab rather than github make it more acceptable to contributors who oppose github?
21:31 <bluesabre> Easier to see at https://github.com/Xubuntu-Team/xubuntu-default-settings
21:31 <Unit193> bluesabre: So if it's code and translations only, yeah that makes sense I guess.  I'm not exactly keen on it either, but it is what it is.
21:33 <bluesabre> jphilips: I think Gitlab keeps the benefit of the more advanced platform, but loses out on the wider userbase. It also creates an issue of where and how to host.
21:33 <bluesabre> Whereas Ubuntu, derivatives, and other projects are already on GitHub.
21:33 <Unit193> I think he means gitlab.com.
21:34 <jphilips> i remember ubuntu mate used to host on gitlab.com and then moved to github.com
21:34 <Unit193> bluesabre: gitlab.xfce.org! :>
21:34 <ochosi> haha
21:34 <ochosi> well we're still working on gitlab.xfce ;)
21:34 <ochosi> i would also go for github
21:34 <ochosi> because of the rest of *buntu also being there
21:35 <jphilips> oh okay. i prefer it as well.
21:35 <bluesabre> :)
21:36 <ochosi> how does ubuntu handle LP bugs vs. GH issues?
21:36 <ochosi> plus do we still run package builds through LP?
21:36 <bluesabre> We'd keep package builds running with mirrored LP repos
21:37 <bluesabre> As for the bugs, we're considering now: disable GH issues, and point visitors to report issues for the packages on Ubuntu. Not sure if that interferes with merge requests.
21:38 <bluesabre> Otherwise, LP has upstream bug linking options, like we currently do for Xfce bugs
21:38 <ochosi> depends on whether you want to be able to automatically close issues with MRs
21:39 <bluesabre> Even now, our bugs are only closed by package uploads (or somebody reviewing them later after upload)
21:39 <Unit193> Which to me, makes more sense.
21:40 <ochosi> sure
21:40 <ochosi> what i meant: i wouldnt expect many troubles with MRs and issues
21:40 <Unit193> I think LP has support for watching for fix committed, but think that only works with bzr. :P
21:40 <ochosi> but the whole mix may end up being a little confusing
21:40 <ochosi> because the code will be mirrored on LP
21:40 <ochosi> but then again, i don#t remember people flocking into LP to contribute...
21:41 <ochosi> (in the last years at least, in the early years yes)
21:41 <pleia2> mirroring of git repos is pretty common practice across open source these days
21:41 <bluesabre> Yeah, I get lots of pastes and random emails with patches.
21:41 <pleia2> usually it's the other way around (so it's discoverable on github, but you contribute elsewhere), but it's still a thing
21:43 <jphilips> ubuntu mate has a page showing where to file bugs and patches for different parts of the development - https://ubuntu-mate.org/get-involved/development/
21:44 <pleia2> if I'm honest, launchpad is already so confusing to navigate, we don't lose much by having people do different things in different places :\
21:44 <bluesabre> jphilips: that's a pretty cool resource
21:45 <jphilips> yep there new website is quite nicely organized
21:45 <jphilips> their*
21:46 <bluesabre> With all the xubuntu things being fairly easy to find from the GH homepage, it might actually make things easier https://github.com/Xubuntu-Team :D
21:46 <pleia2> indeed :)
21:46 <ochosi> yup
21:46 <bluesabre> So yeah, any other concerns or talking points? Should we open up team voting here and resume it in the ML, or just do all in the ML?
21:47 <bluesabre> Or should we just roll with it?
21:48 <Unit193> Moving all code hosting seems like something we might want to vote on. :>
21:48 <bluesabre> Figured as much :D
21:49 <bluesabre> #vote Move code hosting and translations to GitHub and Transifex?
21:49 <meetingology> Please vote on: Move code hosting and translations to GitHub and Transifex?
21:49 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
21:49 <bluesabre> #chair ochosi
21:49 <meetingology> Current chairs: bluesabre ochosi pleia2
21:49 <bluesabre> #chair Unit193
21:49 <meetingology> Current chairs: Unit193 bluesabre ochosi pleia2
21:50 <bluesabre> #voters Unit193 bluesabre ochosi pleia2
21:50 <meetingology> Current voters: Unit193 bluesabre ochosi pleia2
21:50 <bluesabre> #voters knome krytarik
21:50 <meetingology> Current voters: Unit193 bluesabre knome krytarik ochosi pleia2
21:50 <bluesabre> +1
21:50 <meetingology> +1 received from bluesabre
21:51 <pleia2> +1
21:51 <meetingology> +1 received from pleia2
21:51 <Unit193> +1
21:51 <meetingology> +1 received from Unit193
21:52 <bluesabre> ochosi knome krytarik?
21:53 <ochosi> +1
21:53 <meetingology> +1 received from ochosi
21:53 <bluesabre> Neat, 4/6
21:54 <bluesabre> #endvote
21:54 <meetingology> Voting ended on: Move code hosting and translations to GitHub and Transifex?
21:54 <meetingology> Votes for:4 Votes against:0 Abstentions:0
21:54 <meetingology> Motion carried
21:54 <bluesabre> #action bluesabre to move code hosting and translations to GitHub and Transifex
21:54 * meetingology bluesabre to move code hosting and translations to GitHub and Transifex
21:55 <bluesabre> Thanks for voting!
21:55 <bluesabre> #subtopic Telegram Groups and IRC Bridge
21:55 <Unit193> Now, does everyone have an account?  I know krytarik doesn't.
21:55 <bluesabre> That's fun
21:55 <jphilips> i have an account
21:56 <bluesabre> RE: Github, we'll still be able to accept MRs from remote repos
21:56 <bluesabre> #link https://wiki.xubuntu.org/proposals/telegram-bridge
21:56 <bluesabre> jphilips: want to lead on this?
21:57 <jphilips> not sure how to :D
21:57 <jphilips> can answer any questions people have after they've read the proposal
21:58 <bluesabre> There's a in-testing Telegram bridge at https://t.me/XubuntuSupport and #xubuntu-support (I think that's right)
21:58 <jphilips> but the basic idea is to create telegram groups for xubuntu and xubuntu-devel and bridge them to the irc channels to make it easier for people to get involved and get help
21:59 <jphilips> yes we've setup a group for support and bridged it with #xubuntu-support while we await approval
21:59 <Unit193> While I'm fully against the idea, I understand the reasoning, but I don't see the point in linking the support medium.
21:59 <jphilips> aaditya is the one who has setup the bridge
21:59 <Unit193> Reasining for development*
22:00 <ochosi> i don't have a big opinion on this
22:00 <ochosi> i'm not active in the support channel for a while already, not enough time
22:00 <ochosi> and for development i read the backlog when i have time
22:00 <ochosi> on my phone i also read stuff when i *don't* have time
22:00 <Unit193> I #kubuntu, I see spam all the time come across, and general frustration among some of the common folks that help out.
22:02 <bluesabre> Is it general spam, or is it just less-than-ideal visitors?
22:02 <ochosi> can't say that surprises me
22:03 <bluesabre> I'm still pretty new to Telegram, but I have seen more open source projects seeming to embrace it recently.
22:03 <pleia2> who has access to bringing the bridge back up if it goes down?
22:04 <Unit193> bluesabre: Spam, it's getting to the point that when you see a female name join, you wonder if it's another drive-by. :/
22:04 <bluesabre> Ouch.
22:04 <pleia2> Unit193: yikes :(
22:04 <jphilips> pleia2: once its on xubuntu infra, bluesabre would have it
22:04 <bluesabre> Once I have access to the infra
22:04 <pleia2> on dev.xubuntu.org or...?
22:04 <bluesabre> I'd be willing to support if we went forward with the proposal.
22:04 <pleia2> ok, thanks bluesabre
22:05 <jphilips> unlike IRC, its easy to ban someone from the telegram group, unless they create another account with a new cell number
22:05 <pleia2> I'm wondering if we could do a trial, and if it doesn't work just split them off to entirely separate resources
22:05 <bluesabre> Haven't done server-side stuff for Xubuntu to this point, but that's what I spend a lot of my time on in my IRL job
22:06 <pleia2> doesn't work == spam, unreliability, anything else that annoys people
22:07 <Unit193> I *really* don't like that it basically would change #xubuntu-offtopic into a logged channel. :/
22:07 <bluesabre> That seems like a reasonable way to go about it. If the bridges turn out to be bad, the Telegram support group could just be a separate supported.
22:07 <pleia2> I don't think we'd do it for offtopic
22:08 <bluesabre> Unit193: oh, this is only considering #xubuntu and #xubuntu-devel
22:08 <Unit193> bluesabre: Aha!  Thanks!
22:08 <jphilips> does anyone here have OP for #xubuntu, so we can do the trial?
22:09 <bluesabre> jphilips: where is the current bridge currently hosted? Would we need to move infra first?
22:10 <jphilips> aaditya is hosting it now on his private server
22:10 <Unit193> Who is aaditya?
22:10 <jphilips> the sysadmin who volunteered to assist in setting up the bridge
22:10 <Unit193> ...Yes thanks I got that part...
22:10 <pleia2> hehe
22:10 <bluesabre> lol
22:11 <pleia2> jphilips: aaditya is ok with us going "into production" with it still on his server, right?
22:12 <pleia2> aside from that, I suspect it's up to us whether we want to move it now or later
22:13 <jphilips> yes
22:15 <pleia2> so, do we want to move it first? :)
22:15 <pleia2> I'd be more comfortable that way, but it's signing up bluesabre for work :D
22:15 <bluesabre> I'll be deep in Github for the next week
22:16 <jphilips> aaditya could do it to ease the burden
22:16 <pleia2> he's been a very helpful volunteer, but it probably requires giving root on our development server, and I'm not willing to do that :\
22:16 <pleia2> we know bluesabre, but we don't know aaditya yet
22:16 <bluesabre> But if we're fine with waiting a week, I'd happily help get it set up after that.
22:17 <jphilips> okay
22:17 <pleia2> seems fine to me
22:18 <bluesabre> pleia2: do I need to talk to somebody in Canonical to get server access, or do you handle that within our team?
22:18 <pleia2> that's me
22:18 <bluesabre> Neato.
22:18 <pleia2> I just need a public ssh key and preferred username
22:18 <bluesabre> Cool, I'll send those your way.
22:19 <pleia2> great
22:19 <bluesabre> Once I finish the Github migration, we'll do the bridge. :)
22:19 <pleia2> oh, you already have an account
22:19 <bluesabre> Unit193: And you're the one to talk to about OP on #xubuntu, I take it?
22:19 <bluesabre> pleia2: oh
22:19 <ochosi> hah
22:19 <pleia2> so just lmk if you can't log in and we can update your key ;)
22:19 <Unit193> Would this be another thing we vote on?
22:20 <pleia2> Unit193: oh, probably
22:20 <bluesabre> Yeah, that seems fair.
22:20 <bluesabre> :D
22:20 <jphilips> presume OP isn't necessary, was only needed for a trial I was thinking about doing were the telegram bot would muted from the IRC side
22:20 <bluesabre> #vote Connect Telegram with #xubuntu?
22:20 <meetingology> Please vote on: Connect Telegram with #xubuntu?
22:20 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
22:21 <pleia2> +1
22:21 <meetingology> +1 received from pleia2
22:21 <Unit193> -1
22:21 <meetingology> -1 received from Unit193
22:21 <bluesabre> +1
22:21 <meetingology> +1 received from bluesabre
22:21 <bluesabre> ochosi knome krytarik?
22:22 <bluesabre> (this one will probably head to ML)
22:22 <ochosi> hm
22:22 <ochosi> -1
22:22 <meetingology> -1 received from ochosi
22:23 <bluesabre> Alrighty, ML it is for this one :)
22:23 <bluesabre> #endvote
22:23 <meetingology> Voting ended on: Connect Telegram with #xubuntu?
22:23 <meetingology> Votes for:2 Votes against:2 Abstentions:0
22:23 <meetingology> Deadlock, casting vote may be used
22:23 <bluesabre> #action bluesabre to send vote to ML for Xubuntu Telegram bridge
22:23 * meetingology bluesabre to send vote to ML for Xubuntu Telegram bridge
22:24 <bluesabre> #subtopic Xubuntu Council Nominations for the 22.04 Cycle
22:24 <bluesabre> 20.04 was great, and now its time for a 22.04 council
22:25 <bluesabre> I don't remember what we did last time, tbh
22:25 <bluesabre> So I'm gonna have to dig :D
22:25 <Unit193> [18:27:30] < Unit193> If we want to be lazy and use a template: https://lists.ubuntu.com/archives/xubuntu-devel/2018-April/011644.html
22:25 <bluesabre> I love not digging
22:25 <bluesabre> :D
22:26 <Unit193> So, you, Simon and Lyz this time? :>
22:26 <pleia2> lol
22:26 <bluesabre> I'll do lots of begging
22:27 <bluesabre> So yeah, I'll fire that announcement off to the ML too
22:27 <ochosi> i'm more than likely to stick around, just not sure how actively
22:27 <bluesabre> #action bluesabre to notify the ML of Xubuntu Council nominations
22:27 * meetingology bluesabre to notify the ML of Xubuntu Council nominations
22:27 <ochosi> as you've noticed i've drifted more and more towards the various upstreams (be it shimmer or xfce)
22:28 <pleia2> as for me, being a new parent is hard
22:28 <bluesabre> I'm just lazy most days
22:28 <pleia2> hehe
22:29 <bluesabre> Let's get this wrapped up soon so everybody can have a nice evening :)
22:29 <bluesabre> #topic AOB
22:29 <Unit193> We might need more ML list moderators.
22:29 <bluesabre> Anybody, anything to discuss?
22:29 <bluesabre> Yeah
22:29 <bluesabre> I should do a better job of it
22:29 <bluesabre> (or some job of it)
22:30 <Unit193> I do spam, but there's other stuff there now too. :P
22:30 <Unit193> I had another thing, but I can't remember.
22:31 <pleia2> oh yeah, I haven't been tending to the queue at all :\
22:31 <pleia2> sometimes I look and let month+ old things through
22:31 <pleia2> "oops"
22:31 <pleia2> so if anyone wants to help with moderation, do let us know :)
22:31 <bluesabre> "Those darn ubuntu mail servers, they hold email forever"
22:31 <pleia2> for -devel mostly it's letting legit things through and replying to support requests redirecting them to support
22:32 <bluesabre> :)
22:33 <bluesabre> Anything else?
22:33 <bluesabre> (I smell dinner)
22:33 <jphilips> do we want to consider opening a forum or discourse for support?
22:33 <Unit193> Still can't remember it, so guess not.
22:33 <Unit193> ubuntuforums.org
22:34 <bluesabre> ^ seems like the way to go
22:34 <Unit193> Pretty sure they have a flavors section already, so we're set.
22:34 <bluesabre> Nifty.
22:34 <jphilips> yes a section for all flavors
22:34 <jphilips> each flavor has their own forum or discourse
22:35 <Unit193> Seems covered then.
22:35 <jphilips> maybe what i said wasn't clear enough. none of the flavors use ubuntuforums.org
22:36 <bluesabre> I think we have an adequate number of support options for now in askubuntu, irc, xfce forums, and non-specialized ubuntu forums
22:37 <jphilips> okay
22:37 <bluesabre> Wrapping up :)
22:37 <bluesabre> #topic Schedule next meeting
22:37 <bluesabre> #action knome to schedule next meeting
22:37 * meetingology knome to schedule next meeting
22:37 <bluesabre> #endmeeting