22:00 <knome> #startmeeting Xubuntu community meeting
22:00 <meetingology> Meeting started Fri Nov 17 22:00:04 2017 UTC.  The chair is knome. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
22:00 <meetingology> 
22:00 <meetingology> Available commands: action commands idea info link nick
22:00 <knome> !chair bluesabre ochosi
22:00 <ubottu> knome: I am only a bot, please don't think I'm intelligent :)
22:00 <knome> err
22:00 <knome> #chair bluesabre ochosi
22:00 <meetingology> Current chairs: bluesabre knome ochosi
22:00 <flocculant> or
22:00 <bluesabre> hi everyone
22:00 <akxwi-dave> hi
22:00 <knome> who's here for the meeting?
22:00 <flocculant> evening peeps
22:00 <slickymaster> o/
22:00 <knome> ochosi said he'd be here, just a bit late
22:01 <knome> pleia2, want to join the fun?
22:01 <pleia2> ohi
22:01 <slickymaster> not sure if I'll manage to make through the all meeting
22:01 <knome> kryyyyteeeen
22:01 <krytarik> Yes!
22:01 <flocculant> hi pleia2 :)
22:01 <knome> slickymaster, just don't empty the whole rum bottle..
22:01 <knome> wow, dkessel's idle time is 67 days
22:01 <flocculant> but don't let the guests do that either
22:01 <slickymaster> thing is, I also want to have some before it disappears
22:02 <flocculant> that :p
22:02 <knome> #topic Open action items
22:02 <slickymaster> yep
22:02 <knome> there are none
22:02 <bluesabre> they're all done :)
22:02 <knome> #topic Updates and announcements
22:02 <knome> bluesabre, staging PPA
22:02 <knome> want to open that up or just announce?
22:03 <bluesabre> Fine to just announce for now, I think there is/was a mail going out to the ML with more details
22:03 <knome> oki
22:03 <flocculant> is
22:04 <knome> #info QA Staging PPA is now available at https://launchpad.net/~xubuntu-dev/+archive/ubuntu/staging
22:04 <knome> #info PulseAudio Plugin and Status Notifier Plugin are now included in Bionic, replacing indicator-application, indicator-sound, and xfce4-volumed
22:04 <knome> #info Next milestone, November 30: Feature Definition Freeze
22:04 <knome> #topic Discussion
22:04 <knome> #subtopic Replace GNOME components with MATE components (bluesabre)
22:04 <knome> bluesabre, the floor is yours
22:04 <bluesabre> Alrighty, so a bit of rationale
22:05 <bluesabre> Our current GNOME components are patched in Ubuntu to replace the headerbars with normal window manager controls and menus
22:05 <bluesabre> That requires manpower to maintain, and Ubuntu is likely to just drop the patches going forward
22:06 <bluesabre> MATE is a DE more similar to Xfce, window manager and menus included
22:06 <flocculant> question
22:06 <bluesabre> Yes?
22:06 <flocculant> is the dropping (if) down to moving from unity to gnome and not needing the patches?
22:07 <bluesabre> Yes, since Unity needed the menus to work correctly with the global menus
22:07 <flocculant> ok - cool, just wasn't sure
22:07 <flocculant> sorry for interruption :)
22:08 <bluesabre> The components I've listed, evince -> atril, file-roller -> engrampa, gnome-calculator -> mate-calc, are basically drop in replacements
22:08 <knome> headerbar == CSD?
22:08 <bluesabre> yes
22:08 <knome> right, so do we have CSD in other apps
22:08 <knome> like some apps bluesabre wrote
22:08 <bluesabre> Yes, where we have more control to make sure they work well in xfce
22:08 <knome> right
22:09 <bluesabre> gnome-calculator has a menu that seems to come and go when running in xfce
22:09 <bluesabre> Currently, it does not show for me
22:09 <bluesabre> But it would normally show in GNOME shell
22:09 <knome> do you think this transition will happen during 18.04?
22:09 <slickymaster> same here, bluesabre
22:09 <flocculant> :)
22:09 <bluesabre> knome, I think it will
22:09 <bluesabre> And if we are willing to move now, it will probably help their decision
22:09 <knome> also, you say the replacements are drop in... do they share the same codebase?
22:10 <flocculant> I'd hope if it does - then it happens soon
22:10 <bluesabre> MATE components are basically the GNOME 2 variants, ported to GTK3 with bug fixes
22:10 <bluesabre> So, probably 90% same
22:10 <knome> right, so instead of using the GNOME3 components that likely get a bit more attention, we're moving to GNOME2 components that are maintained by mate people?
22:11 <knome> i'm asking this partly because i want to know what the future for these components looks like
22:11 <bluesabre> MATE is pretty popular and has strong development
22:11 <knome> eg. does mate have the manpower to maintain them and are they willing to do it
22:11 <flocculant> flexiondotorg: you about?
22:11 <bluesabre> It could easily be argued they have more eyes on them than xfce
22:12 <flexiondotorg> o/
22:12 <bluesabre> knome: I feel confident they will be maintained for the foreseeable future
22:12 <flocculant> flexiondotorg will likely be able to answer that for us :)
22:12 <bluesabre> flexiondotorg: we're thinking of using some MATE components instead of GNOME, thoughts?
22:13 <knome> flexiondotorg, or in other words, how many bottles of rum are you willing to donate to slickymaster if we do?
22:13 <flexiondotorg> Ok. Applications or components of the DE?
22:13 <flocculant> apps
22:13 <flexiondotorg> Ok
22:13 <bluesabre> just
22:13 <bluesabre> evince -> atril, file-roller -> engrampa, gnome-calculator -> mate-calc
22:13 <bluesabre> for now
22:13 <flexiondotorg> Right.
22:14 * slickymaster waits
22:14 <flocculant> flexiondotorg: the question was
22:14 <flocculant> < knome> eg. does mate have the manpower to maintain them and are they willing to do it
22:14 <flexiondotorg> Interesting. Because just today we've been discussing how we might decouple the apps from the core DE release schedule.
22:14 <flexiondotorg> So the apps can iterate at their own pace.
22:15 <flexiondotorg> We have a small but dedicated team. We've been maintaining them for years and intend to continue to do so.
22:15 <flexiondotorg> Might need to review how deep the deps go on some of the apps.
22:16 <knome> that'd be nice
22:16 <flexiondotorg> Wouldn't want you pulling in stuff you don't require.
22:16 <knome> sounds great
22:16 <flexiondotorg> mate-calc is fine.
22:16 <bluesabre> Those three seem pretty minimal, might need to recommends to include theme alternatives
22:16 <bluesabre> Pretty open to packaging patches?
22:16 <flexiondotorg> I'll check the apps you're interested in and report back in a bit.
22:17 <bluesabre> awesome, thanks flexiondotorg
22:17 <flocculant> flexiondotorg: you are a gent :)
22:17 <flexiondotorg> Yes, more than happy to collaborate and help you guys out.
22:17 <flocculant> thanks
22:17 <knome> i think this is "big enough" that we need a vote just for the sake of it...
22:17 <knome> so let's start it here
22:17 <flexiondotorg> Ubuntu Kylin is based on MATE now too. So we've done this before.
22:17 <knome> team is 11, so we need 6 votes at minimum
22:19 <knome> #vote OK to replace GNOME components with MATE counterparts?
22:19 <meetingology> Please vote on: OK to replace GNOME components with MATE counterparts?
22:19 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
22:19 <bluesabre> +1
22:19 <meetingology> +1 received from bluesabre
22:19 <knome> +1
22:19 <meetingology> +1 received from knome
22:19 <krytarik> +1
22:19 <meetingology> +1 received from krytarik
22:19 <flocculant> +1
22:19 <meetingology> +1 received from flocculant
22:19 <akxwi-dave> +1
22:19 <meetingology> +1 received from akxwi-dave
22:19 * flocculant wakes up pleia2 slickymaster and krytarik
22:19 <knome> slickymaster, you still waiting for the rum offer or ready to vote?
22:19 <slickymaster> +1
22:19 <meetingology> +1 received from slickymaster
22:19 <slickymaster> just having a sip
22:20 <flocculant> :)
22:20 <knome> pleia2, want to cast a vote?
22:20 <pleia2> +0
22:20 <meetingology> +0 received from pleia2
22:20 <flocculant> sorry krytarik - was looking for kryten ...
22:20 <krytarik> lol
22:20 <knome> :)
22:20 <knome> #endvote
22:20 <meetingology> Voting ended on: OK to replace GNOME components with MATE counterparts?
22:20 <meetingology> Votes for:6 Votes against:0 Abstentions:1
22:20 <meetingology> Motion carried
22:21 <knome> #info Carrying on with the transition to MATE components
22:21 <bluesabre> That step was painless
22:21 <knome> yes
22:21 <flocculant> can we have a 'if it's March when it happens - QA can say no' vote ...
22:21 <knome> "but you only won by one vote, lulz"
22:21 <bluesabre> flocculant: planning to make it happen asap
22:21 <flocculant> :)
22:21 <flocculant> bluesabre: I'd assumed so :)
22:21 <knome> #action bluesabre to change seed for GNOME/MATE apps transition before FDF
22:21 * meetingology bluesabre to change seed for GNOME/MATE apps transition before FDF
22:22 <flocculant> tongue was firmly in cheek ;)
22:22 <knome> hopping over power manager for now since ochosi is away
22:22 <knome> #subtopic Core on tracker? (flocculant)
22:22 <bluesabre> flexiondotorg: looking forward to working with you more :)
22:22 <flocculant> oh sigh
22:22 <knome> flocculant, ta-dah!
22:22 <bluesabre> dahhhhhhhhhh
22:22 <flocculant> so this is one simple question - then a not simple question ...
22:22 <flocculant> first then
22:23 <flexiondotorg> So I was about to work on some Ubuntu MATE, but I take a look at the apps you're interested in instead and provide some initial feedback.
22:23 <flocculant> do we add 'Core' to the tracker for Unit193, slickymaster and me to add a result 2 or 3 times?
22:23 <knome> flexiondotorg, great, can you send it to our mailing list? :)
22:23 <flocculant> flexiondotorg: thanks :)
22:23 <flexiondotorg> Given you guys are fmailiar with GTK, would you be up for offering patches and such upstream to address issue you encounter?
22:24 <bluesabre> flexiondotorg: definitely
22:24 * flocculant hangs on
22:24 <bluesabre> We like it when things work well
22:24 <knome> flexiondotorg, just go on... :)
22:24 <knome> err, flocculant
22:24 <knome> silly fl's
22:24 <flocculant> :D
22:24 * flocculant waits a bit longer
22:24 <bluesabre> flocculant: I think we should hold on including on the tracker until we can get core patches in
22:24 <flocculant> secondly
22:25 <bluesabre> I'm planning on reviewing them next week, and them nudging people a bunch
22:25 <flocculant> what's the score with a real core - that we can get on tracker that builds daily?
22:25 <flocculant> that's the real crux of the matter imo
22:25 <knome> i'm still +1 for the core/base thing, and i want to give all support for it
22:25 <flocculant> iirc
22:25 <slickymaster> same here
22:25 <knome> bluesabre, ^ so please let me know if you need help with it
22:25 <bluesabre> That's definitely related
22:25 <flocculant> this is at least the second LTS we've had this discussion
22:26 <bluesabre> yup
22:26 <bluesabre> Going to make these not TODO this cycle
22:26 <knome> one question is how much Unit193 is still interested in getting this forward?
22:26 <bluesabre> [xubuntu-dev] xubuntu-core: Refresh debian-cd patches: TODO
22:26 <bluesabre> [xubuntu-dev] xubuntu-core: Refresh livecd-rootfs patches: TODO
22:26 <bluesabre> [xubuntu-dev] xubuntu-core: Refresh ubuntu-cdimage patches: TODO
22:26 <bluesabre> [ubuntu-cdimage] xubuntu-core: Review and merge patches: BLOCKED
22:26 <slickymaster> :(
22:26 <knome> i mean, i understand this is frustrating and all and if he's lost the interest
22:26 <bluesabre> knome: I'm going to try to spearhead this a bit, Unit193 is probably (rightfully) burned out on this
22:27 <knome> bluesabre, yes, that's a good idea, though the other issue is that soon it will all be on you
22:27 <flocculant> knome: I think it's entirely possivlt that he's considerably fed up with the whole thing - the doing it 'officially' thing that is
22:27 <ochosi> o/
22:27 <flocculant> s/possible
22:27 <knome> hello ochosi
22:27 <ochosi> sry i'm late
22:27 <flocculant> np
22:27 <ochosi> i'll try to catch up
22:27 <knome> flocculant, yes, indeed, which is why i'm bringing up this question
22:27 <flocculant> ochosi: catch up just before the meeting started ...
22:28 <flocculant> knome:
22:28 <bluesabre> knome: once the patches are in, there should be minimal maintenance required after the fact... hopefully I can return it to krytarik  and Unit193 at that point
22:28 <knome> and in case we do get progressing, is he willing to pick it back up then
22:28 <knome> sure
22:28 <flocculant> last time 'we' spoke he was less politely pissed off
22:28 <flocculant> not wanting to put words in someone else's tongue
22:28 <knome> i'm aware
22:29 <bluesabre> flocculant: yeah, no need :)
22:29 <flocculant> and I completely agree with it tbh
22:29 <flexiondotorg> So mate-calc. From a deps point of view no issues.
22:29 <flocculant> frankly I think we've just been given the runaround by canonical people
22:29 <flexiondotorg> However, the .desktop file Name is "MATE Calculator".
22:29 <flocculant> we're perhaps too damn polite
22:30 <knome> i don't know how CC even works nowadays, but maybe we should just contact them if nothing happens
22:30 * flocculant winds his neck in a bit
22:30 <knome> and get on with it
22:30 <flexiondotorg> I've not discussed this with the MATE team, but I've been wanting to drop the MATE prefixes on some of the app names.
22:30 <flexiondotorg> Perhaps now is the time :-)
22:30 <knome> from what i gathered, one of the issues is "core" vs. "base"
22:30 <knome> though i've told them we'll go with "base" if that's really the only issue...
22:30 <flocculant> flexiondotorg turns out to be really useful tonight :D
22:30 <bluesabre> flexiondotorg: that shouldn't be an issue, but cool if that were to happen
22:31 <knome> flexiondotorg, +1 for dropping MATE prefixes, me like
22:31 <bluesabre> flocculant: we're seeing the other benefit of using MATE bits, we're a lot closer to the MATE folks in general
22:31 <flexiondotorg> knome: I'm on the CC. We're all new this time round. If you have questions feel free to ask.
22:31 <flocculant> can we give flexiondotorg a brief resume of the core thing - as he's got his CC hat on
22:31 <knome> probably better leave that to outside the meeting
22:31 <bluesabre> yeah
22:31 <flocculant> why?
22:31 <flocculant> time?
22:31 <knome> that too
22:32 <flexiondotorg> I remember the "core thing" I prepared patches for Xubuntu and Ubuntu MATE ages ago.
22:32 <flocculant> ok - let's shelve it for a bit, but not a very long bit :D
22:32 <knome> flocculant, indeed not
22:32 <flocculant> the discussion
22:32 <slickymaster> yep
22:32 <knome> anything else on core for the meeting?
22:33 <flocculant> I'll hold fire on tracker for the moment then
22:33 <knome> and oh - yes
22:33 <bluesabre> Just gotta refresh patches and then take another stab at it
22:33 <flexiondotorg> Pluma looks all fine. No issues IMO.
22:33 <knome> i don't mind if core is on tracker nevertheless
22:33 <knome> flexiondotorg, pluma? :P
22:33 <bluesabre> flexiondotorg: yeah, we won't be needing pluma though :)
22:33 <flocculant> knome: I don't want to confuse it
22:33 <flexiondotorg> The text editor from MATE.
22:33 <ochosi> k, if i may add a small comment to the s/gnome/mate/ vote (even though the motion has already passed), i would look at each component separately and check if there are any important features we'd be missing
22:33 <flocculant> last cycle - it ended up being rebuilt somehow
22:34 <ochosi> it's not like the gnome components haven't been developed since gtk3 was started
22:34 <knome> flocculant, i understand
22:34 <flexiondotorg> Oh, Pluma wasn't on the list :-)
22:34 <knome> ochosi, right, but tbh what features would there be for those three apps that we needed really?
22:34 <flocculant> :)
22:34 <bluesabre> ochosi: indeed, but the apps we're interested in aren't super feature full... calc, pdf, and archive
22:35 <bluesabre> but noted :)
22:35 <knome> yes, if their basic functions work, they are perfect
22:35 <knome> maybe do a mail about it when they've landed
22:35 <knome> to run some checking
22:35 <bluesabre> yup
22:35 <knome> or even do it before if people are willing
22:35 <bluesabre> Some config and shortcuts to be updated
22:35 <ochosi> dunno, with evince i'd be taking a closer look (at least to me that's a VIA - very important app)
22:35 <flocculant> we can do a testing call when they land
22:36 <knome> but it... reads pdf? :D
22:36 <bluesabre> ochosi: could I have you test any special features there you depend on?
22:36 <flexiondotorg> So Engrampa (archive manager) should be fine.
22:36 <flexiondotorg> Pulls in extension library for Caja (file manager) but that is only 18Kb.
22:36 <knome> OMZG
22:36 <knome> :P
22:37 <knome> does it *really* need it though?
22:37 <flocculant> bluesabre: could we land them in stages?
22:37 <knome> i think if we want "stages", then just first tell people to install them from the repo
22:37 <knome> and if nothing is wrong for a while, change the seed
22:37 <flocculant> or would you rather just jfdi?
22:38 <flexiondotorg> knome: For Xubuntu no. So we could have an or in the Recommends: to reference an something from XFCE :-)
22:38 <bluesabre> flocculant: we could, what sort of staging schedule would you want?
22:38 <slickymaster> flocculant, akxwi-dave and can each pick one and test them
22:38 <bluesabre> I'm more inclined to just do it all at once so I don't go missing for too long :D
22:38 <flocculant> knome: then we don't know if what people have locally are affecting them?
22:38 <flexiondotorg> Would be a good idea to install these one at a time in a clean Xubuntu VM and see what gets pulled in.
22:38 <knome> meh :)
22:38 <flocculant> bluesabre: jfdi then :)
22:38 <akxwi-dave> lol
22:39 <ochosi> flexiondotorg: i think for xfce you don't need any recommends for engrampa (weird gerontophile name btw ;))
22:39 <flocculant> I can do that in a vm tomorrow
22:39 <knome> the change in seed is a small one, it's fast to revert too
22:39 <bluesabre> flexiondotorg: Yeah, I'll check it out and see if anything surprising comes in
22:39 <bluesabre> or flocculant :)
22:39 <flocculant> :D
22:39 <knome> anything surprising or flocculant?
22:39 <bluesabre> flocculant is surprising
22:39 <knome> i would definitely consider flocculant in my app surprising
22:39 <flocculant> both ...
22:39 <knome> anyway
22:39 <flocculant> ha ha ha
22:39 <ochosi> engrampa also pulls in caja-common
22:40 <knome> can we move on from the core (clearly) discussion?
22:40 <ochosi> not just libcaja-extension1
22:40 <flocculant> yep
22:40 <ochosi> plus mate-icon-theme...
22:40 <bluesabre> knome: go for it
22:40 <knome> #subtopic Xfce Power Manager 1.6.x (bluesabre, ochosi)
22:40 <bluesabre> ochosi: yeah, we'd suggest an alt there
22:40 <bluesabre> xfpm!
22:40 <bluesabre> :D
22:40 <ochosi> mkay
22:40 <ochosi> so i've been cleaning up bugzilla quite a bit for 1.6 lately
22:40 <knome> bluesabre, ochosi: btw, you're both chairs too... just saying
22:40 <ochosi> plus ali has started to help out
22:41 <flexiondotorg> So Atril (doc viewer) and Engrampa (archive manager) both pull in libcaja-extension1
22:41 <ochosi> i've been using 1.6 for a long time already and i don't see any 1.6/gtk3 specific breakage
22:41 <bluesabre> ochosi: yeah, I've been using it forever
22:41 <ochosi> there are no functional differences, apart from a few 1.6 features
22:41 <flexiondotorg> That is the 18Kb library for exposing their plugins to Caja.
22:41 <ochosi> e.g. panel-plugin properties dialog
22:42 <bluesabre> But we've not uploaded it... so I wonder if there is any reason to be wary of 1.6 over 1.4?
22:42 <flexiondotorg> bluesabre: Are you interested in Eye of MATE (image viewer)?
22:42 <knome> flexiondotorg, nope
22:42 <flexiondotorg> Cool.
22:42 <ochosi> the difference was the UPower version initially
22:42 <bluesabre> flexiondotorg: nope, we have a good option there already
22:42 <ochosi> and the symbolic icons, but both is a win imo
22:42 <slickymaster> ristretto
22:42 <bluesabre> ochosi: I agree
22:42 <ochosi> one thing that ppl on desktop systems will notice however is the battery-missing icon that is currently showing
22:42 <knome> bluesabre, ochosi: do you need any feedback from others? :D
22:43 <flocculant> hard for me to test xfpm - desktop(s) > mains works ... tick
22:43 <ochosi> but that is something we can fix during this cycle
22:43 <knome> or could you have discussed this in a non-meeting environment
22:43 <ochosi> i've already looked a little
22:43 <flexiondotorg> Well, other than the name of MATE Calculator I see no reason why mate-calc, engrampa and artil can't be seeded in Xubuntu.
22:43 <ochosi> no, i just wanted to inform everyone of the status quo from my pov
22:43 <flocculant> ochosi: don't see the icon
22:43 <bluesabre> knome: I added it since it was the only thing on our "include maybe" list and I wanted to know if anybody had reasons to avoid it
22:43 <flexiondotorg> Just a bit of history on Atril, forked from Evince.
22:43 <ochosi> flocculant: then you likely use 1.4?
22:44 <flocculant> 1.6.0+git-0~2234~ubu
22:44 <flocculant> says dpkg
22:44 <flexiondotorg> Some years a GSoC student added ePub support to Atril. It was not a good job :-(
22:44 <ochosi> flocculant: ah, ok. so what icon do you see?
22:44 <flexiondotorg> We struggled with it ever since, basically getting it stable and working.
22:44 * ochosi doesn't have a desktop to test this...
22:45 <flexiondotorg> We have debated dropping ePub support.
22:45 <flocculant> ochosi: none - just looking to see if I lost it
22:45 <knome> flexiondotorg, no worries from our side if you drop it, i'd say
22:45 <flexiondotorg> But any help to strighten out the ePub implementation would be welcome.
22:45 <flocculant> ochosi: ok - on desktoo I see battery with an X
22:45 <knome> bluesabre, ochosi: you fancy e-books?
22:45 <flexiondotorg> knome: OK, good to know that is not a deal breaker.
22:45 <ochosi> knome: not really
22:46 <knome> nudge nudge, wink wink
22:46 <flocculant> I do e-books, not on the pc though :D
22:46 <ochosi> flocculant: yeah, that is what i would like to improve and the only "regression"
22:46 <bluesabre> knome: I fancy them, on my nook
22:46 <bluesabre> Could test it though
22:46 <flexiondotorg> I discuss the mate-calc name change with the team in the coming days.
22:46 <knome> well i think they already know it's bad ;)
22:46 <bluesabre> :D
22:46 <bluesabre> I'll avoid it then
22:46 <bluesabre> ;')
22:46 <knome> so i was kind of wondering if you were fancying a repair work
22:47 <knome> ochosi, i agree on the icon issue on desktop; that needs to be sorted out
22:47 <flocculant> ochosi: if nothing an AC instead of a battery would make more sense - though really, an icon showing up if not AC would be btter UI guess
22:47 <bluesabre> knome, flexiondotorg, I might be willing to take a look at some point
22:47 <flexiondotorg> Right, I think that is all can do right now.
22:47 <knome> :)
22:47 <flexiondotorg> Ping me if you need anything :-)
22:47 <bluesabre> flexiondotorg: thanks for being so responsive and helpful :)
22:47 <knome> flexiondotorg, we will, thanks a bunch!
22:47 <flexiondotorg> bluesabre: My pleasure.
22:48 <flocculant> flexiondotorg: thanks for looking at that :)
22:48 <slickymaster> thanks flexiondotorg
22:48 <knome> so... what's the thing with xfpm?
22:48 <knome> do we want a vote on it?
22:48 <knome> or just go forward?
22:48 <ochosi> knome, flocculant: the difference between 1.4 and 1.6 in that respect is that we now rely on upower to supply the icon (which is nice because it means all icon themes work properly with xfpm), and battery-missing is what upower reports. doesn't mean we can't fix that though
22:48 <flocculant> mmm
22:48 <knome> ochosi, i know, i've discussed it with you :)
22:48 <bluesabre> knome, ochosi, I think we should plan to include it... bug reports to 1.6 are probably going to get more attention than 1.4
22:49 <flocculant> I mean logically enough I know the battery is missing - I'd be concerned it it wasn't :D
22:49 <knome> in the worst case we can include a more neutral icon for battery-missing
22:49 <ochosi> yeah
22:49 <knome> for our icon theme... whatever that might be... :P
22:49 <ochosi> i would also say we should include that
22:49 <ochosi> that being 1.6
22:49 <knome> ack it with QA :P
22:49 <ochosi> there are also no 1.6 specific bug reports if i'm honest on bugzilla
22:50 <knome> then i'll give my +1 with my council hat
22:50 <bluesabre> flocculant: say "go for it"
22:50 <ochosi> plus i don't plan on doing 1.4 maintenance
22:50 <flocculant> I can't in all honestly do that bluesabre
22:50 <bluesabre> :D
22:50 <flocculant> today is a jfdi day
22:50 <bluesabre> that's fair
22:50 <bluesabre> I respect that
22:50 <flocculant> :)
22:50 <knome> ok, so
22:50 <akxwi-dave> :-)
22:50 <ochosi> so a vote or do we just move on?
22:51 <flocculant> I do check bugzilla as well as lp
22:51 <knome> #action bluesabre and ochosi to get on with it and include xfpm 1.6
22:51 * meetingology bluesabre and ochosi to get on with it and include xfpm 1.6
22:51 <knome> anything else?
22:51 <flocculant> a point
22:51 <knome> .
22:51 <knome> there
22:51 <ochosi> that's a dot.
22:51 <knome> 1
22:51 <knome> ^ that's a point in the eurovision song contest
22:51 <knome> from australia.
22:51 <slickymaster> buh
22:51 <flocculant> if QA find that we're seeing a whole slew of issues - can we revert
22:51 <bluesabre> flocculant: we can
22:51 <ochosi> yup
22:52 <ochosi> i would say that would be a very logical consequence
22:52 <ochosi> of any of the changes
22:52 <knome> well i think if it fails we should hop to xfpm 1.8...
22:52 <knome> i hope it's at least WIP at that point...
22:52 <knome> ;)=
22:52 <flocculant> I'm just remembering my passowrd issue with non-US and the time it took to be listened to ...
22:52 <knome> so anything else?
22:52 <flocculant> for xfpm?
22:52 <slickymaster> nothing here
22:53 <bluesabre> ochosi: will help with maint there as needed
22:53 <knome> for xfpm
22:53 <flocculant> not from me
22:53 <knome> #subtopic Investigate replacing elementary-xfce with Suru (ochosi)
22:53 <bluesabre> knome: think we're done with the xfpm chat, this conversation is what I hoped for
22:53 <bluesabre> :D
22:53 <flocculant> ochosi bluesabre - if you want me to git stuff to check AC on xfpm - shout
22:53 <knome> from the discussion in here and -offtopic today, i'd say this is not going to happen...
22:53 <ochosi> right, that was just an idea i had when i read that suru was going to be the next ubuntu icon theme
22:53 <ochosi> flocculant: will definitely do! thanks!
22:53 <flocculant> np
22:53 <knome> the basic gist is "it's too android-like"
22:53 <knome> from several people
22:54 <ochosi> yeah, i read that too
22:54 <flocculant> ochosi: seen the 'hub' stuff?
22:54 <ochosi> i really just wanted to discuss it
22:54 <flocculant> https://community.ubuntu.com/t/icon-theme-discussions/1925
22:54 <knome> i appreciate trying to blend in with ubuntu more, but i think that's a bit drastic :)
22:54 <ochosi> the idea was mostly to make us more ubuntu-ish again
22:54 <ochosi> but i don't mind if we stick with the tried and true
22:55 <bluesabre> I think we should consider it (or something else) post-18.04... not enough time in 1 cycle to get the themes (lo included) synced up
22:55 * slickymaster kind of likes the fact that we <ren't ochosi
22:55 <ochosi> knome: it would have been a blue-colored version anyway
22:55 <ochosi> bluesabre: ouch, libreoffice... that would also need some love btw...
22:55 <flocculant> I'm pretty much an ellipsish sqircle sort of guy - dont mind what we do
22:55 <knome> ochosi, that doesn't really help with the android-likeyness :)
22:55 <bluesabre> ochosi: yeah, was planning to send some bug reports your way soon there
22:55 <flocculant> but it might be useful to check out the hub icon chats
22:56 <knome> flocculant, ack
22:56 <bluesabre> yes
22:56 <bluesabre> definitely some important chats happening on the community hub
22:56 <knome> so... anything else from this?
22:56 <knome> on
22:56 <knome> this
22:56 <knome> too
22:56 <flocculant> that snhw peep is there talking
22:56 <flocculant> snwh
22:57 <ochosi> snwh is a good designer, i like his gtk+ themes and also most of his icon themes
22:57 <bluesabre> yeah, cool guy, good stuff
22:57 <ochosi> and he's contributing to elementary also a lot
22:57 <ochosi> so we benefit from his doings either way ;)
22:57 <flocculant> wasn't sure if you'd noticed the hub chat - so thought I'd point you there
22:57 <knome> i don't hate the stuff, it's just fine, but i don't think it's the fit for xubuntu
22:57 <flocculant> shrug
22:57 <flexiondotorg> Just had a thought, will Ubuntu Studio be following your lead with regard to app selection?
22:58 <ochosi> i guess i could use some help with elementary-xfce too, it needs more upstream-pulling sometimes (if anyone here wants to help out)
22:58 <knome> flexiondotorg, that's a good question you need to ask the US devs
22:58 <flocculant> knome: on the other hand - xubuntu 6 years ago looked like old
22:58 <flocculant> so - progress is good sometimes :)
22:58 <bluesabre> flexiondotorg: possibly, they tend to stay pretty well synced to our changes
22:58 <knome> flocculant, sure
22:58 <knome> i'm doing a quick switch...
22:59 <knome> #subtopic Xubuntu desktop for 18.04
22:59 <knome> let's talk this a bit more broadly
22:59 <bluesabre> sure
22:59 <flexiondotorg> knome: OK, will do when you're futher along with this. I wondered if they just based on your platform decisions.
22:59 <knome> flexiondotorg, they often have, but it's not automatic
22:59 <flexiondotorg> OK
22:59 <flocculant> flexiondotorg: up to now - they take xubuntu and add some stuff
22:59 <knome> i guess one of the bigger questions is our panel
23:00 <knome> do we want to keep it where it is?
23:00 <knome> and how it is?
23:00 <ochosi> dunno, i haven't heard that many complaints about it
23:00 <knome> except there was just that thread in the ML
23:00 <knome> not really a complaint as is, but a suggestion to move it to the bottom
23:00 <slickymaster> just the one in the m/l
23:00 <ochosi> every now and then there is such a thread tbh
23:00 <flocculant> oh panel
23:01 <flocculant> well
23:01 <knome> yes, but that kind of suggests something
23:01 <knome> that it comes up
23:01 <ochosi> and it probably would also be there if the panel were at the bottom
23:01 <flocculant> that's where mine is :D
23:01 <knome> how many here have the panel at the top?
23:01 <ochosi> o/
23:01 <bluesabre> o/
23:01 <krytarik> o/
23:01 <slickymaster> o/
23:01 <flocculant> ochosi: indeed - we'd get some move it to the top people
23:01 <knome> haha, ok
23:01 <flocculant> woohoo
23:01 <knome> fair enough then
23:01 <flocculant> - odd one out :p
23:01 <bluesabre> :D
23:01 <slickymaster> :)
23:01 <knome> i have the panel at the bottom too
23:02 <flocculant> you 4 would complain :D
23:02 <knome> the next question is if we want to keep it as is
23:02 <flocculant> nope
23:02 <ochosi> i think we should advertise xfpanel-switch more
23:02 <ochosi> (in any case)
23:02 <slickymaster> agree ochosi
23:02 <ochosi> or improve it
23:02 <knome> one suggestion from me is... make it fully transparent
23:02 <flocculant> one from me is stop expanding the thing
23:02 <ochosi> that'll likely suck for a11y
23:02 <knome> not if the wallpaper is designed for that
23:02 <flocculant> ochosi: ack
23:02 <slickymaster> mine is fully transparent, knome
23:02 <knome> and hey, we can do that
23:03 <ochosi> knome: wallpaper sure, but icons are not under our control
23:03 <flocculant> slickymaster: do you needf a11y?
23:03 <bluesabre> knome: but we won't know if we succeeded until the day before UIF ;)
23:03 <knome> bluesabre, hah!
23:03 <ochosi> LOL
23:03 <knome> spikey
23:03 <ochosi> well played, sean
23:03 <flocculant> I've had a transparent panel - and had 2 or 3 things not be
23:04 <knome> just a thought
23:04 <knome> we could play with the transparency without making it completely transparent too
23:04 <slickymaster> yep
23:04 <knome> another thought is to make it not 100%
23:04 <knome> and center it
23:04 <knome> i use the panel this way, and there's one reason for this
23:05 <knome> when i have maximized windows, i still always have two corners to right-click on the desktop
23:05 <knome> for me that opens the apps menu
23:05 <ochosi> you like that it's width changes all the time..?
23:05 * flocculant says knome's mouse in middle of screen most
23:05 <knome> i know that's not the default setting
23:05 <ochosi> for apps menu i use the kb shortcut
23:05 <knome> ochosi, it doesn't
23:05 <knome> ochosi, only that one pixel, but it does it even if it's 100% wide and that bug was fixed :P
23:06 <knome> i'd also say it looks a bit more modern if the panel isn't 100%
23:06 <knome> again - just a thought for you to think about
23:06 <bluesabre> I'm generally not a fan of a non-100% panel
23:06 <slickymaster> me neither
23:07 <flocculant> this is just a personal preference
23:07 <ochosi> hmm, more modern. in what sense?
23:07 <flocculant> I hate a 100% panle
23:07 <bluesabre> But I don't know if there's really a good way to determine panel location defaults, it's all very personal in nature
23:07 <knome> ochosi, just the looks
23:07 <ochosi> bluesabre: +1
23:07 <knome> sure
23:07 <flocculant> irssi is bottom on half screen at the right - so I can see active channels
23:07 <knome> we just want sane defaults
23:08 <knome> so anybody else wants to provoke any thoughts?
23:08 <knome> or do we just keep everything as is?
23:08 <bluesabre> My personal suggestion would be leave it as is
23:08 <flocculant> make panle a sidebar
23:09 <bluesabre> And improve customization discoverability
23:09 <bluesabre> Somehow
23:09 <flocculant> I'd maybe think about the window list plugin defaults
23:09 <knome> bluesabre, pink flashing lights?
23:10 <bluesabre> flocculant: changes there?
23:10 <ochosi> i'd agree with flocculant in terms of discussing plugin settings, may end up being more productive
23:10 <knome> flocculant, right... what are our defaults there anyway?
23:10 <flocculant> knome: make it enormous - then smaller as apps open
23:10 <knome> ochosi, is this the "tease knome" evening?
23:10 <flocculant> maybe use one of the other task plugins?
23:11 <flocculant> bluesabre: ^^
23:11 <flocculant> https://i.imgur.com/xPqWI4K.png
23:12 <knome> flocculant, would you like to make a more detailed proposal on that for the ML to start the discussion?
23:12 <flocculant> is what I have - no names, and it's not enormous
23:12 <bluesabre> flocculant: not really any better options... other than a dock application that has a few other features
23:13 <ochosi> there's only this unmaintained plugin that tries to be a dock...
23:13 <ochosi> taskbar-plugin iirc
23:13 <ochosi> which would be nice, if it worked properly
23:13 <flocculant> bluesabre: not wanting to go there - what we have is better (imo) than the bigh top panel and ' dock panel' we had ~12.04 ish
23:13 <bluesabre> flocculant: yeah
23:13 <flocculant> knome: I can yes
23:14 <bluesabre> I think what we have is pretty good, and definitely an acceptable default
23:14 <flocculant> yea - I'm not complaining as such
23:14 <bluesabre> Folks are always going to prefer top/bottom... usually no other reason than what they've gotten used to
23:14 <flocculant> :)
23:15 <bluesabre> Side panel people are different, but we're not going to be judgemental ;)
23:15 <ochosi> i thought you wanted to replace window-buttons plugin with something else, like something that allows for app pinning
23:15 <flexiondotorg> Umm, just seen this ;-)
23:15 <flexiondotorg> https://community.ubuntu.com/t/suggestion-use-mate-applications-in-the-eventual-unity-7-flavor-of-ubuntu-18-04/1949
23:15 <flocculant> I've had panel on 3 sides at different times - then did some software thing which monitored where mouse pointer spent time
23:15 <flocculant> then moved panel and it worked
23:16 <flocculant> flexiondotorg: yea - saw that too ;)
23:16 <bluesabre> flexiondotorg: seems like you're going to have a lot more friends soon
23:16 <slickymaster> well guys, I have to go now
23:16 <flexiondotorg> Welcome one and welcome all!
23:16 <slickymaster> tty tomorrow
23:16 <flexiondotorg> gn slickymaster
23:16 <bluesabre> seeya sl
23:16 <bluesabre> slickymaster
23:16 <knome> ok, so
23:17 <flocculant> night slickymaster
23:17 <knome> #action flocculant to send a proposal on improving panel configuration
23:17 * meetingology flocculant to send a proposal on improving panel configuration
23:17 <ochosi> night slickymaster
23:17 <knome> anything else?
23:17 <knome> nighty slickymaster
23:17 <flexiondotorg> bluesabre: Do you mind if I reference Xubuntu in that post on the Community Hub?
23:17 <flocculant> flexiondotorg: doubt it :p
23:17 <flocculant> and I'll watch it :p
23:17 <bluesabre> flexiondotorg: don't mind at all
23:18 <flexiondotorg> I don't want to steal anyones thunder.
23:18 <flexiondotorg> bluesabre flocculant Thanks.
23:18 <flocculant> np
23:18 <bluesabre> knome: think we're good for the panel discussion
23:18 <ochosi> +1
23:18 <knome> and other desktop-related ones too?
23:18 <flocculant> quick one
23:18 <knome> sure
23:18 <bluesabre> or not :)
23:18 <ochosi> although it's good to have that panel discussion every once in a while
23:18 <flocculant> do we want to keep this to ml?
23:19 <knome> compared to...?
23:19 <flocculant> I understand the cons of going to talk to people out there ...
23:19 <flocculant> but is it worth the effort?
23:20 <bluesabre> Seems like it could be a can of worms
23:20 <flocculant> I can at least do one of the social things
23:20 <flocculant> yea - but it IS our can of worms ;)
23:20 <flocculant> is this something we can land late?
23:20 <knome> if we want to reach out, then i think it would better be a poll of some sort with some thoughts done beforehand
23:21 <flocculant> maybe do a ml - then reach out - then change?
23:21 <flocculant> mmm
23:21 <knome> rather than "tell us what you use"
23:21 <bluesabre> flocculant: no later than UI Freeze, so docs and screenshots could be updated in time for release
23:21 <knome> because as we just proved here, people really like different things
23:21 <flocculant> knome: how about you and I do a brainstorm and poll choice once we've got some 'data' ?
23:22 <flocculant> bluesabre: ack
23:22 <knome> bluesabre, except that we do not have any screenshots or big mentions in docs about these kind of things - for this reason ;)
23:22 <knome> but yes, this should land for UIF
23:22 <knome> in any case...
23:22 <flocculant> that's March :p
23:22 <knome> flocculant, related: there was a poll on the xfce twitter about vertical panels specifically
23:23 <flocculant> don't twitter so didn't see it
23:23 <knome> that's not really usable here, but looking at that i have an idea what kind of replies we might get
23:23 <flocculant> lets ml - then regroup
23:23 <knome> yup
23:23 <knome> i can help with the drafting if we decide to do that
23:23 <knome> and the social media of course
23:23 <flocculant> give it an arbitrary time scale
23:23 <knome> 2 weeks
23:23 <knome> :P
23:24 <flocculant> decmeber 31st sounds good to me :D
23:24 <knome> that's fine as well
23:24 <bluesabre> Sounds like a good target
23:24 <knome> #topic Schedule next meeting
23:24 <flocculant> okey doke
23:24 <flocculant> hjang on buddy
23:24 <knome> yeeees?
23:24 <knome> :)
23:24 <flocculant> AOB first ...
23:24 <knome> wasn't on the agenda
23:25 <flocculant> AOB should always be on an agenda ...
23:25 <knome> ;)
23:25 <flocculant> :p
23:25 <flocculant> what's going on with the community arty stuff?
23:25 <knome> #topic Other discussions
23:25 * flocculant opens the other can of worms
23:26 <knome> we haven't agreed on the terms on the ML thread
23:26 <knome> i think i'll repoke that thread soonish
23:26 <bluesabre> Good idea
23:26 <knome> #action knome to wake up the discussion about the community wallpaper contest
23:26 * meetingology knome to wake up the discussion about the community wallpaper contest
23:26 <knome> starting the actual contest takes like 5 minutes
23:26 <flocculant> yup
23:26 <knome> so once we are in agreement...
23:26 <knome> anything else?
23:26 <bluesabre> Nothing from me
23:27 <flocculant> nope - just going to go and get all despondent about that now :p
23:27 <knome> :P
23:27 <knome> #topic Schedule next meeting
23:27 <knome> we'll pretend i was pleia2
23:27 <knome> next up is akxwi-dave and flocculant
23:27 <knome> and their clown show
23:27 <flocculant> sigh
23:27 <knome> i mean
23:27 <knome> the QA show
23:27 <knome> ;)
23:28 <knome> thanks everybody
23:28 <ochosi> thanks!
23:28 <bluesabre> and all the BAM and POW sound effects
23:28 <knome> one of those longer meetings today then
23:28 <knome> bluesabre, don't forget the farty effects!
23:28 <knome> #endmeeting