22:00 <bluesabre> #startmeeting Xubuntu community meeting
22:00 <meetingology> Meeting started Fri Sep  9 22:00:26 2016 UTC.  The chair is bluesabre. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
22:00 <meetingology> 
22:00 <meetingology> Available commands: action commands idea info link nick
22:00 <bluesabre> Who's around?
22:00 <flocculant> fairly round
22:01 <bluesabre> #chair flocculant
22:01 <meetingology> Current chairs: bluesabre flocculant
22:01 * flocculant always forgets that
22:01 <bluesabre> !team | meeting time
22:01 <ubottu> meeting time: akxwi-dave, bluesabre, dkessel, flocculant, jjfrv8, knome, krytarik, micahg, Noskcaj, ochosi, pleia2, slickymaster and Unit193
22:02 <knome> o/
22:02 <pleia2> o/
22:02 <flocculant> hi pleia2 :)
22:02 <bluesabre> #chair knome
22:02 <meetingology> Current chairs: bluesabre flocculant knome
22:02 <bluesabre> #chair pleia2
22:02 <meetingology> Current chairs: bluesabre flocculant knome pleia2
22:02 <knome> loads of chairs
22:02 <bluesabre> plenty!
22:02 <bluesabre> :D
22:03 <ochosi> o/
22:03 <bluesabre> surprised so many are here
22:03 <bluesabre> #chair ochosi
22:03 <meetingology> Current chairs: bluesabre flocculant knome ochosi pleia2
22:03 <ochosi> +1
22:03 <knome> where are all the sofas?
22:03 <flocculant> just join the chairs
22:03 <bluesabre> I'm too cheap for that
22:03 <bluesabre> ;)
22:03 <bluesabre> lets get started then
22:03 <flocculant> Unit193 was here - suddenly disappeared :p
22:03 <bluesabre> #topic Open Action Items
22:04 <bluesabre> ochosi to announc opening nominations for Xubuntu Council with timeline
22:04 <bluesabre> well, that's gone and passed :D
22:04 <ochosi> oh, i guess that is done :)
22:04 <flocculant> \o/
22:04 <bluesabre> last meeting was a while back :D
22:05 <bluesabre> #topic Updates and Announcements
22:05 <knome> #info The Xubuntu council is Sean Davis (bluesabre) - chair, Pasi Lallinaho (knome) and Simon Steinbeiß (ochosi)
22:06 <ochosi> thanks flocculant for running the whole election thingy!
22:06 <knome> yes, thank you
22:06 <knome> and for the XSD part too
22:06 <flocculant> welcome ofc
22:06 <flocculant> The Xubuntu Council are
22:06 <flocculant> ...
22:06 <knome> (reminds me nobody whined about the latest changes, should push them live)
22:06 <flocculant> :p
22:06 <bluesabre> thanks flocculant !
22:06 <flocculant> knome: yea - works for me
22:07 <knome> nobody not referring to flocculant only :P
22:07 <flocculant> #info UIFE this week
22:07 <knome> was
22:07 <flocculant> #info Doc String Freeze next week
22:07 <ochosi> yeah, that ^ blows a little
22:07 <ochosi> we still have some UI changes ahead
22:07 <knome> that's fine
22:07 <knome> i can take the paperwork
22:07 <ochosi> i guess i'll do some minor Greybird tweaks if i get to it (mostly removing padding and fixing small things)
22:08 <ochosi> and the wallpaper still needs to go live
22:08 <knome> yeah, it needs to be finished and polished
22:08 <flocculant> ochosi: like the minor issue with the installer?
22:08 <flocculant> cos that looks horrid :(
22:08 <knome> on the subject of doc string freeze
22:09 <bluesabre> #info Final Beta (which Xubuntu is participating in) on September 22nd, freeze on September 19
22:09 <knome> we should make sure we don't have anything out-of-date on the docs
22:09 <knome> and update the installer slideshow as well
22:09 <flocculant> knome: I can do a run through on at least docs this weekend
22:09 <knome> i collected from david's mail he's not going to be around until october
22:09 <flocculant> yea
22:10 <knome> flocculant, great, if you find anything that needs updating, just send a mail to the devel list directly
22:10 <ochosi> flocculant: yeah, also like that one
22:10 <knome> i'll look at the installer slideshow and do the same
22:10 <flocculant> knome: rather than do an mp?
22:10 <ochosi> flocculant: although that's not really UIFe material, more a bugfix
22:10 <knome> flocculant, well if you are up to doing the changes, then obviously MP is better :)
22:10 <flocculant> ochosi: yea - just wanted to make sure it's in the pipeline is all :)
22:11 <ochosi> flocculant: well pipeline is maybe a bit too strong, let's put it this way: i have it on the radar ;)
22:11 * flocculant hates his Physical Graffiti cover being just slightly out of whack too :p
22:11 <knome> yakkety has the same version of slideshow as xenial, so no upload is done there yet
22:11 <knome> #action flocculant to look at docs and make sure everything is up-to-date
22:11 * meetingology flocculant to look at docs and make sure everything is up-to-date
22:11 <flocculant> knome: ack mp - just wondered is why m/l :)
22:11 <knome> #action knome to look at installer slideshow and make sure everyting is up-to-date
22:11 * meetingology knome to look at installer slideshow and make sure everyting is up-to-date
22:12 <knome> thing too, but who cares
22:12 <flocculant> and yea ochosi I get that :)
22:12 <knome> any other action items?
22:12 <knome> oh, well
22:12 <bluesabre> any other updates or announcements?
22:12 <knome> #action knome updates the contributor docs and pushes changes lice
22:12 * meetingology knome updates the contributor docs and pushes changes lice
22:12 <knome> #undo
22:12 <meetingology> Removing item from minutes: ACTION
22:12 <knome> #action knome updates the contributor docs and pushes changes live
22:12 * meetingology knome updates the contributor docs and pushes changes live
22:12 <knome> sigh
22:12 <flocculant> lice \o/
22:13 <flocculant> awesome :p
22:13 <bluesabre> lice /o\
22:13 <flocculant> <- no kids at school finally
22:13 <bluesabre> :D
22:13 <bluesabre> <- no kids yet
22:13 <knome> i think the ups and anns are there
22:13 <flocculant> yep
22:13 <bluesabre> moving on
22:13 <bluesabre> #topic Discussion
22:14 <bluesabre> #subtopic Thunar
22:14 <bluesabre> flocculant added this item... :)
22:14 <flocculant> imagine that ...
22:14 <flocculant> so then - during xenial the sentiment was basically this
22:15 <flocculant> "xfce don't have anyone to test it - we should - and hope things get fixed"
22:15 <flocculant> doesn't appear to be happening
22:15 <bluesabre> indeed
22:15 <knome> xfce has picked up new contributors lately though
22:15 <flocculant> bluesabre: do you still feel "flocculant, yeah... thunar isn't getting better (even in y), and I'm not opposed to moving to a different file manager, but that suggestion tends to rock the boat a bit"
22:15 <bluesabre> there are some new patches around, but we've had some negative tests within our team
22:16 <knome> bluesabre, do you know if those patches have worked for anybody?
22:16 <flocculant> because frankly while it might be ok to test things between LTS - we've landed that on LTS
22:16 <bluesabre> knome, those patches have worked for the folks commenting on the bug report at least
22:16 <flocculant> and now is when we should start thinking about tomorrow
22:16 <flocculant> bluesabre: well I can easily enough comment there that it doesn't work for me on either 16.04 or 16.10
22:17 <bluesabre> flocculant, I still feel that, and now might be the best time to start the discussion into the next cycle
22:17 <flocculant> which makes the core 0
22:17 <knome> that gives me hope... there is somebody working on patches and they are fixing some issues for some people
22:17 <flocculant> knome: for how long do we wait doing nothing and just hoping?
22:17 <flocculant> 6 months? 12? the next LTS for 3 years?
22:18 <knome> i don't know, but the fact is that the bugs are present in 16.04
22:18 <flocculant> perhaps us moving would make people take notice of the fact that thunar isn't very well and ignored
22:18 <bluesabre> the problem seems to stem from the fact that Thunar does not have a single active maintainer... we get patches that fix a few things, but the overall issue seems unresolved
22:18 <flocculant> easy enough to move around now (I assume) than in the last 6 months of the LTS to LTS cycle
22:18 <knome> i'm not sure if that would add to the motivation to fix thunar though
22:18 <bluesabre> it probably requires a much larger effort
22:19 <knome> team members, opinions please?
22:19 <ochosi> interestingly i came across a gtk3 port of thunar on github
22:19 <ochosi> so there seems to be some activity even outside of the xfce team
22:19 <knome> does it fix the issues we are experiencing?
22:19 <ochosi> the same thing happened with the terminal btw, i also managed to reel in a new contributor through contacting him about his port on github
22:20 <ochosi> i'll try to do the same thing again here, but obviously no promises
22:20 <ochosi> i haven't tested the port, so i can't say if it fixes the bug
22:20 <ochosi> i'm pretty sure it's not final so it probably has other issues that we would rather avoid
22:20 <flocculant> please don't anyone get me wrong here - I'd rather we used thunar - but we shouldn't be handing out half-fixed software if we can help it
22:20 <knome> of course
22:20 <ochosi> flocculant: yeah, i get that
22:20 <knome> yep
22:20 <ochosi> and you're right, now is the best time to discuss
22:21 <bluesabre> My opinion is, we should start weighting other options, and if we're still having these same issues into Z, we employ those options early in the cycle and get some feedback
22:21 <flocculant> bluesabre: sounds fair
22:21 <ochosi> yeah, sounds reasonable
22:21 <flocculant> and I'll have some time for a cycle so I could come up with some roadmap type thing for options on that
22:22 <bluesabre> okay, that sounds good to me
22:22 <flocculant> so if someone wants to word that we can action me for it
22:22 <knome> #action bluesabre to prepare testing of other file manager options
22:22 * meetingology bluesabre to prepare testing of other file manager options
22:23 <flocculant> I assume we could change throughout the Z cycle here?
22:23 <knome> #undo
22:23 <meetingology> Removing item from minutes: ACTION
22:23 <knome> #action bluesabre to prepare testing of other file manager options throughout the Z cycle
22:23 * meetingology bluesabre to prepare testing of other file manager options throughout the Z cycle
22:23 <flocculant> eg if foo was really pants we could change to bar?
22:23 <flocculant> bluesabre: I offered :p
22:23 <bluesabre> We can (and should) move around to different options if the ones we try are a no-go
22:24 <flocculant> k
22:24 <bluesabre> "Hey I like this", "Hey its eats my desktop", "Hey, lets try that instead"
22:24 <bluesabre> :D
22:24 <flocculant> okey doke
22:25 <bluesabre> Anything else we want to discuss about thunar?
22:25 <flocculant> one thing
22:25 <flocculant> I'm not at all sure what patches we actually have in thunar
22:26 <flocculant> are there some that 'could' help we don't have - if so - could we have a completely plastered up one in a ppa somewhere?
22:26 <knome> so we make Unit193 write a report on where we stand with it?
22:26 <ochosi> flocculant: yeah, an overview of that would be useful
22:26 <ochosi> also with which patch is supposed to do what
22:26 <bluesabre> current patch filenames
22:26 <flocculant> knome: that's the price of being in -ooftopic I guess :p
22:26 <bluesabre> 0001-Don-t-copy-templates-but-create-them-bug-8312.patch
22:26 <bluesabre> 01_support-non-multiarch-modules.patch
22:26 <bluesabre> 02_Fix-crashes-when-reloading-target-file-after-move.patch
22:26 <bluesabre> 03_Fixing-missing-return-value-in-standard-view.patch
22:26 <bluesabre> Check-if-a-thunar-file-is-still-valid-before-reloading.patch
22:26 <ochosi> (if we don't have that in the names of the patches)
22:26 <flocculant> which apparently we do :D
22:27 <Unit193> There is one we don't have.
22:27 <knome> so as Unit193 is not opposing, i take it as approving..
22:27 <flocculant> bluesabre: quick - chair Unit193 :p
22:27 <bluesabre> #chair Unit193
22:27 <meetingology> Current chairs: Unit193 bluesabre flocculant knome ochosi pleia2
22:27 <flocculant> lol
22:27 <pleia2> heh
22:27 <knome> #action bluesabre and Unit193 to write a report of the state of Thunar (eg. which patches we carry and what they should do) and make sure all of them are in a PPA
22:27 * meetingology bluesabre and Unit193 to write a report of the state of Thunar (eg. which patches we carry and what they should do) and make sure all of them are in a PPA
22:28 <bluesabre> works for me
22:28 <Unit193> knome: I dunno, I see patch, I try it, it seems to help, I accidentally push it to the repo and thus we get stuck with a wrong filename.
22:28 <knome> Unit193, and next you paste a link to an image where a dog flies a helicopter?
22:28 <Unit193> Yes!
22:29 <bluesabre> :D
22:29 <bluesabre> we're probably thunar'd away now
22:29 <flocculant> bluesabre: so would you like some sort of 'this file-manager' adds this much bytes to image - or are we not to concerned about that at the moment?
22:30 <flocculant> I'd guess not currently
22:30 <knome> i don't think the size is very much the problem
22:30 <bluesabre> flocculant, not particularly worried about that
22:30 <knome> if the file manager works and is generally lightweight, then who cares what the size is?
22:30 <bluesabre> obviously dolphin is out ;)
22:30 <flocculant> ha ha ha
22:30 <knome> unless the council approves it
22:30 <bluesabre> the SD says something about qt
22:31 <knome> yes
22:31 <flocculant> and k - was just back in we need to save x KBs for a bit there
22:31 <bluesabre> but that can be council'd away too
22:31 <knome> the new version also says the council can overrule if it's sensible
22:31 <ochosi> the new catch-phrase: "to council away"
22:31 <flocculant> \o/
22:32 <bluesabre> too many new phrases... I have to change "to flocculant" to "to akxwi-dave" soon
22:32 <flocculant> hah
22:33 <knome> bluesabre, you mean to a-nxvpwmlkdgnkd-dave
22:33 <bluesabre> :)
22:33 <flocculant> I'll change nicks - then akxwi-dave can alias flocculant to akxwi-dave :p
22:33 <bluesabre> #subtopic Other Topics
22:33 <flocculant> quick one here
22:33 <bluesabre> Anything else that needs discussed (thats not in the Agenda)?
22:34 <flocculant> depends on if knome does a meeting next week or not?
22:34 * flocculant waits
22:34 <knome> i can do if people need/want
22:34 <flocculant> well I just want to quickly run through beta
22:34 <knome> otoh, there's many of us here today...
22:34 <flocculant> so nothing to stop us doing that now
22:34 <knome> let's do it now
22:35 <bluesabre> We'll definitely want a meeting prior to the beta (Sep 22)
22:35 <knome> bluesabre, mon 19 maybe?
22:35 <flocculant> bluesabre: well we need the meeting prior to freeze which is Monday/Tuesday
22:35 <knome> ok
22:35 <knome> so let's schedule one for later next week
22:35 <bluesabre> s/22/19/
22:35 <bluesabre> alrighty
22:36 <bluesabre> #topic Schedule Next Meeting
22:36 <flocculant> could we perhaps weekend it?
22:36 <knome> hmmh.
22:36 <knome> maybe, i can't promise yet
22:36 <flocculant> mmk
22:36 <ochosi> oh, just a small announcement from my side: i'm completely afk from sept 19 to sept 29
22:36 <knome> nice...
22:36 <ochosi> not that you really need me now that you can council away things
22:36 <knome> or was it italy?
22:36 <knome> :P
22:37 <flocculant> well I'll be sending stuff out to testers 'soon' re beta to wake them up
22:37 <bluesabre> 10 days to spam ochosi with greybird/elementary-xfce bugs
22:37 <knome> #undo
22:37 <meetingology> Removing item from minutes: TOPIC
22:37 <knome> let's just go through the beta now, right?
22:37 <flocculant> akxwi-dave and I will be checking release note
22:37 <ochosi> bluesabre: yeah, time to spam me and get *nothing* fixed ;)
22:37 <knome> we can still have the meeting next week
22:37 <knome> but just in case
22:37 <bluesabre> alrighty
22:37 <bluesabre> good idea :)
22:38 <flocculant> and I'll be doing the obligatory 'I hope people from 'team' will be testing for us ;)
22:38 <flocculant> hopefully we'll get more people - they've had most of the cycle off
22:38 <flocculant> and hopefully they'll not find bugs
22:39 <flocculant> not sure I need to say much more than that :)
22:39 <knome> oki
22:39 <bluesabre> :D
22:39 <knome> poke me/pleia2 about social mediaing
22:39 * pleia2 nods
22:40 <flocculant> knome: yep
22:40 <bluesabre> I'll go through and cleanup dev blueprints this weekend, give us a more realistic idea of where dev is in the cycle
22:40 * flocculant notes the pleia2 nod :)
22:40 <knome> bluesabre, fantastic
22:41 <bluesabre> flocculant, feel free to ping me with priority bugs
22:41 <flocculant> from memory - testing has been me/Dave and nairwolf this cycle
22:41 <flocculant> bluesabre: yup
22:41 <flocculant> I will ;)
22:41 <knome> bluesabre, you mean the grasshoppers that are taking the first class flight?
22:42 <flocculant> bluesabre: I need to dig webcam out - and see how that's fairing given that parole is working with clutter now, unless someone with a laptop can ...
22:42 <bluesabre> knome, or the grasshoppers that are bird food
22:42 <knome> bluesabre, how's that "priority" though? :P
22:42 <bluesabre> flocculant, I should be able to test it
22:42 <bluesabre> running yak and cheese at least works
22:42 <ochosi> flocculant: oh it is? that's quite awesome news then
22:42 <flocculant> bluesabre: obviously I missed mugshot from that sentence ...
22:42 <ochosi> i was afraid clutter was deemed
22:43 <ochosi> doomed i mean
22:43 <ochosi> weird typo
22:43 <flocculant> ochosi: seems to be - works ok here
22:43 <knome> deemed doomed
22:43 * ochosi should go to bed
22:43 <bluesabre> flocculant, (mugshot is built on libcheese)
22:43 <flocculant> bluesabre: mmm - ok so not clutter - not sure why I was getting that confused then
22:43 <bluesabre> flocculant, and cheese is built on clutter
22:43 <bluesabre> sorry for all that :D
22:44 <flocculant> anyway - still needs to be checked
22:44 <knome> troll
22:44 <flocculant> bluesabre: so what you mean is 'it could possibly work now parole does' :p
22:44 <bluesabre> ochosi, pretty sure its still going to get shuttered
22:44 <bluesabre> flocculant, yes, those are the words that were supposed to fldfksfjdfls
22:44 <flocculant> :)
22:45 <bluesabre> ochosi, what greybird updates might we expect in time for the beta (so we know what to watch for)?
22:46 <ochosi> bluesabre: hard to say, depends on how much sleep i need in the next few days
22:46 <flocculant> oh - quick note re release notes - gonna not report any vbox/vm issues - just some 1 liner to cover the possibility
22:46 <ochosi> guess i have to make a list and prioritise
22:47 <knome> flocculant, sounds fair
22:47 <bluesabre> flocculant, yeah, I wonder if we can get vbox-related things in the ubuntu release notes and just link directly to them
22:47 <flocculant> bluesabre: they don't really care if it's not qemu/kvm
22:47 <bluesabre> since the desktop team agrees that they expect it to not be a good situation :)
22:47 <ochosi> bluesabre: i would say: don't expect much, porting greybird to 3.20 sucked out quite a bit of energy and will to live from me, so i might need more breathing space before i tackle your issues
22:48 <bluesabre> ochosi, no problemo, I might even feel inspired to investigate it myself and send you some PRs
22:48 <ochosi> bluesabre: that'd be nice
22:48 <flocculant> bluesabre: and I'd also like to lose <includes> because if I end up having wiki issues - the release note will be on x.wiki :|
22:48 <bluesabre> (but expect nothing)
22:49 <bluesabre> flocculant, sure
22:49 <bluesabre> anything else beta-wise?
22:50 <flocculant> I'm all done :)
22:50 <flocculant> currewntly
22:50 <bluesabre> (for 2 minutes)
22:50 <bluesabre> knome, anything?
22:50 <bluesabre> pleia2, (you're so quiet!) anything?
22:50 <flocculant> bluesabre: bit longer - we've not built tomorrow's image yet:p
22:51 <bluesabre> :)
22:51 <pleia2> nope
22:51 <bluesabre> Unit193, ochosi ?
22:52 <ochosi> nothing from my side
22:52 <bluesabre> Looks like we're done then.  :)
22:53 <bluesabre> #topic Schedule Next Meeting
22:53 <bluesabre> #info knome to schedule next meeting
22:53 <bluesabre> actually
22:53 <bluesabre> #action knome to schedule next meeting
22:53 * meetingology knome to schedule next meeting
22:53 <knome> nope
22:53 <knome> i will
22:53 <bluesabre> #endmeeting