20:00 <flocculant> #startmeeting
20:00 <meetingology> Meeting started Fri Aug 12 20:00:11 2016 UTC.  The chair is flocculant. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
20:00 <meetingology> 
20:00 <meetingology> Available commands: action commands idea info link nick
20:00 <flocculant> that's going to be fun then ...
20:00 <flocculant> who's where
20:01 <flocculant> or even here
20:01 <krytarik> o/
20:01 <flocculant> evening krytarik
20:01 <krytarik> \o/
20:02 <knome> /o\
20:02 <flocculant> #topic Open action items
20:02 <flocculant> we can deal with that waiting to see
20:03 <flocculant> bluesabre and flocculant dealt with their action item
20:03 <flocculant> #done bluesabre and flocculant to reword the SD to formalize the council.
20:03 <flocculant> *shrug*
20:03 <flocculant> #topic Announcements and Updates
20:04 <flocculant> FeatureFreeze DebianImportFreeze next week, 18th August
20:04 <flocculant> #info QA is quiet - pretty normal for post LTS cycle
20:04 <flocculant> now I'll just wait around for a bit
20:04 <knome> #info Feature Freeze and Debian Import Freeze next week (18th August)
20:05 <ochosi> o/
20:06 <ochosi> (sorry iÄm late)
20:06 <knome> yes you Äre
20:06 <dkessel> Hey
20:06 <ochosi> yes i am
20:06 <flocculant> wb ochosi - fashionably late this time, instead of really late :p
20:07 <flocculant> ochosi: any updates?
20:07 <flocculant> hi dkessel
20:08 <flocculant> #info SRU for Intel lock/cursor bug is progressing afaict
20:08 <ochosi> yeah, i saw the SRU progress too
20:08 <ochosi> sounded promising
20:08 <ochosi> other than that i'm still fighting with getting the greybird release out
20:08 <flocculant> :)
20:08 <knome> ochosi, i have a question
20:08 <ochosi> had some showstoppers, but this time it'll *really* be a matter of days :)
20:08 <knome> ochosi, how do you hear with your eyes?
20:09 * flocculant starts counting
20:09 <ochosi> knome: awesome question, thanks :)
20:09 <knome> you're welcome
20:09 <flocculant> any other updates - if not we can move along
20:09 <ochosi> other than that i'll soon set up a physical yakkety machine so i can get some real-world testing done
20:09 <knome> move along from me
20:10 <ochosi> i think i have no real updates at this moment, other than what i mentioned
20:10 <flocculant> k
20:10 <ochosi> i'm working a lot on xfce upstream stuff
20:10 <flocculant> yup
20:10 <flocculant> I see that :)
20:10 <ochosi> but that'll only be relevant if we decide to ship it all in 16.0
20:10 <ochosi> 16.10
20:10 <ochosi> probably worth starting a list of gtk3 components or releases we want to ship
20:10 <knome> ochosi, i have a question
20:11 <knome> ochosi, where would we ship it all?
20:11 <flocculant> to an iso I would hope
20:11 <knome> or maybe to a distant island...
20:11 <flocculant> #topic Discussion items
20:11 <flocculant> #subtopic Xubuntu Council
20:11 <ochosi> knome: in "16.10" (which is a boat of the length of 16m and width of 10m)
20:11 <flocculant> Now that doc change is done we need to open up for nominations, suggest mail out today/tomorrow with nominations ending 26th August, which should be more than enough time. Send vote mail out on 29th August with vote ending on 4th September, meaning council will be in place good 2 weeks prior to the only milestone we're doing this cycle.
20:11 <flocculant> ochosi: that's a plank :D
20:12 <knome> flocculant, sounds like a good plan to me
20:12 <ochosi> flocculant: sure it is :)
20:12 <ochosi> and yeah, +1 on the timeline
20:12 <ochosi> so the council would be in place before the 16.10 release
20:12 <flocculant> ochosi: yea
20:12 <ochosi> had almost given up hope we would make that :)
20:12 <flocculant> well before
20:13 <flocculant> there's this club - you could have joined it ;)
20:13 <flocculant> krytarik dkessel ^^
20:13 <ochosi> yeah, wasn't around enough to give valuable input so i thought i'd stay out of it not to stall things
20:14 <flocculant> ochosi: wrong club - I meant the given up hope one ...
20:14 <knome> yeah, flocculant is the chair for life of that club... :P
20:14 <ochosi> haha
20:15 <ochosi> yeah, i'd also hate to disrupt that club then
20:15 <flocculant> knome: nope - about another 10 weeks ;)
20:15 <knome> (not the benevolent, and not necessarily self-appointed either, but definitely the dictator)
20:15 <knome> O:)
20:15 <flocculant> akxwi can chair it after that
20:15 <dkessel> Oh, should I point out that I agree? I agree with the plan.
20:15 <knome> benches! please give some attention and love to benches too!!
20:16 <flocculant> dkessel: well - you're here and in team so yes why not :)
20:16 <knome> dkessel, not mandatory, but nice to hear you do :)
20:16 <flocculant> anything else on that timeline?
20:16 <knome> flocculant, so shall you take the #action item and get on with it?
20:16 <knome> ^ that :P
20:16 <knome> or does ochosi want to announce
20:16 <knome> since sitting XPL
20:17 <ochosi> yeah, i can, but flocculant did all the work..
20:17 <knome> isn't that how it's used to go
20:17 <flocculant> depends if ochosi can do it today/tomorrow :p
20:17 <knome> ochosi, yeah, welcome to the club (the "let others do the work and take the credit")
20:17 <flocculant> #action ochosi to announc opening nominations for Xubuntu Council with timeline
20:17 * meetingology ochosi to announc opening nominations for Xubuntu Council with timeline
20:17 <knome> announc?
20:18 <knome> [:
20:18 <knome> (just let it be and end the meeting already...)
20:18 <flocculant> yea - I had an e kicking around but lost it
20:18 <knome> /kick e
20:18 <flocculant> anyone got any other pressing issues to add to the meeting?
20:18 <ochosi> i'll just mail out that sentence from flocculant from the scrollback
20:18 <knome> well,
20:19 <ochosi> i have probably a little thing
20:19 <ochosi> since Unit193 brought it up on -ot
20:19 <knome> there's a new finnish youtube channel, where people break stuff with hydraulic *presses*
20:19 <knome> that's a very pressing issue
20:19 <knome> ochosi, go ahead.
20:19 <flocculant> ochosi: subtopic it then :)
20:19 <ochosi> knome obviously had sex with a clown today
20:19 <knome> well i met a client
20:19 <knome> isn't that comparable?
20:19 <flocculant> ochosi: not a very funny one ...
20:20 <ochosi> #subtopic Development releases of Xfce in 16.10?
20:20 <ochosi> flocculant: indeed :)
20:20 <ochosi> so basically what i'd like us to discuss briefly is whether anyone considers it a risk shipping 4.13 releases in 16.10
20:21 <knome> the risk Unit193 saw was that we wouldn't be able to get into xfce 4.14 before 18.04 fwiw
20:21 <ochosi> what i mentioned earlier (putting together a list of components we want in 16.10) was mostly targetted at applications and *maybe* panel plugins
20:21 <flocculant> ochosi: given we shipped broken intel and that file manager in an LTS then I don't ;)
20:21 <ochosi> but it's true that it would help xfce if we shipped 4.13 early in our "regular" releases
20:21 <knome> i don't see a big risk here, but i have a question
20:21 <knome> (not a trolly one)
20:21 <knome> what else do we want to achieve before the next LTS?
20:22 <ochosi> good question...
20:22 <knome> or are we simply going to maintaining mode for the next 3 releases?
20:22 <knome> and if not, how do the other plans work with the xfce development packages being there?
20:22 <ochosi> personally my goal is maintaining the artwork (which seems to be continuous work anyway with the gtk devs breaking stuff) and porting xfce as good as i can
20:22 <knome> do we have the manpower to realistically even plan more stuff if we land the new xfce stuff?
20:23 <knome> let's forget about the rest of the maintaining stuff we need to do anyway
20:23 <ochosi> for xubuntu as a whole i would say try to get rid of as much old technologies as we can
20:23 <knome> i'm talking about new features or something else that needs extra work and planning
20:23 <flocculant> ochosi: the only risk that I see is whether there are enough people checking the 4.13 stuff - as you'd expect
20:23 <Unit193> flocculant: File manager was ours, intel driver isn't really ours.  This would be *us* "breaking" things.
20:23 <ochosi> problem is that at the moment our "developers" are busy with working on upstream xfce stuff
20:23 <knome> so what else old technologies do we have except gtk2?
20:23 <knome> is there still some python2 stuff around?
20:24 <flocculant> Unit193: indeed
20:24 <ochosi> maybe python2, maybe gstreamer stuff, not sure
20:24 <Unit193> gst0.10 is gone.
20:24 <knome> if our plan is to get that out before 18.04, could somebody who is knowledgeable on the subject create a roadmap for that side?
20:24 <ochosi> i guess bluesabre could
20:25 <ochosi> after all he's our snake-charmer
20:25 <ochosi> :]
20:25 <Unit193> ochosi: Can you clarify on 'old technologies' a bit more?
20:25 <knome> that too
20:26 <knome> i don't think that's a discussion for the meeting necessarily
20:26 <knome> it might be better on the mailing list
20:26 <ochosi> Unit193: well, that was mostly targeted at middleware that our applications and desktop use
20:26 <ochosi> so gtk2, gstreamer, ...
20:26 <knome> we might actually get some useful ideas/pointers from the community here
20:26 <ochosi> sure
20:26 <knome> ochosi, want to take the action to send another mail?
20:26 <Unit193> ochosi: Basically I'm trying to figure out if you're trying to do away more with a classic desktop.
20:27 <knome> i don't think this has anything to do with classic/modern desktops
20:27 <ochosi> Unit193: nope, not really thinking about mobile when i say "technology" here ;)
20:27 <knome> or change of direction in the kind of desktop we want here
20:27 <knome> indeed
20:27 <Unit193> No, not mobile either way.
20:27 <ochosi> just getting rid of extra packages we have to ship and that might not be as well maintained anymore
20:27 <ochosi> (or not at all)
20:27 <ochosi> like the murrine engine
20:28 <knome> yep..
20:28 <Unit193> ochosi: That, I'm good with! :P
20:28 <knome> potentially some of this work might mean stuff would get removed from the repositories
20:28 <ochosi> so basically my BIG goal for 18.04 would be to be gtk3 all the way
20:28 <knome> which is not necessarily a bad thing
20:28 <ochosi> yup
20:28 <knome> ochosi, that depends more on xfce though, but yeah, sure
20:28 <ochosi> yeah mostly
20:28 <Unit193> Well, GTK3 only might be pretty big, but otherwise right.
20:28 <ochosi> but we might still have stuff lingering around
20:28 <knome> but again my question is if that's the *only* goal too?
20:29 <ochosi> i'd say it could be the main goal
20:29 <ochosi> since it's quite big on its own
20:29 <knome> i can agree with that, but again it's partly out of our reach
20:29 <ochosi> well it depends
20:29 <knome> i mean out of our control
20:30 <ochosi> if we say it's our goal then one consequence would be to double-down and install (tested) 4.13 releases of xfce components
20:30 <knome> sure, xubuntu developers can user their time in helping xfce, but that doesn't guarantee it's ready for 18.04
20:30 <knome> yes
20:30 <ochosi> well nothing guarantees that anyway
20:30 <knome> of course not
20:30 <knome> but that's exactly what i meant
20:30 <ochosi> i'd say we should clean our front yard
20:30 <ochosi> make a list of what other gtk2 stuff we have
20:30 <ochosi> and try to replace it
20:30 <flocculant> for this amount - should have been on the agenda
20:31 <knome> that was what i was proposing earlier
20:31 <ochosi> thinking of pidgin etc.
20:31 <ochosi> flocculant: yeah, well spontaneous idea. blame Unit193!
20:31 <knome> flocculant, i agree it probably should have been, but i don't want to slow down impromptu discussion
20:31 <knome> we're not making decisions here anyway
20:31 <Unit193> ochosi: Noooope, I didn't mention it here! :P
20:31 <ochosi> as long as "here" is IRC... ;)
20:32 <ochosi> Unit193: wanna make a list of things still gtk2 in our default install?
20:32 <flocculant> at least 2 people who should be involved aren't here
20:32 <Unit193> Anything else for the meeting?  Discussion can continue afterwards I believe.
20:32 <flocculant> knome: ^^
20:32 <knome> flocculant, should that stop us from discussing?
20:32 <ochosi> flocculant: there's no decision-taking anyway, it's more a fact-finding mission (is going all gtk3 even realistic for 18.04, even when we exclude xfce)
20:32 <flocculant> only when you're not running things
20:33 <knome> as i see it, part of the reason we have scheduled meetings is that we give the opportunity for people to meet and discuss, even impromptu, non-agenda items
20:33 <knome> flocculant, i'll take the chair and run the rest of the meeting if that's the issue
20:34 <knome> and i do think that all of the team should be involved in the decision whether we want to ship (gtk3) development versions from xfce or not
20:35 <Unit193> Not entirely keen on the idea.
20:35 <knome> we'll never have everyone here, even if the topic is on the agenda and the meeting is announced well in advance; people simply have blockers
20:36 <knome> Unit193, keen on what? team being involved?
20:36 <flocculant> so the bulk should be on the mailing list
20:36 <Unit193> knome: Exxxactly!  Nope, GTK3 Xfce so early.
20:36 <knome> ...but again, the reason why we schedule meetings (at least as i see it) it is to be able to have these real-time discussions
20:36 <knome> mailing list is so damn slow.
20:37 <knome> Unit193, it wasn't obvious (and i guess that there might've been arguments for the other too)
20:37 <ochosi> Unit193: wanna share your concerns?
20:37 <Unit193> OK, now it is though. :)
20:37 <knome> yes, thanks for clearing
20:37 <knome> (seriously!)
20:39 <knome> and i'd like to hear the concerns too
20:39 <Unit193> Updating my yak iso so I can check gtk2 (maybe) and py2.
20:40 <knome> is the concern that you don't trust enough that the all-gtk3 port is ready?
20:40 <knome> or is something else involved?
20:40 <knome> (not saying the former isn't a good argument)
20:41 <ochosi> sry guys, i'll be afk for 30mins or so, i'll return later on though and read the backlog
20:41 <ochosi> ->
20:41 <knome> i guess we should hear the arguments from Unit193 and end the meeting, or if he wants time to think about it, just end the meeting
20:41 <Unit193> I'm thinking that it's very early for those releases, not a lot of testing outside of the people that ported them (so might well not be fully baked), and then getting stuck with it for 6 months.
20:42 <Unit193> I'm good with ending now, either way.
20:42 <knome> for a longer time, actually
20:42 <flocculant> Unit193: Id' worry about that as well given the testing *we* manage to get
20:42 <knome> if that's the concern, then from xfce's point of view, who's going to do the testing outside those who ported?
20:42 <knome> (rhetorical, and partly offtopic, let's not go to that here)
20:44 <Unit193> That's what Debian experimental is for, people to opt-in not in static releases, like ours.  I'd say we could PPA everything (smoke test it first), and heck even mention that PPA in the official release notes.
20:44 <knome> Unit193, that's a fair suggestion and i considered that as well
20:44 <knome> Unit193, theoretically, could you whip up an ISO with the PPA stuff installed?
20:45 <knome> (and yeah, the other goal for 18.04 at latest should be core/base)
20:45 <Unit193> Just the whole idea of "New release of Xubuntu!"  "Oh, and btw.  You're all testers, you'll file bugs right?"
20:45 <knome> fair.
20:45 <knome> though now is the perfect time
20:46 <knome> well, the best; let me explain
20:46 <knome> 16.10 is the first release after an LTS; at this point those who don't want to be testers can still decide to go the LTS->LTS upgrade route
20:46 <knome> if we land the stuff in 17.04, those who have gone to 16.10 do not have that option any more, and they are even more forced to be testers
20:47 <Unit193> flocculant: Ready to end the meeting?  This is after meeting stuff.
20:48 <flocculant> knome: on the other hand - if it all goes badly wrong - those people are now stuck upgrading to 17.04 as soon as possible
20:48 <flocculant> #info bluesabre to schedule next meeting
20:48 <flocculant> #endmeeting