18:59 <knome> #startmeeting Xubuntu community meeting
18:59 <meetingology> Meeting started Wed Mar 12 18:59:53 2014 UTC.  The chair is knome. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
18:59 <meetingology> 
18:59 <meetingology> Available commands: action commands idea info link nick
19:00 <knome> who's here for the meeting?
19:00 <elfy> just
19:00 <jjfrv8-work> o/
19:01 <knome> #topic Open action items
19:01 <knome> #action ali1234 and micahg to follow up on gtk3 indicator stack issues
19:01 * meetingology ali1234 and micahg to follow up on gtk3 indicator stack issues
19:01 <knome> anything new up with this?
19:01 <ali1234> it's fixed upstream, not sure if it landed in trusty yet
19:02 <knome> okay
19:02 <knome> #info Issues fixed upstream, landed or landing in Trusty soon
19:02 <knome> #action lderan to create the individual merge proposals for the basic Xubuntu tests
19:02 * meetingology lderan to create the individual merge proposals for the basic Xubuntu tests
19:02 <ali1234> if there's any indicator bugs, assign them to me (if you can)
19:02 <knome> #nick michag
19:03 <knome> #undo
19:03 <meetingology> Removing item from minutes: ACTION
19:03 <knome> hmm
19:03 <ali1234> or just send me the link
19:03 <knome> #action lderan to create the individual merge proposals for the basic Xubuntu tests
19:03 * meetingology lderan to create the individual merge proposals for the basic Xubuntu tests
19:03 <knome> #nick micahg
19:03 <knome> #info if anybody notices any bugs with indicators, point ali1234 to them
19:04 <knome> #action micahg to talk with the DMB and separate -dev from upload rights so we can allow more people to push to xubuntu branches
19:04 * meetingology micahg to talk with the DMB and separate -dev from upload rights so we can allow more people to push to xubuntu branches
19:04 <knome> #action Noskcaj to be in touch with elfy on xkb-plugin testing
19:04 * meetingology Noskcaj to be in touch with elfy on xkb-plugin testing
19:04 <knome> elfy?
19:04 <elfy> not heard anything
19:04 <knome> okay
19:04 <knome> #action pleia2 starts working on getting the Processes wikipage updated and cleaned
19:04 * meetingology pleia2 starts working on getting the Processes wikipage updated and cleaned
19:04 <knome> pleia2?
19:05 <knome> #action knome to work on the desktop of the week -stuff
19:05 * meetingology knome to work on the desktop of the week -stuff
19:05 <knome> carrying
19:05 <knome> #topic Team updates
19:05 <knome> please use #info, #action AND the new one, #done as appropriate
19:05 <knome> #done knome merged documentation and slideshow stuff
19:06 <knome> #done knome fixed docs translation validation issues
19:06 <elfy> #info elfy not much to report in qa - only planned calls for testing left are beta and rc
19:06 <jjfrv8-work> I don't have any, knome did it all :)
19:06 <knome> #done knome pushed a new start page for docs
19:07 <elfy> #info xubuntu-qa to get menulibre testcase up within the next week
19:07 <knome> cool
19:07 <knome> finally ;)
19:07 <elfy> mmm
19:07 <lderan> :P
19:07 <knome> i mean, with all the hurdles in many many teams
19:08 <knome> anything else?
19:08 <elfy> not from me
19:08 <lderan> nope
19:08 <Noskcaj> just a few updates, not really worth a #info
19:08 <knome> hmm right,
19:09 <elfy> lderan to create the individual merge proposals for the basic Xubuntu tests - what's going on with that?
19:09 <knome> #done knome and pleia2 worked on the flyer, almost ready
19:09 <knome> also Noskcaj, ACTION: Noskcaj to be in touch with elfy on xkb-plugin testing
19:10 <lderan> elfy, for the autopilot tests
19:10 <elfy> yep
19:10 <knome> he was asking "what's the progress" :P
19:10 <elfy> lol - yea :)
19:10 <lderan> ah, need to start doing it :(
19:10 <knome> oki, np
19:11 <knome> #topic Announcements
19:11 <knome> #info UI freeze is tomorrow
19:11 <GridCube> o/
19:11 <knome> #info We will most probably need at least one UIFe for the new wallpaper and possibly other artwork packages unless we can get them uploaded/sponsored today/tomorrow
19:12 <knome> #info Documentation String Freeze is on March 20th
19:12 <elfy> what about changes to default whiskerment items?
19:12 <knome> elfy, probably those too, but i'd imagine they are in the pending uploads
19:13 <knome> jjfrv8, slickymaster: i asked you before, but i ask you again:
19:13 <elfy> so we decided what they'd be?
19:13 <knome> is there something more or less major that needs to be landed before call for translators?
19:13 <knome> elfy, "everything that's in the slideshow" :)
19:13 <knome> elfy, as mentioned last week, or so
19:13 <elfy> oh yea
19:14 <knome> we think it's fair to do that, because we're advertising that stuff
19:14 <elfy> sorry - ignore me
19:14 <knome> heh, np
19:14 <knome> good to have any doubts cleared ;)
19:14 <jjfrv8-work> knome, not major, afaik, but there will still be minor updates to later chapters
19:14 <jjfrv8-work> should be done before 20th
19:14 <knome> jjfrv8-work, can you give me an oversight on the scale/subject of those?
19:15 <jjfrv8-work> before the end of the day?
19:15 <knome> i was thinking, like, now
19:15 <knome> if you had something specific in mind that we need to do
19:15 <jjfrv8-work> sorry not even able to look at work
19:15 <knome> if not, then it's probably not major enough to be worried about
19:16 <knome> the quicker we have the docs stuff ready, the better for us
19:16 <jjfrv8-work> I've been through the rest of the chapters and didn't see anything stand out
19:16 <pleia2> sorry, was pulled into a meeting, here now
19:16 <knome> yep, that's good
19:16 <knome> so basically, we will get a new docs upload on march 20
19:16 <knome> and then we can just call for translators
19:17 <knome> but practically we can tell translators to start translating now, if we're only going to do minor changes
19:17 <knome> and give translators one more week to work
19:17 <knome> i've even updated the translation template today, and it's already visible in launchpad
19:17 <knome> so everything that was proposed before yesterday is now translatable
19:17 <pleia2> hooray
19:18 <Unit193> I have one more proposal, but it's more backend.
19:18 <knome> yeah, that's not something to worry about for the translators
19:18 <knome> actually, there's more of the docs stuff i want to go through, but let's move on, and then get back to that shortly
19:18 <knome> #topic Agenda
19:18 <knome> #subtopic Start the discussion on the technical review for the Strategy Document
19:19 <knome> i'm dropping this from the agenda since this is postponed in our blueprints; we should add it back when we are actually ready to talk about it
19:19 <knome> #subtopic 12.04 > 14.04 upgrades, removing xscreensaver
19:19 <knome> who added this?
19:19 <elfy> ochosi
19:19 <knome> what's the thing to discuss
19:19 <knome> aha...
19:19 <knome> ochosi, you around?
19:19 <Noskcaj> That it needs to be removed while upgrading
19:20 <Noskcaj> i'm guessing
19:20 <GridCube> he said he be back >20 mins on the meeting knome
19:20 <elfy> yep - that - I'm pretty sure
19:20 <knome> yes... but wouldn't that just be a work item
19:20 <knome> i'm wondering if ochosi added it, if there was something else to discuss
19:20 <knome> GridCube, yeah, noticed that
19:20 <elfy> knome: possibly
19:20 <knome> from my POV, the plan sounds good as long as it "works"
19:20 <GridCube> i guess it was added to discuss if using lightdm locker
19:21 <knome> 14.04 should use light-locker, yes
19:21 <knome> and not have xscreensaver
19:21 <GridCube> for me it should be removed
19:21 <GridCube> it adds problems to viewing videos and such
19:21 <knome> i could imagine the discussion was about the technical side
19:21 <elfy> though - I'd guess we'd need to do the same for 13.10 upgrade too
19:22 <knome> GridCube, again, please, rather file bugs about problems than switch to the "i'm not using it because it's broken and you'll never fix it" -mode
19:22 <knome> elfy, yep.
19:23 <knome> i'm carrying this, and encouraging any off-meeting discussion on it, if one can help the progress
19:23 <knome> #subtopic Documentation stuff
19:23 <GridCube> no, im not saying that, i just say that thats a reason im for the drop, there are plenty of bugs regarding the xscreensaver issue with video if you want me to search them, but that was not the point of my comment
19:23 <knome> GridCube, right, xscreensaver...
19:23 <knome> yeah, we adgree
19:23 <knome> *agree
19:23 <knome> that's why we want to use light-locker anyway
19:23 <knome> or, one of the reasons
19:24 <knome> so, docs stuff
19:24 <GridCube> :)
19:24 <knome> [xubuntu-doc] Investigate how to attribute translators: INPROGRESS
19:24 <knome> anybody have a good idea?
19:24 <knome> the translation string that launchpad adds is a bit lame, and we're unable to theme it
19:24 <elfy> not even aware of it being a thing
19:24 <knome> basically:
19:25 <knome> we want the translated docs to tell: X contributed to this translation
19:25 <ochosi> o/
19:25 <knome> hey ochosi
19:25 <knome> ochosi, we can get back to stuff after the docs stuff
19:25 <knome> Unit193, pleia2: ideas?
19:25 <ochosi> knome: sure, i'll read the backlog meanwhile
19:26 <pleia2> unfortunately I'm really weak on translations stuff, I don't know best policies here
19:26 <knome> from my POV, it's more of a technical issue
19:26 <knome> i *want* to attribute the translators :)
19:26 <knome> i'm just thinking what's the best way
19:27 * pleia2 nods
19:27 <pleia2> how are they tracked in lp?
19:27 <knome> LP creates a translation string in a .po
19:27 <knome> where the source string is "translator-credits" or so
19:27 <knome> and the translated string is a list of people and LP urls
19:28 <knome> ...which is not a list
19:28 <knome> but just names and urls after each other
19:28 <GridCube> can't we ask them to sign some kind of registry?
19:28 <pleia2> it scares me to look at it again, but I wonder if launchpadlib has a way to pull out the names
19:28 <ochosi> sounds like a job for a regexp?
19:28 <knome> Unit193, maybe we could semi-dirtily hack that off from the translation, and add them to a translated xml file
19:28 <GridCube> like "i translated x" and then we check if they did
19:29 <knome> GridCube, no, LP is tracking that
19:29 <knome> the problem is not that we need to check if people actually translated stuff
19:29 <knome> the problem is that we need to show it in a sensible way somewhere
19:29 <knome> or, want
19:29 <knome> pleia2, as i said, they *are* in the .po fiels
19:29 <GridCube> yes, thats why i say, we ask them to say to us if they want their names, and if they do, they sign a registry
19:30 <pleia2> knome: so just grep? :)
19:30 <knome> GridCube, the problem that we have is still around. how to show the registry?
19:30 <knome> pleia2, something like that, but should be automatic and build-time
19:30 <GridCube> oh, maybe a news on our site?
19:31 <pleia2> a lot of translators just look at laucnhpad and do translations, I doubt they'd find our registry
19:31 <knome> pleia2, and should be able to push the names to a translated file after grepping :)
19:31 <GridCube> pleia2, true
19:31 <pleia2> knome: yeah
19:31 <knome> and news on the site... we can do that as well, but the point is we want to attribute people ON the documentation
19:31 <knome> the information is available
19:31 * pleia2 nods
19:31 <knome> Unit193, want to look at that?
19:32 <GridCube> well i have to go :)
19:32 <Unit193> Eh.
19:32 * GridCube pokes knome and ask him to remember the desktop of the week project
19:32 <knome> GridCube, done.
19:32 <GridCube> bye
19:32 <knome> Unit193, that's a yes?
19:33 <Unit193> I don't even see what you're talking about, so you'd likely be better.
19:34 <knome> Unit193, in a Makefile, strip a certain translation string off a translation, grep it and turn it into HTML markup, inject it into a translated file.
19:34 <knome> Unit193, i can help with that.
19:35 <knome> #action Unit193 and knome to look at attributing translators
19:35 * meetingology Unit193 and knome to look at attributing translators
19:35 <knome> :))
19:35 <knome> [xubuntu-doc] Update the installer slideshow: INPROGRESS
19:35 <knome> can we schedule a sprint for this?
19:35 <Unit193> If it's with makefiles, that's up to you.
19:36 <knome> Unit193, well scripts in makefiles. probably nothing too weird...
19:36 <knome> ochosi, jjfrv8-work, slickymaster, pleia2: what time would work for you?
19:36 <knome> something on the weekend?
19:37 <pleia2> I'm traveling these next couple weekends
19:37 <jjfrv8-work> saturday, 13 to 20 or so
19:37 <knome> what about friday then?
19:37 <knome> or monday
19:38 <knome> tomorrow is a bit bad for me
19:38 <jjfrv8-work> friday's okay for me, monday not so much
19:38 <pleia2> I can try for friday
19:38 <knome> wouldn't want to push this after monday though
19:38 <knome> is 19UTC bad?
19:38 <pleia2> fine by me
19:38 <jjfrv8-work> me too
19:38 <knome> ochosi, slickymaster: ?
19:40 <ochosi> slideshow sprint
19:40 <knome> yep
19:40 <ochosi> hm, i'm away for the weekend...
19:40 <ochosi> taking a trip
19:40 <knome> starting from friday?
19:40 <ochosi> so no interwebs and no sprint
19:40 <ochosi> from saturday early on
19:40 <knome> aha
19:40 <knome> we're talking about friday 19utc
19:40 <ochosi> the current meeting-time is kinda meh for me because it's dinner/movie/going-out time
19:41 <ochosi> so it coincides with lots of things potentially
19:41 <ochosi> just saying
19:41 <knome> propose a time later or earlier :)
19:41 <pleia2> earlier is ok for me too
19:41 <knome> both work for me too.
19:41 <ochosi> could be that i'm around, but earlier would certainly be more likely to work for me
19:41 <knome> ochosi, hour or two earlier? or more?
19:41 <ochosi> so something like 16 or 17utc would work just fine
19:41 <pleia2> ok
19:41 <knome> 17utc works for pleia2, jjfrv8-work ?
19:41 <jjfrv8-work> good
19:41 <knome> slickymaster, hallö?
19:42 <knome> #info Slideshow sprint: Friday, March 14 @ 17UTC
19:42 <knome> ochosi, want to discuss the lts->lts upgrade?
19:43 <ochosi> i mostly put that there as a reminder
19:43 <knome> aha
19:43 <ochosi> i personally don't know how this would be implemented
19:43 <knome> okay
19:43 <ochosi> but there are a few things that should be removed on upgrades to trusty
19:43 <knome> maybe we can ask for some help in #ubuntu-devel or sth
19:43 <ochosi> one of them is xscreensaver, another is gtk2-indicators
19:43 <knome> would it be better as a work item?
19:44 <ochosi> both of those conflict with the stuff we ship in trusty
19:44 <ochosi> so i guess asking micahg would be step 1 for me
19:44 <ochosi> (frankly, i had hoped he'd read it there on the whiteboard)
19:44 <ochosi> if he doesn't know how we can do this, we need to ask around
19:45 <ochosi> and sure, it can also be made a workitem
19:45 <knome> yep
19:45 <ochosi> just didn't want to assign it to me ;)
19:45 <ochosi> (better assign it to someone with more technical knowledge)
19:45 <knome> not sure which blueprint is the best for that, but i'll get it up today
19:45 <knome> #topic Schedule next meeting
19:45 <ochosi> there was also another question/thing i wanted to raise
19:45 <knome> aha
19:45 <ochosi> if there's still a minute
19:45 <knome> #undo
19:45 <meetingology> Removing item from minutes: TOPIC
19:46 <knome> #subtopic ochosi's question
19:46 <ochosi> I saw we have a bugs blueprint now
19:46 <knome> yep
19:46 <ochosi> so i was wondering whether you wanna link *all* bugs that affect xubuntu trusty there
19:46 <ochosi> even e.g. bugs in gtk
19:47 <ochosi> (there is one i'm thinking of in particular, https://bugzilla.gnome.org/show_bug.cgi?id=710909)
19:47 <knome> no, only everything that we are committed to fix
19:47 <ubottu> Gnome bug 710909 in .General "Buttons are cut in some windows" [Normal,New]
19:47 <ochosi> i don't think any of us can or is going to fix that
19:47 <knome> or very critical bugs otherwise
19:47 <knome> anything we want to track
19:47 <ochosi> right, well it's just a visual nuisance
19:47 <ochosi> ppl will see it anyway, so we probably dont even need to track it :)
19:47 <ochosi> (and i'm personally tracking it for a while already)
19:48 <knome> sure
19:48 <knome> no hard policy
19:48 <ochosi> ok
19:48 <ochosi> guess i wasn't around when you introduced that blueprint, so i wanted to make sure
19:48 <knome> they are just there to track the status on the work items tracker
19:48 <knome> added all bugs that were reported against xubuntu in the QA trackers after beta1
19:48 <ochosi> right, feel free to move along then
19:49 <knome> so that's where that list came from
19:49 <ochosi> ah ok
19:49 <ochosi> basically the one elfy compiled
19:49 <knome> yeah, pretty much that
19:49 <knome> #topic Schedule next meeting
19:49 <knome> so
19:49 <knome> let's get back to normal schedule
19:50 <knome> what do people think of making the meeting one hour earlier?
19:50 <pleia2> is fine
19:50 <knome> pleia2, is that worse for you?
19:50 <knome> oh, good
19:50 <pleia2> hooray for DST :)
19:50 <ochosi> for me it's a bit better
19:50 <jjfrv8-work> better here too
19:50 <Unit193> So we're putting it back at 2pm?
19:50 <elfy> that'd be a pain for me atm - but there's not much I need to be worrying about atm
19:50 <knome> 2pm what time :P
19:51 <knome> we're proposing 18UTC
19:51 <knome> just to try out if it works any better for people
19:51 <elfy> did it not get moved from there ?
19:52 <knome> it was there because DST :P
19:52 * knome shrugs
19:52 <elfy> anyway - as I said - not much for me to be about for anyway
19:53 <knome> ok
19:53 <knome> #info Next community meeting: Thursday, March 20 at 18UTC
19:53 <knome> #endmeeting