22:00 <knome> #startmeeting Xubuntu documentation checkup meeting
22:00 <meetingology> Meeting started Wed Feb  5 22:00:00 2014 UTC.  The chair is knome. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
22:00 <meetingology> 
22:00 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
22:00 <knome> #chair slickymaster jjfrv8 pleia2
22:00 <meetingology> Current chairs: jjfrv8 knome pleia2 slickymaster
22:00 <pleia2> o/
22:00 <jjfrv8> who wants to start?
22:00 <slickymaster> I think it would be better for you to open the hostilities knome, since you're more used to it
22:01 <knome> mkay
22:01 <slickymaster> or you, jjfrv8
22:01 <knome> #topic Quick run-through of the documentation blueprint
22:01 <knome> https://blueprints.launchpad.net/ubuntu/+spec/xubuntu-t-docs
22:02 <knome> so, the big things left to do are (looking as i type, will take some time):
22:02 <slickymaster> well, the mugshot item is done
22:02 <knome> 1) "what's new" page/slide
22:02 <knome> 2) menulibre docs
22:03 <knome> 3) copy some xfdesktop docs over
22:03 <knome> 4) update tour/about pages
22:03 <knome> 5) update installer slideshow
22:03 <knome> and finally,
22:03 <knome> 6) update documentation regarding the default xubuntu desktop layout/indicator stuff
22:04 <knome> did i miss something?
22:04 <slickymaster> I think not
22:04 <knome> well 7) translations for docs
22:04 <slickymaster> and there's also the bzr, and the code of conduct issues
22:05 <slickymaster> but that's part od the developer documentation
22:05 <knome> right, the developer docs
22:05 <slickymaster> s/od/of
22:05 <knome> i'm not sure if that's been something people have generally been excited about
22:05 <knome> and from my POV, it's on the bottom of the list
22:05 <slickymaster> understandably
22:06 <jjfrv8> that was kind of my idea but since then I see where a lot of that stuff already exists
22:06 <knome> jjfrv8, yeah, it's probably just scattered all over the place
22:07 <slickymaster> well, regarding the points knome enumerate, I'm planning on starting to work on porting the xfdesktop over to docbook
22:07 <slickymaster> and afterwards, start to deal with the MenuLibre -docs
22:07 <knome> i consider 5, 6 and 7 blocked
22:07 <knome> (at least)
22:07 <knome> the rest we can basically work on right now
22:08 <slickymaster> actually, I thought that MenuLibre was something that me and jjfrv8 could do together, similar to what we did with parole and xfdesktop
22:08 <jjfrv8> can we talk about the "what's new" stuff?
22:08 <knome> most definitely
22:08 <knome> #topic What's new?
22:08 <slickymaster> jjfrv8, ^^
22:08 <slickymaster> ups
22:09 <knome> (you can do #topic's as well)
22:09 <jjfrv8> where do you think the subject should go in the offline docs? new chapter?
22:09 <jjfrv8> http://pad.ubuntu.com/8xtc6oWrkg
22:10 <knome> tell me if i said something else before, but i don't know if the docs are the best place for it
22:10 <knome> (i'm not opposed to that idea either though)
22:10 <jjfrv8> maybe not, can't remember
22:10 <knome> maybe website + installer slideshow?
22:11 <jjfrv8> okay
22:11 <knome> we probably want that to be quite vibrant, and the docs aren't exactly that...
22:11 <slickymaster> I think that would be preferable
22:11 <jjfrv8> yeah, cause it pretty much demands screenshots
22:11 <knome> yep, and marketing-like content
22:13 <slickymaster> agree, it kind of seems logical to be in the installer rather than in the -docs
22:13 <slickymaster> and the website
22:14 <knome> hmm, there's surely some logs about it somewhere, but i'm quite certain we thought it's best to mostly cover the LTS->LTS transition
22:16 <jjfrv8> yes, definitely LTS->LTS
22:16 <knome> do we have anything other new than is mentioned on the pad?
22:16 <slickymaster> just a sec
22:17 <slickymaster> back again, sorry
22:19 <knome> didn't even notice you were away ;)
22:19 <knome> pleia2, any thoughts?
22:19 <slickymaster> I don't seem to recall any other new stuff, other then what you already mentioned
22:20 <knome> ok, good
22:20 <knome> should we start working with it?
22:20 <pleia2> not really
22:20 <knome> apart from the integrated desktop stuff, that is
22:20 <jjfrv8> you said slideshow was blocked but I think we could start on it
22:20 <knome> i'm thinking that because we can most probably use the same material in that
22:21 <knome> we probably want a bigger transition than just "update the same old slides"
22:21 <knome> so if we have the "what's new" stuff ready, it's really easy to pick new stuff from there
22:21 <knome> and same with that, we can't really write about the new, better integrated desktop yet
22:21 <slickymaster> do you mean a complete revamp of the entire slideshow?
22:21 <knome> because things aren't in place :/
22:22 <knome> slickymaster, i've done a small visual facelift for it (to match with the website), and yeah, maybe the content is better rewritten as well
22:22 <knome> we've had the same slides for ages
22:22 <knome> and they aren't communicating "14.04 is full of new wonderful features"
22:22 <slickymaster> well, it does goes back in the day :P
22:22 <slickymaster> yeaps
22:23 <knome> so, i would actually try to postpone that as far as possible
22:23 <knome> it's good to keep in mind we have to do it... but other things seem more important now
22:23 <knome> actually, the tour page is kind of blocked for the same reason
22:23 <knome> the about page is ready to be worked on
22:24 <knome> (on the website)
22:24 <slickymaster> well, ideally I'll have xfdesktop ported to docbook format, by the end of the weekend
22:24 <knome> so it seems the things we can do now is the xfdesktop and menulibre docs
22:24 <slickymaster> jjfrv8, did you get to see what I wrote about the MenuLibre -docs?
22:25 <jjfrv8> not yet. I just tried it today for the first time.  Baffled, like elfy
22:25 <jjfrv8> didn't have v 2.0, though
22:25 <knome> ah, 2.0 is something completely different
22:25 <knome> it's a full rewrite
22:25 <jjfrv8> how to get it. I don't know from tar's
22:25 <knome> as with the testcase, i think we should cover the most basic functions
22:26 <slickymaster> jjfrv8,  my idea is that MenuLibre was something that you and me could do together, similar to what we did with parole and xfdesktop
22:26 <jjfrv8> I'm good with that.
22:26 <knome> jjfrv8, 2.x is in trusty
22:26 <slickymaster> once we overcome the initial barriers
22:27 <jjfrv8> then I must have overwritten it :(
22:27 <slickymaster> yes, I've installed it today in my trusty box
22:27 <slickymaster> bluesabre, already has a namespace ready for them: http://smdavis.us/doku/doku.php?id=menulibre-docs
22:28 <knome> slickymaster, unrelated note: that site says "staging site", check with bluesabre if he's ok with us linking there from the docs, or if he's planning to move the docs
22:30 <slickymaster> good point knome. I haven't done that and I've linked http://smdavis.us/doku/doku.php?id=mugshot-docs in the settings-preferences chapter
22:30 <pleia2> we could always upload them to docs.xubuntu.org
22:30 <knome> i just noticed that myself
22:30 <knome> worksforme
22:30 <jjfrv8> but basically, I fine with starting on xfdesktop and menulibre with slicky
22:30 <knome> pleia2, but no can has dokuwiki on docs.
22:31 <pleia2> right, it wouldn't be a wiki
22:31 <pleia2> static snapshot of documentation
22:31 <slickymaster> I'll ping bluesabre on that
22:31 <pleia2> but whatever, we can treat this like any other upstream
22:32 <slickymaster> if not today tomorrow morning at the very least
22:32 <knome> pleia2, yep.
22:34 <slickymaster> jjfrv8, you could start on the MenuLibre while I wrap Xfdesktop until the weekend and by the start of next week I would join exclusively on that
22:35 <jjfrv8> okay
22:35 * slickymaster hopes that elfy won't start to say docs, docs, docs, and no -qa
22:35 <slickymaster> with some luck we might have those ready for alpha1
22:36 <jjfrv8> too late for that :)
22:36 <elfy> alpha1 is long gone ...
22:36 <elfy> some qa bloke you are :p
22:36 * slickymaster hides in shame
22:36 <slickymaster> yeaps, you're right
22:36 <elfy> :)
22:37 <slickymaster> about alpha1, not about doubting my '-qaness'
22:37 <jjfrv8> knome, what about extending the docs? you mentioned two things from the Ubuntu Manual
22:37 <elfy> :)
22:38 <knome> jjfrv8, i'm considering the ubuntu manual stuff bottom of the list as well
22:38 <Unit193> And perhaps a "What application preforms what role"?
22:38 <jjfrv8> okay, fine with that
22:38 <knome> jjfrv8, it's just one more resource to dig some stuff from *when* we are comfortable with everything else and want to extend the docs
22:39 <knome> Unit193, like, extend file:///usr/share/xubuntu-docs/desktop-guide/guide-default-apps.html
22:39 <knome> (expecting you to have the docs installed)
22:41 <Unit193> More or less, but with more core applications.
22:41 <knome> Unit193, would be fine with merge proposals
22:41 <knome> Unit193, also note we have file:///usr/share/xubuntu-docs/desktop-guide/command-line.html#command-line-common-commands, which you might want to extend while at it
22:42 <Unit193> (Do people use `edit` and `editor`?)
22:42 * knome shrugs
22:43 <Unit193> I can chech _history for what I commonly use, at least.
22:43 <knome> i use nano.
22:44 <knome> ochosi, stop hiding
22:49 <jjfrv8> so, we have our plan, at least for the short term?
22:49 * ochosi unhides
22:50 <slickymaster> I would think we have
22:50 <slickymaster> knome, anything you want to add?
22:52 <knome> humph, well
22:52 <knome> talk with ochosi about the desktop stuff
22:53 <knome> i mean, not necessarily now, but...
22:53 <knome> can we do a simple task assiging
22:53 <knome> #topic Assigning some tasks
22:53 <jjfrv8> please
22:53 <slickymaster> go for it
22:53 <knome> or tbe, see who's leading what
22:53 <knome> so slickymaster, you'll be leading the xfdesktop stuff
22:54 <slickymaster> yeaps
22:54 <knome> jjfrv8, want to steer the menulibre docs at least for now?
22:54 <jjfrv8> sure
22:54 <knome> i'll make sure i'll nag myself and you about the installer slideshow
22:54 <knome> pleia2, you ok to nag us about the website?
22:55 <knome> i still need to look at some translation stuff, so i guess i can do the reminders/calls for translators later
22:55 <knome> #action slickymaster to lead porting xfdesktop docs
22:55 * meetingology slickymaster to lead porting xfdesktop docs
22:55 <knome> #action jjfrv8 to lead writing menulibre docs
22:55 * meetingology jjfrv8 to lead writing menulibre docs
22:56 <knome> #action knome to lead/nag about updating the installer slideshow
22:56 * meetingology knome to lead/nag about updating the installer slideshow
22:56 <knome> #action knome to not let the team forget about translations
22:56 * meetingology knome to not let the team forget about translations
22:56 <knome> #action pleia2 (voluntelled) to not let the team forget about website
22:56 * meetingology pleia2 (voluntelled) to not let the team forget about website
22:57 <knome> #action Unit193 to do merge proposals for "X performs Y" styled listings for the docs
22:57 * meetingology Unit193 to do merge proposals for "X performs Y" styled listings for the docs
22:57 <Unit193> >_>
22:57 <slickymaster> lol
22:58 <knome> jjfrv8, you probably got my reply, but will confirm here: the mail looks good as is, go ahead and i'll +1 your application
22:58 <pleia2> :)
22:58 <knome> #action knome to remember to +1 jjfrv8's application for ~ubuntu-core-doc membership
22:58 * meetingology knome to remember to +1 jjfrv8's application for ~ubuntu-core-doc membership
22:58 <knome> anything else?
22:58 <slickymaster> I think that's about it
22:59 <jjfrv8> nope, thanks.
22:59 <knome> ok, great
22:59 <knome> if you have any questions or anything, i'm available as usually in this channel, PM and email
22:59 <knome> thanks! :)
22:59 <knome> #endmeeting