18:57 <knome> #startmeeting Xubuntu community meeting
18:57 <meetingology> Meeting started Thu Jan  9 18:57:46 2014 UTC.  The chair is knome. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
18:57 <meetingology> 
18:57 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
18:58 <knome> i'm starting the meeting now because i might need to run at some point
18:58 <ali1234> o/
18:58 <ochosi> crap, i'll only be halfway here...
18:58 <knome> say hi if you are around, and team leaders, stop lurking so i can make you chair the meeting
18:58 <elfy> just finishing up
18:58 <slickymaster> o/
18:58 <knome> elfy, like to chair?
18:58 <jjfrv8> hi
18:58 <knome> hey jjfrv8, or you ^
18:58 <elfy> ~I hate to chair
18:58 <jjfrv8> no idea how
18:58 <sergio-br2> hi
18:59 <elfy> will if no-one else is about
18:59 <knome> jjfrv8, i can give you a quick tutorial
18:59 <jjfrv8> maybe some other time?
18:59 <knome> sure
18:59 <knome> #chair elfy
18:59 <meetingology> Current chairs: elfy knome
18:59 <knome> elfy, you can now #chair other people if they appear and i'm not here to do that.
18:59 <elfy> k
18:59 <knome> i guess i can start with the bureaucracy
19:00 <knome> #topic Items carried on
19:00 <knome> #subtopic Open action items from previous meeting
19:00 <knome> #action     ali1234 to keep an eye on SRU progress for indicator-sound-GTK2
19:00 * meetingology ali1234 to keep an eye on SRU progress for indicator-sound-GTK2
19:00 <knome> ali1234, ?
19:00 <knome> ah poop
19:00 <knome> brb
19:00 <ali1234> it's in saucy-updates now, landed a couple of days ago
19:00 <ochosi> congrats
19:01 <elfy> here now - sergio-br2 I'll talk to you about nvidia after the meeting
19:02 <sergio-br2> ok
19:02 <knome> ali1234, do you want to carry on that item?
19:02 <ali1234> carry it on?
19:02 <ali1234> it's fixed now afaik
19:02 <knome> make it pop up in the next meeting
19:02 <knome> okay,
19:02 <knome> #undo
19:02 <meetingology> Removing item from minutes: <MeetBot.items.Action object at 0x16231d0>
19:02 <ali1234> i guess not
19:02 <knome> #action     elfy to set up a new vm and get everyone's new bits in so I've got something to look at
19:02 * meetingology elfy to set up a new vm and get everyone's new bits in so I've got something to look at
19:02 <knome> elfy, want to carry on or was that mostly a remark?
19:03 <knome> have you got more things to test already?
19:03 <elfy> was mostly a remark - I've been running with the ppas we have constantly now
19:03 <knome> #undo
19:03 <meetingology> Removing item from minutes: <MeetBot.items.Action object at 0x174a2d0>
19:03 <knome> okay
19:03 <knome> #action ochosi and knome to come up with more testing stuff late
19:03 * meetingology ochosi and knome to come up with more testing stuff late
19:03 <knome> #undo
19:03 <meetingology> Removing item from minutes: <MeetBot.items.Action object at 0x1617850>
19:04 <knome> #action ochosi and knome to come up with more testing stuff later (within a week)
19:04 * meetingology ochosi and knome to come up with more testing stuff later (within a week)
19:04 <knome> #action     knome to be in touch with people re Tech Lead position
19:04 * meetingology knome to be in touch with people re Tech Lead position
19:04 <knome> TBD, carrying on
19:04 <elfy> what testing stuff is that? ^^
19:04 <knome> the things we are supposed to have
19:04 <knome> we went through the -features BP, and i'm much better on top of that now
19:04 <elfy> right - well if we can get that conversation in during the next week - then I'm currently on the week off cycle
19:04 <knome> so basically the same, but i hope we'll have new versions and that kind of stuff soon
19:05 <elfy> and can be about
19:05 <knome> sure, will try to push towards that
19:05 <knome> #action ochosi to follow up on xfce 4.12 release with nick and report back
19:05 * meetingology ochosi to follow up on xfce 4.12 release with nick and report back
19:05 <knome> ochosi, ?
19:06 <elfy> come back to him :)
19:06 * knome slaps ochosi
19:06 <knome> #info Team members wanting things tested need to ensure a mail get's sent to the -dev list
19:06 <ochosi> mm, well, there have been a few releases
19:06 <ochosi> but we're still waiting for the panel
19:07 <knome> ochosi, no news about the final 4.12 release?
19:07 <ochosi> not really
19:07 <knome> oki
19:07 <knome> #topic Team updates
19:07 <knome> please use #info and #action as necessary
19:07 <ochosi> (as there are still dev-releases missing and nick seems busy...)
19:08 <knome> #info knome and ochosi went through https://blueprints.launchpad.net/ubuntu/+spec/xubuntu-t-features, which now has updated whiteboard and work items statuses
19:08 <knome> #info knome finished the finnish tranlsation for xubuntu docs
19:08 <knome> #info knome worked on the website, new release planned soon
19:08 <knome> #undo
19:08 <meetingology> Removing item from minutes: <MeetBot.items.Info object at 0x16f2890>
19:08 <knome> #info knome worked on the website, refreshing release planned soon
19:08 <ali1234> oh, the terminal crash fix also just went into saucy-updates :)
19:09 <knome> ali1234, with #info please
19:09 <knome> (and would be helpful if you can point to a bug number)
19:09 <slickymaster> #info slickymaster finished the portuguese translation for xubuntu docs
19:09 <slickymaster> bug 1206739
19:09 <ubottu> bug 1206739 in xfce4-terminal (Ubuntu) "xfce4-terminal crashed with SIGSEGV in magazine_chain_pop_head()" [Medium,Fix released] https://launchpad.net/bugs/1206739
19:09 <knome> #info ochosi and bluesabre worked on light-locker theming
19:10 <knome> #info bugfix for 1206739 got into saucy-updates
19:10 <ochosi> s/light-locker/lightdm-gtk-greeter/
19:10 <knome> whatever! :P
19:10 <ochosi> sry, something came up, gotta run...
19:10 <ochosi> :/
19:11 <knome> np
19:11 <knome> will assign loads of tasks to you for that
19:11 <knome> is there anything else?
19:11 <ali1234> #info bugfix for 1208204 (indicator-sound-gtk2) also got into saucy-updates
19:11 <elfy> #info work towards use of autopilot is still ongoing - but it's unlikely to get there this cycle
19:11 <elfy> #info package testing moving on - calling for seperate sections every couple of weeks
19:11 <elfy> #info checking of required testcases for each call being lined up by -qa
19:12 <elfy> #info iso testing - moves forward as always
19:12 <elfy> #info calls have been going out to -testers
19:12 <elfy> #info calls having little effect on reported numbers
19:12 <elfy> #action elfy and knome/ochosi to discuss lightlocker testing - perhaps include old post install testing in that
19:12 * meetingology elfy and knome/ochosi to discuss lightlocker testing - perhaps include old post install testing in that
19:12 <elfy> #info we need to be moving towards getting testcase for the other new stuff in the next week or so
19:13 <knome> elfy, let's also discuss the future of -testers
19:13 <elfy> #action elfy to discuss future of -testers with knome
19:13 * meetingology elfy to discuss future of -testers with knome
19:13 <knome> #info alpha 2 is in 2 weeks
19:14 <elfy> if we still don't have a properly booting image then I see no point in doing it
19:14 <knome> #info feature freeze is in 6 weeks
19:14 <knome> elfy, what was holding it again? the session bug?
19:14 <elfy> yep
19:14 <knome> will get that updated
19:14 <knome> /uploaded
19:14 <elfy> ok
19:14 * knome promises, so it'll happen
19:15 <knome> i will try to get the fix soon ASAP
19:15 <knome> xnox, ^
19:15 <elfy> #action knome will get session bug fix uploaded
19:15 * meetingology knome will get session bug fix uploaded
19:15 <elfy> :p
19:15 <knome> anything else for the updates?
19:15 <knome> elfy, works for me :P
19:15 <knome> welcome Noskcaj
19:15 <knome> #topic Announcements
19:15 <elfy> no more updates here
19:16 <Noskcaj> hey knome
19:16 <Noskcaj> one sec
19:16 <knome> #info slickymaster is applying for ubuntu membership, go give him testimonials at https://wiki.ubuntu.com/slickymaster if you are familiar with his work
19:16 <Noskcaj> #info Noskcaj needs more testimonials for xubuntu packageset, add them at https://wiki.ubuntu.com/Noskcaj#Xubuntu_PackageSet
19:16 <Noskcaj> #info Noskcaj is part-way through applyignfor motu and xubuntu packageset via email
19:16 <Noskcaj> #info libxfce4ui is waiting for a sponsor to upload it to trusty
19:16 <Noskcaj> #info debian will upload more 4.11 components this month
19:16 <Noskcaj> #info debian have fixed the power manager systemd issue in svn, it should be uploaded soon
19:16 <Noskcaj> #info gthumb 3.2.6 is now uploaded and web-plugins are re-enabled
19:16 <Noskcaj> #info prpltwtr will release sometime this month
19:17 <Noskcaj> #info Noskcaj is now on the bug control team
19:17 <knome> Noskcaj, thanks
19:18 <knome> other announcements from leaders?
19:18 <elfy> no
19:19 <knome> #topic New and emerging items
19:19 <knome> #subtopic Which GTK3 indicators are we going to ship?
19:19 <knome> https://wiki.ubuntu.com/Xubuntu/Roadmap/Specifications/Trusty/Gtk3Indicators
19:19 <knome> ochosi wanted -power and -messages in
19:19 <ali1234> ship ALL the indicators!
19:20 <knome> yeah, i was wondering if there is any reason *not* to *ship* them all?
19:20 <ali1234> actally yes there is
19:20 <knome> well go ahead and tell us :)
19:21 <ali1234> -datetime is probably not a good idea because of https://bugs.launchpad.net/ubuntu/+source/indicator-datetime/+bug/1074314
19:21 <ubottu> Ubuntu bug 1074314 in indicator-datetime (Ubuntu) "indicator-datetime configuration panel only works in Unity session" [Undecided,Confirmed]
19:21 <ali1234> -session doesn't really work properly with light-locker and xfce-session stuff
19:21 <ali1234> all the others seem okay though
19:22 <knome> okay
19:22 <brainwash_> -power needs to be patched to launch xfce4-power-manager, or?
19:22 <elfy> only got 3 working here - messages/sound and the clock one
19:22 <ali1234> oh and shipping them == having them running in the default setup, unless you blacklist them
19:22 <ali1234> i don't use power (not a laptop)
19:23 <knome> brainwash_, i guess that's the case but afaik there's a fix incoming
19:23 <knome> ali1234, yep, i acknowledge shipping is using :)
19:23 <brainwash_> but aren't the current panel plugins more lightweight and stable?
19:23 <ali1234> not really
19:24 <ali1234> the sound plugin doesn't really work at all with PA, and there is no plugin for indicator-messages or -sync
19:25 <knome> do we want to discuss this further or are we ok?
19:25 <ali1234> bluman is kind of unmaintained now also
19:25 <brainwash_> not talking about the ones which don't have a panel plugin equivalent
19:25 <knome> we're going to need to switch to gtk3 indicators at some point anyway
19:26 <knome> if not for other reasons, to avoid maintaining the whole gtk2 indicator stack
19:26 <ali1234> well ignoring datetime, session, bluetooth, sound, messages... there is not much left really
19:26 <knome> brainwash_, do you know for sure there is some problems with them, or are you just concerned about lightness?
19:26 <ali1234> oh and -application is miles better than the notification plugin which doesn't work properly on dual monitor and never will
19:27 <elfy> doesn't work here ali1234
19:27 <brainwash_> I don't have any numbers
19:27 <knome> elfy, do you have a bug filed?
19:27 <ali1234> elfy: because of that stupid upstart bug. it's being fixed
19:27 <Noskcaj> ali1234, Blueman is semi-active again. https://github.com/cschramm/blueman
19:27 <elfy> ali1234: right ok
19:27 <knome> ali1234, good to know
19:28 <knome> anything else on the subject?
19:28 <ali1234> i talked to tedg about it couple of days ago. apparently he has a plan
19:28 <ali1234> i'll continue to follow up on that
19:28 <knome> ali1234, thanks
19:28 <knome> #action ali1234 follows up on gtk3 indicator status
19:28 * meetingology ali1234 follows up on gtk3 indicator status
19:28 <knome> #subtopic Enabling more people to push to Xubuntu branches
19:28 <sergio-br2> blueman is much better than the bluetooth thing of gnome... will it be change?
19:28 <knome> so, we discussed this briefly with ochosi...
19:28 <sergio-br2> ops, sorry
19:29 <knome> sergio-br2, that's not the question:)
19:29 <knome> currently, only people in -dev can push to xubuntu branches
19:29 <knome> we were wondering if it was possible to allow more people to push into the branches
19:29 <knome> either via creating a new team, like -branches, or assigning them to -team
19:29 <knome> micahg, do you have any insight on this?
19:30 <knome> (are you even around?)
19:30 <elfy> so - -dev is effectively just micahg atm ?
19:30 <knome> elfy, yes
19:30 <Noskcaj> elfy, Yup
19:30 <Noskcaj> And all of core-dev
19:30 <elfy> thought that was the case
19:30 <knome> we're looking to get more people in -dev though, but even then...
19:31 <elfy> yep - it's an issue for sure
19:31 <knome> i mean -team is already moderated, and we have some amount of trust for the members already
19:31 <knome> so we don't expect them to do foolish things with the branches
19:31 * Noskcaj needs a testimonial from knome
19:31 <elfy> knome: I can agree with that
19:32 <slickymaster> +1
19:32 <knome> if -dev members or DMB thinks we can't allow -team to push to branches, we should look at creating a new team which would have push rights, but a bit looser membership requirements than -dev
19:32 <knome> but i guess we need to postpone this, because neither ochosi or micahg are around
19:32 <knome> Noskcaj, i can only give a non-technical one, but i will do that once i have time
19:32 <knome> Noskcaj, (and can clear my thoughts for it)
19:33 <knome> #subtopic Schedule next meeting
19:33 <Noskcaj> knome, ty
19:33 <elfy> knome: maybe set up a specific meeting for you ochosi and micahg - not really something we should leave hanging
19:33 <knome> #info Next meeting Jan 16, 19UTC
19:33 <elfy> and those interested of course
19:33 <knome> elfy, will be in touch with them, but want to get it through the community meeting :)
19:33 <elfy> :)
19:34 <knome> #endmeeting